shotwell-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246
  1. Name: shotwell
  2. Version: 0.12.3
  3. Release: 1%{?_dist_release}
  4. Summary: A photo manager for the GNOME desktop
  5. Summary(ja): GNOME デスクトップ向けの写真管理ツール
  6. Group: Applications/Graphics
  7. # LGPLv2+ for the code
  8. # CC-BY-SA for some of the icons
  9. License: LGPLv2+ and CC-BY-SA
  10. URL: http://www.yorba.org/shotwell/
  11. Source0: http://www.yorba.org/download/shotwell/stable/shotwell-%{version}.tar.bz2
  12. # http://trac.yorba.org/ticket/3379
  13. Source1: shotwell-icons.tar.bz2
  14. #Source2: shotwell-0.8.1-vine2-ja.po
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: GConf2-devel
  17. BuildRequires: LibRaw-devel
  18. BuildRequires: LibRaw-static
  19. BuildRequires: WebKit3-gtk-devel
  20. BuildRequires: dbus-glib-devel
  21. BuildRequires: desktop-file-utils
  22. BuildRequires: gettext
  23. BuildRequires: gtk3-devel
  24. BuildRequires: gstreamer-devel
  25. BuildRequires: gstreamer-plugins-base-devel
  26. BuildRequires: json-glib-devel
  27. BuildRequires: libexif-devel
  28. BuildRequires: libgee-devel
  29. BuildRequires: libgphoto2-devel
  30. BuildRequires: libgudev1-devel
  31. BuildRequires: libgexiv2-devel >= 0.2.0
  32. BuildRequires: libsoup-devel
  33. BuildRequires: libxml2-devel
  34. BuildRequires: lcms2-devel
  35. BuildRequires: sqlite3-devel
  36. BuildRequires: unique3-devel
  37. BuildRequires: vala-devel >= 0.9.5
  38. BuildRequires: rest-devel
  39. Vendor: Project Vine
  40. Distribution: Vine Linux
  41. Packager: kudoh
  42. %description
  43. Shotwell is a new open source photo manager designed for the GNOME desktop
  44. environment. It allows you to import photos from your camera, view and edit
  45. them, and share them with others.
  46. %description -l ja
  47. Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
  48. 画像管理ツールです。
  49. あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
  50. 他の人々と共有するなどができます。
  51. %prep
  52. %setup -q -n %{name}-%{version}
  53. #pushd po
  54. #%__rm -f ja.po
  55. #%__cp %{SOURCE2} ja.po
  56. #popd
  57. %build
  58. # We can't use the configure macro: it's not a standard autotools configure script
  59. export CFLAGS="%{optflags}"
  60. export LIB=%{_lib}
  61. # HACK: Remove fatal-warnings to succeed build with vala 0.13.
  62. sed -i "s:--fatal-warnings ::g" Makefile plugins/Makefile.plugin.mk
  63. ./configure --prefix=%{_prefix} --lib=%{_lib} --disable-schemas-install
  64. #sed -i -e 's/\\n/\n/g' configure.mk
  65. #sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
  66. #sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
  67. make %{?_smp_mflags}
  68. %install
  69. rm -rf $RPM_BUILD_ROOT
  70. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  71. export XDG_DISABLE_MAKEFILE_UPDATES=1
  72. # otherwise gettext always returns English text regardless of LANGUAGE asked
  73. export LANG=en_US.utf8
  74. make install DESTDIR=$RPM_BUILD_ROOT
  75. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
  76. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
  77. # put hi-res icons in place
  78. (
  79. cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
  80. rm -rf 16x16 24x24 scalable
  81. tar xf %{SOURCE1}
  82. )
  83. %find_lang %{name} --all-name
  84. %clean
  85. rm -rf $RPM_BUILD_ROOT
  86. %post
  87. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  88. update-desktop-database &> /dev/null || :
  89. %postun
  90. if [ $1 -eq 0 ] ; then
  91. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  92. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  93. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  94. fi
  95. update-desktop-database &> /dev/null || :
  96. %posttrans
  97. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  98. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  99. %files -f %{name}.lang
  100. %defattr(-,root,root,-)
  101. %doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
  102. %{_bindir}/shotwell
  103. %{_bindir}/shotwell-video-thumbnailer
  104. %{_libdir}/shotwell/plugins/builtin
  105. %{_datadir}/GConf/gsettings/shotwell.convert
  106. %{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
  107. %{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
  108. %{_datadir}/gnome/help/
  109. %{_datadir}/shotwell
  110. %{_datadir}/applications/shotwell.desktop
  111. %{_datadir}/applications/shotwell-viewer.desktop
  112. %{_datadir}/icons/hicolor/*
  113. %exclude %{_datadir}/icons/hicolor/icon-theme.cache
  114. %exclude %{_datadir}/glib-2.0/schemas/gschemas.compiled
  115. %changelog
  116. * Thu May 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.12.3-1
  117. - new upstream release
  118. - dropt Source2
  119. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.2-1
  120. - new upstream release
  121. - remove Patch0
  122. - change BuildRequires: gtk3-devel instead of gtk2-devel
  123. - change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
  124. - change BuildRequires: unique3-devel instead of unique-devel
  125. - remove BuildRequires: hal-devel
  126. - add BuildRequires: rest-devel, lcms2-devel
  127. * Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.6-1
  128. - new upstream release
  129. * Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.5-1
  130. - new upstream release
  131. * Fri Oct 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.4-1
  132. - new upstream release
  133. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.11.2-1
  134. - new upstream release
  135. - add Patch0 (shotwell-0.11.1-vala-0.14.patch)
  136. - add BuildRequires: gstreamer-plugins-base-devel
  137. * Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
  138. - rebuilt with libgexiv2-0.2.2-2
  139. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
  140. - new upstream release
  141. * Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
  142. - add ja.po (Source2): fix <BTS:VineLinux:1142>
  143. - update Summary and description
  144. * Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
  145. - add hi-res icons (SOURCE1)
  146. - add LANG=en_US.utf8 to get gettext to actually generate translated strings
  147. * Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
  148. - dropt Patch0
  149. - added BuildRequires: LibRaw-static
  150. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
  151. - add Patch1 (shotwell-0.8.1-vala.patch)
  152. * Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
  153. - new upstream release
  154. - added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
  155. * Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
  156. - rebuilt with rpm-4.8.1 for pkg-config
  157. - fixed %%changelog in Tue Sep 14 2010
  158. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
  159. - new upstream release
  160. - changed source URL
  161. - added Patch0 to work around desktop file incorrect comment
  162. - changed BuildRequires: vala-devel >= 0.9.5
  163. * Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
  164. - new upstream release
  165. * Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
  166. - new upstream release
  167. - changed BuildRequires: libgexiv2-devel >= 0.2.0
  168. * Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
  169. - fixed LIB_DIRS in libraw-config (for lib64)
  170. * Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
  171. - new upstream release
  172. - added BuildRequires: LibRaw-devel, libgexiv2-devel
  173. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
  174. - new upstream release
  175. * Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
  176. - new upstream release
  177. - added BuildRequires: libgudev1-devel
  178. - applied new naming policy to spec
  179. * Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
  180. - new upstream release
  181. - proved Japanese description
  182. * Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
  183. - new upstrema release
  184. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
  185. - intial build for VineSeed
  186. * Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
  187. * Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  188. - Update to 0.3.2
  189. * Tue Nov 3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
  190. - Version 0.3.0
  191. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
  192. - Rebuild against new libgee
  193. * Sun Aug 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
  194. - Bring icon cache handling in sync with current guidelines
  195. * Sun Aug 9 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
  196. - Initial packaging