zint-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158
  1. Summary: A barcode generator and library
  2. Summary(ja): Zintバーコード作成プログラム
  3. Name: zint
  4. Version: 2.4.2
  5. Release: 1%{?_dist_release}
  6. License: GPLv3+
  7. URL: http://www.zint.org.uk
  8. Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  9. Patch0: zint-2.4.0-qr-kanji.patch
  10. Patch1: %{name}-rpath.patch
  11. Group: Applications/Engineering
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: cmake
  14. BuildRequires: libpng-devel
  15. BuildRequires: zlib-devel
  16. BuildRequires: qt4-devel
  17. BuildRequires: desktop-file-utils
  18. Distribution: Vine Linux
  19. Vendor: Project Vine
  20. Packager: owa
  21. %description
  22. Zint is a C library for encoding data in several barcode variants. The
  23. bundled command-line utility provides a simple interface to the library.
  24. Features of the library:
  25. - Over 50 symbologies including all ISO/IEC standards, like QR codes.
  26. - Unicode translation for symbologies which support Latin-1 and
  27. Kanji character sets.
  28. - Full GS1 support including data verification and automated insertion of
  29. FNC1 characters.
  30. - Support for encoding binary data including NULL (ASCII 0) characters.
  31. - Health Industry Barcode (HIBC) encoding capabilities.
  32. - Output in PNG, EPS and SVG formats with user adjustable sizes and colors.
  33. - Verification stage for SBN, ISBN and ISBN-13 data.
  34. %package devel
  35. Summary: Library and header files for %{name}
  36. Summary(ja): Zintバーコードの開発用ライブラリとヘッダファイル
  37. Group: Development/Libraries
  38. Requires: %{name} = %{version}-%{release}
  39. %description devel
  40. C library and header files needed to develop applications using %{name}.
  41. The API documentation can be found ont the project website:
  42. http://www.zint.org.uk/zintSite/Manual.aspx
  43. %package qt
  44. Summary: Zint Barcode Studio GUI and library
  45. Summary(ja): Zintバーコード作成GUI(QT)とライブラリ
  46. Group: Applications/Engineering
  47. Requires: %{name} = %{version}-%{release}
  48. BuildRequires: qt4-devel >= 4.4
  49. BuildRequires: desktop-file-utils
  50. %description qt
  51. Zint Barcode Studio is a Qt-based GUI which allows desktop users to generate
  52. barcodes which can then be embedded in documents or HTML pages, and a library
  53. which can be used to incorporate barcode generation functionality into other
  54. software.
  55. %package qt-devel
  56. Summary: Library and header files for %{name}-qt
  57. Summary(ja): ZintバーコードのGUI(QT)開発用ライブラリとヘッダファイル
  58. Group: Development/Libraries
  59. Requires: %{name}-devel = %{version}-%{release}
  60. Requires: %{name}-qt = %{version}-%{release}
  61. %description qt-devel
  62. C library and header files needed to develop applications using %{name}-qt.
  63. %prep
  64. %setup -q
  65. %patch0 -p 1 -b .qr-kanji
  66. %patch1 -p 1 -b .rpath
  67. # remove BSD-licensed file required for Windows only
  68. # (just to ensure that this package is plain GPLv3+)
  69. rm -f backend/ms_stdint.h
  70. # remove bundled getopt sources (we use the corresponding Fedora package instead)
  71. rm -f frontend/getopt*.*
  72. %build
  73. %cmake CMakeLists.txt
  74. make VERBOSE=1 %{?_smp_mflags}
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. make install DESTDIR=$RPM_BUILD_ROOT
  78. rm -rf $RPM_BUILD_ROOT/%{_datadir}/cmake
  79. cat <<EOF >%{name}-qt.desktop
  80. [Desktop Entry]
  81. Encoding=UTF-8
  82. Name=Zint Barcode Studio
  83. Name[ja]=Zintバーコードスタジオ
  84. Comment=Zint Barcode Studio
  85. Comment[ja]=バーコードを作成するツールです
  86. GenericName=Zint Barcode Studio
  87. Exec=zint-qt
  88. Icon=zint
  89. Terminal=false
  90. Type=Application
  91. Categories=Utility;
  92. EOF
  93. install -D -p -m 644 %{name}.png %{buildroot}/usr/share/pixmaps/%{name}.png
  94. install -D -p -m 644 %{name}-qt.desktop %{buildroot}%{_datadir}/applications/%{name}-qt.desktop
  95. desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}-qt.desktop
  96. %clean
  97. rm -rf $RPM_BUILD_ROOT
  98. %post -p /sbin/ldconfig
  99. %postun -p /sbin/ldconfig
  100. %post qt -p /sbin/ldconfig
  101. %postun qt -p /sbin/ldconfig
  102. %files
  103. %defattr(-,root,root,-)
  104. %doc COPYING readme
  105. %{_bindir}/%{name}
  106. %{_libdir}/libzint.so.*
  107. %files devel
  108. %defattr(-,root,root,-)
  109. %{_includedir}/%{name}.h
  110. %{_libdir}/libzint.so
  111. %files qt
  112. %defattr(-,root,root,-)
  113. %{_bindir}/%{name}-qt
  114. %{_libdir}/libQZint.so.*
  115. %{_datadir}/applications/%{name}-qt.desktop
  116. %{_datadir}/pixmaps/%{name}.png
  117. %files qt-devel
  118. %defattr(-,root,root,-)
  119. %{_includedir}/qzint.h
  120. %{_libdir}/libQZint.so
  121. %changelog
  122. * Sat May 07 2011 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
  123. - updated zint to 2.4.2
  124. - added %{name}-rpath.patch
  125. - added BR: qt4-devel, desktop-file-utils
  126. * Sat Nov 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.4.0-2
  127. - added zint-2.4.0-qr-kanji.patch (BTS:1062)
  128. - install %{name}.png
  129. * Thu Oct 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.4.0-1
  130. - initial build for Vine