ccid-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169
  1. %define dropdir %(pkg-config libpcsclite --variable usbdropdir 2>/dev/null)
  2. %define libusb_ver 0.1.7
  3. %define pcsc_lite_ver 1.3.3
  4. Name: ccid
  5. Version: 1.3.8
  6. Release: 1%{?_dist_release}
  7. Summary: Generic USB CCID smart card reader driver
  8. Summary(ja): Generic USB CCID smart card reader driver
  9. Group: System Environment/Libraries
  10. License: LGPLv2+
  11. URL: http://pcsclite.alioth.debian.org/ccid.html
  12. Source0: http://alioth.debian.org/download.php/1563/%{name}-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: libusb-devel >= %{libusb_ver}
  15. BuildRequires: pcsc-lite-devel >= %{pcsc_lite_ver}
  16. Requires(post): initscripts
  17. Requires(postun): initscripts
  18. Requires: libusb
  19. Requires: pcsc-lite
  20. Provides: pcsc-ifd-handler
  21. # 390 does not have libusb or smartCards
  22. ExcludeArch: s390 s390x
  23. %description
  24. Generic USB CCID (Chip/Smart Card Interface Devices) driver.
  25. %prep
  26. %setup -q
  27. for f in ChangeLog README ; do
  28. iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
  29. done
  30. %build
  31. %configure --disable-dependency-tracking --disable-static --enable-twinserial --enable-udev
  32. make %{?_smp_mflags}
  33. %install
  34. rm -rf $RPM_BUILD_ROOT
  35. make install DESTDIR=$RPM_BUILD_ROOT
  36. #make install_ccidtwin -C src DESTDIR=$RPM_BUILD_ROOT
  37. mv $RPM_BUILD_ROOT%{_sysconfdir}/reader.conf ./GemPCTwin.reader.conf
  38. mv $RPM_BUILD_ROOT/usr/share/doc/ccid/README_Kobil_mIDentity_switch.txt ./
  39. %{__mkdir_p} $RPM_BUILD_ROOT/%{_sysconfdir}/udev/rules.d
  40. %{__install} -m 644 src/pcscd_ccid.rules $RPM_BUILD_ROOT/%{_sysconfdir}/udev/rules.d/85-pcscd_ccid.rules
  41. %clean
  42. rm -rf $RPM_BUILD_ROOT
  43. %post
  44. [ -x %{_initrddir}/pcscd ] && %{_initrddir}/pcscd status >> /dev/null 2>&1 && %{_sbindir}/pcscd -H > /dev/null 2>&1
  45. exit 0
  46. %postun
  47. [ -x %{_initrddir}/pcscd ] && %{_initrddir}/pcscd status >> /dev/null 2>&1 && %{_sbindir}/pcscd -H > /dev/null 2>&1
  48. exit 0
  49. %files
  50. %defattr(-,root,root,-)
  51. %doc AUTHORS ChangeLog COPYING README GemPCTwin.reader.conf README_Kobil_mIDentity_switch.txt
  52. %{dropdir}/ifd-ccid.bundle/
  53. %{dropdir}/serial/
  54. %config %{_sysconfdir}/udev/rules.d/85-pcscd_ccid.rules
  55. %{_bindir}/RSA_SecurID_getpasswd
  56. %{_mandir}/man1/RSA_SecurID_getpasswd.1.gz
  57. %{_mandir}/man8/Kobil_mIDentity_switch.8.gz
  58. %{_sbindir}/Kobil_mIDentity_switch
  59. #%doc /doc/ccid/
  60. %changelog
  61. * Mon Mar 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.8-1
  62. - initial build for Vine Linux
  63. * Tue Aug 26 2008 Bob Relyea <rrelyea@redhat.com> - 1.3.8-1
  64. - update to ccid 1.3.8
  65. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.1-4
  66. - Autorebuild for GCC 4.3
  67. * Fri Aug 20 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-3
  68. - Update License description to the new Fedora standard
  69. * Mon Apr 30 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-2
  70. - Fix the missed use of the version macro
  71. * Tue Feb 06 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-1
  72. - Pick up ccid 1.2.1
  73. - use pcscd 'hotplug' feature instead of restarting the daemon
  74. - add enable_udev
  75. * Mon Nov 06 2006 Bob Relyea <rrelyea@redhat.com> - 1.1.0-2
  76. - Fix version macro to remove '-'
  77. * Thu Nov 02 2006 Bob Relyea <rrelyea@redhat.com> - 1.1.0-1
  78. - Pickup ccid 1.1.0
  79. * Sun Jul 20 2006 Florian La Roche <laroche@redhat.com> - 1.0.1-5
  80. - require initscripts for post/postun
  81. * Sun Jul 16 2006 Florian La Roche <laroche@redhat.com> - 1.0.1-4
  82. - fix excludearch line
  83. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-3.1
  84. - rebuild
  85. * Mon Jul 10 2006 Bob Relyea <rrelyea@redhat.com> - 1.0.1-3
  86. - remove s390 from the build
  87. * Mon Jun 5 2006 Bob Relyea <rrelyea@redhat.com> - 1.0.1-2
  88. - Move to Fedora Core, removed %%{_dist}.
  89. * Sat Apr 22 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.0.1-1
  90. - 1.0.1.
  91. * Mon Mar 6 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.0.0-1
  92. - 1.0.0, license changed to LGPL.
  93. * Wed Feb 15 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-7
  94. - Rebuild.
  95. * Thu Nov 3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-6
  96. - Clean up build dependencies.
  97. - Convert docs to UTF-8.
  98. * Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.4.1-5
  99. - rebuilt
  100. * Fri Feb 25 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-4
  101. - Drop Epoch: 0.
  102. - Improve summary.
  103. - Build with dependency tracking disabled.
  104. * Thu Jul 1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.3
  105. - Restart pcscd in post(un)install phase if it's available and running.
  106. * Thu May 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.2
  107. - Provide pcsc-ifd-handler (idea from Debian).
  108. * Sat Feb 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.1
  109. - Update to 0.4.1.
  110. * Fri Feb 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.0-0.fdr.1
  111. - Update to 0.4.0.
  112. * Wed Nov 5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.2-0.fdr.1
  113. - Update to 0.3.2.
  114. - Update URL.
  115. * Thu Oct 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.1-0.fdr.1
  116. - Update to 0.3.1.
  117. * Wed Sep 10 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.0-0.fdr.1
  118. - Update to 0.3.0.
  119. * Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.2.0-0.fdr.1
  120. - Update to 0.2.0.
  121. * Tue Aug 19 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.1.0-0.fdr.1
  122. - First build.