123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242 |
- %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
- # biarch support
- %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
- %define _query_suffix %{nil}
- %if %{build_compat32}
- %define _query_suffix -32
- %endif
- Name: gdk-pixbuf2
- Version: 2.22.1
- Release: 1%{?_dist_release}
- Summary: An image loading library
- Group: System Environment/Libraries
- License: LGPLv2+
- URL: http://www.gt.org
- Source0: http://download.gnome.org/sources/gdk-pixbuf/2.22/gdk-pixbuf-%{version}.tar.bz2
- BuildRequires: glib2-devel >= 2.26.0
- BuildRequires: libpng-devel
- BuildRequires: libjpeg-turbo-devel
- BuildRequires: libtiff-devel
- BuildRequires: jasper-devel
- BuildRequires: libX11-devel
- BuildRequires: gobject-introspection-devel
- # gdk-pixbuf does a configure time check which uses the GIO mime
- # layer; we need to actually have the mime type database.
- BuildRequires: shared-mime-info
- BuildRequires: gtk-doc
- ## BuildRequires: libtool >= 2.2.10
- BuildRequires: libtool
- BuildRequires: gettext
- # We also need MIME information at runtime
- Requires: shared-mime-info
- # gdk-pixbuf was included in gtk2 until 2.21.2
- Conflicts: gtk2 <= 2.21.2
- # https://bugzilla.gnome.org/show_bug.cgi?id=624712
- Patch0: 0001-Fix-linking-when-libpng-loader-is-builtin.patch
- %description
- gdk-pixbuf is an image loading library that can be extended by loadable
- modules for new image formats. It is used by toolkits such as GTK+ or
- clutter.
- %package devel
- Summary: Development files for gdk-pixbuf
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: glib2-devel
- Requires: gobject-introspection-devel
- Requires: libpng-devel
- # gdk-pixbuf was included in gtk2 until 2.21.2
- Conflicts: gtk2-devel <= 2.21.2
- %description devel
- This package contains the libraries and header files that are needed
- for writing applications that are using gdk-pixbuf.
- %if %{build_compat32}
- #######################################################################
- # compat32
- %package -n compat32-%{name}
- Summary: An image loading library
- Group: System Environment/Libraries
- Requires(post): compat32-glib2 >= %{glib2_version}
- # gdk-pixbuf was included in gtk2 until 2.21.2
- Conflicts: compat32-gtk2 <= 2.21.2
- %description -n compat32-%{name}
- gdk-pixbuf is an image loading library that can be extended by loadable
- modules for new image formats. It is used by toolkits such as GTK+ or
- clutter.
- %package -n compat32-%{name}-devel
- Summary: Development files for gdk-pixbuf
- Group: Development/Libraries
- Requires: compat32-%{name} = %{version}-%{release}
- Requires: %{name} = %{version}-%{release}
- Requires: compat32-libpng-devel
- # gdk-pixbuf was included in gtk2 until 2.21.2
- Conflicts: compat32-gtk2-devel <= 2.21.2
- %description -n compat32-%{name}-devel
- This package contains the libraries and header files that are needed
- for writing applications that are using gdk-pixbuf.
- %endif
- %prep
- %setup -q -n gdk-pixbuf-%{version}
- ## %patch0 -p1 -b .libpng-linking
- %build
- libtoolize --copy --force
- autoreconf
- (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
- %configure $CONFIGFLAGS \
- --with-libjasper \
- --with-included-loaders=png \
- --enable-introspection=yes )
- make %{?_smp_mflags}
- %install
- make install DESTDIR=$RPM_BUILD_ROOT \
- RUN_QUERY_LOADER_TEST=false
- # Remove unpackaged files
- rm $RPM_BUILD_ROOT%{_libdir}/*.la
- rm $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.la
- touch $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
- %if %{build_compat32}
- cp $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders \
- $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
- %endif
- %find_lang gdk-pixbuf
- %post
- /sbin/ldconfig
- gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
- %postun
- /sbin/ldconfig
- if [ $1 -gt 0 ]; then
- gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
- fi
- %if %{build_compat32}
- %post -n compat32-%{name}
- /sbin/ldconfig
- gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
- %postun -n compat32-%{name}
- /sbin/ldconfig
- if [ $1 -gt 0 ]; then
- gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
- fi
- %endif
- %files -f gdk-pixbuf.lang
- %defattr(-,root,root,-)
- %doc AUTHORS COPYING NEWS
- %{_libdir}/libgdk_pixbuf-2.0.so.*
- %{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
- %{_libdir}/girepository-1.0
- %dir %{_libdir}/gdk-pixbuf-2.0
- %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
- %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
- %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
- %ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
- %{_bindir}/gdk-pixbuf-query-loaders
- %{_mandir}/man1/gdk-pixbuf-query-loaders.1.gz
- %files devel
- %defattr(-,root,root,-)
- %{_includedir}/gdk-pixbuf-2.0
- %{_libdir}/libgdk_pixbuf-2.0.so
- %{_libdir}/libgdk_pixbuf_xlib-2.0.so
- %{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
- %{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
- %{_bindir}/gdk-pixbuf-csource
- %{_datadir}/gtk-doc/html/*
- %{_datadir}/gir-1.0
- %{_mandir}/man1/gdk-pixbuf-csource.1.gz
- %if %{build_compat32}
- %files -n compat32-%{name}
- %defattr(-,root,root,-)
- %{_libdir}/libgdk_pixbuf-2.0.so.*
- %{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
- %dir %{_libdir}/gdk-pixbuf-2.0
- %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
- %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
- %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
- %ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
- %{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
- %files -n compat32-%{name}-devel
- %defattr(-,root,root,-)
- %{_libdir}/libgdk_pixbuf-2.0.so
- %{_libdir}/libgdk_pixbuf_xlib-2.0.so
- %{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
- %{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
- %endif
- %changelog
- * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.1-1
- - new upstream release
- * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
- - new upstream release
- - add configure option (--enable-introspection=yes)
- - drop Patch0
- * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.3-1
- - initial build for Vine Linux
- * Mon Jul 19 2010 Bastien Nocera <bnocera@redhat.com> 2.21.6-3
- - Require libpng for linking
- * Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 2.21.6-2
- - Rebuild with new gobject-introspection
- * Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> - 2.21.6-1
- - Update to 2.21.6
- * Fri Jul 2 2010 Colin Walters <walters@verbum.org> - 2.21.5-4
- - Also Require shared-mime-info for same reason
- * Fri Jul 2 2010 Colin Walters <walters@verbum.org> - 2.21.5-3
- - BR shared-mime-info; see comment above it
- * Tue Jun 29 2010 Colin Walters <walters@pocket> - 2.21.5-2
- - Changes to support snapshot builds
- * Mon Jun 28 2010 Matthias Clasen <mclasen@redhat.com> 2.21.5-1
- - Update to 2.21.5
- * Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-2
- - Rename to gdk-pixbuf2 to avoid conflict with the
- existing gdk-pixbuf package
- * Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-1
- - Update to 2.21.4
- - Incorporate package review feedback
- * Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.3-1
- - Initial packaging
|