gnokii-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473
  1. # TODO: merge patches upstream where applicable
  2. Name: gnokii
  3. Version: 0.6.27
  4. Release: 7%{?_dist_release}
  5. Summary: Linux/Unix tool suite for various mobile phones
  6. Summary(ja): Linux/Unix tool suite for various mobile phones
  7. Group: Applications/Communications
  8. License: GPLv2+
  9. URL: http://www.gnokii.org/
  10. Source0: http://www.gnokii.org/download/gnokii/%{name}-%{version}.tar.bz2
  11. #----------------------------------------------------------------------------
  12. Source2: gnokii-smsd.init
  13. Source3: gnokii-smsd.sysconfig
  14. Source4: gnokii-smsd.logrotate
  15. Source5: gnokii-smsd2mail.sh
  16. Source6: gnokii-smsd-README.smsd2mail
  17. # Patch to make gnokii use "htmlview" instead of "mozilla" as default browser
  18. Patch0: gnokii-htmlview.patch
  19. # Patch to remove port locking and apply the system-wide /usr/sbin directory
  20. # to the path instead of the default /usr/local
  21. Patch1: gnokii-config.patch
  22. #----------------------------------------------------------------------------
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. #----------------------------------------------------------------------------
  25. BuildRequires: flex
  26. BuildRequires: gettext
  27. BuildRequires: gtk2-devel
  28. BuildRequires: desktop-file-utils
  29. BuildRequires: ImageMagick
  30. BuildRequires: postgresql-devel
  31. BuildRequires: mysql-devel
  32. BuildRequires: zlib-devel
  33. BuildRequires: bluez-libs-devel
  34. BuildRequires: libusb-devel
  35. BuildRequires: readline-devel
  36. BuildRequires: libical-devel >= 0.24
  37. # VineSeed
  38. BuildRequires: libXt-devel
  39. BuildRequires: libXpm-devel
  40. ## VineLinux-4.x
  41. ## BuildRequires: XOrg, XOrg-libs, XOrg-sdk
  42. BuildRequires: perl(XML::Parser)
  43. Requires(pre): %{_sbindir}/groupadd
  44. #----------------------------------------------------------------------------
  45. %description
  46. Gnokii provides tools and a user space driver for use with mobile
  47. phones under Linux, various unices and Win32. With gnokii you can do
  48. such things as make data calls, update your address book, change
  49. calendar entries, send and receive SMS messages and load ring tones
  50. depending on the phone you have.
  51. #----------------------------------------------------------------------------
  52. %package -n xgnokii
  53. Summary: Graphical Linux/Unix tool suite for various mobile phones
  54. Group: Applications/Communications
  55. Requires: %{name} = %{version}-%{release}
  56. %description -n xgnokii
  57. Xgnokii is graphical Linux/Unix tool suite for various mobile
  58. phones. It allows you to edit your contacts book, send/read SMS's
  59. from/in computer and more other features.
  60. #----------------------------------------------------------------------------
  61. %package smsd
  62. Summary: Gnokii SMS daemon
  63. Group: System Environment/Daemons
  64. Requires: %{name} = %{version}-%{release}
  65. Requires(pre): %{_sbindir}/useradd
  66. Requires(post): /sbin/chkconfig
  67. Requires(preun): /sbin/chkconfig
  68. %description smsd
  69. The Gnokii SMS daemon receives and sends SMS messages.
  70. #----------------------------------------------------------------------------
  71. %package smsd-pgsql
  72. Summary: PostgreSQL support for Gnokii SMS daemon
  73. Group: System Environment/Daemons
  74. Requires: %{name}-smsd = %{version}-%{release}
  75. Obsoletes: %{name}-smsd-postgresql < 0.6.4-0.lvn.2
  76. %description smsd-pgsql
  77. %{summary}.
  78. #----------------------------------------------------------------------------
  79. %package smsd-mysql
  80. Summary: MySQL support for Gnokii SMS daemon
  81. Group: System Environment/Daemons
  82. Requires: %{name}-smsd = %{version}-%{release}
  83. %description smsd-mysql
  84. %{summary}.
  85. #----------------------------------------------------------------------------
  86. %package devel
  87. Summary: Gnokii development files
  88. Group: Development/Libraries
  89. Requires: %{name} = %{version}-%{release}
  90. Requires: pkgconfig
  91. %description devel
  92. %{summary}.
  93. #----------------------------------------------------------------------------
  94. %prep
  95. %setup -q
  96. %patch0 -p0
  97. %patch1 -p0
  98. install -pm 644 %{SOURCE5} smsd2mail.sh
  99. install -pm 644 %{SOURCE6} README.smsd2mail
  100. %build
  101. %configure --enable-security --disable-rpath --disable-static \
  102. --enable-libical
  103. make %{?_smp_mflags}
  104. #----------------------------------------------------------------------------
  105. %install
  106. make install DESTDIR=$RPM_BUILD_ROOT
  107. # Rename smsd to gnokii-smsd
  108. mv $RPM_BUILD_ROOT%{_bindir}/{,gnokii-}smsd
  109. mv $RPM_BUILD_ROOT%{_mandir}/man8/{,gnokii-}smsd.8
  110. sed -i 's,smsd ,gnokii-smsd ,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
  111. sed -i 's,smsd.,gnokii-smsd.,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
  112. # Remove libtool droppings
  113. rm $RPM_BUILD_ROOT%{_libdir}{,/smsd}/lib*.la
  114. # Fix up the default desktop file
  115. desktop-file-install \
  116. --delete-original \
  117. --vendor "" \
  118. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  119. --mode 644 \
  120. --add-category X-VineLinux \
  121. $RPM_BUILD_ROOT%{_datadir}/applications/xgnokii.desktop
  122. # Convert the default icons to PNG
  123. install -dm 755 $RPM_BUILD_ROOT%{_datadir}/pixmaps
  124. convert Docs/sample/logo/gnokii.xpm \
  125. $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
  126. chmod 644 $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
  127. # Install the configuration files
  128. install -Dpm 755 %{SOURCE2} $RPM_BUILD_ROOT%{_initrddir}/gnokii-smsd
  129. install -Dpm 640 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/gnokii-smsd
  130. install -Dpm 644 %{SOURCE4} \
  131. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/gnokii-smsd
  132. cp -a Docs/sample/gnokiirc $RPM_BUILD_ROOT%{_sysconfdir}/
  133. # Install the docs
  134. mkdir -p temporary-gnokii-docs/
  135. mv $RPM_BUILD_ROOT%{_datadir}/doc/gnokii/ temporary-gnokii-docs/
  136. %find_lang %{name}
  137. %clean
  138. rm -rf $RPM_BUILD_ROOT
  139. #----------------------------------------------------------------------------
  140. %pre
  141. %{_sbindir}/groupadd -r gnokii >/dev/null 2>&1 || :
  142. %pre smsd
  143. %{_sbindir}/useradd -r -M -d / -g gnokii \
  144. -s /sbin/nologin -c "Gnokii system user" gnokii >/dev/null 2>&1 || :
  145. %post -p /sbin/ldconfig
  146. %postun -p /sbin/ldconfig
  147. %post smsd
  148. /sbin/chkconfig --add gnokii-smsd
  149. %preun smsd
  150. if [ $1 -eq 0 ] ; then
  151. %{_initrddir}/gnokii-smsd stop >/dev/null 2>&1 || :
  152. /sbin/chkconfig --del gnokii-smsd
  153. fi
  154. %postun smsd
  155. if [ $1 -ge 1 ] ; then
  156. %{_initrddir}/gnokii-smsd try-restart >/dev/null 2>&1 || :
  157. fi
  158. #----------------------------------------------------------------------------
  159. %files -f %{name}.lang
  160. %defattr(-,root,root,-)
  161. %doc ChangeLog COPY* MAINTAINERS TODO temporary-gnokii-docs/*
  162. %config(noreplace) %{_sysconfdir}/gnokiirc
  163. %attr(4750,root,gnokii) %{_sbindir}/mgnokiidev
  164. %{_bindir}/gnokii
  165. %{_bindir}/sendsms
  166. %{_bindir}/gnokiid
  167. %{_libdir}/libgnokii.so.*
  168. %{_mandir}/man1/gnokii.1*
  169. %{_mandir}/man1/sendsms.1*
  170. %{_mandir}/man8/gnokiid.8*
  171. %{_mandir}/man8/mgnokiidev.8*
  172. %files -n xgnokii
  173. %defattr(-,root,root,-)
  174. %doc xgnokii/ChangeLog xgnokii/README.vcard
  175. %{_bindir}/xgnokii
  176. %{_datadir}/pixmaps/xgnokii.png
  177. %{_datadir}/applications/*xgnokii.desktop
  178. %{_mandir}/man1/xgnokii.1*
  179. %{_prefix}/share/xgnokii/
  180. %files smsd
  181. %defattr(-,root,root,-)
  182. %doc smsd/action smsd/ChangeLog smsd/README README.smsd2mail smsd2mail.sh
  183. %attr(-,gnokii,gnokii) %config(noreplace) %{_sysconfdir}/sysconfig/gnokii-smsd
  184. %config(noreplace) %{_sysconfdir}/logrotate.d/gnokii-smsd
  185. %{_initrddir}/gnokii-smsd
  186. %{_bindir}/gnokii-smsd
  187. %{_mandir}/man8/gnokii-smsd.8*
  188. %dir %{_libdir}/smsd/
  189. %{_libdir}/smsd/libsmsd_file.so
  190. %files smsd-pgsql
  191. %defattr(-,root,root,-)
  192. %doc smsd/sms.tables.pq.sql
  193. %{_libdir}/smsd/libsmsd_pq.so
  194. %files smsd-mysql
  195. %defattr(-,root,root,-)
  196. %doc smsd/sms.tables.mysql.sql
  197. %{_libdir}/smsd/libsmsd_mysql.so
  198. %files devel
  199. %defattr(-,root,root,-)
  200. %{_includedir}/gnokii*
  201. %{_libdir}/libgnokii.so
  202. %{_libdir}/pkgconfig/gnokii.pc
  203. %{_libdir}/pkgconfig/xgnokii.pc
  204. #----------------------------------------------------------------------------
  205. # Maintainers: babasaki@mindgear.org
  206. #
  207. #----------------------------------------------------------------------------
  208. %changelog
  209. * Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.27-7
  210. - add BuildRequires: readline-devel
  211. * Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 0.6.27-6
  212. - rebuilt with postgresql-9.0.3
  213. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.27-5
  214. - rebuilt with rpm-4.8.1 for pkg-config
  215. * Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.27-4
  216. - rebuilt with MySQL-5.1.34.
  217. * Mon Oct 27 2008 Seiichirou Babasaki - 0.6.27-3
  218. - Import gnokii - Packager: Babasaki
  219. - Updated specfile
  220. #----------------------------------------------------------------------------
  221. * Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-2
  222. - Fix htmlview patch
  223. * Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-1
  224. - Update to 0.6.27
  225. * Thu Sep 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-3
  226. - Rebuild
  227. * Thu Jun 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-2
  228. - Rebuild with libical support
  229. * Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-1
  230. - Update to 0.6.26
  231. * Fri May 23 2008 Robert Scheck <robert@fedoraproject.org> 0.6.25-2
  232. - Set empty --vendor rather none for using desktop-file-install
  233. - Fixed initscript as gnokii-smsd stays in /usr/bin not /usr/sbin
  234. * Mon May 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.25-1
  235. - Update to 0.6.25
  236. * Thu Mar 20 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.24-1
  237. - Update to 0.6.24
  238. * Mon Feb 11 2008 - Linus Walleij <triad@df.lth.se> - 0.6.22-3
  239. - Rebuild for GCC 4.3.
  240. * Thu Dec 6 2007 - Linus Walleij <triad@df.lth.se> - 0.6.22-2
  241. - Pick up new libssl .solib version dependency.
  242. * Thu Nov 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.22-1
  243. - Update to 0.6.22
  244. * Thu Nov 01 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.20-1
  245. - Update to 0.6.20
  246. * Sun Oct 28 2007 Jeremy Katz <katzj@redhat.com> - 0.6.18-3
  247. - Even better multilib fixing (#335161)
  248. * Tue Oct 23 2007 - Jeremy Katz <katzj@redhat.com> - 0.6.18-2
  249. - Quick fix to multilib conflict (#335161)
  250. * Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.18-1
  251. - New upstream release
  252. * Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.17-2
  253. - Update license field from GPL to GPLv2+
  254. * Wed Jul 04 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.17-1
  255. - New upstream release
  256. * Mon Jul 02 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.16-1
  257. - New upstream release
  258. - Update smsd name change patch
  259. - ppm2nokia, waitcall and todologo have moved to gnokii-extras, as per
  260. upstream
  261. * Wed Dec 06 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-3
  262. - Rebuild to pick up new libpq IF
  263. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.6.14-2
  264. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  265. * Sat Sep 23 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-1
  266. - New upstream release.
  267. * Tue Aug 29 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-3
  268. - Rebuild for Fedora Extras 6.
  269. * Fri Aug 11 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-2
  270. - Bump because tagged before committing sources and I just
  271. dont know how the f* you delete a tag in CVS at the moment
  272. and it does seem like a too big endavour to find out just
  273. in order to have a nice release tag.
  274. * Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-1
  275. - New upstream release.
  276. - New dependency on libusb for USB serial, DKU no longer needed/wanted
  277. so now we have that troublesome issue resolved once and for all.
  278. - Remove patches to SQL files: these are now fixed upstream!
  279. * Mon Jun 12 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
  280. - Rebuilding due to changed interface on libbluetooth.
  281. * Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
  282. - Goofed up. Fixit it...
  283. * Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-3
  284. - Post-import updates.
  285. * Thu Mar 31 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-2
  286. - Updated after comments from Ville.
  287. * Thu Mar 16 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-1
  288. - New upstream tarball
  289. * Wed Mar 8 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-2
  290. - Updated after comments from Ville.
  291. * Sun Mar 5 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-1
  292. - 0.6.11
  293. - Modified to drop into the Fedora Extras as the nice package it now is
  294. - Based work off Ville's good olde package
  295. * Sun Nov 13 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.10-0.lvn.1
  296. - 0.6.10.
  297. - Clean up pkgconfig file and -devel dependencies from bits needed only
  298. for static libs.
  299. * Thu Nov 3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.9-0.lvn.1
  300. - 0.6.9, desktop entry file included upstream.
  301. - Drop zero Epochs.
  302. * Sat Aug 6 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.lvn.1
  303. - 0.6.8.
  304. - Don't ship static libraries.
  305. - Rename smsd to gnokii-smsd to avoid conflicts with smstools.
  306. - Remove not included files instead of using %%exclude.
  307. * Sat Jun 4 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.2
  308. - BuildRequire openssl-devel to work around https://bugzilla.redhat.com/159569
  309. * Thu Jun 2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.1
  310. - 0.6.7.
  311. - Build unconditionally with bluetooth support.
  312. * Mon May 2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.5-0.lvn.1
  313. - 0.6.5.
  314. * Fri Nov 5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.2
  315. - Rename -smsd-postgresql to -smsd-pgsql for consistency with other similar
  316. packages in FC/Extras.
  317. * Fri Oct 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.1
  318. - Update to 0.6.4, perms and pgsql patches applied upstream.
  319. - Xgnokii help locale symlink hack no longer necessary.
  320. - Don't remove user/group on last erase, move smsd user to -smsd subpackage.
  321. - Add libical support (disabled), rebuild with "--with libical" to enable.
  322. * Mon Jul 5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.3-0.lvn.1
  323. - Update to 0.6.3.
  324. * Sun Jun 20 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.4
  325. - Improve Xgnokii desktop entry according to GNOME HIG.
  326. * Sun Jun 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.3
  327. - Remove duplicate gettext build dependency (bug 95).
  328. * Sun Jun 6 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.2
  329. - Fix chown syntax in smsd init script.
  330. - Summary and description improvements.
  331. - Trim $RPM_OPT_FLAGS out from gnokii.pc.
  332. - Make -devel require XFree86-devel.
  333. * Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.1
  334. - Update to 0.6.1.
  335. * Thu Mar 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.2
  336. - Make -devel require pkgconfig.
  337. * Mon Feb 23 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.1
  338. - Update to 0.6.0.
  339. * Mon Feb 2 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.10-0.lvn.1
  340. - Update to 0.5.10.
  341. * Tue Jan 27 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.9-0.lvn.1
  342. - Update to 0.5.9.
  343. - Specfile cleanups, small init script enhancements.
  344. * Sat Dec 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.7-0.lvn.1
  345. - Update to 0.5.7.
  346. - Move smsd man page into -smsd subpackage.
  347. * Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.6-0.lvn.1
  348. - Update to 0.5.6.
  349. - Include sample action script for forwarding SMSD messages to mail.
  350. - s/fedora/livna/.
  351. - Specfile and init script cleanups.
  352. * Sat Jul 19 2003 Warren Togami <warren@togami.com> - 0:0.5.2-0.fdr.2
  353. - Disable smp flags to prevent build failure
  354. * Sun Jun 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.2-0.fdr.1
  355. - Update to 0.5.2.
  356. * Thu May 29 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.1-0.fdr.1
  357. - Update to 0.5.1.
  358. - Include init script, sysconfig and logrotate config for smsd.
  359. * Tue May 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.0-0.fdr.1
  360. - Update to 0.5.0.
  361. * Sun Nov 3 2002 Ville Skyttä <ville.skytta at iki.fi> 0.4.3-1cr
  362. - RedHat'ified PLD version.