php-ext-clearsilver-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378
  1. %bcond_with php5
  2. %bcond_with php74
  3. %bcond_without php81
  4. %bcond_without php82
  5. %define modname clearsilver
  6. Summary: ClearSilver extension for PHP
  7. Summary(ja): PHP用ClearSilverモジュール
  8. Name: php-ext-%{modname}
  9. Version: 0.4
  10. Release: 18%{_dist_release}
  11. Group: programming
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Packager: tomop
  15. License: The PHP License
  16. URL: http://www.geodata.soton.ac.uk/software/php_clearsilver/
  17. Source: php-%{modname}-%{version}.tar.gz
  18. Patch0: php-clearsilver-0.4-php5.6.0.patch
  19. Patch2: php-clearsilver-0.4-php7.2.0.patch
  20. Patch3: php-clearsilver-0.4-php8.0.0.patch
  21. BuildRequires: clearsilver, zlib-devel
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. %description
  24. This module adds ClearSilver functions to PHP.
  25. %description -l ja
  26. このモジュールはPHPにClearSilverテンプレート機能を追加します。
  27. %if %{with php5}
  28. %package -n php5-ext-%{modname}
  29. Summary: ClearSilver extension for PHP-5.6.x
  30. Summary(ja): PHP-5.6用ClearSilverモジュール
  31. Group: programming
  32. BuildRequires: php5-devel
  33. %if "%{?req_php5_api}" != ""
  34. Requires: %{req_php5_api}
  35. %endif
  36. Obsoletes: php-ext-clearsilver < 0.4-7
  37. %description -n php5-ext-%{modname}
  38. This module adds ClearSilver functions to PHP.
  39. %description -n php5-ext-%{modname} -l ja
  40. このモジュールはPHPにClearSilverテンプレート機能を追加します。
  41. %endif
  42. %if %{with php74}
  43. %package -n php74-ext-%{modname}
  44. Summary: ClearSilver extension for PHP-7.4
  45. Summary(ja): PHP-7.4用ClearSilverモジュール
  46. Group: programming
  47. BuildRequires: php74-devel
  48. %if "%{?req_php74_api}" != ""
  49. Requires: %{req_php74_api}
  50. %endif
  51. %description -n php74-ext-%{modname}
  52. This module adds ClearSilver functions to PHP.
  53. %description -n php74-ext-%{modname} -l ja
  54. このモジュールはPHPにClearSilverテンプレート機能を追加します。
  55. %endif
  56. %if %{with php82}
  57. %package -n php82-ext-%{modname}
  58. Summary: ClearSilver extension for PHP-8.2
  59. Summary(ja): PHP-8.2用ClearSilverモジュール
  60. Group: programming
  61. BuildRequires: php82-devel
  62. %if "%{?req_php82_api}" != ""
  63. Requires: %{req_php82_api}
  64. %endif
  65. %description -n php82-ext-%{modname}
  66. This module adds ClearSilver functions to PHP.
  67. %description -n php82-ext-%{modname} -l ja
  68. このモジュールはPHPにClearSilverテンプレート機能を追加します。
  69. %endif
  70. %if %{with php81}
  71. %package -n php81-ext-%{modname}
  72. Summary: ClearSilver extension for PHP-8.1
  73. Summary(ja): PHP-8.1用ClearSilverモジュール
  74. Group: programming
  75. BuildRequires: php81-devel
  76. %if "%{?req_php81_api}" != ""
  77. Requires: %{req_php81_api}
  78. %endif
  79. %description -n php81-ext-%{modname}
  80. This module adds ClearSilver functions to PHP.
  81. %description -n php81-ext-%{modname} -l ja
  82. このモジュールはPHPにClearSilverテンプレート機能を追加します。
  83. %endif
  84. %debug_package
  85. %prep
  86. %setup -q -c -n php-%{modname}-%{version}
  87. cp -a php-%{modname}-%{version}/{CREDITS,INSTALL,LICENSE,README,doc} ./
  88. %if %{with php5}
  89. cp -a php-clearsilver-%{version} php-clearsilver-%{version}-php5
  90. pushd php-clearsilver-%{version}-php5
  91. %patch0 -p1 -b .php56
  92. popd
  93. %endif
  94. %if %{with php74}
  95. cp -a php-clearsilver-%{version} php-clearsilver-%{version}-php74
  96. pushd php-clearsilver-%{version}-php74
  97. %patch0 -p1 -b .php56
  98. %patch2 -p1 -b .php72
  99. popd
  100. %endif
  101. %if %{with php82}
  102. cp -a php-clearsilver-%{version} php-clearsilver-%{version}-php82
  103. pushd php-clearsilver-%{version}-php82
  104. %patch3 -p1 -b .php80
  105. popd
  106. %endif
  107. %if %{with php81}
  108. cp -a php-clearsilver-%{version} php-clearsilver-%{version}-php81
  109. pushd php-clearsilver-%{version}-php81
  110. %patch3 -p1 -b .php80
  111. popd
  112. %endif
  113. %build
  114. export CFLAGS="%{optflags} -Wno-format-security"
  115. %if %{with php5}
  116. pushd php-clearsilver-%{version}-php5
  117. phpize5
  118. aclocal
  119. autoreconf -vif
  120. %configure --with-php-config=/usr/bin/php-config5
  121. %__make %{_smp_mflags}
  122. popd
  123. %endif
  124. %if %{with php74}
  125. pushd php-clearsilver-%{version}-php74
  126. phpize74
  127. aclocal
  128. %configure --with-php-config=/usr/bin/php-config74
  129. %__make %{_smp_mflags}
  130. popd
  131. %endif
  132. %if %{with php82}
  133. pushd php-clearsilver-%{version}-php82
  134. phpize82
  135. aclocal
  136. %configure --with-php-config=/usr/bin/php-config82
  137. %__make %{_smp_mflags}
  138. popd
  139. %endif
  140. %if %{with php81}
  141. pushd php-clearsilver-%{version}-php81
  142. phpize81
  143. aclocal
  144. %configure --with-php-config=/usr/bin/php-config81
  145. %__make %{_smp_mflags}
  146. popd
  147. %endif
  148. %install
  149. rm -rf %{buildroot}
  150. %if %{with php5}
  151. pushd php-clearsilver-%{version}-php5
  152. mkdir -p %{buildroot}%{_libdir}/php5/
  153. mkdir -p %{buildroot}%{_sysconfdir}/php5/php.d
  154. install -m755 modules/%{modname}.so %{buildroot}%{_libdir}/php5/
  155. cat > %{buildroot}%{_sysconfdir}/php5/php.d/%{modname}.ini <<EOF
  156. ; Enable %{modname} extension module
  157. extension=%{modname}.so
  158. EOF
  159. popd
  160. %endif
  161. %if %{with php74}
  162. pushd php-clearsilver-%{version}-php74
  163. mkdir -p %{buildroot}%{_libdir}/php74/
  164. mkdir -p %{buildroot}%{_sysconfdir}/php74/php.d
  165. install -m755 modules/%{modname}.so %{buildroot}%{_libdir}/php74/
  166. cat > %{buildroot}%{_sysconfdir}/php74/php.d/%{modname}.ini <<EOF
  167. ; Enable %{modname} extension module
  168. extension=%{modname}.so
  169. EOF
  170. popd
  171. %endif
  172. %if %{with php82}
  173. pushd php-clearsilver-%{version}-php82
  174. mkdir -p %{buildroot}%{_libdir}/php82/
  175. mkdir -p %{buildroot}%{_sysconfdir}/php82/php.d
  176. install -m755 modules/%{modname}.so %{buildroot}%{_libdir}/php82/
  177. cat > %{buildroot}%{_sysconfdir}/php82/php.d/%{modname}.ini <<EOF
  178. ; Enable %{modname} extension module
  179. extension=%{modname}.so
  180. EOF
  181. popd
  182. %endif
  183. %if %{with php81}
  184. pushd php-clearsilver-%{version}-php81
  185. mkdir -p %{buildroot}%{_libdir}/php81/
  186. mkdir -p %{buildroot}%{_sysconfdir}/php81/php.d
  187. install -m755 modules/%{modname}.so %{buildroot}%{_libdir}/php81/
  188. cat > %{buildroot}%{_sysconfdir}/php81/php.d/%{modname}.ini <<EOF
  189. ; Enable %{modname} extension module
  190. extension=%{modname}.so
  191. EOF
  192. popd
  193. %endif
  194. %check
  195. %if %{with php5}
  196. pushd php-clearsilver-%{version}-php5
  197. make test NO_INTERACTION=1
  198. popd
  199. %endif
  200. %if %{with php74}
  201. pushd php-clearsilver-%{version}-php74
  202. make test TEST_PHPDBG_EXECUTABLE=/usr/bin/phpdbg74 NO_INTERACTION=1
  203. popd
  204. %endif
  205. %if %{with php82}
  206. pushd php-clearsilver-%{version}-php82
  207. make test TEST_PHPDBG_EXECUTABLE=/usr/bin/phpdbg82 NO_INTERACTION=1
  208. popd
  209. %endif
  210. %if %{with php81}
  211. pushd php-clearsilver-%{version}-php81
  212. make test TEST_PHPDBG_EXECUTABLE=/usr/bin/phpdbg81 NO_INTERACTION=1
  213. popd
  214. %endif
  215. %clean
  216. rm -rf %{buildroot}
  217. %if %{with php5}
  218. %files -n php5-ext-%{modname}
  219. %defattr(-,root,root)
  220. %doc CREDITS INSTALL LICENSE README doc
  221. %{_libdir}/php5/*
  222. %{_sysconfdir}/php5/php.d/*
  223. %endif
  224. %if %{with php74}
  225. %files -n php74-ext-%{modname}
  226. %defattr(-,root,root)
  227. %doc CREDITS INSTALL LICENSE README doc
  228. %{_libdir}/php74/*
  229. %{_sysconfdir}/php74/php.d/*
  230. %endif
  231. %if %{with php82}
  232. %files -n php82-ext-%{modname}
  233. %defattr(-,root,root)
  234. %doc CREDITS INSTALL LICENSE README doc
  235. %{_libdir}/php82/*
  236. %{_sysconfdir}/php82/php.d/*
  237. %endif
  238. %if %{with php81}
  239. %files -n php81-ext-%{modname}
  240. %defattr(-,root,root)
  241. %doc CREDITS INSTALL LICENSE README doc
  242. %{_libdir}/php81/*
  243. %{_sysconfdir}/php81/php.d/*
  244. %endif
  245. %changelog
  246. * Fri Mar 17 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-18
  247. - added php82 support.
  248. - dropped php80 support.
  249. - disabled php74 support.
  250. * Fri Nov 26 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-17
  251. - added php81 support.
  252. * Sat Dec 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-16
  253. - added php80 support.
  254. - dropped php73 support.
  255. * Thu Dec 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-15
  256. - added php74 support.
  257. * Wed Sep 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-14
  258. - disabled php5/php72 support.
  259. * Sat Dec 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-13
  260. - added php73 support.
  261. * Fri Dec 22 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-12
  262. - updated Patch0.
  263. - updated Patch2.
  264. - dropped Patch1: included in Patch0.
  265. - enabled %%check.
  266. * Thu Dec 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-11
  267. - updated Patch2.
  268. * Tue Dec 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-10
  269. - dropped support for php71.
  270. - added support for php72.
  271. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-9
  272. - added support for php71.
  273. * Thu Nov 5 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-8
  274. - fixed summary.
  275. - fixed php70 stuff.
  276. * Thu Nov 5 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-7
  277. - added CGI functions.
  278. - added support for php70.
  279. * Fri Apr 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-6
  280. - rebuilt with php5-5.6.7.
  281. * Thu Jan 09 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-5
  282. - rebuilt with current environment.
  283. * Tue Jun 25 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-4
  284. - added a patch for PHP 5.5.0.
  285. * Sun Apr 29 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-3
  286. - converted encoding to UTF-8.
  287. * Sat Apr 28 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-2
  288. - added an API version macro to "Requires:".
  289. * Sat Dec 12 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4-1
  290. - new upstream release.
  291. * Fri Jul 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.1-2
  292. - fixed for php-5.3.0.
  293. * Mon Apr 28 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.1-1
  294. - initial build.