php-ext-mailparse-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251
  1. %bcond_without php82
  2. %bcond_without php81
  3. %bcond_with php74
  4. %define extname mailparse
  5. Summary: Email message manipulation for PHP
  6. Summary(ja): PHP用e-mailメッセージ操作拡張
  7. Name: php-ext-%{extname}
  8. Version: 3.1.4
  9. Release: 1%{_dist_release}
  10. Group: programming
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Packager: tomop
  14. License: The PHP License
  15. URL: https://pecl.php.net/package/mailparse
  16. Source: https://pecl.php.net/get/%{extname}-%{version}.tgz
  17. %description
  18. Mailparse is an extension for parsing and working with email messages.
  19. It can deal with rfc822 and rfc2045 (MIME) compliant messages.
  20. %description -l ja
  21.  Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
  22. rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
  23. %if %{with php74}
  24. %package -n php74-ext-mailparse
  25. Summary: Email message manipulation for PHP-7.4
  26. Summary(ja): PHP-7.4用e-mailメッセージ操作拡張
  27. Group: programming
  28. BuildRequires: php74-devel
  29. %if "%{?req_php74_api}" != ""
  30. Requires: %{req_php74_api}
  31. %endif
  32. %description -n php74-ext-mailparse
  33. Mailparse is an extension for parsing and working with email messages.
  34. It can deal with rfc822 and rfc2045 (MIME) compliant messages.
  35. %description -n php74-ext-mailparse -l ja
  36.  Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
  37. rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
  38. %endif
  39. %if %{with php82}
  40. %package -n php82-ext-mailparse
  41. Summary: Email message manipulation for PHP-8.2
  42. Summary(ja): PHP-8.2用e-mailメッセージ操作拡張
  43. Group: programming
  44. BuildRequires: php82-devel
  45. %if "%{?req_php82_api}" != ""
  46. Requires: %{req_php82_api}
  47. %endif
  48. %description -n php82-ext-mailparse
  49. Mailparse is an extension for parsing and working with email messages.
  50. It can deal with rfc822 and rfc2045 (MIME) compliant messages.
  51. %description -n php82-ext-mailparse -l ja
  52.  Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
  53. rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
  54. %endif
  55. %if %{with php81}
  56. %package -n php81-ext-mailparse
  57. Summary: Email message manipulation for PHP-8.0
  58. Summary(ja): PHP-8.1用e-mailメッセージ操作拡張
  59. Group: programming
  60. BuildRequires: php81-devel
  61. %if "%{?req_php81_api}" != ""
  62. Requires: %{req_php81_api}
  63. %endif
  64. %description -n php81-ext-mailparse
  65. Mailparse is an extension for parsing and working with email messages.
  66. It can deal with rfc822 and rfc2045 (MIME) compliant messages.
  67. %description -n php81-ext-mailparse -l ja
  68.  Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
  69. rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
  70. %endif
  71. %debug_package
  72. %prep
  73. %setup -q -c -n %{extname}-%{version}
  74. cp %{extname}-%{version}/{LICENSE,README.md,CREDITS} ./
  75. %if %{with php74}
  76. cp -a %{extname}-%{version} php74
  77. pushd php74
  78. phpize74
  79. popd
  80. %endif
  81. %if %{with php82}
  82. cp -a %{extname}-%{version} php82
  83. pushd php82
  84. phpize82
  85. popd
  86. %endif
  87. %if %{with php81}
  88. cp -a %{extname}-%{version} php81
  89. pushd php81
  90. phpize81
  91. popd
  92. %endif
  93. %build
  94. %if %{with php74}
  95. pushd php74
  96. %configure --with-php-config=%{_bindir}/php-config74
  97. %__make %{?_smp_mflags}
  98. popd
  99. %endif
  100. %if %{with php82}
  101. pushd php82
  102. %configure --with-php-config=%{_bindir}/php-config82
  103. %__make %{?_smp_mflags}
  104. popd
  105. %endif
  106. %if %{with php81}
  107. pushd php81
  108. %configure --with-php-config=%{_bindir}/php-config81
  109. %__make %{?_smp_mflags}
  110. popd
  111. %endif
  112. %install
  113. rm -rf %{buildroot}
  114. %if %{with php74}
  115. mkdir -p %{buildroot}%{_libdir}/php74/
  116. mkdir -p %{buildroot}%{_sysconfdir}/php74/php.d
  117. pushd php74
  118. %makeinstall INSTALL_ROOT=%{buildroot}
  119. popd
  120. cat > %{buildroot}%{_sysconfdir}/php74/php.d/%{extname}.ini <<EOF
  121. ; Enable %{extname} extension module
  122. extension=%{extname}.so
  123. EOF
  124. %endif
  125. %if %{with php82}
  126. mkdir -p %{buildroot}%{_libdir}/php82/
  127. mkdir -p %{buildroot}%{_sysconfdir}/php82/php.d
  128. pushd php82
  129. %makeinstall INSTALL_ROOT=%{buildroot}
  130. popd
  131. cat > %{buildroot}%{_sysconfdir}/php82/php.d/%{extname}.ini <<EOF
  132. ; Enable %{extname} extension module
  133. extension=%{extname}.so
  134. EOF
  135. %endif
  136. %if %{with php81}
  137. mkdir -p %{buildroot}%{_libdir}/php81/
  138. mkdir -p %{buildroot}%{_sysconfdir}/php81/php.d
  139. pushd php81
  140. %makeinstall INSTALL_ROOT=%{buildroot}
  141. popd
  142. cat > %{buildroot}%{_sysconfdir}/php81/php.d/%{extname}.ini <<EOF
  143. ; Enable %{extname} extension module
  144. extension=%{extname}.so
  145. EOF
  146. %endif
  147. %clean
  148. rm -rf %{buildroot}
  149. %if %{with php74}
  150. %files -n php74-ext-mailparse
  151. %defattr(-,root,root)
  152. %license LICENSE
  153. %doc README CREDITS
  154. %{_libdir}/php74/*
  155. %config(noreplace) %{_sysconfdir}/php74/php.d/*
  156. %endif
  157. %if %{with php82}
  158. %files -n php82-ext-mailparse
  159. %defattr(-,root,root)
  160. %license LICENSE
  161. %doc README CREDITS
  162. %{_libdir}/php82/*
  163. %config(noreplace) %{_sysconfdir}/php82/php.d/*
  164. %endif
  165. %if %{with php81}
  166. %files -n php81-ext-mailparse
  167. %defattr(-,root,root)
  168. %license LICENSE
  169. %doc README CREDITS
  170. %{_libdir}/php81/*
  171. %config(noreplace) %{_sysconfdir}/php81/php.d/*
  172. %endif
  173. %changelog
  174. * Fri Mar 17 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.4-1
  175. - new upstream release.
  176. - added php82 support.
  177. - dropped php80 support.
  178. - disabled php74 support.
  179. * Fri Nov 26 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.2-2
  180. - added php81 support.
  181. * Mon Nov 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.2-1
  182. - new upstream release.
  183. * Sat Dec 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.1-1
  184. - new upstream release.
  185. - added php80 support.
  186. - dropped php73 support.
  187. * Thu Dec 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.3-1
  188. - dropped Patch0: fixed in upstream.
  189. - added php74 support.
  190. - dropped php72 support.
  191. * Sat Dec 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.2-2
  192. - added php73 support.
  193. * Wed Dec 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.2-1
  194. - new upstream release.
  195. - built with php72.
  196. * Fri Apr 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-2
  197. - rebuilt with php5-5.6.7.
  198. * Fri Dec 13 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-1
  199. - initial build.