php-ext-phpredis-vl.spec 6.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276
  1. %bcond_with php74
  2. %bcond_without php81
  3. %bcond_without php82
  4. %define extname phpredis
  5. Summary: A redis extension for PHP
  6. Summary(ja): PHP用redis拡張
  7. Name: php-ext-phpredis
  8. Version: 5.3.7
  9. Release: 2%{_dist_release}
  10. Group: programming
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Packager: tomop
  14. License: The PHP License
  15. URL: https://github.com/phpredis/phpredis
  16. Source: https://github.com/phpredis/phpredis/archive/%{version}.tar.gz#/phpredis-%{version}.tgz
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. %description
  19. The phpredis extension provides an API for communicating with the Redis
  20. key-value store.
  21. %description -l ja
  22.  phpredis拡張は、Redis KVSと通信するためのAPIを提供します。
  23. %if %{with php81}
  24. %package -n php81-ext-phpredis
  25. Summary: A redis extension for PHP
  26. Summary(ja): PHP用redis拡張
  27. Group: programming
  28. BuildRequires: php81-devel
  29. %if "%{?req_php81_api}" != ""
  30. Requires: %{req_php81_api}
  31. %endif
  32. %description -n php81-ext-phpredis
  33. The phpredis extension provides an API for communicating with the Redis
  34. key-value store.
  35. %description -n php81-ext-phpredis -l ja
  36.  phpredis拡張は、Redis KVSと通信するためのAPIを提供します。
  37. %endif
  38. %if %{with php82}
  39. %package -n php82-ext-phpredis
  40. Summary: A redis extension for PHP
  41. Summary(ja): PHP用redis拡張
  42. Group: programming
  43. BuildRequires: php82-devel
  44. %if "%{?req_php82_api}" != ""
  45. Requires: %{req_php82_api}
  46. %endif
  47. %description -n php82-ext-phpredis
  48. The phpredis extension provides an API for communicating with the Redis
  49. key-value store.
  50. %description -n php82-ext-phpredis -l ja
  51.  phpredis拡張は、Redis KVSと通信するためのAPIを提供します。
  52. %endif
  53. %if %{with php74}
  54. %package -n php74-ext-phpredis
  55. Summary: A redis extension for PHP
  56. Summary(ja): PHP用redis拡張
  57. Group: programming
  58. BuildRequires: php74-devel
  59. %if "%{?req_php74_api}" != ""
  60. Requires: %{req_php74_api}
  61. %endif
  62. %description -n php74-ext-phpredis
  63. The phpredis extension provides an API for communicating with the Redis
  64. key-value store.
  65. %description -n php74-ext-phpredis -l ja
  66.  phpredis拡張は、Redis KVSと通信するためのAPIを提供します。
  67. %endif
  68. %debug_package
  69. %prep
  70. %setup -q -c -n phpredis-%{version}
  71. cp %{extname}-%{version}/{COPYING,CREDITS,Changelog.md,*.markdown} ./
  72. %if %{with php81}
  73. cp -a %{extname}-%{version} php81
  74. pushd php81
  75. phpize81
  76. popd
  77. %endif
  78. %if %{with php82}
  79. cp -a %{extname}-%{version} php82
  80. pushd php82
  81. phpize82
  82. popd
  83. %endif
  84. %if %{with php74}
  85. cp -a %{extname}-%{version} php74
  86. pushd php74
  87. phpize74
  88. popd
  89. %endif
  90. %build
  91. %if %{with php81}
  92. pushd php81
  93. %configure --with-php-config=%{_bindir}/php-config81
  94. %__make %{?_smp_mflags}
  95. popd
  96. %endif
  97. %if %{with php82}
  98. pushd php82
  99. %configure --with-php-config=%{_bindir}/php-config82
  100. %__make %{?_smp_mflags}
  101. popd
  102. %endif
  103. %if %{with php74}
  104. pushd php74
  105. %configure --with-php-config=%{_bindir}/php-config74
  106. %__make %{?_smp_mflags}
  107. popd
  108. %endif
  109. %install
  110. rm -rf %{buildroot}
  111. %if %{with php81}
  112. pushd php81
  113. mkdir -p %{buildroot}%{_libdir}/php81/
  114. mkdir -p %{buildroot}%{_sysconfdir}/php81/php.d
  115. %makeinstall INSTALL_ROOT=%{buildroot}
  116. cat > %{buildroot}%{_sysconfdir}/php81/php.d/redis.ini <<EOF
  117. ; Enable redis extension module
  118. extension=redis.so
  119. ;session.save_handler = redis
  120. ;session.save_path = "tcp://host1:6379?weight=1, tcp://host2:6379?weight=2&timeout=2.5, tcp://host3:6379?weight=2&read_timeout=2.5"
  121. ; Should the locking be enabled? Defaults to: 0.
  122. ;redis.session.locking_enabled = 1
  123. ; How long should the lock live (in seconds)? Defaults to: value of max_execution_time.
  124. ;redis.session.lock_expire = 60
  125. ; How long to wait between attempts to acquire lock, in microseconds (µs)?. Defaults to: 2000
  126. ;redis.session.lock_wait_time = 50000
  127. ; Maximum number of times to retry (-1 means infinite). Defaults to: 10
  128. ;redis.session.lock_retries = 10
  129. EOF
  130. popd
  131. %endif
  132. %if %{with php82}
  133. pushd php82
  134. mkdir -p %{buildroot}%{_libdir}/php82/
  135. mkdir -p %{buildroot}%{_sysconfdir}/php82/php.d
  136. %makeinstall INSTALL_ROOT=%{buildroot}
  137. cat > %{buildroot}%{_sysconfdir}/php82/php.d/redis.ini <<EOF
  138. ; Enable redis extension module
  139. extension=redis.so
  140. ;session.save_handler = redis
  141. ;session.save_path = "tcp://host1:6379?weight=1, tcp://host2:6379?weight=2&timeout=2.5, tcp://host3:6379?weight=2&read_timeout=2.5"
  142. ; Should the locking be enabled? Defaults to: 0.
  143. ;redis.session.locking_enabled = 1
  144. ; How long should the lock live (in seconds)? Defaults to: value of max_execution_time.
  145. ;redis.session.lock_expire = 60
  146. ; How long to wait between attempts to acquire lock, in microseconds (µs)?. Defaults to: 2000
  147. ;redis.session.lock_wait_time = 50000
  148. ; Maximum number of times to retry (-1 means infinite). Defaults to: 10
  149. ;redis.session.lock_retries = 10
  150. EOF
  151. popd
  152. %endif
  153. %if %{with php74}
  154. pushd php74
  155. mkdir -p %{buildroot}%{_libdir}/php74/
  156. mkdir -p %{buildroot}%{_sysconfdir}/php74/php.d
  157. %makeinstall INSTALL_ROOT=%{buildroot}
  158. cat > %{buildroot}%{_sysconfdir}/php74/php.d/redis.ini <<EOF
  159. ; Enable redis extension module
  160. extension=redis.so
  161. ;session.save_handler = redis
  162. ;session.save_path = "tcp://host1:6379?weight=1, tcp://host2:6379?weight=2&timeout=2.5, tcp://host3:6379?weight=2&read_timeout=2.5"
  163. ; Should the locking be enabled? Defaults to: 0.
  164. ;redis.session.locking_enabled = 1
  165. ; How long should the lock live (in seconds)? Defaults to: value of max_execution_time.
  166. ;redis.session.lock_expire = 60
  167. ; How long to wait between attempts to acquire lock, in microseconds (µs)?. Defaults to: 2000
  168. ;redis.session.lock_wait_time = 50000
  169. ; Maximum number of times to retry (-1 means infinite). Defaults to: 10
  170. ;redis.session.lock_retries = 10
  171. EOF
  172. popd
  173. %endif
  174. %clean
  175. rm -rf %{buildroot}
  176. %if %{with php81}
  177. %files -n php81-ext-phpredis
  178. %defattr(-,root,root)
  179. %license COPYING
  180. %doc CREDITS Changelog.md *.markdown
  181. %{_libdir}/php81/*
  182. %config(noreplace) %{_sysconfdir}/php81/php.d/*
  183. %endif
  184. %if %{with php82}
  185. %files -n php82-ext-phpredis
  186. %defattr(-,root,root)
  187. %license COPYING
  188. %doc CREDITS Changelog.md *.markdown
  189. %{_libdir}/php82/*
  190. %config(noreplace) %{_sysconfdir}/php82/php.d/*
  191. %endif
  192. %if %{with php74}
  193. %files -n php74-ext-phpredis
  194. %defattr(-,root,root)
  195. %license COPYING
  196. %doc CREDITS Changelog.md *.markdown
  197. %{_libdir}/php74/*
  198. %config(noreplace) %{_sysconfdir}/php74/php.d/*
  199. %endif
  200. %changelog
  201. * Fri Mar 17 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.7-2
  202. - added php82 support.
  203. * Fri Sep 23 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.7-1
  204. - new upstream release.
  205. - dropped php80 support.
  206. * Fri Nov 26 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.4-1
  207. - new upstream release.
  208. - added php81 support.
  209. * Sat Mar 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.3-1
  210. - new upstream release.
  211. * Sat Dec 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.2-1
  212. - new upstream release.
  213. - added php80 support.
  214. * Thu Dec 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.1-1
  215. - new upstream release.
  216. - built for php74.
  217. * Thu Aug 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-1
  218. - initial build for Vine Linux.