pango-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573
  1. %define glib2_version 2.26.0
  2. %define pkgconfig_version 0.12
  3. %define freetype2_version 2.3.9
  4. %define cairo_version 1.10.0
  5. # biarch support
  6. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  7. %define _querymodules_suffix %{nil}
  8. %if %{build_compat32}
  9. %define _querymodules_suffix -32
  10. %endif
  11. Summary: System for layout and rendering of internationalized text.
  12. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  13. Name: pango
  14. Version: 1.28.3
  15. Release: 1%{?_dist_release}
  16. License: LGPL
  17. Group: System Environment/Libraries
  18. Source: ftp://ftp.gnome.org/pub/gnome/sources/pango/1.28/pango-%{version}.tar.bz2
  19. URL: http://www.pango.org
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. # We need to prereq this so we can run pango-querymodules
  22. Requires: glib2 >= %{glib2_version}
  23. Requires: freetype2 >= %{freetype2_version}
  24. BuildRequires: libtool >= 1.4.2
  25. BuildRequires: glib2-devel >= %{glib2_version}
  26. BuildRequires: pkgconfig >= %{pkgconfig_version}
  27. BuildRequires: freetype2-devel >= %{freetype2_version}
  28. BuildRequires: fontconfig-devel
  29. BuildRequires: libX11-devel, libXft-devel, libXrender-devel
  30. BuildRequires: cairo-devel >= %{cairo_version}
  31. BuildRequires: libSM-devel
  32. BuildRequires: gobject-introspection-devel
  33. Obsoletes: pango-gtkbeta, fribidi-gtkbeta
  34. # Look for pango.modules in an arch-specific directory
  35. Patch0: pango-1.2.5-lib64.patch
  36. Patch1: pango-1.28.1-gobject-introspection.patch
  37. %description
  38. Pango is a system for layout and rendering of internationalized text.
  39. %description -l ja
  40. Pango は国際化テキストのレイアウト・レンダリングシステムです。
  41. %package devel
  42. Summary: System for layout and rendering of internationalized text.
  43. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  44. Group: Development/Libraries
  45. Requires: pango = %{version}
  46. Requires: glib2-devel >= %{glib2_version}
  47. Requires: freetype2-devel >= %{freetype2_version}
  48. Requires: cairo-devel >= %{cairo_version}
  49. Requires: libX11-devel, libXft-devel, libXrender-devel
  50. Obsoletes: fribidi-gtkbeta-devel, pango-gtkbeta-devel
  51. %description devel
  52. The pango-devel package includes the static libraries, header files,
  53. and developer docs for the pango package.
  54. Install pango-devel if you want to develop programs which will use
  55. pango.
  56. #####################################################################
  57. # compat32
  58. %package -n compat32-%{name}
  59. Summary: System for layout and rendering of internationalized text.
  60. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  61. Group: Development/Libraries
  62. %description -n compat32-%{name}
  63. Pango is a system for layout and rendering of internationalized text.
  64. %description -n compat32-%{name} -l ja
  65. Pango は国際化テキストのレイアウト・レンダリングシステムです。
  66. %package -n compat32-%{name}-devel
  67. Summary: Development files for pango
  68. Summary(ja): pango 用の開発ファイル
  69. Group: Development/Libraries
  70. Requires: compat32-%{name} = %{version}
  71. Requires: %{name}-devel = %{version}
  72. %description -n compat32-%{name}-devel
  73. The pango-devel package includes the static libraries, header files,
  74. and developer docs for the pango package.
  75. %prep
  76. %setup -q -n pango-%{version}
  77. %patch0 -p1 -b .lib64
  78. %patch1 -p1 -b .gi
  79. %build
  80. ###%configure --with-included-modules=basic-fc
  81. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  82. %configure CONFIGFLAGS --with-included-modules=basic-fc --disable-silent-rules --enable-introspection=yes)
  83. make %{?_smp_mflags}
  84. %install
  85. rm -rf $RPM_BUILD_ROOT
  86. make DESTDIR=$RPM_BUILD_ROOT install
  87. # biarch support
  88. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}
  89. touch $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}/pango.modules
  90. %if %{build_compat32}
  91. cp $RPM_BUILD_ROOT%{_bindir}/pango-querymodules \
  92. $RPM_BUILD_ROOT%{_bindir}/pango-querymodules%{_querymodules_suffix}
  93. %endif
  94. # remove unpackaged files
  95. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  96. rm -f $RPM_BUILD_ROOT%{_libdir}/pango/*/modules/*.la
  97. rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pango/pango.modules
  98. %clean
  99. rm -rf $RPM_BUILD_ROOT
  100. %post
  101. /sbin/ldconfig
  102. %{_bindir}/pango-querymodules > %{_sysconfdir}/pango/%{_arch}/pango.modules
  103. %postun -p /sbin/ldconfig
  104. %if %{build_compat32}
  105. %post -n compat32-%{name}
  106. /sbin/ldconfig
  107. %{_bindir}/pango-querymodules%{_querymodules_suffix} > %{_sysconfdir}/pango/%{_arch}/pango.modules
  108. %postun -p /sbin/ldconfig -n compat32-%{name}
  109. %endif
  110. %files
  111. %defattr(-, root, root)
  112. %doc README AUTHORS COPYING NEWS
  113. %doc pango-view/HELLO.txt
  114. #doc README AUTHORS COPYING ChangeLog
  115. #doc examples/HELLO.utf8
  116. %{_bindir}/pango-querymodules
  117. %{_bindir}/pango-view
  118. %{_libdir}/libpango*-*.so.*
  119. %{_libdir}/pango
  120. %{_libdir}/girepository-1.0
  121. %{_mandir}/man*/*
  122. %dir %{_sysconfdir}/pango
  123. %config %{_sysconfdir}/pango/pangox.aliases
  124. %ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
  125. %files devel
  126. %defattr(-, root, root)
  127. %{_libdir}/libpango*.so
  128. %{_includedir}/*
  129. %{_libdir}/pkgconfig/*
  130. %{_datadir}/gtk-doc/*
  131. %{_datadir}/gir-1.0
  132. %if %{build_compat32}
  133. %files -n compat32-%{name}
  134. %defattr(-, root, root)
  135. %{_libdir}/libpango*-*.so.*
  136. %{_bindir}/pango-querymodules%{_querymodules_suffix}
  137. %{_libdir}/pango
  138. %dir %{_sysconfdir}/pango/%{_arch}
  139. %ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
  140. %files -n compat32-%{name}-devel
  141. %defattr(-, root, root)
  142. %{_libdir}/libpango*.so
  143. %{_libdir}/pkgconfig/*
  144. %endif
  145. %changelog
  146. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.3-1
  147. - add BuildRequires: libSM-devel, gobject-introspection-devel
  148. - add Patch1 (pango-1.28.1-gobject-introspection.patch)
  149. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.28.1-2
  150. - build with rpm-4.8.1-1 for pkg-config file
  151. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.1-1
  152. - new upstream release
  153. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.0-1
  154. - new upstream release
  155. * Sun Jan 10 2010 Shu KONNO <owa@bg.wakwak.com> 1.26.2-2
  156. - changed %%makeinstall to make install with DESTDIR option
  157. * Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.2-1
  158. - new upstream release
  159. * Sun Nov 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.1-1
  160. - new upstream release
  161. * Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
  162. - new upstream release
  163. * Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.5-1
  164. - new upstream release
  165. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.4-1
  166. - new upstream release
  167. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.2-1
  168. - new upstream release
  169. * Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.24.1-2
  170. - removed %%if !%%{build_compat32} case condition
  171. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.1-1
  172. - new upstream release
  173. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
  174. - new upstream release
  175. * Tue Dec 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.4-1
  176. - new upstream release
  177. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.3-1
  178. - new upstream release
  179. * Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.1-1
  180. - new upstream release
  181. * Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.0-1
  182. - new upstream release
  183. * Thu Jul 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.5-1
  184. - new upstream release
  185. * Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.20.3-2
  186. - spec in UTF-8 actually
  187. * Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.3-1
  188. - new upstream release
  189. - rebuilt with xorg-x11 7.3
  190. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.1-1vl5
  191. - new upstream release
  192. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-1vl5
  193. - used %{?_dist_release}
  194. * Wed Mar 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
  195. - new upstream release
  196. * Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.4-0vl1
  197. - new upstream release
  198. * Fri Nov 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.3-0vl1
  199. - new upstream release
  200. - added Patch0 instead of Patch5
  201. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
  202. - replace build with new environment
  203. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
  204. - rebuild with new environment
  205. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl1
  206. - new upstream release
  207. * Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.2-0vl1
  208. - new upstream release
  209. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.9-0vl1
  210. - new upstream release
  211. * Sun Oct 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.7-0vl1
  212. - new upstream release
  213. * Sat Sep 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.4-0vl1
  214. - new upstream release
  215. * Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.0-0vl1
  216. - new upstream release
  217. * Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl3
  218. - rebuild with cairo-1.2.0
  219. * Tue Aug 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl2
  220. - add Patch10 to create fake style(italic/bold) for all fonts.
  221. http://bugzilla.gnome.org/show_bug.cgi?id=319808
  222. - This patch is not applied in upstream, but it seems usefull
  223. for us.
  224. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl1
  225. - new upstream release
  226. * Sun Apr 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-0vl1
  227. - new upstream release
  228. * Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.1-0vl1
  229. - new upstream release
  230. * Fri Mar 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl2
  231. - fix broken dependancy
  232. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl1
  233. - new upstream release
  234. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.99-0vl1
  235. - new upstream release
  236. - add compat32 package for x86_64 arch support
  237. - add Patch5 for biarch support
  238. * Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-0vl1
  239. - new upstream release
  240. * Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-0vl1
  241. - new upstream release
  242. * Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-0vl1
  243. - new upstream release
  244. * Mon Aug 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl2
  245. - rebuild with cairo-0.9
  246. - add patch10 to disable building example programs
  247. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl1
  248. - new upstream release
  249. * Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
  250. - new upstream release
  251. - drop obsolete patches
  252. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  253. - new upstream release
  254. - import upstream patches from fedora package.
  255. * Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
  256. - new upstream release
  257. * Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
  258. - new upstream release
  259. * Thu Mar 4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
  260. - remove unneeded dependancy to freetype2-devel
  261. * Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl2
  262. - add patch10 to build against freetype-2.1.7
  263. - rebuild with freetype-2.1.7
  264. * Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl1
  265. - new upstream release
  266. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
  267. - new upstream release
  268. * Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
  269. - new upstream release
  270. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl2
  271. - merge patch1,2 from rawhide package.
  272. * Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
  273. - new upstream release
  274. * Thu Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.5-0vl1
  275. - new upstream release
  276. - Build for Vine Linux, specfile are based on rawhide release
  277. * Thu Nov 21 2002 Havoc Pennington <hp@redhat.com>
  278. - change PKG_CONFIG_PATH hack to also search /usr/X11R6/lib64/pkgconfig
  279. * Wed Nov 20 2002 Havoc Pennington <hp@redhat.com>
  280. - explicitly require pangoxft to be built, so we catch situations such
  281. as xft.pc moving to /usr/X11R6
  282. - also add /usr/X11R6/lib/pkgconfig to PKG_CONFIG_PATH as a temporary
  283. hack
  284. * Thu Nov 7 2002 Havoc Pennington <hp@redhat.com>
  285. - 1.1.3
  286. * Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-5
  287. - Require the necessary freetype version, don't just
  288. BuildRequires it (#74744)
  289. * Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-4
  290. - Own /etc/pango (#73962, Enrico Scholz)
  291. - Remove .la files from the build root
  292. * Mon Oct 7 2002 Havoc Pennington <hp@redhat.com>
  293. - require glib 2.0.6-3, try rebuild on more arches
  294. * Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
  295. - Version 1.1.1 (main change, fixes font selection for FT2 backend,
  296. as in gdmgreeter)
  297. * Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
  298. - Fix linked list manipulation problem that was causing hang for anaconda
  299. - Fix warning from loading mini-fonts with context == NULL
  300. * Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
  301. - Fix major memory leak in the last patch
  302. * Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
  303. - Actually use language tags at the rendering layer (should fix #68211)
  304. * Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
  305. - Remove fixed-ltmain.sh, relibtoolize; to fix relink problems without
  306. - Fix bug causing hex boxes to be misrendered
  307. leaving RPATH (#66005)
  308. - For FT2 backend, supply FT_LOAD_NO_BITMAP to avoid problems with
  309. fonts with embedded bitmaps (#67851)
  310. * Mon Jul 8 2002 Owen Taylor <otaylor@redhat.com>
  311. - Make basic-x shaper work with our big-5 fonts
  312. * Wed Jul 3 2002 Owen Taylor <otaylor@redhat.com>
  313. - New upstream tarball with hooks for change-on-the fly font rendering
  314. * Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
  315. - Up FreeType version to deal with FreeType-2.0.x / 2.1.x \
  316. ABI changes for pango's OpenType code.
  317. * Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
  318. - Add some Korean aliases that the installer wants
  319. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  320. - automated rebuild
  321. * Sat Jun 8 2002 Havoc Pennington <hp@redhat.com>
  322. - devel package requires fontconfig/Xft devel packages
  323. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  324. - rebuild in different environment
  325. * Thu Jun 6 2002 Owen Taylor <otaylor@redhat.com>
  326. - Snapshot with Xft2/fontconfig support
  327. * Wed May 29 2002 Owen Taylor <otaylor@redhat.com>
  328. - Version 1.0.2
  329. - Patch for charmaps problem
  330. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  331. - automated rebuild
  332. * Wed May 22 2002 Havoc Pennington <hp@redhat.com>
  333. - rebuild in different environment
  334. * Wed May 22 2002 Havoc Pennington <hp@redhat.com>
  335. - add patch to adjust to newer version of freetype
  336. * Wed Apr 3 2002 Alex Larsson <alexl@redhat.com>
  337. - Update to version 1.0.1, remove patch
  338. * Tue Mar 19 2002 Owen Taylor <otaylor@redhat.com>
  339. - Patch from CVS for big speedup with FreeType-2.0.9
  340. * Mon Mar 11 2002 Owen Taylor <otaylor@redhat.com>
  341. - Rebuild
  342. * Fri Mar 8 2002 Owen Taylor <otaylor@redhat.com>
  343. - Version 1.0.0
  344. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  345. - Update to 0.26
  346. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  347. - Bump for rebuild
  348. * Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
  349. - Update to 0.25
  350. * Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
  351. - add horrible buildrequires hack
  352. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  353. - 0.24.90 cvs snap
  354. * Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
  355. - Version 0.24
  356. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  357. - automated rebuild
  358. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  359. - new snap 0.23.90
  360. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  361. - rebuild with 64-bit-fixed glib
  362. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  363. - Version 0.22
  364. - add explicit check for required glib2 version before we do the build,
  365. so we don't end up with bad RPMs on --nodeps builds
  366. - PreReq the glib2_version version, instead of 1.3.8 hardcoded that
  367. no one had updated recently
  368. * Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
  369. - Version 0.21
  370. * Thu Oct 4 2001 Havoc Pennington <hp@redhat.com>
  371. - cvs snap
  372. - new cvs snap with a bugfix
  373. * Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
  374. - sync with Owen's changes, fix up dependency versions
  375. * Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
  376. - 0.19
  377. * Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
  378. - build CVS snap
  379. * Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
  380. - no relinking junk
  381. * Tue Sep 4 2001 root <root@dhcpd37.meridian.redhat.com>
  382. - Version 0.18
  383. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  384. - Configure --disable-gtk-doc
  385. - BuildRequires freetype-devel, XFree86-devel
  386. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  387. - 0.17
  388. - libtool hackarounds
  389. * Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
  390. - 0.16, rename back to pango from pango-gtkbeta
  391. * Fri Feb 16 2001 Owen Taylor <otaylor@redhat.com>
  392. - Obsolete fribidi-gtkbeta
  393. * Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
  394. - Remove that patch I just put in
  395. * Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
  396. - Patch pangox.pc.in to include -Iincludedir
  397. * Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
  398. - final 0.13
  399. * Tue Nov 14 2000 Owen Taylor <otaylor@redhat.com>
  400. - New 0.13 tarball
  401. * Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
  402. - 0.13pre1
  403. * Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
  404. - Rename to 0.12b to avoid versioning problems
  405. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  406. - Move to a CVS snapshot
  407. * Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
  408. - Move back to /usr
  409. - Version 0.12
  410. * Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
  411. - Add missing %%defattr
  412. * Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
  413. - Rebuild with a prefix of /opt/gtk-beta
  414. * Wed May 31 2000 Owen Taylor <otaylor@redhat.com>
  415. - version 0.11
  416. - add --without-qt
  417. * Wed Apr 26 2000 Owen Taylor <otaylor@redhat.com>
  418. - Make the devel package require *-gtkbeta-* not the normal packages.
  419. * Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
  420. - GTK+ snapshot version installing in /opt/gtk-beta
  421. * Fri Feb 11 2000 Owen Taylor <otaylor@redhat.com>
  422. - Created spec file