perl-GD-vl.spec 2.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394
  1. %define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
  2. Summary: A perl5 interface to Thomas Boutell's gd library
  3. Summary(ja): GD ライブラリの Perl 用インターフェイス
  4. Name: perl-GD
  5. Version: 2.35
  6. Release: 1%{?_dist_release}
  7. License: distributable
  8. Group: Development/Libraries
  9. Source0: http://search.cpan.org/CPAN/authors/id/L/LD/LDS/GD-%{version}.tar.gz
  10. Url: http://search.cpan.org/dist/GD/
  11. BuildRoot: %{_tmppath}/perl-GD-buildroot/
  12. BuildRequires: perl >= 5.6.0, gd-devel >= 2.0.20, libjpeg-devel
  13. BuildRequires: freetype2-devel, libpng-devel, zlib-devel
  14. Requires: perl >= 5.6.0, gd >= 2.0.12, libjpeg, freetype2
  15. Requires: libpng, zlib
  16. %description
  17. This is a autoloadable interface module for libgd, a popular library
  18. for creating and manipulating PNG files. With this library you can
  19. create PNG images on the fly or modify existing files. Features
  20. include:
  21. a. lines, polygons, rectangles and arcs, both filled and unfilled
  22. b. flood fills
  23. c. the use of arbitrary images as brushes and as tiled fill patterns
  24. d. line styling (dashed lines and the like)
  25. e. horizontal and vertical text rendering
  26. f. support for transparency and interlacing
  27. For full information on usage, see the accompanying man and html
  28. documentation.
  29. # Provide perl-specific find-{provides,requires}.
  30. %define __find_provides /usr/lib/rpm/find-provides.perl
  31. %define __find_requires /usr/lib/rpm/find-requires.perl
  32. %prep
  33. %setup -q -n GD-%{version}
  34. %build
  35. CFLAGS="$RPM_OPT_FLAGS" \
  36. perl Makefile.PL --lib_gd_path=%{_libdir} INSTALLDIRS="vendor" << _OPT_
  37. y
  38. _OPT_
  39. make
  40. make test
  41. %clean
  42. rm -rf %{buildroot}
  43. %install
  44. rm -rf %{buildroot}
  45. make DESTDIR=%{buildroot} install
  46. [ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
  47. find %{buildroot}%{_prefix} -type f -print |
  48. sed "s@^%{buildroot}@@g" |
  49. grep -v perllocal.pod |
  50. grep -v "\.packlist" > %{name}-filelist
  51. if [ "$(cat %{name}-filelist)X" = "X" ] ; then
  52. echo "ERROR: EMPTY FILE LIST"
  53. exit -1
  54. fi
  55. find demos -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!/usr/bin/perl|g"
  56. find bdf_scripts -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!/usr/bin/perl|g"
  57. %files -f %{name}-filelist
  58. %defattr(-,root,root)
  59. %doc ChangeLog README* demos bdf_scripts
  60. %dir %{perl_vendorarch}/GD
  61. %dir %{perl_vendorarch}/auto/GD
  62. %changelog
  63. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.35-1vl5
  64. - applied new versioning policy, spec in utf-8
  65. - built with perl-5.10.0
  66. * Sun Sep 3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.35-0vl1
  67. - new upstream release
  68. - changed Group to Development/Libraries
  69. * Sat Sep 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28-0vl1
  70. - new upstream release
  71. - added Japanese summary
  72. * Sun Jan 2 2005 IWAI, Masaharu <iwai@alib.jp> 2.19-0vl1
  73. - new upstream release
  74. - update {Build,}Requires
  75. * Tue Nov 11 2003 IWAI, Masaharu <iwai@alib.jp> 2.11-0vl1
  76. - initial build