pessulus-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %define basever 2.30
  3. Name: pessulus
  4. Version: %{basever}.4
  5. Release: 1%{?_dist_release}
  6. Summary: A lockdown editor for GNOME
  7. Group: Applications/System
  8. License: GPLv2+
  9. URL: http://live.gnome.org/Pessulus
  10. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{basever}/%{name}-%{version}.tar.bz2
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. BuildArch: noarch
  13. BuildRequires: gtk2-devel
  14. BuildRequires: pygtk2-devel
  15. BuildRequires: gnome-python-devel
  16. BuildRequires: GConf2-devel
  17. BuildRequires: gnome-python-desktop
  18. BuildRequires: perl-XML-Parser
  19. #BuildRequires: pkgconfig
  20. BuildRequires: gettext-devel
  21. BuildRequires: intltool >= 0.35.0
  22. BuildRequires: desktop-file-utils
  23. Requires: gnome-python-desktop
  24. %description
  25. Pessulus is a lockdown editor for GNOME, written in python. Pessulus
  26. enables administrators to set mandatory settings in GConf. The
  27. users can not change these settings.
  28. Use of pessulus can be useful on computers that are open to use by
  29. everyone, e.g. in an internet cafe.
  30. %prep
  31. %setup -q
  32. %build
  33. %configure
  34. make %{?_smp_mflags}
  35. %install
  36. rm -rf $RPM_BUILD_ROOT
  37. make install DESTDIR=$RPM_BUILD_ROOT
  38. chmod +x $RPM_BUILD_ROOT%{python_sitelib}/Pessulus/*.py
  39. desktop-file-install --vendor="" --delete-original --remove-category="System" \
  40. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  41. $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
  42. %find_lang %{name}
  43. %clean
  44. rm -rf $RPM_BUILD_ROOT
  45. %post
  46. touch --no-create %{_datadir}/icons/hicolor
  47. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  48. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  49. fi
  50. %postun
  51. touch --no-create %{_datadir}/icons/hicolor
  52. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  53. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  54. fi
  55. %files -f %{name}.lang
  56. %defattr(-,root,root,-)
  57. %doc README AUTHORS COPYING ChangeLog
  58. %{_bindir}/%{name}
  59. %{python_sitelib}/Pessulus/
  60. %{_datadir}/applications/*.desktop
  61. %{_datadir}/%{name}
  62. %{_datadir}/icons/hicolor/*/apps/pessulus.*
  63. %changelog
  64. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-1
  65. - new upstream release
  66. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
  67. - Initial build for Vine Linux
  68. * Tue Apr 06 2010 Haïkel Guémar <karlthered@gmail.com> - 2.30.0-2
  69. - remove gnome-python2-buddy dependency (#579612)
  70. * Wed Mar 23 2010 Haïkel Guémar <karlthered@gmail.com> - 2.30.0-1
  71. - Updated to 2.30.0
  72. - more translations
  73. * Sat Feb 27 2010 Haïkel Guémar <karlthered@gmail.com> - 2.29.91-1
  74. - Updated to 2.29.91
  75. * Sun Sep 25 2009 Haïkel Guémar <karlthered@gmail.com> - 2.28.0-1
  76. - Updated to 2.28.0
  77. * Mon Sep 14 2009 Haïkel Guémar <karlthered@gmail.com> - 2.27.92-1
  78. - Updated to 2.27.92
  79. * Wed Jul 29 2009 Haïkel Guémar <karlthered@gmail.com> - 2.27.5-1
  80. - Updated to 2.24.0
  81. - Remove now unneeded pythondir patch (GNOME #549728 fixed upstream)
  82. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.23.1-5
  83. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  84. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.23.1-4
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  86. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.23.1-3
  87. - Rebuild for Python 2.6
  88. * Thu Aug 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.23.1-2
  89. - fix missing BR, Requires
  90. * Thu Aug 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.23.1-1
  91. - fix license tag
  92. - update to 2.23.1
  93. - install into pythondir (not pyexecdir)
  94. * Mon Apr 16 2007 Damien Durand <splinux@fedoraproject.org> - 2.16.2-2
  95. - Fix desktop-file
  96. * Fri Dec 22 2006 Damien Durand <splinux@fedoraproject.org> - 2.16.2-1
  97. - Upgrade to 2.16.2
  98. - Add gnome-python2-devel in BR
  99. * Sat Sep 23 2006 Damien Durand <splinux@fedoraproject.org> - 2.16.1-1
  100. - Upgrade to 2.16.1
  101. - Fixe #195819
  102. * Sat Sep 23 2006 Damien Durand <splinux@fedoraproject.org> - 2.16-4
  103. - Bump release
  104. * Wed Sep 06 2006 Damien Durand <splinux@fedoraproject.org> - 2.16.0-1
  105. - Upgrade to 2.16 release
  106. - Add gnome-python2-gconf in Requires
  107. * Fri Aug 08 2006 Damien Durand <splinux@fedoraproject.org> - 2.15.91-2
  108. - Bump release
  109. * Fri Aug 08 2006 Damien Durand <splinux@fedoraproject.org> - 2.15.91-1
  110. - Upgraded to 2.15.91
  111. * Fri Jul 28 2006 Damien Durand <splinux@fedoraproject.org> - 2.15.90-1
  112. - Fix URL
  113. - Upgrad to 2.15.90
  114. * Tue Jul 11 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.4-1
  115. - upgrad to 0.10.4
  116. * Tue Jul 04 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.1-3
  117. - fix debuginfo packages
  118. * Thu Jun 15 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.1-2
  119. - fix BuildRequires
  120. * Wed May 3 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.1-1
  121. - upgrade version to 0.10.1
  122. * Fri Apr 7 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 0.9-2
  123. - fix BR
  124. - remove unnecessary Requires
  125. - use version-release in changelog entries
  126. - fix directory ownership
  127. - use python_sitearch
  128. - make python "scripts" executable
  129. * Thu Apr 6 2006 Damien Durand <splinux@fedoraproject.org> - 0.9-1
  130. - Initial package