unbound-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414
  1. %{?!with_munin: %global with_munin 0}
  2. # not ready yet
  3. %{?!with_python: %global with_python 0}
  4. %{?!enable_gost: %global enable_gost 0}
  5. %if %{with_python}
  6. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  7. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  8. %endif
  9. Summary: Validating, recursive, and caching DNS(SEC) resolver
  10. Name: unbound
  11. Version: 1.4.8
  12. Release: 1%{?_dist_release}
  13. License: BSD
  14. Url: http://www.unbound.net/
  15. Source: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
  16. Source1: unbound.init
  17. Source2: unbound.conf
  18. Source3: unbound.munin
  19. Source4: dlv.isc.org.key
  20. Patch1: unbound-1.2-glob.patch
  21. Group: System Environment/Daemons
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  23. BuildRequires: flex, ldns-devel >= 1.5.0,
  24. BuildRequires: libevent-devel
  25. BuildRequires: expat-devel
  26. %if %{with_python}
  27. BuildRequires: python-devel swig
  28. %endif
  29. %if %{enable_gost}
  30. BuildRequires: openssl-devel >= 1.0.0
  31. %else
  32. BuildRequires: openssl-devel
  33. %endif
  34. # Required for SVN versions
  35. #BuildRequires: bison
  36. Requires(post): chkconfig
  37. Requires(preun): chkconfig
  38. Requires(preun): initscripts
  39. Requires(postun): initscripts
  40. Requires: ldns >= 1.5.0
  41. Requires(pre): shadow-utils
  42. Distribution: Vine Linux
  43. Vendor: Project Vine
  44. Packager: iwaim
  45. %description
  46. Unbound is a validating, recursive, and caching DNS(SEC) resolver.
  47. The C implementation of Unbound is developed and maintained by NLnet
  48. Labs. It is based on ideas and algorithms taken from a java prototype
  49. developed by Verisign labs, Nominet, Kirei and ep.net.
  50. Unbound is designed as a set of modular components, so that also
  51. DNSSEC (secure DNS) validation and stub-resolvers (that do not run
  52. as a server, but are linked into an application) are easily possible.
  53. %if %{with_munin}
  54. %package munin
  55. Summary: Plugin for the munin / munin-node monitoring package
  56. Group: System Environment/Daemons
  57. Requires: munin-node
  58. Requires: %{name} = %{version}-%{release}, bc
  59. %description munin
  60. Plugin for the munin / munin-node monitoring package
  61. %endif
  62. %package devel
  63. Summary: Development package that includes the unbound header files
  64. Group: Development/Libraries
  65. Requires: %{name}-libs = %{version}-%{release}, openssl-devel, ldns-devel
  66. %description devel
  67. The devel package contains the unbound library and the include files
  68. %package libs
  69. Summary: Libraries used by the unbound server and client applications
  70. Group: Applications/System
  71. Requires(post): /sbin/ldconfig
  72. Requires(postun): /sbin/ldconfig
  73. Requires: openssl >= 0.9.8g-12
  74. %description libs
  75. Contains libraries used by the unbound server and client applications
  76. %if %{with_python}
  77. %package python
  78. Summary: Python modules and extensions for unbound
  79. Group: Applications/System
  80. Requires: %{name}-libs = %{version}-%{release}
  81. %description python
  82. Python modules and extensions for unbound
  83. %endif
  84. %prep
  85. %setup -q
  86. %patch1 -p1
  87. %build
  88. %configure --with-ldns= --with-libevent --with-pthreads --with-ssl \
  89. --disable-rpath --enable-debug --disable-static \
  90. --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
  91. --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
  92. %if %{with_python}
  93. --with-pythonmodule --with-pyunbound \
  94. %endif
  95. %if !%{enable_gost}
  96. --disable-gost \
  97. %endif
  98. --enable-sha2
  99. %{__make} %{?_smp_mflags}
  100. %install
  101. rm -rf %{buildroot}
  102. %{__make} DESTDIR=%{buildroot} install
  103. install -d 0755 %{buildroot}%{_initrddir}
  104. install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
  105. install -m 0755 %{SOURCE2} %{buildroot}%{_sysconfdir}/unbound
  106. %if %{with_munin}
  107. # Install munin plugin and its softlinks
  108. install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
  109. install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
  110. install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
  111. install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
  112. for plugin in unbound_munin_hits unbound_munin_queue unbound_munin_memory unbound_munin_by_type unbound_munin_by_class unbound_munin_by_opcode unbound_munin_by_rcode unbound_munin_by_flags unbound_munin_histogram; do
  113. ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
  114. done
  115. %endif
  116. # install DLV key
  117. install -m 0644 %{SOURCE4} %{buildroot}%{_sysconfdir}/unbound/
  118. # remove static library from install (fedora packaging guidelines)
  119. rm -rf %{buildroot}%{_libdir}/*.la
  120. %if %{with_python}
  121. rm -rf %{buildroot}%{python_sitelib}/*/*.la
  122. %endif
  123. mkdir -p %{buildroot}%{_localstatedir}/run/unbound
  124. %clean
  125. rm -rf ${RPM_BUILD_ROOT}
  126. %files
  127. %defattr(-,root,root,-)
  128. %doc doc/README doc/CREDITS doc/LICENSE doc/FEATURES
  129. %attr(0755,root,root) %{_initrddir}/%{name}
  130. %attr(0755,root,root) %dir %{_sysconfdir}/%{name}
  131. %attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
  132. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
  133. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
  134. %{_sbindir}/*
  135. %{_mandir}/*/*
  136. %if %{with_python}
  137. %files python
  138. %{python_sitelib}/*
  139. %endif
  140. %if %{with_munin}
  141. %files munin
  142. %defattr(-,root,root,-)
  143. %config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
  144. %{_datadir}/munin/plugins/unbound*
  145. %endif
  146. %files devel
  147. %defattr(-,root,root,-)
  148. %{_libdir}/libunbound.so
  149. %{_includedir}/unbound.h
  150. %doc README
  151. %files libs
  152. %defattr(-,root,root,-)
  153. %{_libdir}/libunbound.so.*
  154. %doc doc/README doc/LICENSE
  155. %pre
  156. getent group unbound >/dev/null || groupadd -r unbound
  157. getent passwd unbound >/dev/null || \
  158. useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
  159. -c "Unbound DNS resolver" unbound
  160. exit 0
  161. %post
  162. /sbin/chkconfig --add %{name}
  163. # dnssec-conf used to contain our DLV key, but now we include it via unbound
  164. # If unbound had previously been configured with dnssec-configure, we need
  165. # to migrate the location of the DLV key file (to keep DLV enabled, and because
  166. # unbound won't start with a bad location for a DLV key file.
  167. sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
  168. %post libs -p /sbin/ldconfig
  169. %preun
  170. if [ "$1" -eq 0 ]; then
  171. /sbin/service %{name} stop >/dev/null 2>&1
  172. /sbin/chkconfig --del %{name}
  173. fi
  174. %postun
  175. if [ "$1" -ge "1" ]; then
  176. /sbin/service %{name} condrestart >/dev/null 2>&1 || :
  177. fi
  178. %postun libs -p /sbin/ldconfig
  179. %changelog
  180. * Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.8-1
  181. - new upstream release
  182. * Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.7-2
  183. - rebuilt with libevent-2.0.10
  184. * Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.7-1
  185. - new upstream release
  186. - add enable_gost flag: default disable
  187. - add BuildRequires: expat-devel
  188. * Thu Sep 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
  189. - new upstream release
  190. * Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
  191. - new upstream release
  192. * Wed May 5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
  193. - initial build for Vine Linux: based Fedora 1.4.3-1.fc14
  194. - update to 1.4.4
  195. - build without munin
  196. * Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
  197. - Update to 1.4.3 that fixes 64bit crasher
  198. * Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
  199. - Updated to 1.4.2
  200. - Updated unbound.conf with new options
  201. - Enabled pre-fetching DNSKEY records (DNSSEC speedup)
  202. - Enabled re-fetching popular records before they expire
  203. - Enabled logging of DNSSEC validation errors
  204. * Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
  205. - Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
  206. with pthreads
  207. * Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
  208. - Change make/configure lines to attempt to fix -lphtread linking issue
  209. * Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
  210. - Removed dependancy for dnssec-conf
  211. - Added ISC DLV key (formerly in dnssec-conf)
  212. - Fixup old DLV locations in unbound.conf file via %%post
  213. - Fix parent child disagreement handling and no-ipv6 present [svn r1953]
  214. * Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
  215. - Updated to 1.4.1
  216. - Changed %%define to %%global
  217. * Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
  218. - Bump version
  219. * Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
  220. - Upgraded to 1.3.4. Security fix with validating NSEC3 records
  221. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
  222. - rebuilt with new openssl
  223. * Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
  224. - Updated to 1.3.3
  225. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
  226. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  227. * Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
  228. - Added missing glob patch to cvs
  229. - Place python macros within the %%with_python check
  230. * Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
  231. - Updated to 1.3.0
  232. - Added unbound-python sub package. disabled for now
  233. - Patch from svn to fix DLV lookups
  234. - Patches from svn to detect wrong truncated response from BIND 9.6.1 with
  235. minimal-responses)
  236. - Added Default-Start and Default-Stop to unbound.init
  237. - Re-enabled --enable-sha2
  238. - Re-enabled glob.patch
  239. * Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
  240. - unbound-iterator.patch was not commited
  241. * Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
  242. - Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
  243. * Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
  244. - Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
  245. * Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
  246. - enable DNSSEC only if it is enabled in sysconfig/dnssec
  247. * Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
  248. - add DNSSEC support to initscript and enabled it per default
  249. - add requires dnssec-conf
  250. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
  251. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  252. * Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
  253. - updated to 1.2.1
  254. * Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
  255. - rebuild with new openssl
  256. * Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
  257. - Updated to 1.2.0
  258. - Added dependancy on minimum SSL for CVE-2008-5077
  259. - Added dependancy on bc for unbound-munin
  260. - Added minimum requirement of libevent 1.4.5. Crashes with older versions
  261. (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
  262. - Removed dependancy on selinux-policy (will get used when available)
  263. - Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
  264. - Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
  265. - Enable val-clean-additional to drop addition unsigned data from signed
  266. response.
  267. - Removed patches (got merged into upstream)
  268. * Mon Jan 5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
  269. - Modified scandir patch to silently fail when wildcard matches nothing
  270. - Patch to allow unbound-checkconf to find empty wildcard matches
  271. * Mon Jan 5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
  272. - Added scandir patch for trusted-keys-file: option, which
  273. is used to load multiple dnssec keys in bind file format
  274. * Mon Dec 8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
  275. - Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
  276. * Mon Dec 1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
  277. - We did not own the /etc/unbound directory (#474020)
  278. - Fixed cvs anomalies
  279. * Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
  280. - removed all obsolete chroot related stuff
  281. - label control certs after generation correctly
  282. * Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
  283. - Updated to unbound 1.1.1 which fixes a crasher and
  284. addresses nlnetlabs bug #219
  285. * Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
  286. - Remove the chroot, obsoleted by SElinux
  287. - Add additional munin plugin links supported by unbound plugin
  288. - Move configuration directory from /var/lib/unbound to /etc/unbound
  289. - Modified unbound.init and unbound.conf to account for chroot changes
  290. - Updated unbound.conf with new available options
  291. - Enabled dns-0x20 protection per default
  292. * Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
  293. - unbound-1.1.0-log_open.patch
  294. - make sure log is opened before chroot call
  295. - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
  296. - removed /dev/log and /var/run/unbound and /etc/resolv.conf from
  297. chroot, not needed
  298. - don't mount files in chroot, it causes problems during updates
  299. - fixed typo in default config file
  300. * Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
  301. - Updated to version 1.1.0
  302. - Updated unbound.conf's statistics options and remote-control
  303. to work properly for munin
  304. - Added unbound-munin package
  305. - Generate unbound remote-control key/certs on first startup
  306. - Required ldns is now 1.4.0
  307. * Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
  308. - Only call ldconfig in -libs package
  309. - Move configure into build section
  310. - devel subpackage should only depend on libs subpackage
  311. * Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
  312. - Fix CFLAGS getting lost in build
  313. - Don't enable interface-automatic:yes because that
  314. causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
  315. * Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
  316. - Split off unbound-libs, make build verbose
  317. * Thu Oct 9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
  318. - FSB compliance, chroot fixes, initscript fixes
  319. * Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
  320. - Upgraded to 1.0.2
  321. * Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
  322. - upgraded to new release
  323. * Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
  324. - Build against ldns-1.3.0
  325. * Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
  326. - Split of -devel package, fixed dependancies, make rpmlint happy
  327. * Thu Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
  328. - Using parts from ports collection entry by Jaap Akkerhuis.
  329. - Using Fedoraproject wiki guidelines.
  330. * Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
  331. - Initial version.