calibre-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. Name: calibre
  3. Version: 0.7.26
  4. Release: 1%{?_dist_release}
  5. Summary: E-book converter and library management
  6. Group: Applications/Multimedia
  7. License: GPLv3
  8. URL: http://calibre-ebook.com/
  9. # SourceURL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  10. # Upstream packages some unfree fonts which we cannot redistribute.
  11. # While we're at it, also delete the liberation fonts which we already have.
  12. #
  13. # Download the upstream tarball and invoke this script while in the tarball's
  14. # directory:
  15. # ./generate-tarball.sh %{version}
  16. Source0: %{name}-%{version}-nofonts.tar.xz
  17. Source1: generate-tarball.sh
  18. Source2: calibre-mount-helper
  19. Patch0: %{name}-manpages.patch
  20. Patch1: %{name}-no-update.patch
  21. #Patch2: %{name}-0.6.53-mounthelper.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: python >= 2.6
  24. BuildRequires: python-devel >= 2.6
  25. BuildRequires: ImageMagick-devel >= 6.5.9
  26. BuildRequires: python-setuptools
  27. BuildRequires: qt4-devel >= 4.6.0
  28. BuildRequires: PyQt4-devel >= 4.7.0
  29. BuildRequires: poppler-qt4-devel >= 0.12
  30. BuildRequires: podofo-devel
  31. BuildRequires: desktop-file-utils
  32. BuildRequires: python-mechanize >= 0.1.1
  33. BuildRequires: python-lxml >= 2.2.1
  34. BuildRequires: python-cssutils >= 0.9.6
  35. BuildRequires: python-dateutil >= 1.4.1
  36. BuildRequires: python-imaging >= 1.1.6
  37. BuildRequires: xdg-utils >= 1.0.2
  38. BuildRequires: python-BeautifulSoup >= 3.0.5
  39. BuildRequires: xz
  40. BuildRequires: unzip
  41. BuildRequires: libwmf-devel >= 0.2.8
  42. BuildRequires: chmlib-devel >= 0.40
  43. Requires: PyQt4
  44. Requires: pyPdf
  45. Requires: python-cherrypy
  46. Requires: python-cssutils
  47. Requires: ImageMagick
  48. Requires: python-odf
  49. Requires: python-django-tagging
  50. Requires: python-lxml
  51. Requires: python-imaging
  52. Requires: python-mechanize
  53. Requires: python-dateutil
  54. Requires: python-genshi
  55. Requires: python-BeautifulSoup
  56. ## vine
  57. Requires: TrueType-liberation
  58. %description
  59. Calibre is meant to be a complete e-library solution. It includes library
  60. management, format conversion, news feeds to ebook conversion as well as
  61. e-book reader sync features.
  62. Calibre is primarily a ebook cataloging program. It manages your ebook
  63. collection for you. It is designed around the concept of the logical book,
  64. i.e. a single entry in the database that may correspond to ebooks in several
  65. formats. It also supports conversion to and from a dozen different ebook
  66. formats.
  67. Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML, CBR, CBZ,
  68. RTF, TXT, PDF and LRS.
  69. %prep
  70. %setup -q -n %{name}
  71. # don't append calibre1 to the name of the manpages. No need to compress either
  72. # upstream won't fix: http://bugs.calibre-ebook.com/ticket/3770#comment:7
  73. %patch0 -p1 -b .manpages
  74. # don't check for new upstream version (that's what packagers do)
  75. %patch1 -p1 -b .no-update
  76. # # Enable mount helper
  77. #%patch2 -p1 -b .mounthelper
  78. # dos2unix newline conversion
  79. %{__sed} -i 's/\r//' src/calibre/web/feeds/recipes/*
  80. # remove shebangs
  81. %{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*/*.py
  82. %{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*.py
  83. %{__sed} -i -e '/^#![ ]*\//, 1d' src/calibre/*/*.py
  84. %{__sed} -i -e '/^#!\//, 1d' src/calibre/*.py
  85. %{__sed} -i -e '/^#!\//, 1d' resources/recipes/*
  86. %{__sed} -i -e '/^#!\//, 1d' resources/default_tweaks.py
  87. %{__chmod} -x src/calibre/*/*/*/*.py
  88. %{__chmod} -x src/calibre/*/*/*.py
  89. %{__chmod} -x src/calibre/*/*.py
  90. %{__chmod} -x src/calibre/*.py
  91. %{__chmod} -x resources/recipes/*
  92. %build
  93. OVERRIDE_CFLAGS="%{optflags}" QMAKE=%{_libdir}/qt4/bin/qmake python setup.py build
  94. %install
  95. %__rm -rf %{buildroot}
  96. %__mkdir -p %{buildroot}%{_datadir}
  97. # create directories for xdg-utils
  98. %__mkdir_p %{buildroot}%{_datadir}/icons
  99. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor
  100. %__mkdir_p %{buildroot}%{_datadir}/packages
  101. %__mkdir_p %{buildroot}%{_datadir}/mime
  102. %__mkdir_p %{buildroot}%{_datadir}/mime/packages
  103. %__mkdir_p %{buildroot}%{_datadir}/applications
  104. %__mkdir_p %{buildroot}%{_datadir}/desktop-directories
  105. # create directory for calibre environment module
  106. # the install script assumes it's there.
  107. %__mkdir_p %{buildroot}%{python_sitelib}
  108. XDG_DATA_DIRS="%{buildroot}%{_datadir}" \
  109. XDG_UTILS_INSTALL_MODE="system" \
  110. LIBPATH="%{_libdir}" \
  111. python setup.py install --root=%{buildroot}%{_prefix} \
  112. --prefix=%{_prefix} \
  113. --libdir=%{_libdir} \
  114. --staging-libdir=%{buildroot}%{_libdir}
  115. # remove shebang from init_calibre.py here because
  116. # it just got spawned by the install script
  117. %{__sed} -i -e '/^#!\//, 1d' %{buildroot}%{python_sitelib}/init_calibre.py
  118. # icons
  119. %__mkdir_p %{buildroot}%{_datadir}/pixmaps/
  120. %__cp -p resources/images/library.png \
  121. %{buildroot}%{_datadir}/pixmaps/%{name}-gui.png
  122. %__cp -p resources/images/viewer.png \
  123. %{buildroot}%{_datadir}/pixmaps/calibre-viewer.png
  124. # every file is empty here
  125. find %{buildroot}%{_datadir}/mime -maxdepth 1 -type f|xargs %__rm -f
  126. # packages aren't allowed to register mimetypes like this
  127. %__rm -f %{buildroot}%{_datadir}/applications/{defaults.list,mimeinfo.cache}
  128. desktop-file-validate \
  129. %{buildroot}%{_datadir}/applications/calibre-ebook-viewer.desktop
  130. desktop-file-validate \
  131. %{buildroot}%{_datadir}/applications/calibre-gui.desktop
  132. desktop-file-validate \
  133. %{buildroot}%{_datadir}/applications/calibre-lrfviewer.desktop
  134. %__mv %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes \
  135. %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes.xml
  136. # mimetype icon for lrf
  137. %__rm -rf %{buildroot}%{_datadir}/icons/hicolor/128x128
  138. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable
  139. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes
  140. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps
  141. %__cp -p resources/images/mimetypes/lrf.png \
  142. %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-sony-bbeb.png
  143. %__cp -p resources/images/viewer.png \
  144. %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/calibre-viewer.png
  145. # don't put bash completions in /usr/etc
  146. %__mv %{buildroot}%{_prefix}%{_sysconfdir} %{buildroot}
  147. # these are provided as separate packages
  148. %__rm -rf %{buildroot}%{_libdir}/%{name}/{odf,cherrypy,pyPdf,encutils,cssutils}
  149. %__rm -rf %{buildroot}%{_libdir}/%{name}/cal/utils/genshi
  150. %__rm -rf %{buildroot}%{_libdir}/%{name}/cal/trac
  151. # link to system fonts after we have deleted (see Source0) the non-free ones
  152. # http://bugs.calibre-ebook.com/ticket/3832
  153. %__mkdir_p %{buildroot}%{_datadir}/%{name}/fonts/prs500/
  154. %__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSans-Regular.ttf \
  155. %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0003m_.ttf
  156. %__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSerif-Regular.ttf \
  157. %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0011m_.ttf
  158. %__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationMono-Regular.ttf \
  159. %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0419m_.ttf
  160. # http://bugs.calibre-ebook.com/ticket/3770#comment:7
  161. # man pages
  162. %__mv %{buildroot}%{_datadir}/%{name}/man %{buildroot}%{_mandir}
  163. # move locales
  164. %__mv %{buildroot}%{_datadir}/%{name}/localization/locales \
  165. %{buildroot}%{_datadir}/locale
  166. for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/messages.mo; do
  167. lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
  168. %__mv %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/messages.mo \
  169. %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}.mo
  170. done;
  171. for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/iso639.mo; do
  172. lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
  173. %__mv %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/iso639.mo \
  174. %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}_iso639.mo
  175. done;
  176. for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/qt.qm; do
  177. lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
  178. %__mv $file %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}_$lang.qm
  179. done;
  180. %find_lang %{name} --with-qt --all-name
  181. # locales should be looked for in the proper place
  182. %{__sed} -i -e "s:P('localization/locales:('/usr/share/locale:" \
  183. -e "s/messages.mo/calibre.mo/" \
  184. -e "s/iso639.mo/calibre_iso639.mo/" \
  185. %{buildroot}%{_libdir}/%{name}/%{name}/utils/localization.py
  186. %{__rm} -f %{buildroot}%{_bindir}/%{name}-uninstall
  187. %__cp -a %{SOURCE2} %{buildroot}%{_bindir}/
  188. %clean
  189. %{__rm} -rf %{buildroot}
  190. %post
  191. update-desktop-database &> /dev/null ||:
  192. update-mime-database %{_datadir}/mime &> /dev/null || :
  193. touch --no-create %{_datadir}/icons/hicolor || :
  194. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  195. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  196. fi
  197. %postun
  198. update-desktop-database &> /dev/null ||:
  199. update-mime-database %{_datadir}/mime &> /dev/null || :
  200. touch --no-create %{_datadir}/icons/hicolor || :
  201. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  202. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  203. fi
  204. %files -f %{name}.lang
  205. %defattr(-,root,root,-)
  206. %doc COPYRIGHT LICENSE Changelog.yaml
  207. %{_bindir}/calibre
  208. %{_bindir}/calibre-complete
  209. %{_bindir}/calibre-customize
  210. %{_bindir}/calibre-debug
  211. %{_bindir}/calibre-parallel
  212. %{_bindir}/calibre-server
  213. %{_bindir}/calibre-smtp
  214. %{_bindir}/calibre-mount-helper
  215. %{_bindir}/calibredb
  216. %{_bindir}/ebook-convert
  217. %{_bindir}/ebook-device
  218. %{_bindir}/ebook-meta
  219. %{_bindir}/ebook-viewer
  220. %{_bindir}/epub-fix
  221. %{_bindir}/fetch-ebook-metadata
  222. %{_bindir}/librarything
  223. %{_bindir}/lrf2lrs
  224. %{_bindir}/lrfviewer
  225. %{_bindir}/lrs2lrf
  226. %{_bindir}/markdown-calibre
  227. %{_bindir}/pdfmanipulate
  228. %{_bindir}/web2disk
  229. %config(noreplace) %{_sysconfdir}/bash_completion.d/
  230. %{_libdir}/%{name}
  231. %{_datadir}/%{name}
  232. %{_datadir}/pixmaps/*
  233. %{_datadir}/applications/*
  234. %{_datadir}/mime/packages/*
  235. %{_datadir}/icons/hicolor/scalable/mimetypes/*
  236. %{_datadir}/icons/hicolor/scalable/apps/*
  237. %{python_sitelib}/init_calibre.py*
  238. %{_mandir}/man1/*
  239. %changelog
  240. * Fri Nov 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.26-1
  241. - new upstream release
  242. * Sun Oct 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.25-1
  243. - new upstream release
  244. * Tue Oct 19 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.24-1
  245. - Update to 0.7.24
  246. * Sat Oct 09 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.23-1
  247. - Update to 0.7.23
  248. - Fix up mount helper with our own local script.
  249. - Change files to list binaries so missing ones can more easily be noted.
  250. * Mon Oct 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.22-1
  251. - Update to 0.7.22
  252. * Fri Oct 01 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.21-1
  253. - Update to 0.7.21
  254. * Wed Sep 29 2010 jkeating - 0.7.20-2
  255. - Rebuilt for gcc bug 634757
  256. * Fri Sep 24 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.20-1
  257. - Update to 0.7.20
  258. * Wed Sep 15 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-3
  259. - Rebuild for new ImageMagick
  260. * Wed Sep 29 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.18-1
  261. - new upstream release
  262. - Fix svg/png changes.
  263. * Mon Sep 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-2
  264. - Fix svg/png changes.
  265. * Sun Sep 12 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-1
  266. - Update to 0.7.18
  267. - Require > 0.9.6 cssutils
  268. * Fri Sep 03 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.17-1
  269. - Update to 0.7.17
  270. * Fri Aug 27 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.16-1
  271. - Update to 0.7.16
  272. * Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.15-1
  273. - initial build based on Fedora development
  274. * Sat Aug 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.15-1
  275. - Update to 0.7.15
  276. * Thu Aug 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.14-2
  277. - rebuild (poppler)
  278. * Fri Aug 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.14-1
  279. - Update to 0.7.14
  280. * Fri Aug 06 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.13-1
  281. - Update to 0.7.13
  282. * Mon Aug 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.12-1
  283. - Update to 0.7.12
  284. * Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.11-1
  285. - Update to 0.7.11
  286. * Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-2
  287. - Rebuilt for python2.7
  288. * Fri Jul 23 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-1
  289. - Update to 0.7.10
  290. * Sat Jul 17 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.9-1
  291. - Update to 0.7.9
  292. * Sun Jul 11 2010 Michal Nowak <mnowak@redhat.com> - 0.7.8-1
  293. - Update to 0.7.8
  294. - build tar.xz instead of tar.bz2
  295. * Fri Jul 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.7-1
  296. - Update to 0.7.7
  297. * Wed Jun 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.6-1
  298. - Update to 0.7.6
  299. * Fri Jun 25 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.5-1
  300. - Update to 0.7.5
  301. * Sun Jun 20 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.4-1
  302. - Update to 0.7.4
  303. * Tue Jun 08 2010 Dan Horák <dan@danny.cz> - 0.7.1-2
  304. - rebuilt with podofo 0.8.1
  305. * Mon Jun 07 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.1-1
  306. - Update to 0.7.1
  307. - Added versioned dep on python-cssutils to make sure at least 0.9.6 is installed.
  308. * Fri Jun 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.0-1
  309. - Update to 0.7.0
  310. * Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.55-1
  311. - Update to 0.6.55
  312. * Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.54-1
  313. - Update to 0.6.54
  314. * Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.53-1
  315. - Update to 0.6.53
  316. * Wed May 5 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.6.47-2
  317. - Rebuild against new poppler
  318. * Sat Apr 10 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.47-1
  319. - new upstream release 0.6.47
  320. - new chmlib requirement
  321. - create directory for calibre's environment module
  322. - use bzip2 instead of gzip when preparing tarball in generate-tarball.sh
  323. - remove cssutils patches (we now have python-cssutils 0.9.6 in Fedora)
  324. * Fri Feb 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.42-1
  325. - new upstream release 0.6.42
  326. - remove shebang from default_tweaks.py
  327. * Mon Feb 1 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.37-1
  328. - new upstream release 0.6.37
  329. * Fri Jan 29 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.36-1
  330. - new upstream release 0.6.36
  331. - fixed a cssprofiles issue with loading the profiles
  332. * Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-3
  333. - added -cssprofiles patch to cvs
  334. * Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-2
  335. - remove python-cssutils 0.9.6 dependency
  336. * Mon Jan 25 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-1
  337. - new upstream release
  338. - fedora includes cssutils >= 0.9.6 now; removed the cssprofiles patch
  339. - removed -executables patch, upstream fixed it: http://bugs.calibre-ebook.com/ticket/4437
  340. * Wed Jan 6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-2
  341. - fix for package tagged without adding new patch to cvs
  342. * Wed Jan 6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-1
  343. - new upstream release 0.6.32
  344. - project website has changed
  345. - added python-BeautifulSoup BuildRequire
  346. - new patch to fix full buildpath in binary files
  347. * Sun Dec 6 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.26-1
  348. - New upstream version
  349. - Regenerated no-update patch because of code relocation
  350. * Wed Dec 2 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.25-1
  351. - New upstream release
  352. * Wed Nov 18 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.24-1
  353. - New upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2416Nov2009
  354. * Mon Nov 16 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.23-1
  355. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2313Nov2009
  356. - patch to stop checking for new upstream version
  357. * Sat Nov 7 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.21-1
  358. - new upstream version: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2106Nov2009
  359. - added python-BeautifulSoup requirement
  360. * Wed Nov 4 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.20-1
  361. - new upstream version:
  362. http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2030Oct2009
  363. - upstream now ships correct .desktop files
  364. - fixed missing dependency: PyQt4
  365. - fixed calibre-gui icon
  366. * Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-3
  367. - removed unfree fonts from source package
  368. * Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-2
  369. - readability enhancements
  370. - added python-genshi requires
  371. - removed libwmf require since ImageMagick provides libwmf-lite as a
  372. dependency and that's what we actually need
  373. * Wed Oct 21 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-1
  374. - new upstream version:
  375. http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1920Oct2009
  376. - delete fonts, calibre can find the system fonts
  377. - specify libdir as an install option, so calibre will link properly
  378. even on 64bit
  379. * Mon Oct 19 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.18-1
  380. - updated requires list
  381. - new upstream release
  382. - can override CFLAGS now
  383. - removed trac and genshi duplicates
  384. - use xdg env variables to do desktop integration in the buildroot
  385. - added xdg-utils buildrequire
  386. - install udev rules in /usr/lib even on 64bit and don't own the whole dir
  387. - removed wrongly used Version field from .desktop files
  388. * Mon Oct 12 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-2
  389. - mimick what calibre's desktop-integration script does (mimetypes, icons etc.)
  390. - removed unneeded INSTALL file
  391. - marked bash completion file as config(noreplace) and take ownership of the dir
  392. * Sat Oct 10 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-1
  393. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1709Oct2009
  394. - the install process changed significantly
  395. - locales were added
  396. * Thu Sep 10 2009 Ionuț Arțăriși <mapleoin@lavabit.com> - 0.6.11-1
  397. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1104Sep2009
  398. - minor path fixes
  399. - rearranged files section
  400. * Fri Aug 28 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.10-1
  401. - handle desktop files
  402. - don't compress manpages and don't list them as duplicates
  403. - added lrfviewer icon
  404. * Tue Aug 25 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.8-1
  405. - Initial RPM release