medit-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177
  1. %define name medit
  2. %define version 0.10.5
  3. Name: %{name}
  4. Version: %{version}
  5. Release: 2%{?_dist_release}
  6. Summary: Multiplatform GTK+2 text editor
  7. Summary(ja): マルチプラットフォームな GTK+2 テキストエディタ
  8. Group: Applications/Editors
  9. License: GPLv2+
  10. URL: http://mooedit.sourceforge.net/
  11. Source0: http://prdownloads.sourceforge.net/mooedit/%{name}-%{version}.tar.bz2
  12. Source1: medit_ja.po
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Buildrequires: cairo-devel
  15. BuildRequires: cmake >= 2.6
  16. BuildRequires: desktop-file-utils
  17. BuildRequires: gettext
  18. BuildRequires: gtk2-devel glib2-devel
  19. BuildRequires: intltool
  20. BuildRequires: libxml2-devel
  21. BuildRequires: libX11-devel libXext-devel libICE-devel
  22. Buildrequires: perl-XML-Parser pango-devel
  23. BuildRequires: pcre-devel
  24. BuildRequires: python-devel
  25. BuildRequires: pygtk2-devel
  26. %description
  27. Medit is a multiplatform GTK+2 text editor.
  28. Features:
  29. * Configurable syntax highlighting.
  30. * Configurable keyboard accelerators.
  31. * Multiplatform - works both on unix and windows.
  32. * Plugins: can be written in C or Python.
  33. * Configurable tools available from the main and context menus.
  34. They can be written in Python or Lua, or it can be a shell script.
  35. * Regular expression search/replace, grep and find frontends, builtin file selector, etc.
  36. %description -l ja
  37. Medit はマルチプラットフォームな GTK+2 テキストエディタです。
  38. 機能一覧:
  39. * 設定可能な構文強調機能。
  40. * 設定可能なキーボードアクセラレータ。
  41. * マルチプラットフォーム - unix と windows の両者で動作。
  42. * プラグイン: C あるいは Python で作成可能。
  43. * メインメニューおよびコンテキストメニューから設定可能なツールを利用可能。
  44. Python あるいは lua 、シェルスクリプトで作成可能。
  45. * 正規表現による検索/置換、grep と find のフロントエンド、組み込みファイルセレクタなどなど。
  46. %prep
  47. %setup -q
  48. sed -i 's|fr|fr\nja|g' po/LINGUAS
  49. %__cp -f %{SOURCE1} po/ja.po
  50. %build
  51. cmake -D CMAKE_INSTALL_PREFIX=/usr .
  52. make %{?_smp_mflags}
  53. %install
  54. rm -rf %buildroot
  55. make install DESTDIR=$RPM_BUILD_ROOT
  56. desktop-file-install --vendor="" \
  57. --dir=${RPM_BUILD_ROOT}%{_datadir}/applications \
  58. --mode 0644 \
  59. $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
  60. %post
  61. update-desktop-database %{_datadir}/applications
  62. touch --no-create %{_datadir}/icons/hicolor
  63. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  64. gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
  65. fi
  66. %postun
  67. update-desktop-database %{_datadir}/applications
  68. touch --no-create %{_datadir}/icons/hicolor
  69. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  70. gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
  71. fi
  72. %clean
  73. rm -rf %buildroot
  74. %files
  75. %defattr(-,root,root)
  76. %doc COPYING README
  77. %{_bindir}/*
  78. %{_datadir}/applications/%{name}.desktop
  79. %{_datadir}/moo
  80. %{_datadir}/pixmaps/*
  81. %{_datadir}/icons/hicolor/*
  82. %{_datadir}/locale/*
  83. %{_docdir}/%{name}/*
  84. %{_mandir}/man?/
  85. %changelog
  86. * Sun Oct 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-2
  87. - updated Source1
  88. * Fri Oct 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-1
  89. - new upstream release
  90. - cleaned up spec
  91. * Sat Jul 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-2
  92. - updated Source1
  93. - added BuildRequires: cairo-devel, gettext, libX11-devel, perl-XML-Parser, pango-devel
  94. - changed BuildRequires: cmake >= 2.6
  95. * Wed May 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-1
  96. - new upstream release
  97. - added Japanese language file
  98. - added man directory in %files
  99. * Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
  100. - new upstream release
  101. - applied new naming policy to spec
  102. * Fri Mar 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.0-1
  103. - initial build for VineSeed
  104. * Mon Jan 21 2008 Funda Wang <fundawang@mandriva.org> 0.9.2-1mdv2008.1
  105. + Revision: 155675
  106. - New version 0.9.2
  107. - rediff patch0
  108. + Olivier Blin <oblin@mandriva.com>
  109. - restore BuildRoot
  110. + Thierry Vignaud <tvignaud@mandriva.com>
  111. - kill re-definition of %%buildroot on Pixel's request
  112. * Sat Dec 01 2007 Funda Wang <fundawang@mandriva.org> 0.9.0-1mdv2008.1
  113. + Revision: 114221
  114. - New version 0.9.0
  115. * Sat Nov 17 2007 Jérôme Soyer <saispo@mandriva.org> 0.8.11-1mdv2008.1
  116. + Revision: 109208
  117. - New release 0.8.11
  118. * Tue Aug 07 2007 Funda Wang <fundawang@mandriva.org> 0.8.10-1mdv2008.0
  119. + Revision: 59667
  120. - New version 0.8.10
  121. * Wed Aug 01 2007 Funda Wang <fundawang@mandriva.org> 0.8.9-1mdv2008.0
  122. + Revision: 57568
  123. - New version 0.8.9
  124. * Thu Jul 12 2007 Funda Wang <fundawang@mandriva.org> 0.8.8-1mdv2008.0
  125. + Revision: 51500
  126. - Fix file list
  127. - New version
  128. * Thu Jun 14 2007 Funda Wang <fundawang@mandriva.org> 0.8.6-1mdv2008.0
  129. + Revision: 39539
  130. - SILent renew tarball
  131. - New version
  132. - New version
  133. add dirty patch that skips update-icon-cache and mime database when building
  134. + Jérôme Soyer <saispo@mandriva.org>
  135. - Import medit
  136. * Tue May 09 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.98-1mdk
  137. - new release
  138. * Mon May 08 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.97-1mdk
  139. - first spec for Mandriva