openhpi-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343
  1. Summary: Hardware Platform Interface library and tools
  2. Summary(ja): ハードウエアプラットフォームインタフェースライブラリおよびツール
  3. Name: openhpi
  4. Version: 2.14.1
  5. Release: 1%{?_dist_release}
  6. License: BSD
  7. Group: System Environment/Base
  8. URL: http://www.openhpi.org
  9. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  10. Source1: %{name}.initd
  11. Source2: %{name}.sysconfig
  12. # https://sourceforge.net/tracker/?func=detail&aid=2932689&group_id=71730&atid=532251
  13. Patch0: openhpi-2.14.1-fumi-type.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: sysfsutils-devel, net-snmp-devel, OpenIPMI-devel, glib2-devel
  16. BuildRequires: libtool-ltdl-devel, openssl-devel, ncurses-devel
  17. BuildRequires: libxml2-devel, docbook-utils, libuuid-devel
  18. Requires(post): chkconfig
  19. Requires(preun): chkconfig
  20. Requires(preun): initscripts
  21. %description
  22. OpenHPI is an open source project created with the intent of providing an
  23. implementation of the SA Forum's Hardware Platform Interface (HPI). HPI
  24. provides an abstracted interface to managing computer hardware, typically for
  25. chassis and rack based servers. HPI includes resource modeling; access to and
  26. control over sensor, control, watchdog, and inventory data associated with
  27. resources; abstracted System Event Log interfaces; hardware events and alerts;
  28. and a managed hot swap interface.
  29. OpenHPI provides a modular mechanism for adding new hardware and device support
  30. easily. Many plug-ins exist in the OpenHPI source tree to provide access to
  31. various types of hardware. This includes, but is not limited to, IPMI based
  32. servers, Blade Center, and machines which export data via sysfs.
  33. %package libs
  34. Group: System Environment/Libraries
  35. Summary: The system libraries for the OpenHPI project
  36. Summary(ja): OpenHPI のシステムライブラリ
  37. Obsoletes: %{name} < 2.10.2-1
  38. %description libs
  39. The system libraries for the OpenHPI project.
  40. %package devel
  41. Group: Development/Libraries
  42. Summary: The development environment for the OpenHPI project
  43. Summary(ja): OpenHPIの開発環境
  44. Requires: %{name}-libs = %{version}-%{release}
  45. Requires: glib2-devel, pkgconfig
  46. %description devel
  47. The development libraries and header files for the OpenHPI project.
  48. %prep
  49. %setup -q
  50. %patch0 -p1 -b .fumi-type
  51. # fix permissions
  52. chmod a-x plugins/simulator/*.[ch]
  53. chmod a-x clients/*.[ch]
  54. %build
  55. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  56. %configure --disable-static
  57. # Don't use rpath!
  58. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  59. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  60. make %{?_smp_mflags}
  61. %install
  62. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
  63. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  64. mkdir -p $RPM_BUILD_ROOT%{_initddir}
  65. mkdir -p -m1777 $RPM_BUILD_ROOT%{_var}/lib/%{name}
  66. make install DESTDIR=$RPM_BUILD_ROOT
  67. rm -f $RPM_BUILD_ROOT%{_sysconfdir}/init.d/openhpid
  68. install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initddir}/openhpid
  69. install -p -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/openhpid
  70. rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la
  71. rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/*.la
  72. # fix perms for generated docs
  73. chmod 0644 docs/hld/openhpi-manual/*.html
  74. %check
  75. make check
  76. %clean
  77. rm -rf $RPM_BUILD_ROOT
  78. %post
  79. /sbin/chkconfig --add openhpid
  80. %preun
  81. if [ $1 = 0 ] ; then
  82. /sbin/service openhpid stop >/dev/null 2>&1
  83. /sbin/chkconfig --del openhpid
  84. fi
  85. %postun
  86. if [ "$1" -ge "1" ] ; then
  87. /sbin/service openhpid condrestart >/dev/null 2>&1
  88. fi
  89. %post libs -p /sbin/ldconfig
  90. %postun libs -p /sbin/ldconfig
  91. %files
  92. %defattr(-,root,root,-)
  93. %doc COPYING README README.daemon docs/hld/openhpi-manual openhpi.conf.example
  94. %dir %{_sysconfdir}/%{name}
  95. %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
  96. %config(noreplace) %{_sysconfdir}/%{name}/%{name}client.conf
  97. %{_initddir}/openhpid
  98. %config(noreplace) %{_sysconfdir}/sysconfig/openhpid
  99. %attr(1777,root,root) %{_var}/lib/%{name}
  100. %{_bindir}/*
  101. %{_sbindir}/*
  102. %{_libdir}/%{name}
  103. %{_mandir}/man1/*
  104. %{_mandir}/man7/*
  105. %{_mandir}/man8/*
  106. %files libs
  107. %defattr(-,root,root,-)
  108. %{_libdir}/*.so.*
  109. %files devel
  110. %defattr(-,root,root,-)
  111. %doc COPYING
  112. %{_libdir}/*.so
  113. %{_includedir}/%{name}
  114. %{_libdir}/pkgconfig/*.pc
  115. %changelog
  116. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-1
  117. - initial build for Vine Linux
  118. * Wed Feb 24 2010 Dan Horák <dan[at]danny.cz> - 2.14.1-3
  119. - update initscript (#521648, #521830)
  120. * Fri Jan 15 2010 Dan Horák <dan[at]danny.cz> - 2.14.1-2
  121. - added fix for inconsistent SaHpi.h
  122. * Wed Nov 25 2009 Dan Horák <dan[at]danny.cz> - 2.14.1-1
  123. - updated to bug fix release 2.14.1
  124. * Fri Oct 9 2009 Dan Horák <dan[at]danny.cz> - 2.14.0-6
  125. - rebuilt with net-snmp 5.5
  126. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.14.0-5
  127. - rebuilt with new openssl
  128. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14.0-4
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  130. * Wed Jul 14 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-3
  131. - add BR: libuuid-devel
  132. * Fri Apr 17 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-2
  133. - use upstream default config
  134. - libtoolize/autoreconf is not needed
  135. * Fri Apr 17 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-1
  136. - update to 2.14.0
  137. * Wed Feb 25 2009 Dan Horak <dan[at]danny.cz> - 2.13.3-2
  138. - fix ppc/ppc64 builds
  139. * Wed Feb 25 2009 Dan Horak <dan[at]danny.cz> - 2.13.3-1
  140. - update to 2.13.3
  141. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.13.1-3
  142. - rebuild with new openssl
  143. * Tue Nov 25 2008 Dan Horak <dan[at]danny.cz> - 2.13.1-2
  144. - shorten Summary
  145. * Thu Nov 20 2008 Dan Horak <dan[at]danny.cz> - 2.13.1-1
  146. - update to 2.13.1
  147. * Mon Nov 17 2008 Dan Horak <dan[at]danny.cz> - 2.12.0-2
  148. - rebuild for new libtool
  149. * Sat Jul 26 2008 Dan Horak <dan[at]danny.cz> - 2.12.0-1
  150. - update to 2.12.0
  151. * Thu Jun 27 2008 Dan Horak <dan[at]danny.cz> - 2.11.3-1
  152. - update to 2.11.3
  153. * Thu Apr 18 2008 Dan Horak <dan[at]danny.cz> - 2.10.2-2
  154. - enable the sysfs plugin
  155. - add missing R: for -devel subpackage
  156. * Thu Mar 13 2008 Dan Horak <dan[at]danny.cz> - 2.10.2-1
  157. - update to 2.10.2
  158. - spec file and patch cleanup
  159. * Thu Feb 28 2008 Phil Knirsch <pknirsch@redhat.com> - 2.10.1-3
  160. - Removed incorrect patch for IBM BC snmp_bc plugin
  161. - Fixed GCC 4.3 rebuild problems
  162. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.10.1-2
  163. - Autorebuild for GCC 4.3
  164. * Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.10.1-1
  165. - Updated to openhpi-2.10.1
  166. - Bump release and rebuild due to new openssl
  167. * Thu Aug 23 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-5
  168. - Bump release and rebuild because of PPC issues
  169. - Fix rebuild problems due to new glibc open macro
  170. * Fri Jul 20 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-4
  171. - Fix for hpipower segfaulting when using -b option out of range (#247279)
  172. * Tue Jul 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-3
  173. - Fixed a bug where the snmp_bc plugin didn't work in IBM BC (#247280)
  174. * Mon Jun 04 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-2.fc7
  175. - Fixed missing e2fsprogs-devel and openssl-devel build requires
  176. * Fri Mar 30 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-1.fc7
  177. - Update to openhpi-2.8.1
  178. * Thu Feb 08 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-3.fc7
  179. - Fixed some silly bugs in the specfile
  180. * Wed Feb 07 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-2.fc7
  181. - Bump and rebuild.
  182. * Tue Feb 06 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-1.fc7
  183. - Update to openhpi-2.8.0
  184. * Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-7.fc7
  185. - Rebuilt due to new net-snmp-5.4
  186. - Small specfile updates
  187. * Fri Sep 29 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-6
  188. - Fixed file conflicts for openhpi-switcher (#205226)
  189. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.1-5.1
  190. - rebuild
  191. * Mon Jul 10 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-5
  192. - Had to disable sysfs support due to new libsysfs and incompatible API.
  193. - Added missing ncurses-devel buildrequires
  194. * Wed Jun 07 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-4
  195. - Rebuilt with final memset patch
  196. - Added missing pkgconfig buildprereq (#191935)
  197. * Fri May 26 2006 Radek Vokal <rvokal@redhat.com> - 2.4.1-2
  198. - rebuilt for new libnetsnmp and net-snmp-config changes
  199. * Wed May 24 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-1
  200. - Fixed buggy use of memset throughout the code
  201. - Made the package build and install properly
  202. * Fri May 19 2006 Phil Knirsch <pknirsch@redhat.com>
  203. - Added missing glib2-devel build prereq (#191935)
  204. - Update to latest stable version openhpi-2.4.1
  205. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.1-4.2
  206. - bump again for double-long bug on ppc(64)
  207. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.1-4.1
  208. - rebuilt for new gcc4.1 snapshot and glibc changes
  209. * Mon Jan 9 2006 Peter Jones <pjones@redhat.com> 2.2.1-4
  210. - Don't use -Werror, it doesn't build with that on ppc64 currently.
  211. * Mon Jan 06 2006 Jesse Keating <jkeating@redhat.com> 2.2.1-3
  212. - Fix to not use stict-aliasing.
  213. * Wed Jan 04 2006 Radek Vokal <rvokal@redhat.com> 2.2.1-2
  214. - Rebuilt against new libnetsnmp
  215. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  216. - rebuilt
  217. * Fri Nov 11 2005 Phil Knirsch <pknirsch@redhat.com> 2.2.1-1
  218. - Update to stable openhpi-2.2.1
  219. * Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-5
  220. - Rebuilt to link against latest openssl lib.
  221. * Mon Nov 07 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-4
  222. - Added the openhpi config file
  223. - Added missing /var/lib/openhpi dir with proper rights
  224. - Added a few missing BuildPreReqs
  225. * Thu Nov 03 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-3
  226. - Rebuild against new net-snmp libs
  227. * Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-1
  228. - Moved the pkgconfig files to the devel package (#152507)
  229. - Update to openhpi-2.0.3
  230. - Had to manually disable ipmi support for now until openhpi builds correctly
  231. against it again
  232. - Dropped net-snmp-config patch, not needed anymore
  233. * Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-5
  234. - Fixed gcc4 rebuild problems
  235. * Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-4
  236. - bump release and rebuild with gcc 4
  237. * Mon Feb 14 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-3
  238. - Rebuilt for new rpm-4.4
  239. * Mon Dec 20 2004 Phil Knirsch <pknirsch@redhat.com> 1.9.2-2
  240. - Fixed overflow in plugins/sysfs/sysfs2hpi.c
  241. - Fixed rebuild problem with latest net-snmp
  242. - Removed is_simulator patch, not needed anymore
  243. * Fri Nov 26 2004 Florian La Roche <laroche@redhat.com> 1.9.2-1
  244. - update to 1.9.2
  245. * Tue Nov 02 2004 Phil Knirsch <pknirsch@redhat.com> 1.9.1-1
  246. - Added proper BuildRequires
  247. - Drop ia64 for first build, something fishy with the compiler and warning.
  248. * Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
  249. - Initial version
  250. - Disable dummy plugin, doesn't compile
  251. - Fix missing () in snmp_bc_session.c