python-sphinx-vl.spec 7.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
  2. %global upstream_name Sphinx
  3. %global prerel b2
  4. Name: python-sphinx
  5. Version: 1.0
  6. Release: 1.%{?prerel}%{?_dist_release}
  7. Summary: Python documentation generator
  8. Group: Development/Tools
  9. # Unless otherwise noted, the license for code is BSD
  10. # sphinx/util/stemmer.py Public Domain
  11. # sphinx/pycode/pgen2 Python
  12. # jquery (MIT or GPLv2)
  13. License: BSD and Public Domain and Python and (MIT or GPLv2)
  14. URL: http://sphinx.pocoo.org/
  15. Source0: http://pypi.python.org/packages/source/S/%{upstream_name}/%{upstream_name}-%{version}%{?prerel}.tar.gz
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildArch: noarch
  18. BuildRequires: python-devel >= 2.4
  19. BuildRequires: python-setuptools
  20. BuildRequires: python-docutils
  21. BuildRequires: python-jinja2
  22. BuildRequires: python-nose
  23. Requires: python-docutils
  24. Requires: python-jinja2
  25. Requires: python-pygments
  26. %description
  27. Sphinx is a tool that makes it easy to create intelligent and
  28. beautiful documentation for Python projects (or other documents
  29. consisting of multiple reStructuredText sources), written by Georg
  30. Brandl. It was originally created to translate the new Python
  31. documentation, but has now been cleaned up in the hope that it will be
  32. useful to many other projects.
  33. Sphinx uses reStructuredText as its markup language, and many of its
  34. strengths come from the power and straightforwardness of
  35. reStructuredText and its parsing and translating suite, the Docutils.
  36. Although it is still under constant development, the following
  37. features are already present, work fine and can be seen "in action" in
  38. the Python docs:
  39. * Output formats: HTML (including Windows HTML Help) and LaTeX,
  40. for printable PDF versions
  41. * Extensive cross-references: semantic markup and automatic links
  42. for functions, classes, glossary terms and similar pieces of
  43. information
  44. * Hierarchical structure: easy definition of a document tree, with
  45. automatic links to siblings, parents and children
  46. * Automatic indices: general index as well as a module index
  47. * Code handling: automatic highlighting using the Pygments highlighter
  48. * Various extensions are available, e.g. for automatic testing of
  49. snippets and inclusion of appropriately formatted docstrings.
  50. %package doc
  51. Summary: Documentation for %{name}
  52. Group: Documentation
  53. License: BSD
  54. Requires: %{name} = %{version}-%{release}
  55. %description doc
  56. Sphinx is a tool that makes it easy to create intelligent and
  57. beautiful documentation for Python projects (or other documents
  58. consisting of multiple reStructuredText sources), written by Georg
  59. Brandl. It was originally created to translate the new Python
  60. documentation, but has now been cleaned up in the hope that it will be
  61. useful to many other projects.
  62. This package contains documentation in reST and HTML formats.
  63. %prep
  64. %setup -q -n %{upstream_name}-%{version}%{?prerel}
  65. %__sed '1d' -i sphinx/pycode/pgen2/token.py
  66. %build
  67. %{__python} setup.py build
  68. pushd doc
  69. %__make html
  70. %__rm -rf _build/html/.buildinfo
  71. %__mv _build/html ..
  72. %__rm -rf _*
  73. popd
  74. %install
  75. %__rm -rf %{buildroot}
  76. %{__python} setup.py install --skip-build --root %{buildroot}
  77. # Manpages not in beta release yet
  78. #pushd doc
  79. # Deliver man pages
  80. #install -d %{buildroot}%{_mandir}/man1
  81. #mv sphinx-*.1 %{buildroot}%{_mandir}/man1/
  82. #popd
  83. # Deliver rst files
  84. %__mv doc reST
  85. # Move language files to /usr/share in association with %patch1
  86. pushd %{buildroot}%{python_sitelib}
  87. for lang in `find sphinx/locale -maxdepth 1 -mindepth 1 -type d -printf "%f "`;
  88. do
  89. install -d %{buildroot}%{_datadir}/sphinx/locale/$lang
  90. install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
  91. %__mv sphinx/locale/$lang/LC_MESSAGES/sphinx.js \
  92. %{buildroot}%{_datadir}/sphinx/locale/$lang/
  93. %__mv sphinx/locale/$lang/LC_MESSAGES/sphinx.mo \
  94. %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
  95. %__rm -rf sphinx/locale/$lang
  96. done
  97. popd
  98. %find_lang sphinx
  99. # Language files; Since these are javascript, it's not immediately obvious to
  100. # find_lang that they need to be marked with a language.
  101. (cd %{buildroot} && find . -name 'sphinx.js') | %__sed -e 's|^.||' | %__sed -e \
  102. 's:\(.*/locale/\)\([^/_]\+\)\(.*\.js$\):%lang(\2) \1\2\3:' \
  103. >> sphinx.lang
  104. %clean
  105. %__rm -rf %{buildroot}
  106. %check
  107. %__make test
  108. %files -f sphinx.lang
  109. %defattr(-,root,root,-)
  110. %doc AUTHORS CHANGES EXAMPLES LICENSE README TODO
  111. %{_bindir}/sphinx-*
  112. %{python_sitelib}/*
  113. %{_datadir}/sphinx/
  114. %exclude %{_datadir}/sphinx/locale/*/sphinx.js
  115. #%{_mandir}/man1/*
  116. %files doc
  117. %defattr(-,root,root,-)
  118. %doc html reST
  119. %changelog
  120. * Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-1.b2
  121. - initial build based on Fedora development
  122. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.0-0.1.b2.1
  123. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  124. * Mon May 31 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 1.0-0.2.b2
  125. - Update to 1.0 beta 2
  126. - Fixes problem building html documentation in non-English locales
  127. * Wed May 26 2010 Michel Salim <salimma@fedoraproject.org> - 1.0-0.1.b1
  128. - Update to 1.0 beta 1
  129. * Tue May 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.6.6-1
  130. - Update to 0.6.6
  131. * Fri May 21 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.5-2
  132. - Few minor tweaks to Gareth's spec file update
  133. * Mon May 10 2010 Gareth Armstrong <gareth.armstrong@hp.com> - 0.6.5-1.hp
  134. - Update to 0.6.5
  135. - Initial import of python-sphinx from Fedora Rawhide for use in HP CMS
  136. - Enforce that Sphinx requires Python 2.4 or later via an explicit BR
  137. - Minor tweaks to spec file
  138. - Move language files to %%{_datadir}, idea borrowed from Debian's sphinx
  139. package
  140. - Deliver man pages for sphinx-build & sphinx-quickstart
  141. - Deliver rst documentation files to reST directory in doc sub-package
  142. - Add %%check section for Python2 and add BR on python-nose
  143. * Wed Jan 13 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.4-1
  144. - Update to 0.6.4
  145. - Fixes a problem using autodoc with pylons projects.
  146. * Fri Sep 4 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.3-1
  147. - Update to 0.6.3
  148. * Mon Aug 17 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.2-1
  149. - Update to 0.6.2 -- upstream bugfix requested inside bz#512438
  150. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-3
  151. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  152. * Fri Jun 05 2009 Luke Macken <lmacken@redhat.com> - 0.6.1-2
  153. - Add a patch to use our own setuptools package
  154. * Fri Apr 17 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
  155. - Update to 0.6.1
  156. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-2
  157. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  158. * Fri Jan 2 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
  159. - Update to 0.5.1
  160. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.5-2
  161. - Rebuild for Python 2.6
  162. * Mon Nov 24 2008 Michel Salim <salimma@fedoraproject.org> - 0.5-1
  163. - Update to 0.5
  164. * Fri Oct 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.3-1
  165. - Update to 0.4.3
  166. * Wed Aug 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 0.4.2-1.1
  167. - Fix for EL-5 build.
  168. * Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.2-1
  169. - Update to 0.4.2
  170. * Mon May 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.3-1
  171. - Update to 0.3
  172. * Fri May 2 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.61950-3
  173. - Split documentation into subpackage
  174. - Exclude C files (not built by default anyway)
  175. * Wed Apr 16 2008 José Matos <jamatos@fc.up.pt> - 0.1.61950-2
  176. - Build html documentation, include it and include the rst
  177. documentation.
  178. * Thu Mar 27 2008 Michel Salim <michel.sylvan@gmail.com> 0.1.61950-1
  179. - Initial package