ninja-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110
  1. Name: ninja
  2. Version: 1.6.0
  3. Release: 1%{?_dist_release}
  4. Summary: A small build system with a focus on speed
  5. Summary(ja): スピードを重視した小さなビルドシステム
  6. License: ASL 2.0
  7. URL: http://martine.github.com/ninja/
  8. Source0: https://github.com/martine/ninja/archive/v%{version}.tar.gz#/ninja-%{version}.tar.gz
  9. Source1: ninja.vim
  10. BuildRequires: asciidoc
  11. BuildRequires: gtest-devel
  12. BuildRequires: python-devel
  13. BuildRequires: re2c >= 0.11.3
  14. %description
  15. Ninja is a small build system with a focus on speed. It differs from other
  16. build systems in two major respects: it is designed to have its input files
  17. generated by a higher-level build system, and it is designed to run builds as
  18. fast as possible.
  19. %prep
  20. %setup -qn ninja-%{version}
  21. %build
  22. CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" \
  23. %{__python} configure.py --bootstrap --verbose
  24. ./ninja -v manual
  25. ./ninja -v ninja_test
  26. %install
  27. # TODO: Install ninja_syntax.py?
  28. mkdir -p %{buildroot}/{%{_bindir},%{_datadir}/bash-completion/completions,%{_datadir}/emacs/site-lisp,%{_datadir}/vim/vimfiles/syntax,%{_datadir}/vim/vimfiles/ftdetect,%{_datadir}/zsh/site-functions}
  29. install -pm755 ninja %{buildroot}%{_bindir}/ninja
  30. ln -sf ninja %{buildroot}%{_bindir}/ninja-build
  31. install -pm644 misc/bash-completion %{buildroot}%{_datadir}/bash-completion/completions/ninja-bash-completion
  32. install -pm644 misc/ninja-mode.el %{buildroot}%{_datadir}/emacs/site-lisp/ninja-mode.el
  33. install -pm644 misc/ninja.vim %{buildroot}%{_datadir}/vim/vimfiles/syntax/ninja.vim
  34. install -pm644 %{SOURCE1} %{buildroot}%{_datadir}/vim/vimfiles/ftdetect/ninja.vim
  35. install -pm644 misc/zsh-completion %{buildroot}%{_datadir}/zsh/site-functions/_ninja
  36. %check
  37. # workaround possible too low default limits
  38. ulimit -n 4096 && ulimit -u 4096
  39. ./ninja_test
  40. %files
  41. %doc COPYING HACKING.md README doc/manual.html
  42. %{_bindir}/ninja
  43. %{_bindir}/ninja-build
  44. %{_datadir}/bash-completion/completions/ninja-bash-completion
  45. %{_datadir}/emacs/site-lisp/ninja-mode.el
  46. %{_datadir}/vim/vimfiles/syntax/ninja.vim
  47. %{_datadir}/vim/vimfiles/ftdetect/ninja.vim
  48. # zsh does not have a -filesystem package
  49. %{_datadir}/zsh/
  50. %changelog
  51. * Mon Jan 18 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-1
  52. - update to 1.6.0
  53. - remove R: vim, emacsen
  54. (TODO: vim or el should be splitted to subpackage)
  55. - add ninja-build symlink to compatible with other rpm distros.
  56. * Thu Jun 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.0-1
  57. - initial build for Vine Linux
  58. * Wed Nov 20 2013 Ben Boeckel <mathstuf@gmail.com> - 1.4.0-1
  59. - Update to 1.4.0
  60. * Sun Nov 3 2013 Ville Skyttä <ville.skytta@iki.fi> - 1.3.4-4
  61. - Use special %%doc to install all docs (#994005).
  62. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-3
  63. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  64. * Fri Jun 21 2013 Dan Horák <dan[at]danny.cz> - 1.3.4-2
  65. - workaround possible too low limits for number of processes and open files,
  66. fixes build on ppc/ppc64 and s390(x)
  67. * Sun Jun 09 2013 Ben Boeckel <mathstuf@gmail.com> - 1.3.4-1
  68. - Update to 1.3.4
  69. - Run test suite
  70. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
  71. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  72. * Sun Nov 04 2012 Ben Boeckel <mathstuf@gmail.com> - 1.0.0-1
  73. - Update to 1.0.0
  74. * Thu Jul 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.6.20120719git5dc55a3
  75. - Update to new snapshot
  76. * Mon Jul 09 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.5.20120709gitb90d038
  77. - Preserve timestamps on install
  78. - Install as ninja-build to avoid conflicts with the ninja IRC package
  79. - Update snapshot
  80. * Tue Jun 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.4.20120605git54553d3
  81. - Add an ftdetect file for ninja
  82. - Fix zsh-stuff directory ownership
  83. * Thu Jun 07 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.3.20120605git54553d3
  84. - Add a Group tag
  85. * Tue Jun 05 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.2.20120605git54553d3
  86. - Update to new snapshot
  87. * Fri Mar 30 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.1.20120330gitabd33d5
  88. - Initial package