indent-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161
  1. Summary: A GNU program for formatting C code.
  2. Summary(ja): C のコードを整形する GNU プログラム
  3. Name: indent
  4. Version: 2.2.10
  5. Release: 1%{?_dist_release}
  6. License: GPLv3
  7. Group: Development/Tools
  8. URL: http://www.gnu.org/software/indent/
  9. Source: ftp://ftp.gnu.org/pub/gnu/indent-%{version}.tar.gz
  10. Patch0: indent-2.2.9-indent_h.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Requires(post): /sbin/install-info
  13. Requires(preun): /sbin/install-info
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. %description
  17. Indent is a GNU program for beautifying C code, so that it is easier to
  18. read. Indent can also convert from one C writing style to a different
  19. one. Indent understands correct C syntax and tries to handle incorrect
  20. C syntax.
  21. Install the indent package if you are developing applications in C and
  22. you want a program to format your code.
  23. %description -l ja
  24. Indent は C のコードを読みやすく整形する GNU プログラムです.Indent を
  25. 使うと,C コードのあるスタイルから別のスタイルへと返還することも出来ます.
  26. Indent は C 文法を理解しますので,間違った C の文法を可能な限り解釈しよう
  27. とします.
  28. C によるアプリケーション開発を行っていて,プログラムコードを整形したい
  29. 場合には indent パッケージをインストールして下さい.
  30. %prep
  31. %setup -q
  32. #patch0 -p0 -b .indent_h
  33. %build
  34. %configure
  35. export PATH=$PATH:.
  36. make
  37. %install
  38. rm -rf $RPM_BUILD_ROOT
  39. %makeinstall
  40. rm -f $RPM_BUILD_ROOT/%{_infodir}/dir $RPM_BUILD_ROOT/usr/bin/texinfo2man \
  41. $RPM_BUILD_ROOT/usr/doc/indent/indent.html
  42. %find_lang %name
  43. %clean
  44. rm -rf $RPM_BUILD_ROOT
  45. %post
  46. /sbin/install-info %{_infodir}/indent.info.gz %{_infodir}/dir --entry="* indent: (indent). Program to format source code."
  47. %preun
  48. if [ "$1" = 0 ]; then
  49. /sbin/install-info --delete %{_infodir}/indent.info.gz %{_infodir}/dir --entry="* indent: (indent). Program to format source code."
  50. fi
  51. %files -f %{name}.lang
  52. %defattr(-,root,root)
  53. %{_bindir}/indent
  54. %{_mandir}/*/*
  55. %{_infodir}/*
  56. %changelog
  57. * Sat Sep 27 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.2.10-1
  58. - updated to 2.2.10
  59. - dropt Patch0
  60. - changed Group to Development/Tools
  61. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.9-6
  62. - rebuild with VineSeed environment
  63. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.2.9-5
  64. - rebuilt with rpm-4.8.1-3
  65. * Tue Sep 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.9-4vl5
  66. - applied new versioning policy, spec in utf-8
  67. - added indent-2.2.9-indent_h.patch
  68. * Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.2.9-3vl2
  69. - rebuilt for x86_64 architecture
  70. * Mon Jul 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3vl1
  71. - rebuild with new toolchains
  72. - based on Redhat Rawhide 2.2.9-3
  73. * Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  74. - 2.2.6-1vl2
  75. - Oops the spec was in Shift_JIS. Fixed.
  76. * Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  77. - 2.2.6-1vl1
  78. - rebuilt for Vine Linux
  79. * Sun Nov 19 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  80. - update to 2.2.6
  81. * Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
  82. - rebuild
  83. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  84. - automatic rebuild
  85. * Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
  86. - use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir}
  87. and %%{_tmppath}
  88. - don't use %%{_prefix}
  89. * Wed May 10 2000 Trond Eivind Glomsr <teg@redhat.com>
  90. - added URL
  91. - remove manual stripping
  92. * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
  93. - man pages are compressed
  94. * Thu Jan 20 2000 Bill Nottingham <notting@redhat.com>
  95. - 2.2.5
  96. * Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
  97. - 2.2.0
  98. * Fri Jul 16 1999 Bill Nottingham <notting@redhat.com>
  99. - update to 2.1.1
  100. * Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
  101. - update to 1.10.0.
  102. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  103. - auto rebuild in the new build environment (release 11)
  104. * Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
  105. - build for 6.0 tree
  106. * Thu Aug 13 1998 Jeff Johnson <jbj@redhat.com>
  107. - build root
  108. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  109. - translations modified for de, fr, tr
  110. * Tue Oct 21 1997 Otto Hammersmith <otto@redhat.com>
  111. - use install-info
  112. * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
  113. - built against glibc