texlive-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713
  1. # -*- coding: utf-8-unix -*-
  2. %bcond_with firstbuild
  3. %global _use_internal_dependency_generator 0
  4. %global __find_provides %{SOURCE99}
  5. %global __find_requires %{SOURCE98}
  6. %global texlivesrcver 20131002
  7. Summary: The TeX text formatting system
  8. Summary(ja): TeX 文書整形システム
  9. Name: texlive
  10. Version: 2013
  11. Release: 4%{?_dist_release}
  12. License: distributable
  13. Group: Applications/Publishing
  14. URL: http://www.tug.org/texlive/
  15. ## original TeX Live source
  16. #Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
  17. ## snapshot
  18. # $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
  19. # $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
  20. Source: %{name}-source-%{texlivesrcver}.tar.xz
  21. ## tlptexlive: pmetapost
  22. Source1: http://www.preining.info/software/build-tlptexlive-20130815.zip
  23. Source2: http://www.tug.org/texlive/updmap-kanji.html
  24. ## our updmap{,-hdr}.cfg from collection-basic 20130823
  25. # NOTE:
  26. # * texmf.cnf: we use the conf file texmf.cnf generated from Source0
  27. Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
  28. Source7: updmap.cfg.texlive-%{texlivesrcver}
  29. ## desktop files
  30. # Source10: pxdvi.desktop
  31. Source11: texdoctk.desktop
  32. # ## pxdvi from tlptexlive 2012
  33. # Source50: texlive-source-xdvik-20130106.tar.xz
  34. # Source51: http://www.preining.info/software/build-tlptexlive-20130106.zip
  35. Source98: find-requires-texlive.sh
  36. ## find library sonames for libkpathsea and libptexenc
  37. Source99: find-provides-texlive.sh
  38. ## etc...
  39. #Source100: texlive.cron
  40. ######
  41. # TeX patches
  42. ######
  43. ## vine
  44. Patch0: reautoconf-parallel.diff
  45. Patch1: texlive-%{texlivesrcver}-vine.patch
  46. Patch2: texlive-%{texlivesrcver}-texmfcnf-vine.patch
  47. Patch3: texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
  48. #Patch10: texlive-%{texlivesrcver}-pxdvik-vine.patch
  49. ## security
  50. Requires: perl-Tk perl-Tk-TableMatrix
  51. Requires: ghostscript >= 8.71
  52. Requires: nkf
  53. Requires(post,postun): fontconfig
  54. Requires(post): ed mktemp
  55. Requires(post): vutils >= 7.1
  56. %{!?with_firstbuild:Requires: texlive-common = %{version}}
  57. BuildRequires: bison flex
  58. BuildRequires: bzip2-devel
  59. BuildRequires: zlib-devel
  60. BuildRequires: libpng-devel
  61. BuildRequires: gd-devel
  62. BuildRequires: ncurses-devel
  63. BuildRequires: libjpeg-devel
  64. BuildRequires: XOrg-devel
  65. BuildRequires: freetype2-devel >= 2.1.10
  66. BuildRequires: autoconf >= 2.68
  67. BuildRequires: openMotif-devel
  68. BuildRequires: poppler-devel >= 0.20
  69. BuildRequires: openssl-devel
  70. BuildRequires: libpaper-devel
  71. BuildRequires: fontconfig-devel
  72. BuildRequires: nkf
  73. ## needs to build pxdvi
  74. #BuildRequires: t1lib-devel
  75. BuildRequires: texlive-vtlpkg = %{version}
  76. Buildroot: %{_tmppath}/%{name}-%{version}-root
  77. Vendor: Project Vine
  78. Distribution: Vine Linux
  79. Packager: munepi
  80. %description
  81. The TeX Live software distribution offers a complete TeX system for a
  82. variety of Unix, Macintosh, Windows and other platforms. It
  83. encompasses programs for editing, typesetting, previewing and printing
  84. of TeX documents in many different languages, and a large collection
  85. of TeX macros and font libraries.
  86. The distribution includes extensive general documentation about TeX,
  87. as well as the documentation for the included software packages.
  88. %description -l ja
  89. TeX Live ソフトウェアディストリビューションは、
  90. さまざまな Unix, Macintosh, Windows、および
  91. 他のプラットホームに対して完全な TeX システムを提供します。
  92. 多くの異なった言語を含む TeX ドキュメントの
  93. 編集、組版、閲覧、印刷するためのプログラム、
  94. そして、TeX マクロやフォントライブラリの大きなコレクションを
  95. 同梱しています。
  96. このディストリビューションは
  97. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  98. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  99. %package doc
  100. Summary: TeX Live: Documentation files of %{name}
  101. Group: Applications/Publishing
  102. Requires: %{name} = %{version}-%{release}
  103. BuildArch: noarch
  104. %description doc
  105. This package contains documentation files of %{name}.
  106. %package -n libkpathsea
  107. Summary: path search library for the TeX Live
  108. Summary(ja): TeX Live 用パス検索ライブラリ
  109. Group: System Environment/Libraries
  110. %description -n libkpathsea
  111. This package includes runtime part of the Kpathsea library.
  112. %package -n libkpathsea-devel
  113. Summary: path search libary and header files for the TeX Live
  114. Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
  115. Group: Development/Libraries
  116. Requires: libkpathsea = %{version}-%{release}
  117. %description -n libkpathsea-devel
  118. This package includes static library and header files of the Kpathsea library.
  119. %package -n libptexenc
  120. Summary: Kanji code convert library for Japanese pTeX
  121. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
  122. Group: System Environment/Libraries
  123. Requires: libkpathsea = %{version}-%{release}
  124. %description -n libptexenc
  125. This package includes runtime part of the ptexenc library.
  126. %package -n libptexenc-devel
  127. Summary: Kanji code convert library and header files for Japanese pTeX
  128. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
  129. Group: Development/Libraries
  130. Requires: libptexenc = %{version}-%{release}
  131. %description -n libptexenc-devel
  132. This package includes header files of the ptexenc library.
  133. %prep
  134. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  135. #%setup -q -n %{name}-%{texlivesrcver}-source
  136. %setup -q -n %{name}-source-%{texlivesrcver} -a 1
  137. %patch0 -p0 -b .parallel
  138. %patch1 -p1 -b .vine
  139. %patch2 -p1 -b .vine
  140. %patch3 -p1 -b .vine
  141. ## Applying tlptexlive that provides pxdvi(k) and pmpost
  142. echo "applying patches"
  143. cat "$(pwd)/build-tlptexlive-20130815/patches/series" | while read p r ; do
  144. echo $p | grep '^#' >/dev/null || \
  145. patch -p1 $r < "$(pwd)/build-tlptexlive-20130815/patches/$p" || exit 1
  146. done
  147. # ## pxdvi from tlptexlive 2012
  148. # echo "creating pxdvi folder"
  149. # [ -d texk/pxdvik ] && exit 1
  150. # %__cp -pR texlive-source-20130106/texk/xdvik texk/pxdvik
  151. # echo "applying patches"
  152. # cat "$(pwd)/build-tlptexlive-20130106/patches/series" | \
  153. # grep -v -e freetype-modules -e pmpost -e reautoconf | while read p r ; do
  154. # echo $p | grep '^#' >/dev/null || \
  155. # patch -p1 $r < "$(pwd)/build-tlptexlive-20130106/patches/$p" || exit 1
  156. # done
  157. #
  158. # # customize pxdvik for Vine Linux
  159. # %patch10 -p1 -b .vine
  160. ## Avoid pollution from internal libraries.
  161. %__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,pixman,poppler,t1lib,unzip,xpdf,zlib} || exit 1
  162. # ./reautoconf || exit 1
  163. %build
  164. set -x
  165. unset TEXINPUTS || :
  166. unset HOME || :
  167. export CFLAGS="$RPM_OPT_FLAGS" \
  168. CXXFLAGS="$RPM_OPT_FLAGS" \
  169. LANG=C
  170. PREFIX=$(pwd)/work
  171. TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
  172. TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
  173. TL_CONFIGURE_ARGS=" \
  174. --disable-multiplatform \
  175. --disable-native-texlive-build \
  176. --with-banner-add=\"/Vine Linux\" \
  177. --enable-shared --disable-static \
  178. --enable-compiler-warnings=max \
  179. --without-cxx-runtime-hack \
  180. \
  181. --enable-web2c \
  182. --enable-web-progs --enable-dvipdfmx --enable-mendexk \
  183. --enable-makejvf --enable-pxdvik --enable-dvipsk \
  184. --enable-tetex --enable-texlive \
  185. \
  186. --with-system-xpdf \
  187. --with-system-gd \
  188. --with-system-t1lib \
  189. --with-system-libpng \
  190. --with-system-zlib \
  191. --with-system-freetype2 \
  192. --with-system-pixman \
  193. --with-system-poppler \
  194. --with-system-cairo \
  195. --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
  196. --with-pic \
  197. \
  198. --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
  199. --disable-dvi2tty \
  200. --disable-t1utils --disable-psutils --disable-detex \
  201. --disable-dvipng --disable-lcdf-typetools \
  202. "
  203. export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
  204. TL_MAKE=%__make ./Build || exit 1
  205. %install
  206. ## prepare %%install session
  207. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  208. ## copy inst directory to /usr
  209. %__mkdir_p %{buildroot}
  210. %__cp -a inst %{buildroot}%{_prefix} || exit 1
  211. %ifarch x86_64
  212. %__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
  213. %endif
  214. ## make some fundamental texmf trees
  215. %__mkdir_p %{buildroot}%{_tl_texmfvine}
  216. %__mkdir_p %{buildroot}%{_tl_texmfdist}
  217. %__mkdir_p %{buildroot}%{_tl_texmflocal}
  218. %__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
  219. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}
  220. %__mkdir_p %{buildroot}%{_tl_vartexfonts}
  221. %__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
  222. %__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
  223. cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
  224. The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
  225. distribution wide.
  226. You must not do any changes in this directory.
  227. EOF
  228. cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
  229. The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
  230. You should not use this directory to manage any other packages because
  231. we Project Vine use this directory to manage non-CTAN packages, some
  232. enhancement packages and so on.
  233. EOF
  234. cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
  235. The directory %{_tl_texmflocal} is the texmf tree of the system wide.
  236. If you are a privileged user of this system,
  237. you can use this directory to manage your local packages.
  238. EOF
  239. ## our texmf-dist/web2c/updmap{,-hdr}.cfg
  240. %__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
  241. %__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
  242. %__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
  243. ## our map files for dvipdfmx
  244. %__mkdir_p %{buildroot}%{_tl_aliasttfdir}
  245. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
  246. for x in ptex uptex otf otf-up; do
  247. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
  248. done
  249. for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
  250. touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
  251. done
  252. ## desktop things
  253. %__mkdir_p %{buildroot}%{_datadir}/applications
  254. # %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
  255. %__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
  256. # for created fonts
  257. %__mkdir_p %{buildroot}%{_tl_vartexfonts}
  258. # %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
  259. # %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
  260. ## set executable bit for the library
  261. %__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
  262. %__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
  263. # configure ConTeXt
  264. for x in context ctxtools luatools texexec texmfstart; do
  265. %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
  266. done
  267. # touch ghosts
  268. touch %{buildroot}%{_tl_texmfvine}/ls-R
  269. touch %{buildroot}%{_tl_texmfdist}/ls-R
  270. touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
  271. touch %{buildroot}%{_tl_texmfsysvar}/ls-R
  272. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
  273. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
  274. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
  275. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
  276. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
  277. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
  278. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
  279. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
  280. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
  281. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
  282. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
  283. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
  284. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
  285. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
  286. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
  287. ## remove unpackaging files
  288. find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
  289. find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
  290. %__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
  291. find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
  292. find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
  293. %__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
  294. %__rm -f %{buildroot}%{_infodir}/*
  295. ## use external packages
  296. %__rm %{buildroot}/usr/bin/latexmk || exit 1
  297. ### Files list
  298. find %{buildroot} -type f -or -type l | \
  299. %__sed -e "s|%{buildroot}||g" | \
  300. %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
  301. %__grep -v "%{_includedir}" | \
  302. %__grep -v "%{_libdir}" | \
  303. %__grep -v "%{_infodir}" | \
  304. %__sed -e "s|.*ls-R$|%ghost &|" \
  305. -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
  306. -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
  307. -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
  308. -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
  309. -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
  310. -e "s|.*\.cnf$|%config(noreplace) &|" \
  311. -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
  312. -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
  313. -e "s|^.*/updmap/$|%config &|" \
  314. -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
  315. -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
  316. -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
  317. -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
  318. -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
  319. -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
  320. -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
  321. -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
  322. -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
  323. -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
  324. -e "s|%{_mandir}/.*|&*|" \
  325. > %{_builddir}/filelist.full
  326. find %{buildroot}%{_tl_texmfvine}* -type d | \
  327. %__sed -e "s|^%{buildroot}|%dir |" \
  328. -e "s|$|/|" >> %{_builddir}/filelist.full
  329. ## subpackages
  330. %__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
  331. cat %{_builddir}/filelist.doc \
  332. %{_builddir}/filelist.full | \
  333. sort | uniq -u > %{_builddir}/filelist.tmp
  334. %__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
  335. %clean
  336. %__rm -rf %{buildroot}
  337. %pretrans
  338. rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012
  339. [ $? -eq 1 ] && exit 0
  340. _trans_time=$(date +%Y%m%d)
  341. echo "Running some transitional processes on your TeX system ... "
  342. x=(
  343. #/var/lib/texmf
  344. #/etc/texmf
  345. /usr/share/texmf-local
  346. /usr/share/texmf-var
  347. /usr/share/texmf-config
  348. )
  349. for dir in ${x[@]}; do
  350. _trans_dir=${dir}.${_trans_time}.rpmorig
  351. [ -d ${_trans_dir}.old ] && \
  352. echo -n " " && \
  353. echo "Found ${_trans_dir}.old: " && \
  354. echo -n " " && \
  355. %__rm -rvf ${_trans_dir}.old
  356. [ -d ${_trans_dir} ] && \
  357. echo -n " " && \
  358. echo "Found ${_trans_dir}: " && \
  359. echo -n " " && \
  360. %__mv -v ${_trans_dir} ${_trans_dir}.old
  361. [ -d ${dir} ] && \
  362. echo -n " " && \
  363. echo "Found ${dir}: " && \
  364. echo -n " " && \
  365. %__mv -v ${dir} ${_trans_dir}
  366. done
  367. echo "done."
  368. %postun
  369. if [ "$1" = 0 ]; then
  370. %__rm -rf %{_tl_vartexfonts}
  371. fi
  372. exit 0
  373. %post
  374. %_tl_touch_run texhash
  375. %_tl_touch_run updmap
  376. %_tl_touch_run mtxrun
  377. %_tl_touch_run fmtutil
  378. exit 0
  379. %posttrans
  380. %__mkdir_p %{_tl_vartexfonts}
  381. %__chmod 1777 %{_tl_vartexfonts}
  382. ## create our map files {ptex,uptex,otf,otf-up}-vine.map
  383. ( %{_tl_exec_upddeffont} ) ||:
  384. %{_tl_exec_texhash}
  385. %{_tl_exec_mtxrun}
  386. %{_tl_exec_updmap}
  387. %{_tl_exec_fmtutil}
  388. exit 0
  389. %post -n libkpathsea
  390. /sbin/ldconfig
  391. # for x in kpathsea tds web2c; do
  392. # /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
  393. # done
  394. # %preun -n libkpathsea
  395. # if [ "$1" = 0 ]; then
  396. # for x in kpathsea tds web2c; do
  397. # /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
  398. # done
  399. # fi
  400. %postun -n libkpathsea
  401. /sbin/ldconfig
  402. %post -n libptexenc
  403. /sbin/ldconfig
  404. %postun -n libptexenc
  405. /sbin/ldconfig
  406. %triggerin -- ghostscript
  407. %__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
  408. if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
  409. %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
  410. elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
  411. %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
  412. fi
  413. %_tl_touch_run texhash
  414. exit 0
  415. %files -f %{_builddir}/filelist.full
  416. %defattr(-,root,root)
  417. %dir %{_tl_aliasttfdir}
  418. %attr(1777,root,root) %dir %{_tl_vartexfonts}
  419. # %config %{_sysconfdir}/cron.daily/texlive.cron
  420. %files doc -f %{_builddir}/filelist.doc
  421. %defattr(-,root,root)
  422. %files -n libkpathsea
  423. %defattr(-,root,root)
  424. %{_libdir}/libkpathsea.so.*
  425. # %{_infodir}/kpathsea.info*
  426. %files -n libkpathsea-devel
  427. %defattr(-,root,root)
  428. %{_libdir}/libkpathsea.so
  429. %dir %{_includedir}/kpathsea
  430. %{_includedir}/kpathsea/*
  431. %files -n libptexenc
  432. %defattr(-,root,root)
  433. %{_libdir}/libptexenc.so.*
  434. %files -n libptexenc-devel
  435. %defattr(-,root,root)
  436. %{_libdir}/libptexenc.so
  437. %dir %{_includedir}/ptexenc
  438. %{_includedir}/ptexenc/*
  439. %changelog
  440. * Mon Oct 7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
  441. - updated texlive-20131002-texmfcnf-vine.patch:
  442. texmf.cnf (shell_escape_commands): added some programs
  443. * Wed Oct 2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
  444. - texlive-source-20131002 2014/dev + tlptexlive 20130815
  445. - defined %%global __find_requires find-requires-texlive.sh
  446. - dropped unused dependencies of Requires
  447. * Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
  448. - texlive-source-20130919 2014/dev + tlptexlive 20130815
  449. - correct some scripts of README.vine for each texmf trees
  450. * Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
  451. - upgrade to TeX Live 2013
  452. - texlive-source-20130823 2014/dev + tlptexlive 20130815
  453. - dropped Requires: jvf
  454. * Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
  455. - update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
  456. - fixed duplicated lw35 for updmap.pl
  457. - updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
  458. * Sat Mar 9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
  459. - touch the map files generated by updmap-sys
  460. * Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
  461. - fixed Source7: updmap.cfg.texlive-20120701
  462. (upto /etc/texmf/web2c/updmap.cfg)
  463. - fixex %%triggerin -- ghostscript
  464. - replaced %%exec_texhash with %%touch_run texhash
  465. * Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
  466. - TeX Live 2012 + tlptexlive 20121107
  467. * Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
  468. - drop BR: poppler-devel temporaly
  469. - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
  470. * Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
  471. - build with poppler-0.18.4
  472. - remove tlmgr
  473. * Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
  474. - updated to tl11supp-120120
  475. - run %%{exec_fmtutil} at %%post when upgrading
  476. * Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
  477. - updated to tl11supp-111214
  478. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
  479. - added BuildRequires: texlive-common
  480. - Babel needs docstrip.tex, which is contained in texlive-collection-latex
  481. - check japanese.ldf
  482. - updated tl11supp-111120-vine.patch
  483. - added the following options to $$TL_CONFIGURE_ARGS:
  484. --disable-detex
  485. --disable-dvipng
  486. --disable-lcdf-typetools
  487. - remove some files of asymptote
  488. - remove a man file of latexmk
  489. - remove man files of lcdf-typetools
  490. - remove man files of dvipng
  491. - remove a man file of detex
  492. * Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
  493. - added find-provides-texlive.sh and set it to %%__find_provides
  494. - use to find library sonames for libkpathsea and libptexenc
  495. - added cmex.enc (%%{SOURCE110})
  496. - do not install cmex.enc in our TDS, yet
  497. - removed some unused directories in texmf/fonts/map
  498. - removed man files of lcdf-typetools
  499. - moved texdoc{,tk} and its related files to texlive-doc
  500. * Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  501. - TeX Live 2011 + tl11supp-111120
  502. * Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
  503. - make the directory VARTEXFONTS (%%posttrans)
  504. - dropped %%triggerpostun -- texlive < 2009-17vl6
  505. * Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
  506. - fixed ptexlive-20100711-dvipdfmx-vine.patch
  507. - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
  508. * Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
  509. - added %%pre to avoid conflictions of texmf-{config,var}
  510. * Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
  511. - dropped Requires: texlive-common
  512. - added perl-Tk-TableMatrix
  513. - supported texdoctk
  514. - removed broken symbolic links in /usr/bin
  515. - for each these symbolic links, the package of its real file/path
  516. should be its owner.
  517. * Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
  518. - added %%triggerpostun -- texlive < 2009-17vl6
  519. - make the directory VARTEXFONTS
  520. * Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
  521. - fixed %%dir VARTEXFONTS around in %%files
  522. - dropped BuildRequires: t1utils
  523. * Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
  524. - updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
  525. - changed VARTEXFONTS to /var/lib/texmf/fonts
  526. * Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
  527. - fixed updmap.cfg
  528. * Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
  529. - dropped Requires: texlive-macros
  530. * Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
  531. - updated ptexlive-20100711-pxdvik-vine.patch
  532. and added texlive-20091107-xdvik-vine.patch
  533. - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
  534. * Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
  535. - supported Vine Linux 5
  536. - for vl5, changed a requirement of Japanese VF package
  537. - added Requires: texlive-jvf = 2009 (vl5)
  538. - dropped dependencies of Provides:/Obsoletes: tags
  539. - merged these dependencies in texlive-common-vl.spec
  540. * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
  541. - rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
  542. * Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
  543. - applied some security patches from Debian
  544. - texlive-2009-CVE-2010-0827.patch
  545. - texlive-2009-CVE-2010-1440.patch
  546. - applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
  547. - applied texlive-2009-luatexdir-libpoppler-0.12.patch
  548. based on texlive-2009-pdftexdir-libpoppler-0.12.patch
  549. - fixed some dependencies
  550. * Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
  551. - added BuildArch: noarch in %%package doc
  552. - removed some comment-out sentences
  553. * Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
  554. - separeted texmf-dist to texlive-common package
  555. * Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
  556. - unpacked texlive-20091107-source.tar.xz
  557. - babel is available now
  558. - applied eptex-100420 and some patches:
  559. - eptex-100420-vine.patch
  560. - eptex-100420-patch1.diff
  561. * Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
  562. - updated ptexlive-20100711
  563. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
  564. - customized updmap.cfg to correspond installed fonts
  565. * Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  566. - fixed insttexfont()
  567. * Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  568. - added jvf of MORISAWA basic 5 fonts
  569. - added cm-super, mathdesign in fntlst
  570. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  571. - define insttexfont() in %%install
  572. - copy almost compatible tetex-3.0
  573. * Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  574. - ptexlive-20090322 + TeXLive 2009
  575. - added BuildRequires: openssl-devel
  576. * Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
  577. - ptexlive-20091009 + TeXLive 2008