galera-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255
  1. %bcond_with systemd
  2. %bcond_with python3
  3. %if %{with python3}
  4. %global scons scons-3
  5. %else
  6. %global scons scons
  7. %endif
  8. Name: galera
  9. Version: 25.3.25
  10. Release: 4%{?_dist_release}
  11. Summary: Synchronous multi-master wsrep provider (replication engine)
  12. License: GPLv2
  13. URL: http://galeracluster.com/
  14. # Actually, the truth is, we do use galera source tarball provided by MariaDB on
  15. # following URL (without macros):
  16. # https://mirror.vpsfree.cz/mariadb/mariadb-10.2.13/galera-25.3.23/src/galera-25.3.23.tar.gz
  17. Source0: http://releases.galeracluster.com/source/%{name}-%{version}.tar.gz
  18. Source1: garbd.service
  19. Source2: garbd-wrapper
  20. Source3: garbd.init
  21. Patch0: galera-python3.patch
  22. BuildRequires: libboost-devel libboost-program-options check-devel openssl-devel scons gcc-c++ asio-devel
  23. %if %{with systemd}
  24. BuildRequires: systemd
  25. %endif
  26. Requires: nmap
  27. %if %{with systemd}
  28. Requires(post): systemd
  29. Requires(preun): systemd
  30. Requires(postun): systemd
  31. %else
  32. Requires(post): chkconfig
  33. Requires(preun): chkconfig initscripts
  34. %endif
  35. %description
  36. Galera is a fast synchronous multi-master wsrep provider (replication engine)
  37. for transactional databases and similar applications. For more information
  38. about wsrep API see http://launchpad.net/wsrep. For a description of Galera
  39. replication engine see http://www.codership.com.
  40. %prep
  41. %setup -q
  42. %if %{with python3}
  43. %patch0 -p1
  44. %endif
  45. %build
  46. CPPFLAGS="%{optflags}"
  47. CPPFLAGS=`echo $CPPFLAGS| sed -e "s|-Wp,-D_GLIBCXX_ASSERTIONS||g" `
  48. export CPPFLAGS
  49. %{scons} %{?_smp_mflags} strict_build_flags=0
  50. %install
  51. %if %{with systemd}
  52. install -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/garbd.service
  53. install -D -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/garbd-wrapper
  54. %else
  55. install -D -m 644 %{SOURCE3} %{buildroot}%{_initdir}/garbd
  56. %endif
  57. install -D -m 755 garb/garbd %{buildroot}%{_sbindir}/garbd
  58. install -D -m 755 libgalera_smm.so %{buildroot}%{_libdir}/galera/libgalera_smm.so
  59. install -D -m 644 garb/files/garb.cnf %{buildroot}%{_sysconfdir}/sysconfig/garb
  60. install -D -m 644 COPYING %{buildroot}%{_docdir}/galera/COPYING
  61. install -D -m 644 chromium/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.chromium
  62. install -D -m 644 asio/LICENSE_1_0.txt %{buildroot}%{_docdir}/galera/LICENSE.asio
  63. install -D -m 644 www.evanjones.ca/LICENSE %{buildroot}%{_docdir}/galera/LICENSE.crc32
  64. install -D -m 644 scripts/packages/README %{buildroot}%{_docdir}/galera/README
  65. install -D -m 644 scripts/packages/README-MySQL %{buildroot}%{_docdir}/galera/README-MySQL
  66. %post
  67. /sbin/ldconfig
  68. %if %{with systemd}
  69. %systemd_post garbd.service
  70. %else
  71. /sbin/chkconfig --add garbd
  72. %endif
  73. %preun
  74. %if %{with systemd}
  75. %systemd_preun garbd.service
  76. %else
  77. if [ $1 = 0 ]; then
  78. /sbin/service garbd stop >/dev/null 2>/dev/null ||:
  79. /sbin/chkconfig --del garbd
  80. fi
  81. %endif
  82. %postun
  83. /sbin/ldconfig
  84. %if %{with systemd}
  85. %systemd_postun_with_restart garbd.service
  86. %endif
  87. %files
  88. %config(noreplace,missingok) %{_sysconfdir}/sysconfig/garb
  89. %dir %{_docdir}/galera
  90. %dir %{_libdir}/galera
  91. %{_sbindir}/garbd
  92. %if %{with systemd}
  93. %{_sbindir}/garbd-wrapper
  94. %{_unitdir}/garbd.service
  95. %else
  96. %{_initdir}/garbd
  97. %endif
  98. %{_libdir}/galera/libgalera_smm.so
  99. %license %{_docdir}/galera/COPYING
  100. %license %{_docdir}/galera/LICENSE.asio
  101. %license %{_docdir}/galera/LICENSE.crc32
  102. %license %{_docdir}/galera/LICENSE.chromium
  103. %doc %{_docdir}/galera/README
  104. %doc %{_docdir}/galera/README-MySQL
  105. %changelog
  106. * Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 25.3.25-4
  107. - initial build for Vine Linux.
  108. * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.25-3
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  110. * Tue Jan 29 2019 Jonathan Wakely <jwakely@redhat.com> - 25.3.25-2
  111. - Rebuilt for Boost 1.69
  112. * Tue Jan 01 2019 Michal Schorm <mschorm@redhat.com> - 25.3.25-1
  113. - Rebase to 25.3.25
  114. * Mon Jul 16 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-5
  115. - Require asio also on rhel
  116. * Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-4
  117. - Add explicit gcc-c++ BR
  118. - Use python3-scons
  119. * Fri Jul 13 2018 Honza Horak <hhorak@redhat.com> - 25.3.23-3
  120. - Do not require asio on rhel
  121. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.23-2
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  123. * Fri Feb 16 2018 Michal Schorm <mschorm@redhat.com> - 25.3.23-1
  124. - Update to 25.3.23
  125. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.22-2
  126. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  127. * Fri Nov 24 2017 Honza Horak <hhorak@redhat.com> - 25.3.22-1
  128. - Update to 25.3.22
  129. * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-6
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  131. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-5
  132. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  133. * Mon Jul 03 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-4
  134. - Rebuilt for Boost 1.64
  135. * Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.16-3
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
  137. * Sat Feb 18 2017 Jonathan Wakely <jwakely@redhat.com> - 25.3.16-2
  138. - Use asio-devel instead of bundled asio library
  139. * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.16-2
  140. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  141. * Wed Jun 22 2016 Mike Bayer <mbayer@redhat.com> - 25.3.16-1
  142. - Update to 25.3.16
  143. * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.12-4
  144. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  145. * Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 25.3.12-3
  146. - Rebuilt for Boost 1.60
  147. * Wed Sep 30 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 25.3.12-2
  148. - Remove use of -mtune=native which breaks build on secondary architectures
  149. * Fri Sep 25 2015 Richard W.M. Jones <rjones@redhat.com> - 25.3.12-1
  150. - Update to 25.3.12.
  151. - Should fix the build on 32 bit ARM (RHBZ#1241164).
  152. - Remove ExcludeArch (should have read the BZ more closely).
  153. * Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 25.3.10-5
  154. - Rebuilt for Boost 1.59
  155. * Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.10-4
  156. - Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
  157. * Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 25.3.10-3
  158. - rebuild for Boost 1.58
  159. * Wed Jul 08 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-2
  160. - Disable ARM builds (#1241164, #1239516)
  161. * Mon Jul 06 2015 Ryan O'Hara <rohara@redhat.com> - 25.3.10-1
  162. - Update to version 25.3.10
  163. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-11
  164. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  165. * Mon Jan 26 2015 Petr Machata <pmachata@redhat.com> - 25.3.5-10
  166. - Rebuild for boost 1.57.0
  167. * Thu Nov 27 2014 Richard W.M. Jones <rjones@redhat.com> - 25.3.5-9
  168. - Add aarch64 support.
  169. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-8
  170. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  171. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 25.3.5-7
  172. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  173. * Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 25.3.5-6
  174. - Rebuild for boost 1.55.0
  175. * Wed Apr 30 2014 Dan Horák <dan[at]danny.cz> - 25.3.5-5
  176. - set ExclusiveArch
  177. * Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-4
  178. - Use strict_build_flags=0 to avoid -Werror
  179. - Remove unnecessary clean section
  180. * Thu Apr 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-3
  181. - Include galera directories in file list
  182. - Set CPPFLAGS to optflags
  183. * Wed Apr 23 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-2
  184. - Fix client certificate verification (#1090604)
  185. * Thu Mar 27 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.5-1
  186. - Update to version 25.3.5
  187. * Mon Mar 24 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-2
  188. - Add systemd service
  189. * Sun Mar 09 2014 Ryan O'Hara <rohara@redhat.com> - 25.3.3-1
  190. - Initial build