f-spot-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388
  1. Name: f-spot
  2. Version: 0.6.1.5
  3. Release: 1%{?_dist_release}
  4. Summary: Photo management application
  5. Summary(ja): 写真管理アプリケーション
  6. Group: Applications/Multimedia
  7. License: GPLv2+ and LGPLv2+ and CPL and MIT
  8. URL: http://f-spot.org/
  9. Source0: http://ftp.gnome.org/pub/gnome/sources/f-spot/0.6/f-spot-%{version}.tar.bz2
  10. # Use system mono-addins
  11. Patch2: 0001-use-system-Mono.Addins-if-available.patch
  12. # unmount cameras before importing
  13. Patch3: 0002-enhance-the-f-spot-import-script.patch
  14. # Use system gnome-keyring
  15. Patch4: 0003-use-system-Gnome.Keyring-if-available.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: mono-devel mono-web mono-data mono-data-sqlite lcms-devel
  18. BuildRequires: libexif-devel gphoto2-devel >= 2.1.4
  19. BuildRequires: gtk-sharp2 libgnome-devel libgnomeui-devel
  20. BuildRequires: gtk2-devel mono-devel libjpeg-devel sqlite3-devel
  21. BuildRequires: gnome-sharp2 gnome-desktop-sharp2 gtk-sharp2-gapi
  22. BuildRequires: gconf-sharp2
  23. BuildRequires: gettext
  24. BuildRequires: autoconf, automake, libtool, intltool
  25. BuildRequires: perl-XML-Parser
  26. BuildRequires: gnome-doc-utils
  27. BuildRequires: ndesk-dbus-glib
  28. BuildRequires: mono-addins
  29. BuildRequires: desktop-file-utils
  30. BuildRequires: gnome-keyring-sharp-devel
  31. Requires: sqlite3
  32. Requires: lcms
  33. Requires: dcraw
  34. Requires: hicolor-icon-theme
  35. Requires: yelp
  36. Requires(post): desktop-file-utils
  37. Requires(postun): desktop-file-utils
  38. # no mono available
  39. ExcludeArch: sparc64
  40. # Some compiler segfault on ia64:
  41. ExcludeArch: ia64
  42. # No libgphoto etc on s390
  43. ExcludeArch: s390
  44. %description
  45. F-Spot is an application designed to provide personal photo management
  46. to the GNOME desktop. Features include import, export, printing and advanced
  47. sorting and tagging of digital images.
  48. %package screensaver
  49. Summary: F-Spot gnome-screensaver plugin
  50. Summary(ja): F-Spot gnome-screensaver plugin
  51. Group: Applications/Multimedia
  52. Requires: %{name} = %{version}-%{release}
  53. Requires: gnome-screensaver
  54. Obsoletes: f-spot < 0.6.1.1
  55. %description screensaver
  56. F-Spot provides a plugin for gnome-screensaver which displays parts of the
  57. photo collection in a slideshow as a screensaver.
  58. %prep
  59. %setup -q
  60. %patch2 -p1 -F 2 -b .link-system-mono-addins
  61. %patch3 -p1 -b .gvfs-gphoto
  62. %patch4 -p1 -b .link-system-keyring
  63. %build
  64. autoreconf -f -i
  65. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  66. %configure --disable-scrollkeeper
  67. make %{?_smp_mflags}
  68. %install
  69. rm -rf $RPM_BUILD_ROOT
  70. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  71. make install DESTDIR=$RPM_BUILD_ROOT
  72. rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
  73. rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
  74. rm $RPM_BUILD_ROOT%{_libdir}/pkgconfig/f-spot.pc
  75. # only files marked executable are used to auto-generate the
  76. # requires/provides of the package
  77. find $RPM_BUILD_ROOT \( -name '*.exe' -or -name '*.dll' \) \
  78. -exec chmod a+x {} \;
  79. for file in $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
  80. do
  81. desktop-file-validate $file
  82. done
  83. %find_lang %name
  84. %clean
  85. rm -rf $RPM_BUILD_ROOT
  86. %post
  87. update-desktop-database &> /dev/null ||:
  88. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  89. %postun
  90. update-desktop-database &> /dev/null ||:
  91. if [ $1 -eq 0 ] ; then
  92. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  93. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  94. fi
  95. %posttrans
  96. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  97. %files -f %{name}.lang
  98. %defattr(-,root,root,-)
  99. %doc AUTHORS COPYING README NEWS
  100. %{_datadir}/applications/*.desktop
  101. %{_datadir}/gnome/help/f-spot/
  102. %{_datadir}/icons/hicolor/*/*/*.png
  103. %{_datadir}/f-spot/
  104. %dir %{_libdir}/f-spot/
  105. %{_libdir}/f-spot/*.dll
  106. %{_libdir}/f-spot/*.exe
  107. %{_libdir}/f-spot/*.addins
  108. %{_libdir}/f-spot/*.config
  109. %{_libdir}/f-spot/*.mdb
  110. %{_libdir}/f-spot/*.so
  111. %{_libdir}/f-spot/*.so.*
  112. %exclude %{_libdir}/f-spot/extensions/ScreensaverConfig.dll
  113. %{_libdir}/f-spot/extensions/
  114. %{_bindir}/f-spot
  115. %{_bindir}/f-spot-import
  116. %{_bindir}/f-spot-sqlite-upgrade
  117. %{_datadir}/omf/f-spot/
  118. %files screensaver
  119. %defattr(-,root,root,-)
  120. %{_libdir}/f-spot/extensions/ScreensaverConfig.dll
  121. %{_prefix}/libexec/gnome-screensaver/f-spot-screensaver
  122. %{_datadir}/applications/screensavers/f-spot-screensaver.desktop
  123. %changelog
  124. * Sun May 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1.5-1
  125. - initial build for Vine Linux
  126. * Mon Dec 14 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-2
  127. - Corrected the permission fix for all .exe and .dll files in order
  128. to generate the dependencies correctly (BZ 547063)
  129. * Sun Nov 08 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-1
  130. - Update to 0.6.1.5 (BZ 531955)
  131. - Build f-spot against system gnome-keyring-sharp library (BZ 442343)
  132. - Make all .dll and .exe files executable so that they are respected
  133. by the find-requires/find-provides scripts
  134. - Remove upstreamed patch
  135. * Mon Oct 26 2009 Dennis Gilmore <dennis@ausil.us> - 0.6.1.3-2
  136. - ExcludeArch sparc64
  137. * Sun Oct 04 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.3-1
  138. - Update to 0.6.1.3 (BZ 526217)
  139. - Remove two upstreamed patches
  140. - Use a slightly different fix for the cairo-devel dependency
  141. (suggested by upstream)
  142. * Wed Sep 30 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-3
  143. - Add patch to fix f-spot crash when using "soft focus" and cairo-devel
  144. was not installed (BZ 526563)
  145. - Minor spec file beautification
  146. * Tue Sep 22 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-2
  147. - Add upstream patches (
  148. commit b87604bc9782bf92f053aaf3ceb739a32f44ea13
  149. commit 807dab4344ecdadc7e46793369821de8b49692e5 )
  150. to fix crash in facebook exporter (BZ 524860)
  151. * Thu Sep 17 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-1
  152. - Update to 0.6.1.2 (BZ 519290)
  153. * Fri Aug 28 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-2
  154. - Move the screensaver plugin into a sub-package (BZ 519640)
  155. - Let f-spot-screensaver obsolete older f-spot version so that it
  156. is pulled in during update (fresh installations of f-spot will not
  157. pull in gnome-screensaver)
  158. * Wed Aug 26 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-1
  159. - Update to 0.6.1.1
  160. - Remove upstreamed patch
  161. - Updated use-system-Mono.Addins-if-available patch
  162. - Add a patch to enable parallel build
  163. * Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-3
  164. - Build arch ppc64.
  165. * Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-2
  166. - Fix Icon Cache script in %%post section
  167. * Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-1
  168. - Update to new upstream version 0.6.0.0
  169. - Cleanup spec file
  170. * Sat Jul 25 2009 Christian Krause <chkr@fedoraproject.org> - 0.5.0.3-9
  171. - Avoid showing f-spot twice for photo imports
  172. - Make f-spot-import work with gvfs
  173. - Minor indentation fix
  174. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-8
  175. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  176. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-7
  177. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  178. * Sun Feb 8 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.5.0.3-6
  179. - Rebuild against new mono stack to fix broken deps
  180. * Thu Dec 4 2008 Matthias Clasen <mclasen@redhat.com> - 0.5.0.3-5
  181. - Update to 0.5.0.3
  182. * Fri Nov 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-8
  183. - Better URL
  184. - Tweak %%description
  185. * Tue Oct 28 2008 Orion Poplawski <orion@cora.nwra.com.com> - 0.4.4-7
  186. - Run desktop-file-validate against desktop files
  187. * Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-6
  188. - rebuild against new gnome-sharp
  189. * Thu Oct 2 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-5
  190. - Use a standard icon name instead of a non-existing one
  191. * Mon Jul 14 2008 Nigel Jones <dev@nigelj.com> - 0.4.4-4
  192. - Remove Tom's patch in -2, there is a gtk-sharp 2.12.1, just nobody bothered
  193. packaging it.
  194. - Patch Makefile{.in,am} to use DESTDIR for the gio-sharp.dll, this is
  195. effectively a backport of r4010 Upstream.
  196. - Patch libfspot/Makefile{.in,am} to remove -DGTK_DISABLE_DEPRECATED per
  197. recommendation of upstream.
  198. - Re-add patch to use system mono-addins
  199. - Include GIO stuff for now (until it appears in gtk-sharp)
  200. * Wed Jul 5 2008 Alex Lancaster <alexlan[AT] fedoraproject org> - 0.4.4-3
  201. - gtkhtml dependency now provided by gnome-desktop-sharp-devel
  202. rather than gnome-sharp-devel, so add as BuildRequires
  203. * Wed Jun 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-2
  204. - Fix it to not look for non-existant glib-sharp-2.12.1
  205. * Wed Jun 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-1
  206. - update to 0.4.4
  207. - fix license tag
  208. * Tue May 13 2008 Matthias Clasen <mclasne@redhat.com> - 0.4.3.1-1
  209. - Update to 0.4.3.1
  210. * Tue Apr 15 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.4.2-5
  211. - Add patch from Debian to use system mono-addins (from #442343)
  212. * Sat Mar 1 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-4
  213. - Require dcraw
  214. * Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-3
  215. - Fix the build
  216. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
  217. - Autorebuild for GCC 4.3
  218. * Thu Feb 14 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.2-1
  219. - Update to 0.4.2
  220. * Fri Jan 18 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.1-2
  221. - Add support for content-types
  222. * Thu Dec 6 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.1-1
  223. - Update to 0.4.1
  224. * Sat Nov 17 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-4
  225. - Remove comments from ExclusiveArch line (#388581)
  226. * Tue Oct 2 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-3
  227. - Add alpha to ExclusiveArch
  228. * Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 0.4.0-2
  229. - Rebuild for build ID
  230. * Sat Aug 4 2007 Matthis Clasen <mclasen@redhat.com> - 0.4.0-1
  231. - Update to 0.4.0
  232. * Mon Jul 2 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-3
  233. - Hack to get screensavers to work again (#221546)
  234. * Fri Apr 13 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-2
  235. - Now with validated desktop files!
  236. * Wed Mar 7 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-1
  237. - Update to 0.3.5
  238. * Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
  239. - Update to 0.3.4
  240. * Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.3-1
  241. - Update to 0.3.3
  242. * Tue Jan 23 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  243. - Update to 0.3.2
  244. * Fri Oct 20 2006 Christopher Aillon <caillon@redhat.com> - 0.2.2-1
  245. - Update to 0.2.2
  246. * Mon Oct 16 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.1-2
  247. - Fix a directory ownership issue (#211009)
  248. * Wed Sep 13 2006 Christopher Aillon <caillon@redhat.com> - 0.2.1-1
  249. - Update to 0.2.1
  250. * Tue Sep 12 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2
  251. - Add libgphoto2_port version to dll config (#205302)
  252. * Mon Sep 4 2006 Christopher Aillon <caillon@redhat.com> - 0.2.0-1
  253. - Update to 0.2.0
  254. * Fri Aug 18 2006 Alexander Larsson <alexl@redhat.com> - 0.1.11-5
  255. - Rebuild with new mono and gtk-sharp2
  256. * Thu Jul 27 2006 Matthias Clasen <mclasen@redhat.com> - 0.1.11-4
  257. - Fix dbus-sharp BR
  258. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.1.11-3.1
  259. - rebuild
  260. * Sun Jun 24 2006 Jesse Keating <jkeating@redhat.com> 0.1.11-3
  261. - Add missing BR gettext
  262. * Wed May 31 2006 Alexander Larsson <alexl@redhat.com> 0.1.11-2
  263. - Rebuild for gmime update
  264. * Fri Mar 17 2006 Christopher Aillon <caillon@redhat.com> 0.1.11-1
  265. - Update to 0.1.11
  266. * Fri Feb 24 2006 Christopher Aillon <caillon@redhat.com> 0.1.10-1
  267. - Update to 0.1.10
  268. * Tue Feb 21 2006 Karsten Hopp <karsten@redhat.de> 0.1.9-2
  269. - add BuildRequires libgnome-devel libgnomeui-devel
  270. gtk2-devel mono-devel libjpeg-devel sqlite-devel
  271. * Fri Feb 17 2006 Christopher Aillon <caillon@redhat.com> - 0.1.9-1
  272. - Update to 0.1.9
  273. * Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-3
  274. - Rebuild
  275. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.8-2.1
  276. - rebuilt for new gcc4.1 snapshot and glibc changes
  277. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-2
  278. - Add sqlite3.patch to ensure that sqlite3 is used if both
  279. sqlite2 and sqlite3 are installed.
  280. * Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-1
  281. - Update to 0.1.8
  282. - Use sqlite3 instead of sqlite2
  283. * Tue Jan 31 2006 Ray Strode <rstrode@redhat.com> - 0.1.5-3
  284. - don't blindly run f-spot from current working directory
  285. (bug 177407)
  286. * Tue Jan 10 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-2
  287. - Add lcms depencency
  288. * Mon Jan 9 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-1
  289. - Update to 0.1.5
  290. * Thu Dec 8 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-3
  291. - Use sqlite2 to avoid problems with beagle
  292. * Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-2
  293. - Make exes and dlls executable to pick up dependencies
  294. - Remove .a and .la files
  295. * Wed Nov 16 2005 Alexander Larsson <alexl@redhat.com> - 0.1.3-1
  296. - Initial version