freerdp-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230
  1. Name: freerdp
  2. Summary: Remote Desktop Protocol client
  3. Summary(ja): リモートデスクトッププロトコルクライアント
  4. Version: 1.0.2
  5. Release: 1%{?_dist_release}
  6. Group: Applications/Internet
  7. License: GPLv2+
  8. URL: http://www.freerdp.com/
  9. Source0: https://github.com/downloads/FreeRDP/FreeRDP/%{name}-%{version}.tar.gz
  10. # https://github.com/FreeRDP/FreeRDP/commit/165d39a290a109c0af16a1d223d1426cb524a844 backport
  11. Patch0: fastpath_send_input_pdu-sec_bytes.patch
  12. Patch1: c10866db66c0d462ea7c2c38bb01740bcfb4fcb4.patch
  13. Patch2: freerdp-1.0.2_xmlto.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: cmake
  16. BuildRequires: xmlto
  17. BuildRequires: openssl-devel
  18. BuildRequires: libX11-devel
  19. BuildRequires: libXext-devel
  20. BuildRequires: libXinerama-devel
  21. BuildRequires: libXcursor-devel
  22. BuildRequires: libXdamage-devel
  23. BuildRequires: libXv-devel
  24. BuildRequires: libxkbfile-devel
  25. BuildRequires: pulseaudio-libs-devel
  26. BuildRequires: cups-devel
  27. BuildRequires: pcsc-lite-devel
  28. BuildRequires: desktop-file-utils
  29. Provides: xfreerdp = %{version}-%{release}
  30. Requires: %{name}-libs = %{version}-%{release}, %{name}-plugins = %{version}-%{release}
  31. Requires: %{name}-plugins = %{version}-%{release}
  32. %description
  33. The xfreerdp Remote Desktop Protocol (RDP) client from the FreeRDP
  34. project.
  35. xfreerdp can connect to RDP servers such as Microsoft Windows
  36. machines, xrdp and VirtualBox.
  37. %package libs
  38. Summary: Core libraries implementing the RDP protocol
  39. Summary(ja): RDPプロトコル実装のコアライブラリ
  40. Group: System Environment/Libraries
  41. %description libs
  42. libfreerdp implements the core of the RDP protocol.
  43. libfreerdpchanman can be used to load plugins that can handle channels
  44. in the RDP protocol.
  45. libfreerdpkbd implements functionality for handling keyboards in X.
  46. %package plugins
  47. Summary: Plugins for handling the standard RDP channels
  48. Summary(ja): 標準RDPチャンネルを扱うためのプラグイン
  49. Group: System Environment/Libraries
  50. Requires: %{name}-libs = %{version}-%{release}
  51. %description plugins
  52. A set of plugins to the channel manager implementing the standard virtual
  53. channels extending RDP core functionality. For example, sounds, clipboard
  54. sync, disk/printer redirection, etc.
  55. %package devel
  56. Summary: Development files for %{name}
  57. Summary(ja): %{name}の開発ファイル
  58. Group: Development/Libraries
  59. Requires: %{name}-libs = %{version}-%{release}
  60. Requires: pkgconfig
  61. %description devel
  62. The %{name}-devel package contains libraries and header files for
  63. developing applications that use %{name}-libs.
  64. %prep
  65. %setup -q -n FreeRDP-%{version}
  66. #patch0 -p1
  67. #patch1 -p1
  68. %patch2 -p1
  69. cat << EOF > xfreerdp.desktop
  70. [Desktop Entry]
  71. Type=Application
  72. Name=X FreeRDP
  73. NoDisplay=true
  74. Comment=Connect to RDP server and display remote desktop
  75. Icon=%{name}
  76. Exec=/usr/bin/xfreerdp
  77. Terminal=false
  78. Categories=Network;RemoteAccess;
  79. EOF
  80. %build
  81. %cmake \
  82. -DCMAKE_BUILD_TYPE=Release \
  83. -DWITH_CUPS=ON \
  84. -DWITH_PCSC=ON \
  85. -DWITH_PULSEAUDIO=ON \
  86. -DWITH_X11=ON \
  87. -DWITH_XCURSOR=ON \
  88. -DWITH_XEXT=ON \
  89. -DWITH_XINERAMA=ON \
  90. -DWITH_XKBFILE=ON \
  91. -DWITH_XV=ON \
  92. -DWITH_ALSA=OFF \
  93. -DWITH_CUNIT=OFF \
  94. -DWITH_DIRECTFB=OFF \
  95. -DWITH_FFMPEG=OFF \
  96. -DWITH_SSE2=OFF \
  97. -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
  98. .
  99. make %{?_smp_mflags}
  100. %install
  101. rm -rf $RPM_BUILD_ROOT
  102. make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
  103. # No need for keymap files when using xkbfile
  104. rm -rf $RPM_BUILD_ROOT/usr/share/freerdp
  105. desktop-file-install --dir=$RPM_BUILD_ROOT%{_datadir}/applications xfreerdp.desktop
  106. install -p -D resources/FreeRDP_Icon_256px.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
  107. %clean
  108. rm -rf $RPM_BUILD_ROOT
  109. %post
  110. # This is no gtk application, but try to integrate nicely with GNOME if it is available
  111. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  112. %post libs -p /sbin/ldconfig
  113. %postun libs -p /sbin/ldconfig
  114. %files
  115. %defattr(-,root,root,-)
  116. %{_bindir}/xfreerdp
  117. %{_mandir}/man1/xfreerdp.*
  118. %{_datadir}/applications/xfreerdp.desktop
  119. %{_datadir}/icons/hicolor/256x256/apps/%{name}.png
  120. %files libs
  121. %defattr(-,root,root,-)
  122. %doc LICENSE README ChangeLog
  123. %{_libdir}/lib%{name}-*.so.*
  124. %dir %{_libdir}/%{name}/
  125. %files plugins
  126. %defattr(-,root,root,-)
  127. %{_libdir}/%{name}/*
  128. %files devel
  129. %defattr(-,root,root,-)
  130. %{_includedir}/%{name}/
  131. %{_libdir}/lib%{name}-*.so
  132. %{_libdir}/pkgconfig/%{name}.pc
  133. %changelog
  134. * Tue Sep 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.2-1
  135. - update to 1.0.2
  136. - fixed typo in Group
  137. - dropped Patch0 and Patch1
  138. - added Patch2 to build with current xmlto
  139. * Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  140. - update to 1.0.1
  141. - import patches from fedora package.
  142. - add BRs.
  143. * Fri May 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
  144. - initial build for Vine Linux
  145. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.2-3
  146. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  147. * Fri Jan 28 2011 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-2
  148. - rebuild on rawhide because of broken dependencies
  149. * Tue Nov 16 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-1
  150. - freerdp-0.8.2
  151. * Mon Nov 08 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-2
  152. - make -devel require pkgconfig
  153. - first official Fedora package
  154. * Sun Nov 07 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-1
  155. - freerdp-0.8.1
  156. * Sat Sep 25 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-2
  157. - hack the generated libtool to not set rpath on x86_64
  158. - configure with alsa explicitly
  159. * Tue Aug 24 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-1
  160. - freerdp-0.7.4
  161. - cleanup of packaging structure
  162. * Wed Jul 28 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.3-1
  163. - 0.7.3
  164. - fix some minor pylint warnings
  165. * Fri Jul 23 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.2-2
  166. - 0.7.2
  167. - Address many comments from cwickert:
  168. - - cleanup of old formatting, alignment with spectemplate-lib.spec and
  169. cwickert spec from #616193
  170. - - add alsa as build requirement
  171. - - remove superfluous configure options and disable static libs
  172. - - add missing rpm groups
  173. * Sun Jun 13 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.0-1
  174. - First official release, first review request