tar-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381
  1. Summary: A GNU file archiving program.
  2. Summary(ja): GNU ファイルアーカイブプログラム
  3. Name: tar
  4. Version: 1.28
  5. Release: 1%{?_dist_release}
  6. License: GPLv3+
  7. Group: Applications/Archiving
  8. Source: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.xz
  9. Patch0: tar-1.13.18-manpage.patch
  10. Patch8: tar-1.20-loneZeroWarning.patch
  11. Patch10: tar-1.15.1-gcc4.patch
  12. #Fix extracting sparse files to a filesystem like vfat,
  13. #when ftruncate may fail to grow the size of a file.(#179507)
  14. Patch11: tar-1.15.1-vfatTruncate.patch
  15. #change inclusion defaults of tar to "--wildcards --anchored
  16. #--wildcards-match-slash" for compatibility reasons (#206841)
  17. Patch12: tar-1.17-wildcards.patch
  18. # Fix for bad cooperation of -C and -u options.
  19. # ~> #688567
  20. # ~> http://lists.gnu.org/archive/html/bug-tar/2012-02/msg00007.html
  21. # ~> still downstream
  22. Patch15: tar-1.26-update-with-change-directory.patch
  23. # adhoc but useful patch for z option accepts bzip2ed tarball.
  24. Patch100: tar-1.13.6-barterly.patch
  25. Patch110: tar-1.22-rtapelib-overflow.patch
  26. BuildRequires: autoconf texinfo gettext
  27. Requires(post,postun): install-info
  28. Buildroot: %{_tmppath}/%{name}-%{version}-root
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. %description
  32. The GNU tar program saves many files together in one archive and can
  33. restore individual files (or all of the files) from that archive. Tar
  34. can also be used to add supplemental files to an archive and to update
  35. or list files in the archive. Tar includes multivolume support,
  36. automatic archive compression/decompression, the ability to perform
  37. remote archives, and the ability to perform incremental and full
  38. backups.
  39. If you want to use tar for remote backups, you also need to install
  40. the rmt package.
  41. %description -l ja
  42. GNU tar プログラムは多くのファイルを一つのファイルにまとめたりアーカイブ
  43. から個々のファイルを(または全てのファイルを)リストアしたりする。tar はまた
  44. 追加ファイルを加えたりアーカイブファイル中のリストを更新したりするために
  45. 使われる。
  46. tar はマルチボリュームサポート、自動アーカイブ圧縮/伸長、リモート
  47. アーカイブの取り扱う機能、そして差分バックアップとフルバックアップをする
  48. 機能を含んでいる。
  49. もしリモートバックアップのために tar をインストールするなら、rmt パッケージ
  50. もまたインストールする必要がある。
  51. %prep
  52. %setup -q
  53. %patch0 -p1 -b .manpage
  54. %patch8 -p1 -b .loneZeroWarning
  55. %patch11 -p1 -b .vfatTruncate
  56. %patch12 -p1 -b .wildcards
  57. %patch15 -p1 -b .update_and_changedir
  58. %patch100 -p1 -b .accept-bz2
  59. %patch110 -p1 -b .CVE-2010-0624
  60. %build
  61. autoreconf
  62. %configure --bindir=/bin --libexecdir=/sbin
  63. make LIBS=-lbsd %{?_smp_mflags}
  64. %install
  65. rm -rf $RPM_BUILD_ROOT
  66. make prefix=${RPM_BUILD_ROOT}%{_prefix} \
  67. localedir=${RPM_BUILD_ROOT}%{_prefix}/share/locale \
  68. bindir=${RPM_BUILD_ROOT}/bin \
  69. libexecdir=${RPM_BUILD_ROOT}/sbin \
  70. mandir=${RPM_BUILD_ROOT}%{_mandir} \
  71. infodir=${RPM_BUILD_ROOT}%{_infodir} \
  72. install
  73. ln -s tar ${RPM_BUILD_ROOT}/bin/gtar
  74. ( cd $RPM_BUILD_ROOT
  75. for dir in ./bin ./sbin .%{_prefix}/bin .%{_prefix}/libexec
  76. do
  77. [ -d $dir ] || continue
  78. strip $dir/* || :
  79. done
  80. gzip -9nf .%{_infodir}/tar.info*
  81. rm -f .%{_infodir}/dir
  82. )
  83. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
  84. install -c -m644 tar.1 ${RPM_BUILD_ROOT}%{_mandir}/man1
  85. rm -f ${RPM_BUILD_ROOT}/sbin/rmt
  86. %find_lang %name
  87. %post
  88. /sbin/install-info %{_infodir}/tar.info.gz %{_infodir}/dir
  89. %preun
  90. if [ $1 = 0 ]; then
  91. /sbin/install-info --delete %{_infodir}/tar.info.gz %{_infodir}/dir
  92. fi
  93. %clean
  94. rm -rf ${RPM_BUILD_ROOT}
  95. %files -f %{name}.lang
  96. %defattr(-,root,root)
  97. %doc AUTHORS COPYING ChangeLog* NEWS README THANKS TODO
  98. /bin/tar
  99. /bin/gtar
  100. %{_mandir}/man1/tar.1*
  101. %{_mandir}/man8/rmt.8*
  102. %{_infodir}/tar.info*
  103. %changelog
  104. * Fri Jan 16 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.28-1
  105. - new upstream release
  106. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.27.1-1
  107. - new upstream release
  108. - remove Patch13 (tar-1.23-oldarchive.patch)
  109. - add Patch15 (tar-1.26-update-with-change-directory.patch) from Fedora
  110. * Wed May 18 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.26-1
  111. - new upstream release
  112. - added BuildRequires: gettext
  113. * Mon Nov 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.25-1
  114. - new upstream release
  115. - changed source archive type (gzip to bzip2)
  116. - modified Patch8 a little
  117. - added Patch11,12,13 from Fedora development
  118. - added BuildRequires: autoconf texinfo
  119. - run autoreconf on %%build
  120. * Tue Mar 16 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.22-4
  121. - add patch110 for fix CVE-2010-0624 (rmt) from fc11
  122. * Thu Apr 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.22-3
  123. - add missing documents
  124. * Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-2
  125. - spec in utf-8
  126. * Mon Mar 16 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.22-1
  127. - new upstream release
  128. - improved tar-1.20-loneZeroWarning.patch (refer to Fedora package)
  129. * Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-1
  130. - new upstream release
  131. - remove unneeded patches
  132. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.15.1-0vl3
  133. - rebuilt for VineSeed
  134. * Thu Nov 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2.1
  135. - add patch120 for fix CVE-2006-6097
  136. * Sun Sep 17 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2
  137. - add patch110 for fix CVE-2006-0300
  138. * Mon May 02 2005 Satoshi MACHINO <machino@vinelinux.org> 1.15.1-0vl1
  139. - new upstream release
  140. - fixed patch6 and patch7 for new upstream release
  141. - some patches are imported from fedora package. and fixed
  142. -- stop issuing lone zero block warnings(patch8)
  143. -- fixed testsuite(patch9)
  144. -- don't applyed(patch10)
  145. -- fixed offset had incorrect type(patch11)
  146. * Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
  147. - new upstream release
  148. - some patches are imported from fedora package.
  149. * Fri May 2 2003 IWAI Masaharu <iwai@alib.jp> 1.3.25-8vl4
  150. - rebuild with new toolchain
  151. - update BuildRequire (autoconf253 -> autoconf)
  152. * Thu Oct 31 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.25-8vl3
  153. - add adhoc but useful patch100 for "z" option to accepts bz2 tarball.
  154. * Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl2
  155. - Oops the spec was in Shift-JIS. Fixed.
  156. * Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl1
  157. - based on 1.3.25-8 from Rawhide and built for Vine Linux
  158. - the previous Vine package was 1.3.18-0vl2. Vine's changelog was as follows:
  159. - Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13.18-0vl2
  160. - rebuild to remove rpmlib dependancy
  161. - Sat May 26 2001 <sagami@vinelinux.org>
  162. - 1.13.18-0vl1: based on 1.13.18-1 and added Japanese summary and description
  163. - added barterly patch
  164. * Fri Aug 23 2002 Phil Knirsch <pknirsch@redhat.com> 1.13.25-8
  165. - Included security patch from errata release.
  166. * Mon Jul 1 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-7
  167. - Fix argv NULL termination (#64869)
  168. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  169. - automated rebuild
  170. * Tue Apr 9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-4
  171. - Fix build with autoconf253 (LIBOBJ change; autoconf252 worked)
  172. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  173. - automated rebuild
  174. * Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-2
  175. - Don't include hardlinks to sockets in a tar file (#54827)
  176. * Thu Sep 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-1
  177. - 1.13.25
  178. * Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.22-1
  179. - Update to 1.13.22, adapt patches
  180. * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-6
  181. - Fix #52084
  182. * Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-5
  183. - Fix build with current autoconf (stricter checking on AC_DEFINE)
  184. - Fix segfault when tarring directories without having read permissions
  185. (#40802)
  186. * Tue Mar 6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  187. - Don't depend on librt.
  188. * Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
  189. - langify
  190. * Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  191. - Fix up the man page (#28915)
  192. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  193. - 1.3.19, nukes -I and fixes up -N
  194. - Add -I back in as an alias to -j with a nice loud warning
  195. * Mon Oct 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  196. - 1.3.18
  197. - Update man page to reflect changes
  198. * Thu Oct 5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  199. - Fix the "ignore failed read" option (Bug #8330)
  200. * Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  201. - fix hang on tar tvzf - <something.tar.gz, introduced by
  202. exit code fix (Bug #15448), Patch from Tim Waugh <twaugh@redhat.com>
  203. * Fri Aug 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  204. - really fix exit code (Bug #15448)
  205. * Mon Aug 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  206. - fix exit code (Bug #15448), patch from Tim Waugh <twaugh@redhat.com>
  207. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  208. - automatic rebuild
  209. * Mon Jun 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  210. - FHSify
  211. * Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
  212. - fix for ia64
  213. * Wed Feb 9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  214. - Fix the exclude bug (#9201)
  215. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  216. - man pages are compressed
  217. - fix description
  218. - fix fnmatch build problems
  219. * Sun Jan 9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  220. - 1.13.17
  221. - remove dotbug patch (fixed in base)
  222. - update download URL
  223. * Fri Jan 7 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  224. - Fix a severe bug (tar xf any_package_containing_. would delete the
  225. current directory)
  226. * Wed Jan 5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  227. - 1.3.16
  228. - unset LINGUAS before running configure
  229. * Tue Nov 9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
  230. - 1.13.14
  231. - Update man page to know about -I / --bzip
  232. - Remove dependancy on rmt - tar can be used for anything local
  233. without it.
  234. * Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
  235. - upgrade to 1.13.11.
  236. * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
  237. - update to 1.13.9.
  238. * Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
  239. - update to 1.13.6.
  240. - support -y --bzip2 options for bzip2 compression (#2415).
  241. * Fri Jul 23 1999 Jeff Johnson <jbj@redhat.com>
  242. - update to 1.13.5.
  243. * Tue Jul 13 1999 Bill Nottingham <notting@redhat.com>
  244. - update to 1.13
  245. * Sat Jun 26 1999 Jeff Johnson <jbj@redhat.com>
  246. - update to 1.12.64014.
  247. - pipe patch corrected for remote tars now merged in.
  248. * Sun Jun 20 1999 Jeff Johnson <jbj@redhat.com>
  249. - update to tar-1.12.64013.
  250. - subtract (and reopen #2415) bzip2 support using -y.
  251. - move gtar to /bin.
  252. * Tue Jun 15 1999 Jeff Johnson <jbj@redhat.com>
  253. - upgrade to tar-1.12.64011 to
  254. - add bzip2 support (#2415)
  255. - fix filename bug (#3479)
  256. * Mon Mar 29 1999 Jeff Johnson <jbj@redhat.com>
  257. - fix suspended tar with compression over pipe produces error (#390).
  258. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  259. - auto rebuild in the new build environment (release 8)
  260. * Mon Mar 08 1999 Michael Maher <mike@redhat.com>
  261. - added patch for bad name cache.
  262. - FIXES BUG 320
  263. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  264. - Injected new description and group.
  265. * Fri Dec 18 1998 Preston Brown <pbrown@redhat.com>
  266. - bumped spec number for initial rh 6.0 build
  267. * Tue Aug 4 1998 Jeff Johnson <jbj@redhat.com>
  268. - add /usr/bin/gtar symlink (change #421)
  269. * Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
  270. - Fiddle bindir/libexecdir to get RH install correct.
  271. - Don't include /sbin/rmt -- use the rmt from dump.
  272. - Turn on nls.
  273. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  274. - translations modified for de, fr, tr
  275. * Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
  276. - updated from 1.11.8 to 1.12
  277. - various spec file cleanups
  278. - /sbin/install-info support
  279. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  280. - built against glibc
  281. * Thu May 29 1997 Michael Fulbright <msf@redhat.com>
  282. - Fixed to include rmt