kdevelop-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510
  1. Name: kdevelop
  2. Summary: Integrated Development Environment for C++/C
  3. Summary(ja): C++/C 向け統合開発環境
  4. Version: 4.4.1
  5. Release: 1%{?_dist_release}
  6. License: GPLv2
  7. URL: http://www.kdevelop.org/
  8. Group: Applications/Development
  9. Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.tar.bz2
  10. # fixing https://bugs.kde.org/show_bug.cgi?id=236315
  11. Patch100: kdevelop-4.0.0-qmake_qt4.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: desktop-file-utils
  14. BuildRequires: gettext
  15. BuildRequires: kdebase-workspace-devel
  16. BuildRequires: kdevplatform-devel >= 1.4.0
  17. BuildRequires: kdelibs-devel
  18. BuildRequires: kdesdk-devel
  19. BuildRequires: soprano-devel
  20. BuildRequires: valgrind
  21. Requires: %{name}-libs = %{version}-%{release}
  22. Requires: kdevplatform >= 1.4.0
  23. #Conflicts: kdevelop
  24. %description
  25. The KDevelop Integrated Development Environment provides many features
  26. that developers need as well as providing a unified interface to programs
  27. like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
  28. All development tools needed for C++ programming like Compiler,
  29. Linker, automake and autoconf; KAppWizard, which generates complete,
  30. ready-to-go sample applications; Classgenerator, for creating new
  31. classes and integrating them into the current project; File management
  32. for sources, headers, documentation etc. to be included in the
  33. project; The creation of User-Handbooks written with SGML and the
  34. automatic generation of HTML-output with the KDE look and feel;
  35. Automatic HTML-based API-documentation for your project's classes with
  36. cross-references to the used libraries; Internationalization support
  37. for your application, allowing translators to easily add their target
  38. language to a project;
  39. KDevelop also includes WYSIWYG (What you see is what you get)-creation
  40. of user interfaces with a built-in dialog editor; Debugging your
  41. application by integrating KDbg; Editing of project-specific pixmaps
  42. with KIconEdit; The inclusion of any other program you need for
  43. development by adding it to the "Tools"-menu according to your
  44. individual needs.
  45. %package libs
  46. Summary: %{name} runtime libraries
  47. Summary(ja): %{name} のランタイムライブラリ
  48. Group: System Environment/Libraries
  49. #Requires: %{name} = %{version}-%{release}
  50. Requires: kdelibs4
  51. %description libs
  52. %{summary}.
  53. %package devel
  54. Summary: Development files for %{name}
  55. Summary(ja): %{name} の開発用ファイル
  56. Group: Development/Libraries
  57. Requires: %{name}-libs = %{version}-%{release}
  58. %description devel
  59. %{summary}.
  60. %prep
  61. %setup -q -n kdevelop-%{version}
  62. #patch100 -p1 -b .qmake_qt4
  63. %build
  64. mkdir -p %{_target_platform}
  65. pushd %{_target_platform}
  66. %cmake \
  67. -DCMAKE_BUILD_TYPE=release \
  68. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  69. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  70. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  71. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  72. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  73. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  74. ..
  75. popd
  76. make %{?_smp_mflags} -C %{_target_platform}
  77. %install
  78. rm -rf $RPM_BUILD_ROOT
  79. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  80. %find_lang %{name} --all-name --with-kde
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %post
  84. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  85. %postun
  86. if [ $1 -eq 0 ] ; then
  87. touch --no-create %{_datadir}/icons/hicolor &> /dev/null
  88. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  89. update-desktop-database -q &> /dev/null
  90. update-mime-database %{_datadir}/mime &> /dev/null
  91. fi
  92. %posttrans
  93. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  94. update-desktop-database -q &> /dev/null
  95. update-mime-database %{_datadir}/mime &> /dev/null
  96. %post libs -p /sbin/ldconfig
  97. %postun libs -p /sbin/ldconfig
  98. %files -f %{name}.lang
  99. %defattr(-,root,root)
  100. %{_bindir}/*
  101. %config %{_datadir}/config/kdeveloprc
  102. %{_datadir}/applications/kde4/*.desktop
  103. %{_datadir}/config/kdevelop-qthelp.knsrc
  104. %{_datadir}/kde4/apps/kdev*/
  105. %{_datadir}/kde4/apps/plasma/plasmoids/kdevelopsessions/contents/ui/kdevelopsessions.qml
  106. %{_datadir}/kde4/apps/plasma/plasmoids/kdevelopsessions/metadata.desktop
  107. %{_datadir}/kde4/apps/plasma/services/org.kde.plasma.dataengine.kdevelopsessions.operations
  108. %{_datadir}/kde4/services/*.desktop
  109. %{_datadir}/icons/hicolor/*/*/*
  110. %{_datadir}/mime/packages/kdevelop.xml
  111. #{_datadir}/servicetypes/*
  112. #doc %{_datadir}/doc/HTML/en/*
  113. %files libs
  114. %defattr(-,root,root,-)
  115. %{_libdir}/lib*.so
  116. %{_libdir}/kde4/*.so
  117. %files devel
  118. %defattr(-,root,root,-)
  119. %{_datadir}/kde4/apps/cmake/modules/FindKDevelop.cmake
  120. %{_includedir}/kde4/kdevelop/
  121. %changelog
  122. * Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.1-1
  123. - new upstream release
  124. * Sat Oct 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.0-1
  125. - new upstream release
  126. * Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.3.1-1
  127. - new upstream release
  128. * Sat Jun 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.3-1
  129. - new upstream release
  130. * Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-2
  131. - add BuildRequires: kdesdk-devel, soprano-devel
  132. * Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.0-1
  133. - new upstream release
  134. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.2-1
  135. - new upstream release
  136. * Sat May 8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.0-1
  137. - new upstream release
  138. - split shared libraries and header files
  139. * Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
  140. - new upstream release
  141. - applied new versioning policy, spec in UTF-8
  142. - changed Group to Applications/Development
  143. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
  144. - rebuild for VineSeed
  145. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
  146. - new upstream release
  147. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
  148. - rebuild for VineSeed
  149. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
  150. - new upstream release
  151. * Fri Jun 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
  152. - rebuild for VineSeed
  153. * Fri Jun 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
  154. - new upstream release
  155. - use ap?-config for Vine3.x and use ap?-1-config for VineSeed
  156. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
  157. - rebuild for VineSeed
  158. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
  159. - new upstream release
  160. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  161. - rebuild for VineSeed
  162. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  163. - new upstream release
  164. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
  165. - rebuild for VineSeed
  166. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
  167. - new upstream release
  168. - add BuildPrereq: apache2-devel subversion-devel
  169. * Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
  170. - new upstream release
  171. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
  172. - new upstream release
  173. - delete Patch0
  174. * Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
  175. - new upstream release
  176. - add Patch0
  177. - update %%files
  178. * Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
  179. - rebuild for VineSeed
  180. * Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
  181. - new upstream release
  182. * Tue Jul 5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
  183. - rebuild for VineSeed
  184. * Tue Jul 5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
  185. - new upstream release
  186. - add --disable-rpath to configure option
  187. - remove BuildPrereq: qt-static
  188. * Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
  189. - rebuild for VineSeed
  190. * Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
  191. - new upstream release
  192. - update %%files
  193. - add +w to %%{_prefix}/kdevbdb/*
  194. * Sun Jan 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
  195. - rebuild for VineSeed
  196. * Sun Jan 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
  197. - new upstream release
  198. - update %%files
  199. * Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
  200. - source upgrade
  201. - add BuildPrereq: qt-static
  202. * Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
  203. - rebuild with qt32
  204. * Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
  205. - source upgrade
  206. - remove lines about vine26
  207. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
  208. - source upgrade
  209. - add Requires: ctags
  210. * Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
  211. - source upgrade
  212. - remove all patches
  213. - remove c references
  214. - add Requires: htdig
  215. * Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
  216. - change spec to build both VineSeed and Vine2.5/2.6
  217. - change configure options
  218. - add %%clean section
  219. - add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
  220. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
  221. - source upgrade
  222. - change spec to build both VineSeed and Vine2.5/2.6
  223. - change configure option (add -enable--final, remove -enable--debug)
  224. - update %%files section
  225. * Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
  226. - source upgrade
  227. - remove patch1 (rejected)
  228. * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
  229. - BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
  230. * Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
  231. - source upgrade
  232. - revised Source1
  233. - remove Patch1 and Patch4
  234. * Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
  235. - merged with rawhide 2.1.1-3
  236. - clean up spec
  237. - add BuildPrereq: objprelink (i386 only)
  238. - remove Obsoletes: kdevelop-c_c++_ref
  239. - add BuildPrereq: autoconf252 automake15
  240. - There is Vine's previous changes, hacked for Vine
  241. -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
  242. - build for VineSeed
  243. - delete Epoch
  244. - update Patch1 and delete Patch2
  245. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  246. - automated rebuild
  247. * Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
  248. - don't forcibly strip binaries
  249. * Sun Jun 2 2002 Than Ngo <than@redhat.com> 2.1.1-1
  250. - 2.1.1
  251. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  252. - automated rebuild
  253. * Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
  254. - Use automake15
  255. * Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
  256. - Change sonames
  257. * Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
  258. - final
  259. * Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
  260. - update
  261. * Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
  262. - update to 2.1rc3
  263. * Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
  264. - update to 2.1rc2
  265. * Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
  266. - rebuild against new kdelibs
  267. * Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
  268. - fixed Strange characters appear in the output window (bug #59217)
  269. - fixed return-line feed sign in Kdevelop setup tool (bug #55032)
  270. * Wed Mar 8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
  271. - update to 2.1beta2
  272. * Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
  273. - rebuild against new kdelibs
  274. * Wed Jan 9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
  275. - update to 2.1 beta1
  276. - fix build against gcc 3
  277. - fix some typo bugs
  278. - get rid of libkfile
  279. - update c_cpp_reference to 2.0.1
  280. * Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
  281. - add patch to show non lattin1 font in build-in editor correct (bug #54457)
  282. * Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
  283. - fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
  284. - backport some major bugfixes from 2.0.1
  285. * Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
  286. - Don't crash on startup
  287. * Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
  288. - Fix file list
  289. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
  290. - Update
  291. * Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  292. - Yet another respin - printing was broken.
  293. * Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  294. - Update the C/C++ reference guide docs. The older version had a
  295. couple of examples that won't work with gcc 2.96-*
  296. * Thu Feb 22 2001 Than Ngo <than@redhat.com>
  297. - fix version number
  298. * Wed Feb 21 2001 Than Ngo <than@redhat.com>
  299. - 1.4-respin
  300. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  301. - 1.4
  302. * Wed Feb 14 2001 Than Ngo <than@redhat.com>
  303. - update (only bugfixes)
  304. - fix up kdelibs documentation path
  305. - fix a dependency problem with kde-i18n package (Bug #27675)
  306. - add qt-designer into requires
  307. * Sun Feb 11 2001 Than Ngo <than@redhat.com>
  308. - fixed to build on s390
  309. * Tue Feb 06 2001 Than Ngo <than@redhat.com>
  310. - update, only bugfixes
  311. * Wed Jan 24 2001 Than Ngo <than@redhat.com>
  312. - hacked for building of KDE references
  313. * Tue Jan 23 2001 Than Ngo <than@redhat.com>
  314. - work-around to build on alpha
  315. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  316. - Update
  317. * Wed Jan 10 2001 Than Ngo <than@redhat.com>
  318. - update new snapshot, only require KDE2/Qt2
  319. * Fri Dec 22 2000 Than Ngo <than@redhat.com>
  320. - fixed dependency problem with kde-i18n
  321. * Thu Dec 21 2000 Than Ngo <than@redhat.com>
  322. - updated to 1.4beta1 with KDE2 support
  323. - fixed to build on s390
  324. - fixed some broken codes
  325. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  326. - fixed for building on ia64
  327. * Wed Nov 15 2000 Than Ngo <than@redhat.com>
  328. - build snapshot 20001112, it works now with KDE2 and kde1-compat
  329. - fix libtool to build on sparc and alpha
  330. - don't use make -j
  331. * Sun Aug 13 2000 Than Ngo <than@redhat.com>
  332. - fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
  333. * Tue Aug 01 2000 Than Ngo <than@redhat.de>
  334. - add missing ldconfig in %post and %postun section (Bug #14924)
  335. - add missing C references stuff to kdevelop
  336. * Sun Jul 30 2000 Than Ngo <than@redhat.de>
  337. - rebuilt against compat-egcs-c++, put KDE1 under /usr
  338. - cleanup specfile
  339. * Tue Jul 25 2000 Than Ngo <than@redhat.de>
  340. - fix dependency problem
  341. * Wed Jul 19 2000 Than Ngo <than@redhat.de>
  342. - rebuilt against compat-libstdc++
  343. * Mon Jul 17 2000 Than Ngo <than@redhat.de>
  344. - install under /usr/share instead /usr/lib/kde1-compat/share,
  345. fix dependency problem
  346. * Sat Jul 15 2000 Than Ngo <than@redhat.de>
  347. - rebuilt with egcs-c++-1.1.2
  348. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  349. - automatic rebuild
  350. * Mon Jul 03 2000 Than Ngo <than@redhat.de>
  351. - fix docdir
  352. - add requires kdebase
  353. * Sun Jul 02 2000 Than Ngo <than@redhat.de>
  354. - rebuilt with kde1-compat
  355. * Sun Jun 18 2000 Than Ngo <than@redhat.de>
  356. - rebuilt in the new build environment, fix docdir
  357. - FHS packaging
  358. * Thu Jun 08 2000 Than Ngo <than@redhat.de>
  359. - update to 1.2
  360. - move from powertools to main CD
  361. - use %%configure
  362. * Mon Apr 3 2000 Ngo Than <than@redhat.de>
  363. - fix up reference (Bug #10368)
  364. * Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  365. - Fix up documentation path (Bug #7291)
  366. - Update to current stable branch - this should fix up the debugger problem
  367. - clean up spec file
  368. * Fri Jan 6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  369. - Update to current stable branch
  370. - Adapt to 6.2 Qt libraries
  371. - Use BuildPrereq
  372. * Wed Jan 05 2000 Ngo Than <than@redhat.de>
  373. - added patch for alpha
  374. * Tue Dec 21 1999 Ngo Than <than@redhat.de>
  375. - updated kdevelop-1.0 release
  376. * Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
  377. - kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
  378. * Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
  379. - initial packaging for 6.1.