libsigc++-vl.spec 8.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271
  1. %define lib_name sigc++-2.0
  2. Summary: The Typesafe Signal Framework for C++
  3. Summary(ja): C++ 用の型安全なシグナルフレームワーク
  4. Name: libsigc++
  5. Version: 2.10.3
  6. Release: 1%{?_dist_release}
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: LGPLv2
  10. URL: https://github.com/libsigcplusplus/libsigcplusplus
  11. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  12. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  13. Buildroot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: gcc-c++
  15. BuildRequires: m4
  16. %description
  17. This library implements a full callback system for use in widget libraries,
  18. abstract interfaces, and general programming. Originally part of the Gtk--
  19. widget set, %{name} is now a seperate library to provide for more general
  20. use. It is the most complete library of its kind with the ablity to connect
  21. an abstract callback to a class method, function, or function object. It
  22. contains adaptor classes for connection of dissimilar callbacks and has an
  23. ease of use unmatched by other C++ callback libraries.
  24. Package gtkmm2, which is a C++ binding to the GTK2 library, uses libsigc++.
  25. %package devel
  26. Summary: development tools for the Typesafe Signal Framework for C++
  27. Group: Development/Libraries
  28. Requires: %{name} = %{version}-%{release}
  29. Requires: pkgconfig
  30. %description devel
  31. The %{name}-devel package contains the static libraries and header files
  32. needed for development with %{name}.
  33. %package examples
  34. Summary: examples and tests for the Typesafe Signal Framework for C++
  35. Group: Development/Libraries
  36. Requires: %{name}-devel = %{version}-%{release}
  37. %description examples
  38. The %{name}-devel package contains source code of example and test
  39. programs for %{name}.
  40. %prep
  41. %setup -q
  42. %build
  43. %configure --disable-static --enable-silent-rules
  44. make %{_smp_mflags}
  45. %install
  46. rm -rf $RPM_BUILD_ROOT
  47. make install DESTDIR=$RPM_BUILD_ROOT
  48. # removed unpackage files
  49. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  50. mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
  51. cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
  52. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
  53. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .deps |xargs -r rm -rf
  54. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
  55. grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
  56. for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/{examples,tests}/Makefile; do
  57. rm -f $i.*
  58. done
  59. rm -rf docs-toinstall
  60. mkdir -p docs-to-install
  61. cp -pr $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0/* docs-to-install/
  62. rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0
  63. # devhelp path fix
  64. sed -i 's/doc\/%{name}-2.0/doc\/%{name}-devel-%{version}/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-2.0/%{name}-2.0.devhelp2
  65. #sed -i 's/html\/..\/..\/index\.html/html\/index\.html/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/libglademm-%{ver}/libglademm-%{ver}.devhelp
  66. %post -p /sbin/ldconfig
  67. %postun -p /sbin/ldconfig
  68. %clean
  69. rm -rf $RPM_BUILD_ROOT
  70. %files
  71. %defattr(-,root,root,755)
  72. %license COPYING
  73. %doc AUTHORS README NEWS ChangeLog TODO
  74. %attr(755,root,root) %{_libdir}/lib*.so.*
  75. %files devel
  76. %defattr(-,root,root,755)
  77. %{_includedir}/*
  78. %{_libdir}/%{lib_name}/include
  79. %{_libdir}/pkgconfig/*.pc
  80. #{_libdir}/lib*.la
  81. %{_libdir}/lib*.so
  82. %{_datadir}/devhelp/books/%{name}-2.0/*
  83. %doc docs-to-install/index.html docs-to-install/images
  84. %doc docs-to-install/reference docs-to-install/tutorial
  85. %files examples
  86. %defattr(-,root,root,755)
  87. %{_libdir}/%{lib_name}/examples
  88. %{_libdir}/%{lib_name}/tests
  89. %changelog
  90. * Sat Aug 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.3-1
  91. - new upstream release.
  92. * Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.2-1
  93. - new upstream release.
  94. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.0-1
  95. - new upstream release.
  96. * Fri Jul 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
  97. - new upstream release
  98. * Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-2
  99. - rebuild with gcc-5.4.0
  100. * Sat Nov 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  101. - new upstream release
  102. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.1-1
  103. - new upstream release
  104. * Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.11-1
  105. - new upstream release
  106. * Sun Dec 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.10-1
  107. - new upstream release
  108. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.8-2
  109. - build with rpm-4.8.1-1 for pkg-config file
  110. * Thu Sep 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.8-1
  111. - new upstream release
  112. * Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-1
  113. - new upstream release
  114. - built with new toolchain
  115. * Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4.2-1
  116. - new upstream release
  117. - remove static libraries from devel package
  118. * Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
  119. - new upstream release
  120. - spec in UTF-8
  121. * Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-2vl5
  122. - removed .la files from devel package
  123. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-1vl5
  124. - new upstream release
  125. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.17-0vl2
  126. - rebuild with new environment/toolchain
  127. * Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
  128. - new upstream release
  129. * Tue Aug 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl2
  130. - rebuild with new libtool
  131. * Tue Aug 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl1
  132. - new upstream release
  133. * Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
  134. - new upstream release
  135. * Sat Jun 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.14-0vl1
  136. - new upstream release
  137. * Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.10-0vl1
  138. - new upstream release
  139. - added tutorial to devel package
  140. * Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.6-0vl1
  141. - update to 2.0.6
  142. * Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
  143. - update to 1.2.5
  144. - add Requires: pkgconfig
  145. * Sat Oct 4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
  146. - rebuild to remove dependance <5371>
  147. - add Japanese summary
  148. - use better macros
  149. - s/Copyright/License/
  150. * Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
  151. - rebuild with new toolchain
  152. * Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
  153. - 1.0.4-0vl1
  154. - Build for Vine Linux 2.5
  155. * Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
  156. - packaged for Vine Linux 2.1
  157. * Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
  158. - updated Url and Source fileds
  159. - 1.0.0 stable release
  160. * Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
  161. - filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
  162. - minor install section cleanup
  163. * Wed Jan 19 2000 Allan Rae <rae@lyx.org>
  164. - autogen just creates configure, not runs it, so cleaned that up too.
  165. * Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
  166. - minor attr fix
  167. - removed unnecessary curly braces
  168. - fixed Herbert's adjustement
  169. * Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
  170. - minor package dependence fix
  171. * Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
  172. - fixed typo of mine
  173. - added traditional CUSTOM_RELEASE stuff
  174. - added SMP support
  175. * Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
  176. - adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
  177. * Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
  178. - split into three packages: %name, %name-devel and %name-examples
  179. * Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  180. - updated source field and merged conflicts between revisions.
  181. * Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
  182. - updated Prefix and BuildRoot fields
  183. * Thu Aug 5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
  184. - made sure configure works on all alphas
  185. * Wed Jul 7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  186. - Added autoconf macro for sigc.
  187. * Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  188. - Made into a .in to keep version field up to date
  189. - Still need to do release by hand
  190. * Mon Jun 7 1999 Dmitry V. Levin <ldv@fandra.org>
  191. - added Vendor and Packager fields
  192. * Sat Jun 5 1999 Dmitry V. Levin <ldv@fandra.org>
  193. - updated to 0.8.0
  194. * Tue Jun 1 1999 Dmitry V. Levin <ldv@fandra.org>
  195. - initial revision