html-helper-mode-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define origname html-helper-mode
  4. %define origver 2.19.1.1
  5. %define release 7
  6. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  7. # Main
  8. Summary: Major mode for editing HTML (for Emacsen)
  9. Name: %{origname}
  10. Version: %{origver}
  11. Release: %{release}%{?_dist_release}
  12. License: GPLv2+
  13. Group: Applications/Editors/Emacs
  14. URL: http://www.santafe.edu/~nelson/tools/
  15. Source0: http://www.santafe.edu/~nelson/hhm-beta/html-helper-mode.el
  16. Source1: http://www.santafe.edu/~nelson/hhm-beta/tempo.el
  17. Source2: http://www.santafe.edu/~nelson/hhm-beta/index.html
  18. Source3: http://www.santafe.edu/~nelson/tools/configuring.html
  19. Source4: http://www.santafe.edu/~nelson/tools/differences.html
  20. Source5: http://www.santafe.edu/~nelson/tools/documentation.html
  21. Source6: http://www.santafe.edu/~nelson/tools/keybindings.html
  22. Source7: hhm.dot.emacs
  23. Source8: HHM-MK
  24. Source9: html-helper-mode-install.sh
  25. Source10: html-helper-mode-remove.sh
  26. Source11: vine-default-%{origname}.el
  27. Source12: %{origname}-init.el
  28. Buildroot: %{_tmppath}/%{name}-root
  29. PreReq: emacsen
  30. Requires: emacsen
  31. %prereq_ge emacsen-common
  32. BuildArchitectures: noarch
  33. #Obsoletes: %{name}-2.19.1.1-3
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. %description
  37. html-helper-mode makes it easier to write HTML documents.
  38. This mode handles inserting HTML codes in a variety of ways
  39. (keybindings, completion in the buffer).
  40. It also supports indentation, timestamps, skeletons for new documents,
  41. hilit19 patterns, and a variety of other things.
  42. Initialization
  43. ===============
  44. Please refer the following file:
  45. "%{_docdir}/%{name}-%{version}/hhm.dot.emacs"
  46. "%{_docdir}/%{name}-%{version}/*.html"
  47. %description -l ja
  48. html-helper-mode は、HTML ドキュメントの作成を簡単にします。
  49. このモードでは、HTML コードの挿入に多様な方法が使えます。
  50. また、INDENTATION、タイムスタンプ等をサポートします。
  51. 初期設定
  52. =========
  53. 下記を参考にしてください:
  54. "%{_docdir}/%{name}-%{version}/hhm.dot.emacs"
  55. "%{_docdir}/%{name}-%{version}/*.html"
  56. # '
  57. %prep
  58. %setup -q -T -c %{name}-%{version}
  59. cp %SOURCE0 ./
  60. cp %SOURCE1 ./
  61. cp %SOURCE2 ./
  62. cp %SOURCE3 ./
  63. cp %SOURCE4 ./
  64. cp %SOURCE5 ./
  65. cp %SOURCE6 ./
  66. cp %SOURCE7 ./
  67. cp %SOURCE8 ./
  68. %build
  69. # byte-compile
  70. #emacs-%{emacsver} -batch -l HHM-MK
  71. %install
  72. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  73. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  74. mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
  75. mkdir -p %{buildroot}%{emacsen_pkgdir}/install
  76. mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
  77. #
  78. # install el files
  79. #
  80. cp -a html-helper-mode.el tempo.el HHM-MK %{SOURCE11} %{SOURCE12} \
  81. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  82. #
  83. # install script( bytecompile el and install elc , remove )
  84. #
  85. %_installemacsenscript %{origname} %{SOURCE9}
  86. %_removeemacsenscript %{origname} %{SOURCE10}
  87. %post
  88. #
  89. # bytecompile and install
  90. #
  91. if [ "$1" = 2 ]; then
  92. %_emacsenPackageRemove %{origname}
  93. fi
  94. %_addemacsenlist %{origname}
  95. %_emacsenPackageInstall %{origname}
  96. %preun
  97. if [ "$1" = 0 ]; then
  98. %_emacsenPackageRemove %{origname}
  99. %_removeemacsenlist %{origname}
  100. fi
  101. %clean
  102. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  103. rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
  104. %files
  105. %defattr(-,root,root)
  106. %doc *.html hhm.dot.emacs
  107. %{_datadir}/emacs/site-lisp/%{origname}
  108. %{emacsen_pkgdir}/install/%{origname}
  109. %{emacsen_pkgdir}/remove/%{origname}
  110. %changelog
  111. * Mon Apr 19 2010 IWAI, Masaharu <iwai@alib.jp> 2.19.1.1-7
  112. - fix html-helper-mode-install.sh: installing vine-default file
  113. * Wed Apr 7 2010 IWAI, Masaharu <iwai@alib.jp> 2.19.1.1-6
  114. - apply vine-default
  115. - add vine-default (Source11)
  116. - add init.el (Source12)
  117. - update html-helper-mode-{install,removce}.sh for init.el file
  118. - using %%{emacsen_pkgdir} macro
  119. - update %%description
  120. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.19.1.1-5
  121. - spec in utf8
  122. - applied new versioning policy
  123. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.19.1.1-4vl3
  124. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  125. - s/Copyright/License/
  126. * Wed Jan 2 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 2.19.1.1-4vl2
  127. - emacsenize
  128. - rewrite Summary and %%description for emacesnize
  129. * Sun Oct 15 2000 Jun Nishii <jun@vinelinux.org>
  130. - 2.19.1.1-4vl1
  131. - rebuid for Vine Linux 2.1/emacs-20.7
  132. * Mon Apr 17 2000 Jun Nishii <jun@vinelinux.org>
  133. - rebuid for Vine Linux 2.0
  134. * Fri Dec 17 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  135. - Released as version "html-helper-mode-emacs20-2.19.1.1-3".
  136. Changed from "html-helper-mode-emacs20-2.19.1.1-2".
  137. - Changed emacs version, "20.4" => "20.5".
  138. - Revised some, the definition part of data.
  139. * Thu Dec 2 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  140. - Released as version "html-helper-mode-emacs20-2.19.1.1-2".
  141. Changed from "html-helper-mode-emacs20-2.19.1.1-1".
  142. - Added source file, "HHM-MK".
  143. - Revised some, the definition part of data.
  144. - Revised some, part of "%description, %build".
  145. * Thu Nov 25 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  146. - Released as version "html-helper-mode-emacs20-2.19.1.1-1".
  147. # $Id: html-helper-mode-emacs20-2.19.1.1.spec,v 1.7 1999-12-17 17:50:58+09 ushio Exp $