texlive-collection-langswedish-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2009-2:
  3. ## tlpdb2rpmspec collection-langswedish
  4. %bcond_with firstbuild
  5. %define tex_destdir %{_datadir}
  6. %define texmf %{tex_destdir}/texmf
  7. %define texlive_src %{tex_destdir}/texlive-sources
  8. %define build_tex_destdir %{buildroot}%{tex_destdir}
  9. %define build_texmf %{buildroot}%{texmf}
  10. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  11. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  12. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
  13. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  14. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  15. %define vartexfonts %{_var}/lib/texmf
  16. %define __find_provides %{nil}
  17. %define __find_requires %{nil}
  18. %define __perl_provides %{nil}
  19. %define __perl_requires %{nil}
  20. Autoreq: 0
  21. Summary: TeX Live: Swedish
  22. Summary(ja): TeX Live: Swedish
  23. Name: texlive-collection-langswedish
  24. Version: 2009
  25. Release: 2%{?_dist_release}
  26. License: LPPL
  27. Group: Applications/Publishing
  28. URL:http://www.tug.org/texlive/
  29. Requires: texlive = %{version}
  30. Requires: texlive-collection-basic = %{version}
  31. Requires(post): texlive = %{version}
  32. Requires(postun): texlive = %{version}
  33. BuildRequires: texlive-sources = %{version}
  34. BuildArch: noarch
  35. Buildroot: %{_tmppath}/%{name}-%{version}-root
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. Packager: munepi
  39. %description
  40. The TeX Live software distribution offers a complete TeX system for a
  41. variety of Unix, Macintosh, Windows and other platforms. It
  42. encompasses programs for editing, typesetting, previewing and printing
  43. of TeX documents in many different languages, and a large collection
  44. of TeX macros and font libraries.
  45. The distribution includes extensive general documentation about TeX,
  46. as well as the documentation for the included software packages.
  47. This package is a collection of Swedish:
  48. Support for typesetting Swedish.
  49. This package contains the following CTAN packages:
  50. swebib: Swedish bibliography styles.
  51. hyphen-swedish:
  52. %description -l ja
  53. TeX Live ソフトウェアディストリビューションは、
  54. さまざまな Unix, Macintosh, Windows、および
  55. 他のプラットホームに対して完全な TeX システムを提供します。
  56. 多くの異なった言語を含む TeX ドキュメントの
  57. 編集、組版、閲覧、印刷するためのプログラム、
  58. そして、TeX マクロやフォントライブラリの大きなコレクションを
  59. 同梱しています。
  60. このディストリビューションは
  61. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  62. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  63. このパッケージは以下のようなパッケージ集です。
  64. Swedish:
  65. Support for typesetting Swedish.
  66. このパッケージは以下の CTAN パッケージを含んでいます:
  67. swebib: Swedish bibliography styles.
  68. hyphen-swedish:
  69. %package doc
  70. Summary: TeX Live: Documentation files of %{name}
  71. Group: Applications/Publishing
  72. Requires: %{name} = %{version}-%{release}
  73. %description doc
  74. This package contains documentation files of %{name}.
  75. %prep
  76. %build
  77. %install
  78. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  79. PREF=%{buildroot}%{tex_destdir}
  80. manifest=(
  81. texmf-dist/doc/latex/swebib/README
  82. texmf-dist/bibtex/bst/swebib/sweabbrv.bst
  83. texmf-dist/bibtex/bst/swebib/swealpha.bst
  84. texmf-dist/bibtex/bst/swebib/sweplain.bst
  85. texmf-dist/bibtex/bst/swebib/sweplnat.bst
  86. texmf-dist/bibtex/bst/swebib/sweunsrt.bst
  87. )
  88. %__mkdir_p ${PREF}/texmf-dist
  89. for i in "${manifest[@]}"; do
  90. %__install -D %{texlive_src}/$i ${PREF}/$i
  91. done
  92. ## info
  93. %__rm -f %{buildroot}%{_infodir}/dir
  94. %__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
  95. ## man
  96. ## man t1* files are provided by t1utils
  97. for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
  98. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  99. done
  100. ## man some files are provided by psutils
  101. for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
  102. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  103. done
  104. ## fix perl path
  105. for i in source/metapost/expressg/expressg.dtx doc/metapost/expressg/n2mpsprl.prl doc/latex/songbook/contrib/crd2sb/crd2sb; do
  106. [ -f %{build_texmf}-dist/${i} ] && %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
  107. done
  108. ## remove asymptote directries, which provides asymptote package
  109. find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
  110. # find %{buildroot} -name "Makefile" | xargs %__rm -f
  111. # ## remove xindy
  112. # find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
  113. # ## remove tex4ht
  114. # find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
  115. ## remove arch dependent binaries
  116. %__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
  117. ## remove unpackaging files
  118. find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
  119. find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
  120. ## Files list
  121. find %{buildroot} -type f -or -type l | \
  122. %__sed -e "s|%{buildroot}||g" > filelist.full
  123. find %{buildroot}%{texmf}-dist -type d | \
  124. %__sed -e "s|^%{buildroot}|%dir |" \
  125. -e "s|$|/|" >> filelist.full
  126. ## subpackages
  127. grep "/texmf-dist/doc/" filelist.full > filelist.doc
  128. cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
  129. %__mv -f filelist.tmp filelist.full
  130. %clean
  131. %__rm -rf %{buildroot}
  132. %post
  133. %{exec_texhash}
  134. echo -n " "
  135. echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
  136. exit 0
  137. %postun
  138. if [ "$1" = 0 ]; then
  139. %{exec_texhash}
  140. fi
  141. exit 0
  142. %files -f filelist.full
  143. %defattr(-,root,root)
  144. %files -f filelist.doc doc
  145. %defattr(-,root,root)
  146. %changelog
  147. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  148. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langswedish
  149. - removed arch dependent binaries (texlive-collection-latexextra)
  150. - fixed perl path
  151. - improved updmap process in %%post and %%postun
  152. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  153. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langswedish