ntfs-3g-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270
  1. %bcond_with externalfuse
  2. Summary: Linux NTFS userspace driver
  3. Summary(ja): Linux NTFS ユーザ空間ドライバ
  4. Name: ntfs-3g
  5. Version: 2012.1.15
  6. Release: 1%{?_dist_release}
  7. License: GPL
  8. Group: System Environment/Base
  9. URL: http://www.ntfs-3g.org/
  10. Source0: http://www.ntfs-3g.org/%{name}_ntfsprogs-%{version}.tgz
  11. Source1: 20-ntfs-config-write-policy.fdi
  12. Patch0: ntfs-3g_ntfsprogs-2011.10.9-RC-ntfsck-unsupported-return-0.patch
  13. Patch1: ntfs-3g-junction-point-fix.patch
  14. # Windows 8 safety checks
  15. Patch2: ntfs-3g-4d0b9163c9ef1f0cdbbf533317b291220c7fd1c7.patch
  16. Patch3: ntfs-3g-559270a8f67c77a7ce51246c23d2b2837bcff0c9.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. BuildRequires: libtool
  19. BuildRequires: libattr-devel
  20. BuildRequires: libconfig-devel
  21. BuildRequires: libgcrypt-devel
  22. BuildRequires: gnutls-devel
  23. BuildRequires: libuuid-devel
  24. %if %{with externalfuse}
  25. BuildRequires: fuse-devel
  26. Requires: fuse
  27. %endif
  28. %description
  29. The ntfs-3g driver is an open source, GPL licensed, third generation
  30. Linux NTFS driver. It provides full read-write access to NTFS, excluding
  31. access to encrypted files, writing compressed files, changing file
  32. ownership, access right.
  33. Technically it's based on and a major improvement to the third
  34. generation Linux NTFS driver, ntfsmount. The improvements include
  35. functionality, quality and performance enhancements.
  36. ntfs-3g features are being merged to ntfsmount. In the meanwhile,
  37. ntfs-3g is currently the only free, as in either speech or beer, NTFS
  38. driver for Linux that supports unlimited file creation and deletion.
  39. %package devel
  40. Summary: Development files and libraries for ntfs-3g
  41. Summary(ja): ntfs-3g の開発ファイルとライブラリ
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. Provides: ntfsprogs-devel = %{version}-%{release}
  45. Obsoletes: ntfsprogs-devel < 2.0.0-3
  46. %description devel
  47. Headers and libraries for developing applications that use ntfs-3g
  48. functionality.
  49. %package -n ntfsprogs
  50. Summary: NTFS filesystem libraries and utilities
  51. Summary(ja): NTFS ファイルシステム用ライブラリおよびユーティリティ
  52. Group: System Environment/Base
  53. Provides: ntfsprogs-gnomevfs = %{version}-%{release}
  54. Obsoletes: ntfsprogs-gnomevfs < 2.0.0-3
  55. %description -n ntfsprogs
  56. The ntfsprogs package currently consists of a library and utilities
  57. such as mkntfs, ntfscat, ntfsls, ntfsresize, and ntfsundelete
  58. (for a full list of included utilities see man 8 ntfsprogs after
  59. installation).
  60. %prep
  61. %setup -q -n %{name}_ntfsprogs-%{version}
  62. %patch0 -p1 -b .unsupported
  63. %patch1 -p1 -b .junction-fix
  64. %patch2 -p1 -b .4d0b9163
  65. %patch3 -p1 -b .559270a8
  66. %build
  67. %configure --disable-static \
  68. --disable-ldconfig \
  69. %{?with_ externalfuse:--with-fuse=external} \
  70. --exec-prefix=/ \
  71. --bindir=/bin \
  72. --sbindir=/sbin \
  73. --libdir=/%{_lib} \
  74. --enable-crypto \
  75. --enable-extras
  76. make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
  77. %install
  78. rm -rf $RPM_BUILD_ROOT
  79. mkdir -p $RPM_BUILD_ROOT/sbin
  80. make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=%{_bindir}/libtool install
  81. rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
  82. rm -f $RPM_BUILD_ROOT/%{_lib}/libntfs-3g.a
  83. # make the symlink an actual copy to avoid confusion
  84. rm -rf $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
  85. cp -a $RPM_BUILD_ROOT/bin/ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
  86. # make compatibility symlinks
  87. ln -s ntfs-3g $RPM_BUILD_ROOT/bin/ntfsmount
  88. ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-fuse
  89. ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs
  90. ln -s ../bin/ntfsck $RPM_BUILD_ROOT/sbin/fsck.ntfs
  91. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  92. ln -s /bin/ntfs-3g $RPM_BUILD_ROOT%{_bindir}/ntfs-3g
  93. ln -s /bin/ntfsmount $RPM_BUILD_ROOT%{_bindir}/ntfsmount
  94. # Put the .pc file in the right place.
  95. mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
  96. mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig/libntfs-3g.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
  97. mkdir -p $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
  98. cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
  99. rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
  100. rm -f $RPM_BUILD_ROOT/%{_lib}/libntfs-3g.la
  101. %clean
  102. rm -rf $RPM_BUILD_ROOT
  103. %post -p /sbin/ldconfig
  104. %postun -p /sbin/ldconfig
  105. %files
  106. %defattr(-,root,root,-)
  107. %doc AUTHORS ChangeLog COPYING CREDITS NEWS README
  108. /sbin/mount.lowntfs-3g
  109. /sbin/mount.ntfs
  110. %attr(4754,root,root) /sbin/mount.ntfs-3g
  111. /sbin/mount.ntfs-fuse
  112. /bin/lowntfs-3g
  113. /bin/ntfs-3g
  114. /bin/ntfs-3g.probe
  115. /bin/ntfs-3g.secaudit
  116. /bin/ntfs-3g.usermap
  117. /bin/ntfsmount
  118. %{_bindir}/ntfs-3g
  119. %{_bindir}/ntfsmount
  120. /%{_lib}/libntfs-3g.so.*
  121. %{_datadir}/hal/fdi/policy/10osvendor/20-ntfs-config-write-policy.fdi
  122. %{_mandir}/man8/mount.lowntfs-3g.*
  123. %{_mandir}/man8/mount.ntfs-3g.*
  124. %{_mandir}/man8/ntfs-3g*
  125. %files devel
  126. %defattr(-,root,root,-)
  127. %{_includedir}/ntfs-3g/
  128. /%{_lib}/libntfs-3g.so
  129. %{_libdir}/pkgconfig/*.pc
  130. %files -n ntfsprogs
  131. %doc AUTHORS COPYING CREDITS ChangeLog NEWS README
  132. /bin/ntfscat
  133. /bin/ntfscluster
  134. /bin/ntfscmp
  135. /bin/ntfsfix
  136. /bin/ntfsinfo
  137. /bin/ntfsls
  138. # extras
  139. /bin/ntfsck
  140. /bin/ntfsdecrypt
  141. /bin/ntfsdump_logfile
  142. /bin/ntfsmftalloc
  143. /bin/ntfsmove
  144. /bin/ntfstruncate
  145. /bin/ntfswipe
  146. /sbin/fsck.ntfs
  147. /sbin/mkfs.ntfs
  148. /sbin/mkntfs
  149. /sbin/ntfsclone
  150. /sbin/ntfscp
  151. /sbin/ntfslabel
  152. /sbin/ntfsresize
  153. /sbin/ntfsundelete
  154. %{_mandir}/man8/mkntfs.8*
  155. %{_mandir}/man8/mkfs.ntfs.8*
  156. %{_mandir}/man8/ntfs[^m][^o]*.8*
  157. %changelog
  158. * Mon Nov 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012.1.15-1
  159. - new upstream release
  160. - merge ntfsprogs
  161. - add Obsoletes and Provides ntfsprogs*
  162. - add BR: for ntfsprogs
  163. * Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2011.1.15-1
  164. - new upstream release
  165. - fix %%files (add lowntfs-3g)
  166. * Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.4.4-1
  167. - new upstream release
  168. - use internal fuse-lite, remove BR: fuse-devel and R: fuse
  169. - move binaries to /bin
  170. - move libraries to /%%{_lib}
  171. - add fdi file to enable hal automounting
  172. * Sun Jan 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.1.1-1
  173. - new upstream release
  174. * Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2812-1
  175. - new upstream release
  176. * Fri Jul 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2712-1
  177. - new upstream release
  178. * Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2412-1
  179. - new upstream release
  180. * Tue Jun 05 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.516-0vl1
  181. - initial build for Vine Linux
  182. * Tue May 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.516-1
  183. - bump to 1.516
  184. - fix bugzilla 232031
  185. * Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.417-1
  186. - bump to 1.417
  187. * Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.416-1
  188. - bump to 1.416
  189. - drop patch0, upstreamed
  190. * Wed Apr 4 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-2
  191. - allow non-root users to mount/umount ntfs volumes (Laszlo Dvornik)
  192. * Sat Mar 31 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-1
  193. - bump to 1.328
  194. - drop patch, use --disable-ldconfig instead
  195. * Wed Feb 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.0-1
  196. - 1.0 release!
  197. * Fri Jan 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.9.20070118
  198. - symlink to mount.ntfs
  199. * Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.8.20070118
  200. - bump to 20070118
  201. * Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.7.20070116
  202. - bump to latest version for all active dists
  203. * Wed Jan 3 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.6.20070102
  204. - bump to latest version (note that upstream fixed their date mistake)
  205. * Wed Nov 1 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.5.20070920
  206. - add an obsoletes for ntfsprogs-fuse
  207. - make some convenience symlinks
  208. * Wed Oct 25 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.4.20070920
  209. - add some extra Provides
  210. * Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.3.20070920
  211. - add explicit Requires on fuse
  212. * Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.2.20070920
  213. - fixed versioning (bumped epoch, since it now shows as older)
  214. - change sbin symlink to actual copy to be safe
  215. * Sun Oct 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.20070920-1
  216. - Initial package for Fedora Extras