xulrunner-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760
  1. # Minimal required versions
  2. %global nspr_version 4.8.9
  3. %global nss_version 3.13.1
  4. %global cairo_version 1.10.2
  5. %global freetype_version 2.1.9
  6. %global libnotify_version 0.7.0
  7. # gecko_dir_ver should be set to the version in our directory names
  8. # alpha_version should be set to the alpha number if using an alpha, 0 otherwise
  9. # beta_version should be set to the beta number if using a beta, 0 otherwise
  10. # rc_version should be set to the RC number if using an RC, 0 otherwise
  11. %global gecko_dir_ver 2
  12. %global alpha_version 0
  13. %global beta_version 0
  14. %global rc_version 0
  15. %global mozappdir %{_libdir}/%{name}-%{gecko_dir_ver}
  16. %global tarballdir mozilla-esr10
  17. Summary: XUL Runtime for Gecko Applications
  18. Summary(ja): Gecko アプリケーションのための XUL ランタイム
  19. Name: xulrunner
  20. Version: 10.0.8
  21. Release: 1%{?_dist_release}
  22. URL: http://developer.mozilla.org/En/XULRunner
  23. License: MPLv1.1 or GPLv2+ or LGPLv2+
  24. Group: Applications/Internet
  25. # You can get sources at ftp://ftp.mozilla.org/pub/firefox/releases/%{version}/source
  26. Source0: %{name}-%{version}esr.source.tar.bz2
  27. Source10: %{name}-mozconfig-vine
  28. Source12: %{name}-redhat-default-prefs.js
  29. Source21: %{name}.sh.in
  30. # build patches
  31. Patch0: xulrunner-version.patch
  32. Patch1: mozilla-build.patch
  33. Patch14: xulrunner-2.0-chromium-types.patch
  34. Patch17: xulrunner-10.0-gcc47.patch
  35. # Fedora specific patches
  36. Patch20: mozilla-193-pkgconfig.patch
  37. Patch23: wmclass.patch
  38. Patch24: crashreporter-remove-static.patch
  39. # Upstream patches
  40. Patch38: mozilla-696393.patch
  41. # https://bugzilla.mozilla.org/show_bug.cgi?id=707993
  42. Patch39: xulrunner-8.0-fix-maemo-checks-in-npapi.patch
  43. Patch40: mozilla-682832-proxy.patch
  44. # cherry-picked from 13afcd4c097c
  45. Patch41: xulrunner-9.0-secondary-build-fix.patch
  46. Patch42: mozilla-706724.patch
  47. Patch43: mozilla-file.patch
  48. # Needed to detect/use libvpx-1.0.0
  49. # https://bugzilla.mozilla.org/show_bug.cgi?id=722127
  50. Patch44: mozilla-722127.patch
  51. Patch46: mozilla-724615.patch
  52. Patch47: mozilla-691898.patch
  53. # ---------------------------------------------------
  54. BuildRequires: nspr-devel >= %{nspr_version}
  55. BuildRequires: nss-devel >= %{nss_version}
  56. BuildRequires: cairo-devel >= %{cairo_version}
  57. BuildRequires: libpng-devel
  58. BuildRequires: libjpeg-turbo-devel
  59. BuildRequires: zip
  60. BuildRequires: bzip2-devel
  61. BuildRequires: zlib-devel
  62. BuildRequires: libIDL-devel
  63. BuildRequires: gtk2-devel
  64. BuildRequires: krb5-devel
  65. BuildRequires: pango-devel
  66. BuildRequires: freetype2-devel >= %{freetype_version}
  67. BuildRequires: libXt-devel
  68. BuildRequires: libXrender-devel
  69. BuildRequires: startup-notification-devel
  70. BuildRequires: alsa-lib-devel
  71. BuildRequires: libnotify-devel >= %{libnotify_version}
  72. BuildRequires: mesa-libGL-devel
  73. BuildRequires: curl-devel
  74. BuildRequires: yasm
  75. Requires: nspr
  76. Requires: nss
  77. Provides: gecko-libs = %{gecko_verrel}
  78. Conflicts: firefox < 3.6
  79. Vendor: Project Vine
  80. Distribution: Vine Linux
  81. Packager: daisuke
  82. %description
  83. XULRunner is a Mozilla runtime package that can be used to bootstrap XUL+XPCOM
  84. applications that are as rich as Firefox and Thunderbird. It provides mechanisms
  85. for installing, upgrading, and uninstalling these applications. XULRunner also
  86. provides libxul, a solution which allows the embedding of Mozilla technologies
  87. in other projects and products.
  88. %package devel
  89. Summary: Development files for Gecko
  90. Summary(ja): Geckoの開発ファイル
  91. Group: Development/Libraries
  92. Obsoletes: mozilla-devel < 1.9
  93. Obsoletes: firefox-devel < 2.1
  94. Obsoletes: xulrunner-devel-unstable
  95. Provides: gecko-devel = %{gecko_verrel}
  96. Provides: gecko-devel-unstable = %{gecko_verrel}
  97. Requires: xulrunner = %{version}-%{release}
  98. Requires: nspr-devel
  99. Requires: nss-devel
  100. Requires: cairo-devel
  101. Requires: libjpeg-devel
  102. Requires: zip
  103. Requires: bzip2-devel
  104. Requires: zlib-devel
  105. Requires: libIDL-devel
  106. Requires: gtk2-devel
  107. Requires: krb5-devel
  108. Requires: pango-devel
  109. Requires: freetype-devel
  110. Requires: libXt-devel
  111. Requires: libXrender-devel
  112. Requires: startup-notification-devel
  113. Requires: alsa-lib-devel
  114. Requires: libnotify-devel
  115. Requires: mesa-libGL-devel
  116. %description devel
  117. This package contains the libraries amd header files that are needed
  118. for writing XUL+XPCOM applications with Mozilla XULRunner and Gecko.
  119. #---------------------------------------------------------------------
  120. %prep
  121. %setup -q -c
  122. cd %{tarballdir}
  123. sed -e 's/__RPM_VERSION_INTERNAL__/%{gecko_dir_ver}/' %{P:%%PATCH0} \
  124. > version.patch
  125. %{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
  126. %patch1 -p2 -b .build
  127. %patch14 -p1 -b .chromium-types
  128. %patch17 -p1 -b .gcc47
  129. %patch20 -p2 -b .pk
  130. %patch23 -p1 -b .wmclass
  131. %patch24 -p1 -b .static
  132. %patch38 -p2 -b .696393
  133. %patch39 -p1 -b .707993
  134. %patch40 -p2 -b .682832
  135. %patch41 -p2 -b .secondary-build
  136. %patch42 -p1 -b .706724
  137. %patch43 -p1 -b .file
  138. %patch44 -p2 -b .vpx1.0.0
  139. %patch46 -p1 -b .724615
  140. %patch47 -p1 -b .691898
  141. %{__rm} -f .mozconfig
  142. %{__cp} %{SOURCE10} .mozconfig
  143. echo "ac_add_options --disable-system-sqlite" >> .mozconfig
  144. %ifarch armv7hl
  145. echo "ac_add_options --with-arch=armv7-a" >> .mozconfig
  146. echo "ac_add_options --with-float-abi=hard" >> .mozconfig
  147. echo "ac_add_options --with-fpu=vfpv3-d16" >> .mozconfig
  148. echo "ac_add_options --disable-elf-hack" >> .mozconfig
  149. %endif
  150. %ifarch armv7hnl
  151. echo "ac_add_options --with-arch=armv7-a" >> .mozconfig
  152. echo "ac_add_options --with-float-abi=hard" >> .mozconfig
  153. echo "ac_add_options --with-fpu=neon" >> .mozconfig
  154. echo "ac_add_options --disable-elf-hack" >> .mozconfig
  155. %endif
  156. %ifarch armv5tel
  157. echo "ac_add_options --with-arch=armv5te" >> .mozconfig
  158. echo "ac_add_options --with-float-abi=soft" >> .mozconfig
  159. echo "ac_add_options --disable-elf-hack" >> .mozconfig
  160. %endif
  161. %ifnarch %{ix86} x86_64
  162. echo "ac_add_options --disable-methodjit" >> .mozconfig
  163. echo "ac_add_options --disable-monoic" >> .mozconfig
  164. echo "ac_add_options --disable-polyic" >> .mozconfig
  165. echo "ac_add_options --disable-tracejit" >> .mozconfig
  166. %endif
  167. #---------------------------------------------------------------------
  168. %build
  169. cd %{tarballdir}
  170. # -fpermissive is needed to build with gcc 4.6+ which has become stricter
  171. #
  172. # Mozilla builds with -Wall with exception of a few warnings which show up
  173. # everywhere in the code; so, don't override that.
  174. #
  175. # Disable C++ exceptions since Mozilla code is not exception-safe
  176. #
  177. MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS -fpermissive" | \
  178. %{__sed} -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')
  179. export CFLAGS=$MOZ_OPT_FLAGS
  180. export CXXFLAGS=$MOZ_OPT_FLAGS
  181. export PREFIX='%{_prefix}'
  182. export LIBDIR='%{_libdir}'
  183. MOZ_SMP_FLAGS=-j1
  184. # On x86 architectures, Mozilla can build up to 4 jobs at once in parallel,
  185. # however builds tend to fail on other arches when building in parallel.
  186. %ifarch %{ix86} x86_64
  187. [ -z "$RPM_BUILD_NCPUS" ] && \
  188. RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
  189. [ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
  190. [ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
  191. %endif
  192. make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS" MOZ_SERVICES_SYNC="1"
  193. #---------------------------------------------------------------------
  194. %install
  195. cd %{tarballdir}
  196. # set up our prefs before install, so it gets pulled in to omni.jar
  197. %{__cp} -p %{SOURCE12} dist/bin/defaults/pref/all-redhat.js
  198. DESTDIR=$RPM_BUILD_ROOT make install
  199. # Start script install
  200. %{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
  201. %{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{gecko_dir_ver},g' > \
  202. $RPM_BUILD_ROOT%{_bindir}/%{name}
  203. %{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
  204. %{__rm} -f $RPM_BUILD_ROOT%{mozappdir}/%{name}-config
  205. # Copy pc files (for compatibility with 1.9.1)
  206. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
  207. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
  208. %{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
  209. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
  210. # Fix multilib devel conflicts...
  211. function install_file() {
  212. genheader=$*
  213. mv ${genheader}.h ${genheader}%{__isa_bits}.h
  214. cat > ${genheader}.h << EOF
  215. /* This file exists to fix multilib conflicts */
  216. #if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__) || (defined(__sparc__) && defined(__arch64__))
  217. #include "${genheader}64.h"
  218. #else
  219. #include "${genheader}32.h"
  220. #endif
  221. EOF
  222. }
  223. INTERNAL_APP_NAME=%{name}-%{gecko_dir_ver}
  224. pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
  225. install_file "mozilla-config"
  226. install_file "js-config"
  227. popd
  228. # Link libraries in sdk directory instead of copying them:
  229. pushd $RPM_BUILD_ROOT%{_libdir}/%{name}-devel-%{gecko_dir_ver}/sdk/lib
  230. for i in *.so; do
  231. rm $i
  232. ln -s %{mozappdir}/$i $i
  233. done
  234. popd
  235. # Library path
  236. LD_SO_CONF_D=%{_sysconfdir}/ld.so.conf.d
  237. LD_CONF_FILE=xulrunner-%{__isa_bits}.conf
  238. %{__mkdir_p} ${RPM_BUILD_ROOT}${LD_SO_CONF_D}
  239. %{__cat} > ${RPM_BUILD_ROOT}${LD_SO_CONF_D}/${LD_CONF_FILE} << EOF
  240. %{mozappdir}
  241. EOF
  242. # Copy over the LICENSE
  243. %{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT%{mozappdir}
  244. # ghost files
  245. %{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/components
  246. touch $RPM_BUILD_ROOT%{mozappdir}/components/compreg.dat
  247. touch $RPM_BUILD_ROOT%{mozappdir}/components/xpti.dat
  248. #---------------------------------------------------------------------
  249. %post -p /sbin/ldconfig
  250. %postun -p /sbin/ldconfig
  251. %preun
  252. # is it a final removal?
  253. if [ $1 -eq 0 ]; then
  254. %{__rm} -rf %{mozappdir}/components
  255. fi
  256. %files
  257. %defattr(-,root,root,-)
  258. %{_bindir}/xulrunner
  259. %dir %{mozappdir}
  260. %doc %attr(644, root, root) %{mozappdir}/LICENSE
  261. %doc %attr(644, root, root) %{mozappdir}/README.txt
  262. %{mozappdir}/chrome
  263. %{mozappdir}/chrome.manifest
  264. %{mozappdir}/dictionaries
  265. %dir %{mozappdir}/components
  266. %ghost %{mozappdir}/components/compreg.dat
  267. %ghost %{mozappdir}/components/xpti.dat
  268. %{mozappdir}/components/*.so
  269. %{mozappdir}/components/*.manifest
  270. %{mozappdir}/omni.ja
  271. %{mozappdir}/plugins
  272. %{mozappdir}/*.so
  273. %{mozappdir}/mozilla-xremote-client
  274. %{mozappdir}/run-mozilla.sh
  275. %{mozappdir}/xulrunner
  276. %{mozappdir}/xulrunner-bin
  277. %{mozappdir}/xulrunner-stub
  278. %{mozappdir}/platform.ini
  279. %{mozappdir}/dependentlibs.list
  280. %{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
  281. %{mozappdir}/plugin-container
  282. %files devel
  283. %defattr(-,root,root,-)
  284. %dir %{_libdir}/%{name}-devel-*
  285. %{_datadir}/idl/%{name}*%{gecko_dir_ver}
  286. %{_includedir}/%{name}*%{gecko_dir_ver}
  287. %{_libdir}/%{name}-devel-*/*
  288. %{_libdir}/pkgconfig/*.pc
  289. %{mozappdir}/xpcshell
  290. #---------------------------------------------------------------------
  291. %changelog
  292. * Wed Oct 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.8-1
  293. - update to 10.0.8esr
  294. * Sat Jul 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.6-1
  295. - update to 10.0.6 (based on firefox-10.0.6esr source)
  296. * Wed Mar 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.3-1
  297. - update to 10.0.3 (based on firefox-10.0.3esr source)
  298. - clean up spec
  299. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.1-3
  300. - rebuild with libnotify-0.7
  301. * Tue May 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-2
  302. - modify gre.conf to promote internal gecko version.
  303. * Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-1
  304. - update to 2.0.1 (sync with firefox-4.0.1)
  305. * Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-1
  306. - update to 2.0 (sync with firefox-4.0)
  307. - BR: libjpeg-turbo-devel >= 1.1.0
  308. - BR: nspr-devel >= 4.8.7
  309. - BR: nss-devel >= 3.12.9
  310. - BR: cairo-devel >= 1.10.2-2
  311. - add Patch130 to use omni.jar (upstream patch)
  312. * Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.15-1
  313. - update to 1.9.2.15 (sync with firefox-3.6.15)
  314. * Wed Mar 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.14-1
  315. - update to 1.9.2.14 (sync with firefox-3.6.14)
  316. * Sat Jan 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.13-1
  317. - update to 1.9.2.13 (sync with firefox-3.6.13)
  318. * Thu Oct 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.11-1
  319. - update to 1.9.2.11 (sync with firefox-3.6.11)
  320. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.2.9-2
  321. - rebuild with rpm-4.8.1 for pkg-config file
  322. * Mon Sep 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.9-1
  323. - update to 1.9.2.9 (sync with firefox-3.6.9)
  324. - add patch10 to build with libjpeg-turbo
  325. - build with sqlite-3.7.2
  326. - BR: nspr >= 4.8.6
  327. * Mon Jul 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.8-1
  328. - update tp 1.9.2.8 (sync with firefox-3.6.8)
  329. * Wed Jul 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.7-1
  330. - update tp 1.9.2.7 (sync with firefox-3.6.7)
  331. * Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
  332. - enable ipc only on ix86/x86_64 arches
  333. * Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
  334. - update to 1.9.2.4 (sync with firefox-3.6.4)
  335. - add patch10 to fix build failure
  336. * Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
  337. - update to 1.9.2.3 (sync with firefox-3.6.3)
  338. * Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
  339. - update to 1.9.2.2 (sync with firefox-3.6.2)
  340. - add patch7,9 for fix build failure
  341. * Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
  342. - enable libnotify support
  343. - add ac_add_options --enable-libnotify
  344. - disable Necko wifi monitor
  345. - add ac_add_options --disable-necko-wifi
  346. - remove BR: wireless-tools-devel
  347. - fix %%files devel
  348. - add patch3,5 to fix jemalloc alignment assertion
  349. - add Patch8 to fix mozilla-plugin.pc
  350. * Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
  351. - add BR: libnotify-devel, wireless-tools-devel
  352. * Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
  353. - update to 1.9.2 (sync with firefox-3.6)
  354. - obsoletes xulrunner-devel-unstable
  355. * Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
  356. - use internal sqlite3 on vine5
  357. * Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
  358. - update to 1.9.1.7
  359. * Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
  360. - update to 1.9.1.6
  361. - build with sqlite3-3.6.21
  362. * Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
  363. - update to 1.9.1.5
  364. * Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
  365. - update to 1.9.1.3
  366. * Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
  367. - really update to 1.9.1.2 (<BTS:0748>)
  368. * Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
  369. - update to 1.9.1.2 (sync with firefox-3.5.2)
  370. * Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
  371. - update to 1.9.1.1 (sync with firefox-3.5.1)
  372. - add missing Requires to -devel
  373. - add missing BR
  374. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
  375. - enable-system-cairo
  376. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
  377. - update to 1.9.1 (based on firefox 3.5)
  378. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
  379. - update to 1.9.1rc3 (sync with firefox 3.5rc3)
  380. * Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
  381. - update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
  382. - remove old patches
  383. - require nspr >= 4.8
  384. * Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
  385. - new upstream release
  386. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
  387. - update mozconfig
  388. - disable-system-cairo for stability
  389. * Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
  390. - new upstream release
  391. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
  392. - new upstream release
  393. - add ja locale
  394. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
  395. - new upstream release
  396. * Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
  397. - new upstream release
  398. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
  399. - add Patch3
  400. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
  401. - update to xulrunner 1.9.0.2 byild 6
  402. - build with gnome-2.24
  403. * Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
  404. - new upstream release
  405. * Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
  406. - initial build for Vine Linux
  407. * Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
  408. - Update to 1.9 final
  409. * Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
  410. - Simplify PS/PDF operators
  411. * Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
  412. - Upstream patch to fsync() less
  413. * Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
  414. - Ensure we enable startup notification; add BR and modify config
  415. (bug #445543)
  416. * Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
  417. - Some files moved to mozilla-filesystem; kill them and add the Req
  418. * Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
  419. - Clean up the %%files list and get rid of the executable bit on some files
  420. * Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
  421. - Fix font scaling
  422. * Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
  423. - Enabled phishing protection (#443403)
  424. * Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
  425. - Changed "__ppc64__" to "__powerpc64__",
  426. "__ppc64__" doesn't work anymore
  427. - Added fix for #443725 - Critical hanging bug with fix
  428. available upstream (mozbz#429903)
  429. * Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
  430. - Fixed multilib issues, added starting script instead of a symlink
  431. to binary (#436393)
  432. * Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
  433. - Add upstream patches for dpi, toolbar buttons, and invalid keys
  434. - Re-enable system cairo
  435. * Mon Apr 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
  436. - Spec cleanups
  437. * Wed Apr 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
  438. - Beta 5
  439. * Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
  440. - Beta 5 RC2
  441. * Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
  442. - Update to latest trunk (2008-03-27)
  443. * Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
  444. - Update to latest trunk (2008-03-26)
  445. * Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
  446. - Update to latest trunk (2008-03-25)
  447. * Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
  448. - Update to latest trunk (2008-03-24)
  449. * Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
  450. - Update to latest trunk (2008-03-20)
  451. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
  452. - Update to latest trunk (2008-03-17)
  453. * Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
  454. - Revert to trunk from the 15th to fix crashes on HTTPS sites
  455. * Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
  456. - Update to latest trunk (2008-03-16)
  457. - Add patch to negate a11y slowdown on some pages (#431162)
  458. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
  459. - Update to latest trunk (2008-03-15)
  460. * Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
  461. - Avoid conflicts between gecko debuginfo packages
  462. * Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
  463. - Update to latest trunk (2008-03-12)
  464. * Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
  465. - Update to latest trunk (2008-03-11)
  466. * Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
  467. - Update to latest trunk (2008-03-10)
  468. * Sun Mar 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
  469. - Update to latest trunk (2008-03-09)
  470. * Fri Mar 7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
  471. - Update to latest trunk (2008-03-07)
  472. * Thu Mar 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
  473. - Update to latest trunk (2008-03-06)
  474. * Tue Mar 4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
  475. - Update to latest trunk (2008-03-04)
  476. * Sun Mar 2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
  477. - Update to latest trunk (2008-03-02)
  478. * Sat Mar 1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
  479. - Update to latest trunk (2008-03-01)
  480. * Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
  481. - Update to latest trunk (2008-02-29)
  482. * Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
  483. - Update to latest trunk (2008-02-28)
  484. * Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
  485. - Update to latest trunk (2008-02-27)
  486. * Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
  487. - Update to latest trunk (2008-02-26)
  488. * Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
  489. - Update to latest trunk (2008-02-23)
  490. * Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
  491. - Update to latest trunk (2008-02-22)
  492. * Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
  493. - Update to latest trunk (2008-02-21)
  494. * Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
  495. - Update to latest trunk (2008-02-20)
  496. * Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
  497. - Update to latest trunk (2008-02-17)
  498. * Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
  499. - Update to latest trunk (2008-02-15)
  500. * Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
  501. - Update to latest trunk (2008-02-14)
  502. - Use system hunspell
  503. * Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
  504. - Update to latest trunk (2008-02-11)
  505. * Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
  506. - STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
  507. you know, debuginfo.
  508. * Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
  509. - Update to latest trunk (2008-02-10)
  510. * Sat Feb 9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
  511. - Update to latest trunk (2008-02-09)
  512. * Wed Feb 6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
  513. - Update to latest trunk (2008-02-06)
  514. * Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
  515. - Update to latest trunk (2008-01-30)
  516. * Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
  517. - rebuild agains new nss
  518. - enabled gnome vfs
  519. * Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
  520. - fixed stable pkg-config files (#429654)
  521. - removed sqlite patch
  522. * Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
  523. - Update to latest trunk (2008-01-21)
  524. * Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
  525. - Update to latest trunk (2008-01-15)
  526. - Now with system extensions directory support
  527. * Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
  528. - Update to latest trunk (2008-01-13)
  529. - Use CFLAGS instead of configure arguments
  530. - Random cleanups: BuildRequires, scriptlets, prefs, etc.
  531. * Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
  532. - Provide gecko-devel-unstable as well
  533. * Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
  534. - divided devel package to devel and devel-unstable
  535. * Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
  536. - removed fedora specific pkg-config files
  537. - updated to the latest trunk (2008-01-07)
  538. - removed unnecessary patches
  539. - fixed idl dir (#427965)
  540. * Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
  541. - Re-enable camellia256 support now that NSS supports it
  542. * Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
  543. - updated to the latest trunk (2008-01-03)
  544. * Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
  545. - Don't Provide webclient (xulrunner is not itself a webclient)
  546. - Don't Obsolete old firefox, only firefox-devel
  547. - Kill legacy obsoletes (phoenix, etc) that were never in rawhide
  548. * Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
  549. - added java and plugin subdirs to plugin includes
  550. * Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
  551. - dependency fixes, obsoletes firefox < 3 and firefox-devel now
  552. * Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
  553. - updated to Beta 2.
  554. - moved SDK to xulrunner-sdk
  555. * Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
  556. - fixed mozilla-plugin.pc (#412971)
  557. * Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
  558. - export /etc/gre.d/gre.conf (it's used by python gecko applications)
  559. * Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
  560. - added xulrunner/js include dir to xulrunner-js
  561. * Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
  562. - update to beta 1
  563. * Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
  564. - packed all gecko libraries (#389391)
  565. * Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
  566. - registered xulrunner libs system-wide
  567. - added xulrunner-gtkmozembed.pc
  568. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
  569. - added proper nss/nspr dependencies
  570. * Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
  571. - more build fixes, use system nss libraries
  572. * Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
  573. - build fixes
  574. * Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
  575. - updated to the latest trunk
  576. * Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
  577. - build fixes for ppc/ppc64
  578. * Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
  579. - removed conflicts with the current gecko-based apps
  580. - added updated ppc64 patch
  581. * Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
  582. - build fixes
  583. * Wed Sep 5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
  584. - Initial cut at XULRunner 1.9 Alpha 7
  585. - Temporarily revert camellia 256 support since our nss doesn't support it yet