libghc-build-pandoc-vl.spec 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119
  1. %define pkg_name build-pandoc
  2. %define pkg_version 1.17.0.3
  3. %define pkg_release 1%{?_dist_release}
  4. %define ghc_version 7.10.3
  5. Summary: Haskell libraries: %{pkg_name} and dependent libraries
  6. Name: libghc-%{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: BSD3
  10. Group: Applications/Text
  11. URL: http://hackage.haskell.org
  12. Source0: JuicyPixels-3.2.7.tar.gz
  13. Source1: SHA-1.6.4.2.tar.gz
  14. Source2: blaze-markup-0.7.0.3.tar.gz
  15. Source3: blaze-html-0.8.1.1.tar.gz
  16. Source4: cmark-0.5.2.tar.gz
  17. Source5: digest-0.0.1.2.tar.gz
  18. Source6: extensible-exceptions-0.1.1.4.tar.gz
  19. Source7: haddock-library-1.2.1.tar.gz
  20. Source8: hslua-0.4.1.tar.gz
  21. Source9: pandoc-types-1.16.1.tar.gz
  22. Source10: regex-pcre-builtin-0.94.4.8.8.35.tar.gz
  23. Source11: tagsoup-0.13.9.tar.gz
  24. Source12: temporary-1.2.0.4.tar.gz
  25. Source13: unix-compat-0.4.1.4.tar.gz
  26. Source14: filemanip-0.3.6.3.tar.gz
  27. Source15: utf8-string-1.0.1.1.tar.gz
  28. Source16: highlighting-kate-0.6.2.tar.gz
  29. Source17: xml-1.3.14.tar.gz
  30. Source18: texmath-0.8.6.2.tar.gz
  31. Source19: zip-archive-0.3.0.2.tar.gz
  32. Source100: packages
  33. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  34. BuildRequires: ghc haskell-platform-base cabal-install
  35. BuildRequires: libffi-devel gmp-devel zlib-devel
  36. BuildRequires: libghc-data-default-class
  37. BuildRequires: libghc-dlist
  38. BuildRequires: libghc-data-default
  39. BuildRequires: libghc-aeson
  40. BuildRequires: libghc-http-client-tls
  41. BuildRequires: yaml
  42. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  43. BuildRequires: hscolour
  44. Requires: ghc haskell-platform-base cabal-install
  45. Requires: libghc-data-default-class
  46. Requires: libghc-dlist
  47. Requires: libghc-data-default
  48. Requires: libghc-aeson
  49. Requires: libghc-http-client-tls
  50. Requires: yaml
  51. Vendor: Project Vine
  52. Distribution: Vine Linux
  53. Packager: ara_t
  54. %description
  55. Haskell libraries: %{pkg_name}
  56. %prep
  57. %{__rm} -rf ${RPM_BUILD_ROOT}
  58. %setup -q -T -c %{name}-%{version}
  59. %build
  60. # Initialise the package db
  61. ghc-pkg init %{_builddir}/package.conf
  62. PKG_CONF_DIR=${RPM_BUILD_ROOT}%{_libdir}/ghc-%{ghc_version}/package.conf.d
  63. %{__mkdir_p} ${PKG_CONF_DIR}
  64. cd %{_builddir}
  65. for pkg in `cat %{SOURCE100}`; do
  66. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  67. cd ${pkg}
  68. cabal configure \
  69. --prefix=%{_prefix} \
  70. --libdir=%{_libdir}/ghc-lib/%{name}/${pkg} \
  71. --libsubdir= \
  72. --datadir=%{_datadir}/%{name}/${pkg} \
  73. --datasubdir= \
  74. --docdir=%{_docdir}/%{name}/${pkg}
  75. cabal build
  76. cabal haddock || : # aviod Error
  77. cabal copy --destdir=${RPM_BUILD_ROOT}
  78. cabal register --inplace
  79. cabal register --gen-pkg-config=${PKG_CONF_DIR}/%{pkg_name}_${pkg}.conf
  80. cd ..
  81. done
  82. %clean
  83. %{__rm} -rf ${RPM_BUILD_ROOT}
  84. %post
  85. ghc-pkg recache
  86. %postun
  87. ghc-pkg recache
  88. %files
  89. %defattr(-, root, root)
  90. %{_libdir}/ghc-%{ghc_version}/
  91. %{_libdir}/ghc-lib/
  92. %{_docdir}/%{name}
  93. %changelog
  94. * Fri May 06 2016 Toshiaki Ara <ara_t@384.jp> 1.17.0.3-1
  95. - new package