tix-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283
  1. %define tcl_major 8.4
  2. %define tk_major 8.4
  3. %define thread_major 2.6
  4. %define tix_major 8.4
  5. %define tixversion %{tix_major}.2
  6. Summary: A Tcl/Tk development environment: tix
  7. Summary(ja): Tcl/Tk 開発環境: tix
  8. Name: tix
  9. Version: %{tixversion}
  10. Release: 2%{?_dist_release}
  11. Group: Development/Languages
  12. License: BSD
  13. URL: http://tix.sourceforge.net/
  14. Source0: Tix%{tixversion}-src.tar.gz
  15. Patch20: tix-8.1.4-perf.patch
  16. Patch22: tix-8.2.0b1-dirtree.patch
  17. BuildRequires: tcl >= %{tcl_major}
  18. BuildRequires: tk >= %{tk_major}
  19. BuildRequires: thread >= %{thread_major}
  20. Requires: tcl >= %{tcl_major}
  21. Requires: tk >= %{tk_major}
  22. Requires: thread >= %{thread_major}
  23. Buildroot: %{_tmppath}/%{name}-%{version}-root
  24. %description -n tix
  25. Tix (Tk Interface Extension), an add-on for the Tk widget set, is an
  26. extensive set of over 40 widgets. In general, Tix widgets are more
  27. complex and more capable than the widgets provided in Tk. Tix widgets
  28. include a ComboBox, a Motif-style FileSelectBox, an MS Windows-style
  29. FileSelectBox, a PanedWindow, a NoteBook, a hierarchical list, a
  30. directory tree and a file manager.
  31. Install the tix package if you want to try out more complicated widgets
  32. for Tk. You'll also need to have the tcl and tk packages installed.
  33. %description -n tix -l ja
  34. Tk ウィジェットセットのためのアドオンである、Tix (Tk Interface Extension)
  35. は 40 ウィジェットを超える拡張セットです。Tix ウィジェットの多くが、
  36. Tk から供給されるウィジェットよりも高機能です。Tix ウィジェットは
  37. コンボボックス、Motif スタイルのファイルボックス、MS Windows スタイルの
  38. ファイルボックス、パネルウィンドウ、ノートブック、階層リスト、
  39. ディレクトリツリー、ファイルマネージャを含んでいます。
  40. Tk で、より複雑ななウィジェットを試したい時には、tix パッケージをインストール
  41. してください。tcl と tk のパッケージもインストールする必要があります。
  42. %prep
  43. %setup -q -n Tix%{tixversion}
  44. %patch20 -p1 -b .perf
  45. %patch22 -p1 -b .dirtree
  46. %build
  47. # make the libraries reentrant
  48. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
  49. %configure \
  50. --with-tcl=%{_libdir} \
  51. --with-tk=%{_libdir} \
  52. --enable-shared \
  53. --enable-threads \
  54. make %{?_smp_mflags} all
  55. %install
  56. rm -rf ${RPM_BUILD_ROOT}
  57. %makeinstall
  58. SOFILE=libTix%{version}.so
  59. mv $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE $RPM_BUILD_ROOT%{_libdir}
  60. ln -sf ../$SOFILE $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE
  61. ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix.so
  62. ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix%{tix_major}.so
  63. ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix.so
  64. ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix%{tix_major}.so
  65. install -d $RPM_BUILD_ROOT%{_mandir}/man1
  66. install -d $RPM_BUILD_ROOT%{_mandir}/mann
  67. install -m 644 man/tixwish.1 $RPM_BUILD_ROOT%{_mandir}/man1
  68. install -m 644 man/*.n $RPM_BUILD_ROOT%{_mandir}/mann
  69. install -d $RPM_BUILD_ROOT%{_includedir}
  70. install -m 0644 generic/tix.h $RPM_BUILD_ROOT%{_includedir}/tix.h
  71. ## others
  72. SHAREDDIR=$RPM_BUILD_ROOT%{_datadir}/tix-%{version}
  73. install -d $SHAREDDIR/demos/bitmaps
  74. install -d $SHAREDDIR/demos/samples
  75. install -m 755 demos/widget $SHAREDDIR/demos
  76. install -m 644 demos/{*.tcl,tclIndex} $SHAREDDIR/demos
  77. install -m 644 demos/bitmaps/* $SHAREDDIR/demos/bitmaps
  78. install -m 644 demos/samples/* $SHAREDDIR/demos/samples
  79. cp -a tests $SHAREDDIR
  80. ## * old scripts *
  81. ## find . -type d -name CVS | xargs -r rm -frv
  82. ## echo "%%defattr(-,root,root)" > tix.files
  83. ## (find ${RPM_BUILD_ROOT}%{_bindir} \
  84. ## ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
  85. ## find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
  86. ## | sort | uniq -u >> tix.files
  87. ##
  88. ## set +x +H
  89. ## for n in `cat tix.files`; do
  90. ## test -f $n || continue
  91. ## head -1 $n | grep -q ^#! || continue
  92. ## chmod u+w $n
  93. ## perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
  94. ## done
  95. ## set -x -H
  96. ##
  97. ## #==========================================
  98. ## # post process the *.files list, removing build sys references and mark
  99. ## # which are directories
  100. ## set +x
  101. ## for n in *.files; do
  102. ## mv $n $n.in
  103. ## sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
  104. ## if [ -d ${RPM_BUILD_ROOT}/$file ]; then
  105. ## echo -n '%dir '
  106. ## fi
  107. ## echo $file
  108. ## done > $n
  109. ## rm -f $n.in
  110. ## done
  111. ## set -x
  112. ##
  113. ## # Man pages can be compressed
  114. ## perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
  115. %post -p /sbin/ldconfig -n tix
  116. %postun -p /sbin/ldconfig -n tix
  117. %clean
  118. rm -rf $RPM_BUILD_ROOT
  119. %files -n tix
  120. %defattr(-,root,root,-)
  121. %doc ChangeLog README.txt man/html man/index.html
  122. %{_libdir}/lib*.so
  123. %{_libdir}/Tix%{version}
  124. %{_datadir}/tix-8.4.2
  125. %{_mandir}/man1/tixwish.1.gz
  126. %{_mandir}/mann/*.n.gz
  127. %{_includedir}/*.h
  128. %changelog
  129. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-2
  130. - rebuilt with tcl/tk-8.4.19-2
  131. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
  132. - applied new versioning policy
  133. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
  134. - rebuild with tcl/tk-8.4.18
  135. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
  136. - rebuild with tcl/tk-8.4.16
  137. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl1
  138. - updated tix to 8.4.2
  139. - rebuilt with new toolchain
  140. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl5
  141. - rebuild for tcl/tk-8.4.12, and x86_64 architecture support
  142. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl4
  143. - changed url to http://tix.sourceforge.net/download.shtml
  144. - rebuild for tcl/tk-8.4.11
  145. * Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl3
  146. - rebuild for tcl/tk-8.4.6
  147. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl2
  148. - rebuild for tcl/tk-8.4.5
  149. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl1
  150. - update based on BitWalk's tcltk-8.4.2-83bw
  151. * Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
  152. - splite source package
  153. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  154. - expand some macros.. (FIXME)
  155. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  156. - use %configure macros
  157. - add Patch 47,50
  158. * Thu May 31 2001 <sagami@vinelinux.org>
  159. - 8.0.5_jp-10
  160. - unexpand old %%{configure}, new one causes build failure
  161. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  162. - install manpages into %%{_mandir} and mode 644
  163. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  164. - 8.0.5_jp-9
  165. - modified %install section to handle compressed man pages
  166. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  167. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  168. - changed default fonts
  169. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  170. - added defattr
  171. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  172. - added some symlinks, such as libtcl8.0.so.
  173. - obsoletes version number using _jp, now 8.0.5-31vl1
  174. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  175. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  176. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  177. - fix tclX symlinks.
  178. - compile on systems where SIGPWR == SIGLOST.
  179. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  180. - update tcl/tk to 8.0.5.
  181. - avoid "containing" in Tix (#2332).
  182. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  183. - use /usr/bin/write in kibitz (#1320).
  184. - use cirrus.sprl.umich.edu in weather (#1926).
  185. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  186. - auto rebuild in the new build environment (release 28)
  187. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  188. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  189. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  190. - expect does unaligned access on alpha (#989)
  191. - upgrade tcl/tk/tclX to 8.0.4
  192. - upgrade expect to 5.28.
  193. - add itcl 3.0.1
  194. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  195. - call libtoolize to allow building on the arm
  196. - build for glibc 2.1
  197. - strip binaries
  198. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  199. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  200. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  201. - expect: mkpasswd needs delay before sending password (problem #576)
  202. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  203. - translations modified for de, fr, tr
  204. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  205. - fixed expect binaries exec permissions
  206. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  207. - updated to Tix 4.1.0.006
  208. - updated version numbers of tcl/tk to relflect includsion of p2
  209. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  210. - updated tcl/tk to patch level 2
  211. - updated tclX to 8.0.2
  212. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  213. - fixed filelist for tix... replacing path to the expect binary in scripts
  214. was leaving junk files around.
  215. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  216. - added patch to remove libieee test in configure.in for tcl and tk.
  217. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  218. solution for all systems
  219. - fixed src urls
  220. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  221. - removed version numbers from descriptions
  222. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  223. - updated to tcl/tk 8.0 and related versions of packages
  224. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  225. - built against glibc
  226. - fixed dangling tclx/tkx symlinks