grep-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330
  1. Summary: The GNU versions of grep pattern matching utilities.
  2. Summary(ja): GNU版 grep パターンマッチングユーティリティ
  3. Name: grep
  4. Version: 3.4
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Base
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPLv3+
  10. URL: http://www.gnu.org/software/grep/
  11. Source: https://ftp.gnu.org/pub/gnu/grep/grep-%{version}.tar.xz
  12. Source1: colorgrep.sh
  13. Source2: colorgrep.csh
  14. Source3: GREP_COLORS
  15. # upstream ticket 39444
  16. Patch0: grep-3.33-man-fix-gs.patch
  17. # upstream ticket 39445
  18. Patch1: grep-3.33-help-align.patch
  19. Buildroot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: pcre-devel >= 8.31
  21. BuildRequires: texinfo, gettext, gzip
  22. BuildRequires: autoconf, automake
  23. Requires(post): install-info
  24. Requires(preun): install-info
  25. %description
  26. The GNU versions of commonly used grep utilities. Grep searches
  27. through textual input for lines which contain a match to a specified
  28. pattern and then prints the matching lines. GNU's grep utilities
  29. include grep, egrep and fgrep.
  30. You should install grep on your system, because it is a very useful
  31. utility for searching through text.
  32. %description -l ja
  33. 一般に使われるgrepユーティリティのGNU版です。Grep は指定したパターンと一致
  34. する行を入力ファイルから捜し出して、その行を表示します。GNUのgrepユーティリ
  35. ティにはgrep, egrep, fgrepが入っています。
  36. テキストファイルの検索や、システム管理にとても役に立つので、是非インストール
  37. してください。
  38. %prep
  39. %setup -q
  40. %patch0 -p1 -b .man-fix-gs
  41. %patch1 -p1 -b .help-align
  42. %build
  43. %configure \
  44. --without-included-regex
  45. %__make %{?_smp_mflags}
  46. %install
  47. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  48. %__make DESTDIR=$RPM_BUILD_ROOT install
  49. gzip $RPM_BUILD_ROOT%{_infodir}/grep*
  50. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  51. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  52. install -pm 644 %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  53. install -pm 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
  54. mkdir -p $RPM_BUILD_ROOT/bin
  55. mv $RPM_BUILD_ROOT%{_prefix}/bin/* $RPM_BUILD_ROOT/bin/
  56. rm -rf $RPM_BUILD_ROOT%{_bindir}
  57. %find_lang %{name}
  58. %check
  59. make check
  60. %clean
  61. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  62. %post
  63. [ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/grep.info.gz || :
  64. %preun
  65. if [ $1 = 0 ]; then
  66. [ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/grep.info.gz
  67. fi
  68. %files -f %{name}.lang
  69. %defattr(-,root,root)
  70. %license COPYING
  71. %doc AUTHORS THANKS TODO NEWS README ChangeLog
  72. /bin/*
  73. %config(noreplace) %{_sysconfdir}/profile.d/colorgrep.*sh
  74. %config(noreplace) %{_sysconfdir}/GREP_COLORS
  75. %{_infodir}/*.info.gz
  76. %{_mandir}/*/*
  77. %changelog
  78. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4-1
  79. - new upstream release.
  80. - updated patches.
  81. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22-1
  82. - updated to 2.22
  83. * Mon Dec 22 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.21-1
  84. - updated to 2.21
  85. - dropt patch2 which was merged into upstream
  86. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14-1
  87. - update to 2.14
  88. - build with pcre-8.31
  89. * Thu Feb 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  90. - new upstream release
  91. - drop unneeded old patches
  92. - add BR: pcre-devel
  93. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-60
  94. - rebuilt against current toolchain
  95. - fix license tag
  96. - use CPPFLAGS= argument to configure to add an -I option.
  97. - Do not set LDFLAGS=-s for "make install".
  98. * Wed Sep 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-57
  99. - rebuilt for VineSeed (previous version in VineSeed was 2.5.1-50 somehow)
  100. - Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.1-50vl5
  101. - applied new versioning policy, spec in utf-8
  102. * Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl0.1
  103. - rebuild for Vine Linux 4.x
  104. * Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl1
  105. - add Patch100 to fix infinite loop with 'grep -F'
  106. thanks to M.H (<BTS:484>)
  107. - based on Fedora devel 2.5.1-57
  108. * Mon Jan 22 2007 Tim Waugh <twaugh@redhat.com> 2.5.1-57
  109. - Make preun scriptlet unconditionally succeed (bug #223697).
  110. * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-56
  111. - Fixed count of patterns when the last is an empty string (bug #204255).
  112. * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-55
  113. - Fix 'memory exhausted' errors by limiting in-memory buffer (bug #198165).
  114. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-54.1
  115. - rebuild
  116. * Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-54
  117. - Applied upstream patch to fix '-D skip' (bug #189580).
  118. * Mon Feb 20 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-53
  119. - Applied Tim Robbins' patch for 'grep -w' (bug #179698).
  120. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.2
  121. - bump again for double-long bug on ppc(64)
  122. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.1
  123. - rebuilt for new gcc4.1 snapshot and glibc changes
  124. * Fri Feb 3 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-52
  125. - Prevent 'grep -P' from segfaulting (bug #171379).
  126. * Sat Oct 7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl2
  127. - changed Group to System Environment/Base
  128. * Tue Aug 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl1
  129. - based on Fedora development 2.5.1-50
  130. * Tue Jun 28 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-50
  131. - Futher fixing for bug #161700.
  132. * Mon Jun 27 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-49
  133. - Fix 'grep -Fw' for encodings other than UTF-8 (bug #161700).
  134. * Wed Apr 13 2005 Tim Waugh <twaugh@redhat.com>
  135. - Build requires recent pcre-devel (bug #154626).
  136. * Fri Jan 7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-47
  137. - Run 'make check'.
  138. - Fixed -w handling for EGexecute. Now 'make check' passes.
  139. - Cache MB_CUR_MAX value in egf-speedup patch.
  140. - Fixed variable shadowing in egf-speedup patch.
  141. - Removed redundant (and incorrect) code in prline.
  142. * Fri Jan 7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-46
  143. - More -w tests from Jakub Jelinek.
  144. - Rebased on 2.5.1a.
  145. * Fri Dec 31 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-45
  146. - More tests (Jakub Jelinek).
  147. - Jakub Jelinek's much improved -Fi algorithm.
  148. - Removed bogus part of grep-2.5.1-fgrep patch.
  149. * Tue Dec 21 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-44
  150. - Fixed -Fi for multibyte input (bug #143079).
  151. * Thu Dec 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-43
  152. - Bypass kwset matching when ignoring case and processing multibyte input
  153. (bug #143079).
  154. * Tue Dec 14 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-42
  155. - Further UTF-8 processing avoided since a '\n' byte is always an
  156. end-of-line character in that encoding.
  157. * Fri Dec 3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-41
  158. - Fixed a busy loop in the egf-speedup patch (bug #140781).
  159. * Thu Nov 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-40
  160. - Fixed a bug in the fgrep patch, exposed by the dfa-optional patch
  161. (bug #138558).
  162. * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-39
  163. - Fixed last patch.
  164. * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-38
  165. - Applied patch from Karsten Hopp to fix background colour problems with
  166. --color output (bug #138913).
  167. * Wed Nov 10 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-37
  168. - Prevent false matches when DFA is disabled (bug #138558).
  169. * Mon Nov 8 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-36
  170. - Automatically disable DFA when processing multibyte input. GREP_USE_DFA
  171. environment variable overrides.
  172. * Fri Nov 5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-35
  173. - Fixes to egf-speedup patch: now it does not change any functionality,
  174. as intended.
  175. - GREP_NO_DFA now turns off the DFA engine, for performance testing.
  176. * Thu Nov 4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-34
  177. - More improvements to egf-speedup patch (bug #138076).
  178. * Thu Nov 4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-33
  179. - Small improvements to egf-speedup patch.
  180. * Wed Nov 3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-32
  181. - Remove mb-caching hack.
  182. - Better multibyte handling in EGexecute() and Fexecute().
  183. - Don't need regex.c changes in grep-2.5-i18n.patch.
  184. * Wed Oct 13 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-31
  185. - Make 'grep -F' avoid UTF-8 processing if the pattern contains no
  186. multibyte characters (bug #133932).
  187. * Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-30
  188. - Applied patch from Robert Scheck to tidy spec file and add a URL
  189. tag (bug #135185).
  190. * Sun Sep 5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-29vl1
  191. - based on Fedora development 2.5.1-29
  192. * Fri Jun 4 2004 Tim Waugh <twaugh@redhat.com>
  193. - More build requirements (bug #125323).
  194. * Tue May 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-27
  195. - Fix dfa multibyte character class matching when -i is used (bug #123363).
  196. - Use bracket patch before i18n patch to make it clear that the bug exists
  197. upstream.
  198. * Thu Feb 26 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-26
  199. - Fix fgrep (bug #116909).
  200. * Mon Jan 5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-24
  201. - Work around glibc bug #112869 (segfault in re_compile_pattern).
  202. - Avoid patching Makefile.am, to avoid automake/autoconf weirdness.
  203. * Wed Dec 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-23
  204. - Another multibyte efficiency bug-fix (bug #111800).
  205. * Mon Dec 8 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-22
  206. - Fixed [:alpha:]-type character classes (bug #108484).
  207. - Fixed -o -i properly (bug #111489).
  208. * Sat Dec 6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-21
  209. - Fixed 'fgrep -i' (bug #111614).
  210. * Fri Nov 21 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-20
  211. - Another two multibyte efficiency bug-fixes (bug #110524).
  212. * Thu Nov 6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-19
  213. - Fixed a multibyte efficiency bug.
  214. * Thu Nov 6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-18
  215. - Turn on multibyte efficiency patch again to shake out bugs.
  216. * Wed Oct 8 2003 Tim Waugh <twaugh@redhat.com>
  217. - Fixed man page bug (bug #106267).
  218. * Thu Sep 18 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-17
  219. - Use symlinks for egrep/fgrep, rather than shell script wrappers.
  220. * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com>
  221. - Fix debuginfo package.
  222. * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-16
  223. - Finally give up on making grep go fast. :-(
  224. * Thu Jun 26 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-15
  225. - Fixed grep -i bug introduced by cache.
  226. * Mon Jun 23 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-14
  227. - Redo the gofast patch (bug #97785).
  228. * Thu Jun 12 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-13
  229. - Fixed a bug in the gofast patch (bug #97266).
  230. * Tue Jun 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-12
  231. - Go faster (bug #69900).
  232. - Fix man page.
  233. * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-10
  234. - Use system regex again.
  235. * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-9
  236. - Fixed bug in go-fast patch.
  237. * Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-8
  238. - Go fast (bug #69900).
  239. - Run test suite.
  240. - rebuild with new toolchains
  241. - build with --disable-prel-regexp option
  242. * Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-7vl3
  243. - based on Rawhide 2.5.1-7
  244. - Don't install /usr/share/info/dir.
  245. - Fix -o -i (bug #72641).
  246. - i18n patch.
  247. * Sat Jul 6 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
  248. - 2.5-0vl1
  249. - update to 2.5
  250. - change i18n patch
  251. * Sun Jan 20 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
  252. - 2.5-0vl1
  253. - update to 2.5
  254. - change i18n patch
  255. * Sat Jan 20 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  256. - 2.4.2-4vl1
  257. - usr better macros (%%configure/%%makeinstall)
  258. * Mon Jun 19 2000 Jun Nishii <jun@vinelinux.org>
  259. - 2.4-3vl1
  260. - merge ja patch
  261. * Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  262. - gzip info pages (Bug #9035)
  263. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  264. - fix description
  265. * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
  266. - update to 2.4.
  267. * Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
  268. - prereq install-info
  269. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  270. - auto rebuild in the new build environment (release 2)
  271. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  272. - upgraded to grep 2.3, added install-info %post/%preun for info
  273. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  274. - Injected new description and group.
  275. * Sat May 09 1998 Prospector System <bugs@redhat.com>
  276. - translations modified for de, fr, tr
  277. * Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
  278. - updated to 2.2
  279. * Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
  280. - updated from 2.0 to 2.1
  281. - spec file cleanups
  282. - added BuildRoot
  283. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  284. - built against glibc