gdb-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386
  1. Summary: A GNU source-level debugger for C, C++ and other languages.
  2. Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
  3. Name: gdb
  4. Version: 7.0.1
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: Development/Debuggers
  8. Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.bz2
  9. Buildroot: %{_tmppath}/%{name}-%{version}-root
  10. URL: http://sources.redhat.com/gdb/
  11. BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
  12. Requires: install-info
  13. #Prereq: /sbin/install-info
  14. %description
  15. GDB, the GNU debugger, allows you to debug programs written in C, C++,
  16. and other languages, by executing them in a controlled fashion and
  17. printing their data.
  18. %description -l ja
  19. GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
  20. 使うツールです.プログラムの実行を制御し,データを出力することができます.
  21. %prep
  22. %setup -q
  23. %build
  24. export CFLAGS="$RPM_OPT_FLAGS"
  25. rm -fr dejagnu tcl expect
  26. ./configure \
  27. --prefix=%{_prefix} \
  28. --sysconfdir=%{_sysconfdir} \
  29. --mandir=%{_mandir} \
  30. --infodir=%{_infodir} \
  31. %{_target_platform}
  32. make
  33. make info
  34. cp gdb/NEWS .
  35. %install
  36. rm -rf $RPM_BUILD_ROOT
  37. %makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
  38. # install the gcore script in /usr/bin
  39. install -m755 $RPM_BUILD_DIR/gdb-%{version}/gdb/gdb_gcore.sh $RPM_BUILD_ROOT%{_bindir}/gcore
  40. # The above is broken, do this for now:
  41. #mkdir -p $RPM_BUILD_ROOT/%{_infodir}
  42. #cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
  43. # These are part of binutils
  44. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  45. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
  46. rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
  47. rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
  48. rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
  49. rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,iberty*,opcodes*}
  50. rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
  51. rm -rf $RPM_BUILD_ROOT%{_includedir}
  52. %clean
  53. rm -rf $RPM_BUILD_ROOT
  54. %post
  55. [ -f %{_infodir}/annotate.info ] && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
  56. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  57. [ -f %{_infodir}/gdb.info ] && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
  58. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  59. [ -f %{_infodir}/gdbint.info ] && /sbin/install-info %{_infodir}/gdbint.info %{_infodir}/dir || :
  60. [ -f %{_infodir}/gdbint.info.gz ] && /sbin/install-info %{_infodir}/gdbint.info.gz %{_infodir}/dir || :
  61. [ -f %{_infodir}/stabs.info ] && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir || :
  62. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  63. %preun
  64. if [ $1 = 0 ]; then
  65. [ -f %{_infodir}/annotate.info ] && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir || :
  66. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  67. [ -f %{_infodir}/gdb.info ] && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir || :
  68. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  69. [ -f %{_infodir}/gdbint.info ] && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir || :
  70. [ -f %{_infodir}/gdbint.info.gz ] && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir || :
  71. [ -f %{_infodir}/stabs.info ] && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir || :
  72. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  73. fi
  74. %files
  75. %defattr(-,root,root)
  76. %doc COPYING COPYING.LIB README NEWS
  77. %{_bindir}/*
  78. %{_mandir}/*/*
  79. %{_datadir}/gdb/syscalls
  80. %{_infodir}/annotate.info*
  81. %{_infodir}/gdb.info*
  82. %{_infodir}/gdbint.info*
  83. %{_infodir}/stabs.info*
  84. %exclude %{_infodir}/dir
  85. ## don't include the files in include, they are part of binutils
  86. #%{_includedir}/*
  87. #%{_infodir}/bfd.info*
  88. #%{_infodir}/configure.info*
  89. #%{_infodir}/standard.info*
  90. #%{_libdir}/*
  91. #%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
  92. #%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
  93. %changelog
  94. * Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
  95. - updated gdb to 7.0.1
  96. - rebuilt with new environment
  97. * Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
  98. - applied new versioning policy, spec in utf-8
  99. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
  100. - rebuild with expat-2.0.1
  101. - add BuildRequires: expat-devel
  102. * Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
  103. - dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
  104. * Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
  105. - dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
  106. * Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
  107. - new upstream release
  108. * Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
  109. - new upstream release
  110. * Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
  111. - new upstream release
  112. * Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
  113. - Oops, spec was written in Shift-JIS. Fixed.
  114. * Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
  115. - based on 5.2.1-4 from Rawhide and built for Vine Linux
  116. * Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  117. - added mainframe patch from developerworks
  118. * Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
  119. - Add changelogs to the previous patch
  120. * Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
  121. - Add some patches from Elena Zannoni <ezannoni@redhat.com>
  122. * Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
  123. - 5.2.1
  124. * Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  125. - compile on mainframe
  126. * Mon Jul 8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
  127. - Rebuild
  128. * Tue May 7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
  129. - Rebuild
  130. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
  131. - 5.2
  132. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
  133. - 5.1.92. Hopefully identical to 5.2 final
  134. * Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
  135. - 5.1.91. 5.2 expected in a week
  136. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
  137. - Update to current
  138. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
  139. - Update to current
  140. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
  141. - Update to current
  142. * Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
  143. - Update to current
  144. * Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
  145. - Update to current 5.2 branch
  146. * Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
  147. - 5.1.1
  148. - add URL
  149. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  150. - automated rebuild
  151. * Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
  152. - Fix some thread+fpu problems
  153. * Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
  154. - 5.1
  155. * Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
  156. - 5.0.94. Almost there....
  157. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
  158. - Add patch from jakub@redhat.com to improve handling of DWARF
  159. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
  160. - 5.0.93
  161. - handle missing info pages in post/pre scripts
  162. * Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
  163. - 5.0.92
  164. * Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
  165. - New snapshot
  166. - Use the 5.0.91 versioning from the snapshot
  167. * Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
  168. - New snapshot
  169. * Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
  170. - New snapshot
  171. * Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
  172. - New snapshot
  173. * Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
  174. - Don't buildrequire compat-glibc (#51690)
  175. * Thu Aug 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  176. - New snapshot, from the stable branch eventually leading to gdb 5.1
  177. * Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
  178. - s/Copyright/License/
  179. - Add texinfo to BuildRequires
  180. * Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
  181. - New snapshot
  182. * Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
  183. - New snapshot
  184. - Add ncurses-devel to buildprereq
  185. - Remove perl from buildprereq, as gdb changed the way
  186. version strings are generated
  187. * Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
  188. - New snapshot
  189. * Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  190. - New snapshot - this had thread fixes for curing #39070
  191. - New way of specifying version
  192. * Tue May 1 2001 Trond Eivind Glomsr <teg@redhat.com>
  193. - New tarball
  194. - Kevin's patch is now part of gdb
  195. * Mon Apr 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  196. - Add patch from kevinb@redhat.com to fix floating point + thread
  197. problem (#24310)
  198. - remove old workarounds
  199. - new snapshot
  200. * Thu Apr 5 2001 Trond Eivind Glomsr <teg@redhat.com>
  201. - New snapshot
  202. * Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
  203. - on ia64, there are no old headers :)
  204. * Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  205. - build with old headers, new compiler
  206. * Wed Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  207. - new snapshot
  208. * Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
  209. - new snapshot which should fix some more IA64 problems (#29151)
  210. - remove IA64 patch, it's now integrated
  211. * Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
  212. - add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
  213. - use perl instead of patch for fixing the version string
  214. * Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
  215. - don't use kgcc anymore
  216. - mark it as our own version
  217. - new snapshot
  218. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  219. - Link with ncurses 5.x even though we're using kgcc.
  220. No need to drag in requirements on ncurses4 (Bug #24445)
  221. * Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
  222. - new snapshot
  223. * Thu Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  224. - new snapshot
  225. * Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
  226. - new snapshot
  227. - new alpha patch - it now compiles everywhere. Finally.
  228. * Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
  229. - new snapshot
  230. * Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  231. - new CVS snapshot
  232. - disable the patches
  233. - don't use %%configure, as it confuses the autoconf script
  234. - enable SPARC, disable Alpha
  235. * Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
  236. - added patch from GDB team for C++ symbol handling
  237. * Mon Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
  238. - upgrade to CVS snapshot
  239. - excludearch SPARC, build on IA61
  240. * Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
  241. - rebuild
  242. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  243. - automatic rebuild
  244. * Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
  245. - rebuild
  246. * Fri Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
  247. - use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
  248. and %%{_tmppath}
  249. - the install scripts for info are broken(they don't care about
  250. you specify in the installstep), work around that.
  251. - don't build for IA64
  252. * Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
  253. - upgraded to 5.0 - dump all patches. Reapply later if needed.
  254. - added the NEWS file to the %%doc files
  255. - don't delete files which doesn't get installed (readline, texinfo)
  256. - let build system handle stripping and gzipping
  257. - don't delete libmmalloc
  258. - apply patch from jakub@redhat.com to make it build on SPARC
  259. * Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
  260. - rebuilt against new ncurses
  261. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  262. - rebuild for sparc baud rates > 38400.
  263. * Tue Feb 8 2000 Jakub Jelinek <jakub@redhat.com>
  264. - fix core file handling on i386 with glibc 2.1.3 headers
  265. * Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
  266. - fix reading registers from core on sparc.
  267. - hack around build problems on i386 with glibc 2.1.3 headers
  268. * Thu Oct 7 1999 Jim Kingdon
  269. - List files to install in /usr/info specifically (so we don't pick up
  270. things like info.info from GDB snapshots).
  271. * Thu Oct 7 1999 Jim Kingdon
  272. - Update GDB to 19991004 snapshot. This eliminates the need for the
  273. sigtramp, sparc, xref, and threads patches. Update sparcmin patch.
  274. * Mon Aug 23 1999 Jim Kingdon
  275. - Omit readline manpage.
  276. * Tue Aug 7 1999 Jim Kingdon
  277. - Remove H.J. Lu's patches (they had been commented out).
  278. - Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
  279. from code fusion CD-ROM).
  280. * Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
  281. - merge H.J. Lu's patches into 4.18.
  282. * Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
  283. - updated the kern22 patch with stuff from davem
  284. * Thu Apr 1 1999 Jeff Johnson <jbj@redhat.com>
  285. - sparc with 2.2 kernels no longer uses sunos ptrace (davem)
  286. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  287. - auto rebuild in the new build environment (release 3)
  288. * Mon Mar 8 1999 Jeff Johnson <jbj@redhat.com>
  289. - Sparc fiddles for Red Hat 6.0.