gd-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A graphics library for drawing .png files.
  3. Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
  4. Name: gd
  5. Version: 2.0.35
  6. Release: 6%{_dist_release}
  7. Source0: http://www.libgd.org/releases/gd-%{version}.tar.bz2
  8. Patch1: gd-2.0.35-overflow.patch
  9. Patch2: gd-2.0.35-CVE-2009-3546.diff
  10. License: BSD-style
  11. URL: http://www.libgd.org/
  12. Group: System Environment/Libraries
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: libjpeg-devel zlib-devel freetype2-devel
  15. BuildRequires: libpng-devel >= 2:1.2.5
  16. BuildRequires: libX11-devel libXpm-devel
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. %description
  20. Gd is a graphics library for drawing .png files. Gd allows your code to
  21. quickly draw images (lines, arcs, text, multiple colors, cutting and
  22. pasting from other images, flood fills) and write out the result as a
  23. .png file. Gd is particularly useful in web applications, where .pngs
  24. are commonly used as inline images. Note, however, that gd is not a
  25. paint program.
  26. Install gd if you are developing applications which need to draw .png
  27. files. If you install gd, you'll also need to install the gd-devel
  28. package.
  29. %description -l ja
  30. GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
  31. 画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
  32. 簡単に描写して、PNGファイルへ結果を出力することができます。
  33. Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
  34. 便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
  35. ん。
  36. PNGファイルを描写する必要のあるアプリケーションを開発する場合、
  37. Gdをインストールしてください。gdをインストールした場合、gd-devel
  38. パッケージも必要になります。
  39. %package progs
  40. Summary: Utility programs that use libgd.
  41. Summary(ja): libgd を用いたユーティリティプログラム
  42. Group: Applications/Graphics
  43. Requires: gd = %{version}, perl
  44. %description progs
  45. These are utility programs supplied with gd, the .png graphics library.
  46. If you install these, you must install gd.
  47. %description progs -l ja
  48. これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
  49. プログラムです。これをインストールするには, gdをインストールする必要
  50. があります。
  51. %package devel
  52. Requires: gd = %{version}
  53. Summary: The development libraries and header files for gd.
  54. Summary(ja): gd用の開発ライブラリとヘッダファイル
  55. Group: Development/Libraries
  56. %description devel
  57. These are the development libraries and header files for gd, the .png
  58. graphics library.
  59. If you're installing the gd graphics library, you must install gd-devel.
  60. %description devel -l ja
  61. これらは開発ライブラリです。
  62. PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
  63. です。
  64. gdをインストールした場合、gd-develパッケージも必要になります。
  65. ## to build compat32 for x86_64 architecture support
  66. %package -n compat32-%{name}
  67. Summary: A graphics library for drawing .png files.
  68. Group: System Environment/Libraries
  69. %description -n compat32-%{name}
  70. Gd is a graphics library for drawing .png files. Gd allows your code to
  71. quickly draw images (lines, arcs, text, multiple colors, cutting and
  72. pasting from other images, flood fills) and write out the result as a
  73. .png file. Gd is particularly useful in web applications, where .pngs
  74. are commonly used as inline images. Note, however, that gd is not a
  75. paint program.
  76. Install gd if you are developing applications which need to draw .png
  77. files. If you install gd, you'll also need to install the gd-devel
  78. package.
  79. %package -n compat32-%{name}-devel
  80. Summary: The development libraries and header files for gd.
  81. Group: Development/Libraries
  82. %description -n compat32-%{name}-devel
  83. These are the development libraries and header files for gd, the .png
  84. graphics library.
  85. If you're installing the gd graphics library, you must install gd-devel.
  86. %prep
  87. %setup -q
  88. %patch1 -p1 -b .overflow
  89. %patch2 -p0 -b .CVE-2009-3546
  90. %build
  91. # %if %{build_compat32}
  92. # export CC='gcc -m32'
  93. # %configure CPPFLAGS="-DJISX0208"
  94. # make %{?_smp_mflags} LDFLAGS='-L/usr/lib -Wl,-rpath,/usr/lib -L/usr/X11R6/lib'
  95. # %else
  96. %configure CPPFLAGS="-DJISX0208"
  97. make %{?_smp_mflags}
  98. # %endif
  99. %install
  100. [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
  101. make DESTDIR=$RPM_BUILD_ROOT install
  102. ## remove unuse files
  103. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  104. %clean
  105. [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
  106. %post -p /sbin/ldconfig
  107. %postun -p /sbin/ldconfig
  108. %if %{build_compat32}
  109. %post -n compat32-%{name} -p /sbin/ldconfig
  110. %postun -n compat32-%{name} -p /sbin/ldconfig
  111. %endif
  112. # %if !%{build_compat32}
  113. %files
  114. %defattr(-,root,root)
  115. %doc COPYING README*
  116. %{_libdir}/*.so.*
  117. %files progs
  118. %defattr(-,root,root)
  119. %{_bindir}/*
  120. %files devel
  121. %defattr(-,root,root)
  122. %{_includedir}/*
  123. %{_libdir}/*.so
  124. %{_libdir}/*.a
  125. #%{_libdir}/*.la
  126. # %endif
  127. %if %{build_compat32}
  128. %files -n compat32-%{name}
  129. %defattr(-,root,root)
  130. %{_libdir}/*.so.*
  131. %files -n compat32-%{name}-devel
  132. %defattr(-,root,root)
  133. %{_libdir}/*.so
  134. %{_libdir}/*.a
  135. #%{_libdir}/*.la
  136. %endif
  137. %changelog
  138. * Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
  139. - build on current VineSeed
  140. * Tue Nov 3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
  141. - fix build_compat32 if-endif sections
  142. * Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
  143. - add patch2 for fix CVE-2009-3546 (_gdGetColors())
  144. * Wed Apr 8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
  145. - updated URL
  146. - changed progs Group to Applications/Graphics
  147. - added %%postun section
  148. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
  149. - removed *.la
  150. - spec in utf-8
  151. * Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
  152. - add patch1 from centos5
  153. - new versioning policy
  154. * Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
  155. - new upstream release with security fix (CVE-2007-2756)
  156. * Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
  157. - new upstream release with security fix
  158. - change source tarball format gz -> bz2
  159. * Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
  160. - added compat32-* packages for x86_64 architecture support
  161. * Sat Nov 6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
  162. - source upgrade
  163. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
  164. - source update
  165. - added -DJISX0208 flag
  166. * Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
  167. - source upgrade
  168. - BuildPrereq: XOrg-devel instead of XFree86-devel
  169. * Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
  170. - source upgrade
  171. - remove patch0 (no need for freetype2-2.1.7)
  172. * Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
  173. - add patch0 to build against freetype2-2.1.7
  174. * Sat Jun 7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
  175. - source upgrade
  176. - add URL
  177. - remove all patches
  178. - use %%configure script
  179. - add BuildPrereq: freetype2-devel XFree86-devel
  180. - remove BuildPrereq: VFlib-devel
  181. - update %%files
  182. - update Requires:
  183. - use License tag instead of Copyright
  184. * Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
  185. - rebuild with libpng-devel-1.2.5-0vl1
  186. * Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
  187. - rebuild with new toolchain
  188. * Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  189. - 1.8.3-0vl2
  190. - symlink to libgd.so.1 (for backward compatibility)
  191. * Mon Jun 6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  192. - first gd 1.8.x release for Vine from rawhide.
  193. - enable freetype support and defined JISX208 macro.
  194. * Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
  195. - break out a -progs subpackage
  196. - disable freetype support
  197. * Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  198. - update to latest version (1.8.2)
  199. - disable xpm support
  200. * Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
  201. - auto rebuild in the new build environment (release 6)
  202. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  203. - auto rebuild in the new build environment (release 5)
  204. * Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
  205. - buiuld for glibc 2.1
  206. * Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
  207. - built for 5.2