dbus-python-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  3. %define dbus_glib_version 0.70
  4. %define dbus_version 0.90
  5. %define pkg_release 4%{?_dist_release}
  6. Summary: D-Bus Python Bindings
  7. Summary(ja): D-Bus Python バインディング
  8. Name: dbus-python
  9. Version: 0.83.0
  10. Release: %{pkg_release}
  11. Source0: http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
  12. Patch0: dbus-python-0.83.0-memleak.patch
  13. License: MIT
  14. Group: System Environment/Libraries
  15. URL: http://www.freedesktop.org/software/dbus/
  16. BuildRequires: dbus-devel >= %{dbus_version}
  17. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  18. BuildRequires: python-devel
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. %description
  21. D-Bus python bindings for use with python programs.
  22. %description -l ja
  23. D-Bus を python プログラムから使う為のバインディングです。
  24. %package devel
  25. Summary: Libraries and headers for dbus-python
  26. Summary(ja): dbus-python のライブラリ及びヘッダファイル
  27. Group: Development/Libraries
  28. Requires: %name = %{version}-%{release}
  29. %description devel
  30. Headers and static libraries for hooking up custom mainloops to the dbus python
  31. bindings.
  32. %description devel -l ja
  33. dbus-python バインディング用のカスタム・メインループをフックする為の
  34. ヘッダファイルとスタティック・ライブラリです。
  35. %prep
  36. %setup -q
  37. %patch0 -p0 -b .memleak
  38. %build
  39. %configure
  40. %{__make} %{?_smp_mflags}
  41. %install
  42. %{__rm} -rf ${RPM_BUILD_ROOT}
  43. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  44. # remove unnecessary *.la files
  45. find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} \;
  46. %clean
  47. rm -rf ${RPM_BUILD_ROOT}
  48. %files
  49. %defattr(-,root,root)
  50. %doc COPYING ChangeLog README NEWS TODO
  51. %doc doc/API_CHANGES.txt doc/HACKING.txt doc/tutorial.txt
  52. %exclude %{_datadir}/doc/dbus-python
  53. %dir %{python_sitelib}/dbus
  54. %dir %{python_sitelib}/dbus/mainloop
  55. %{python_sitearch}/*.so
  56. %{python_sitelib}/*.py*
  57. %{python_sitelib}/dbus/*.py*
  58. %{python_sitelib}/dbus/mainloop/*.py*
  59. %files devel
  60. %defattr(-,root,root)
  61. %{_includedir}/dbus-1.0/dbus/dbus-python.h
  62. %{_libdir}/pkgconfig/dbus-python.pc
  63. %changelog
  64. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.83.0-4
  65. - rebuilt with gcc-4.4.3-3 on ppc
  66. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.83.0-3
  67. - rebuilt with rpm-4.8.0-3 (on ppc)
  68. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.83.0-2
  69. - rebuild with python-2.6
  70. * Sat Dec 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.83.0-1
  71. - initital build for Vine Linux based on fedora package
  72. * Tue Sep 16 2008 Marco Pesenti Gritti - 0.83.0-3
  73. - Add patch for https://bugs.freedesktop.org/show_bug.cgi?id=17551
  74. * Tue Aug 05 2008 Huang Peng <phuang@redhat.com> - 0.83.0-2
  75. - Update to 0.83.0.
  76. * Wed Jul 16 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.82.4-3
  77. - fix license tag
  78. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.82.4-2
  79. - Autorebuild for GCC 4.3
  80. * Sun Jan 20 2008 Matthias Clasen <mclasen@redhat.com> - 0.82.4-1
  81. - Update to 0.82.4
  82. * Mon Oct 22 2007 Matthias Clasen <mclasen@redhat.com> - 0.82.0-3
  83. - Rebuild against new dbus-glib
  84. * Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.82.0-2
  85. - Rebuild for selinux ppc32 issue.
  86. * Fri Jun 22 2007 Matthias Clasen <mclasen@redhat.com> - 0.82.0-1
  87. - Update to 0.82.0
  88. - Put all docs in the usual place
  89. * Tue Apr 03 2007 David Zeuthen <davidz@redhat.com> - 0.80.2-3
  90. - Rebuild
  91. * Tue Apr 03 2007 David Zeuthen <davidz@redhat.com> - 0.80.2-2
  92. - Don't examine args for functions declared METH_NOARGS (#235017)
  93. * Tue Feb 13 2007 John (J5) Palmieri <johnp@redhat.com> - 0.80.2-1
  94. - upgrade to 0.80.2 which fixes some memleaks
  95. * Wed Jan 24 2007 John (J5) Palmieri <johnp@redhat.com> - 0.80.1-1
  96. - upgrade to 0.80.1
  97. - remove dependency on Pyrex and libxml2
  98. - some API breakage,
  99. please see http://dbus.freedesktop.org/doc/dbus-python/NEWS.html
  100. for notes on changes
  101. * Wed Jan 3 2007 David Zeuthen <davidz@redhat.com> - 0.70-9%{?dist}
  102. - rebuild against new Pyrex
  103. * Wed Dec 6 2006 Jeremy Katz <katzj@redhat.com> - 0.70-8
  104. - rebuild against python 2.5
  105. * Tue Nov 7 2006 Matthias Clasen <mclasen@redhat.com> - 0.70-7
  106. - Fix a typo in the spec file
  107. * Fri Aug 18 2006 Karsten Hopp <karsten@redhat.com> - 0.70-6
  108. - require libxml2-python for site-packages/dbus/introspect_parser.py
  109. * Thu Jul 20 2006 Jesse Keating <jkeating@redhat.com> - 0.70-5
  110. - Remove unnecessary obsoletes
  111. * Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-4
  112. - Try python_sitearch this time
  113. * Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-3
  114. - Add a BR on dbus-devel
  115. * Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-2
  116. - Spec file cleanups
  117. - Add PKG_CONFIG_PATH
  118. * Mon Jul 17 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-1
  119. - Initial package import