MAKEDEV-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208
  1. Summary: A script for creating the device files in /dev.
  2. Summary(ja): /dev 以下のデバイスファイルを作成するスクリプト
  3. Name: MAKEDEV
  4. Version: 3.24
  5. Release: 2%{?_dist_release}
  6. License: GPLv2
  7. Group: System Environment/Base
  8. URL: http://www.lanana.org/docs/device-list/
  9. Source: MAKEDEV-%{version}-1.tar.gz
  10. Source10: fedora-changelog
  11. Patch10: MAKEDEV-3.24-vine.patch
  12. BuildRoot: %{_tmppath}/%{name}-root
  13. Requires(pre): shadow-utils
  14. Requires(pre): sed, coreutils, mktemp
  15. %description
  16. This package contains the MAKEDEV program, which makes it easier to create
  17. and maintain the files in the /dev directory. /dev directory files
  18. correspond to a particular device supported by Linux (serial or printer
  19. ports, scanners, sound cards, tape drives, CD-ROM drives, hard drives,
  20. etc.) and interface with the drivers in the kernel.
  21. You should install the MAKEDEV package because the MAKEDEV utility makes
  22. it easy to manage the /dev directory device files.
  23. %description -l ja
  24. このパッケージには MAKEDEV スクリプトが含まれています。これは /dev ディレ
  25. クトリ以下のファイルを簡単に作成するものです。/dev ディレクトリのファイル
  26. は、それぞれ Linux がサポートしているデバイス (シリアル/プリンタポート、
  27. スキャナ、サウンドカード、テープデバイス、CD-ROM ドライブ、ハードディスク
  28. 等) に対応しており、カーネルのドライバがこれらのファイルを介してデバイス
  29. にアクセスします。
  30. MAKEDEV ユーティリティは /dev ディレクトリ以下のデバイスファイルを簡単に
  31. 作成すことができますので MAKEDEV パッケージをインストールしてください。
  32. %prep
  33. %setup -q
  34. %patch10 -p1 -b .vine
  35. cp %{SOURCE10} .
  36. %build
  37. %__make OPTFLAGS="$RPM_OPT_FLAGS"
  38. %install
  39. %__make install DESTDIR=$RPM_BUILD_ROOT devdir=/dev makedevdir=/sbin
  40. rm -f $RPM_BUILD_ROOT/dev/MAKEDEV
  41. %clean
  42. rm -fr $RPM_BUILD_ROOT
  43. %pre
  44. # Add the floppy group and the vcsa user.
  45. getent group floppy >/dev/null || groupadd -g 19 -r floppy
  46. getent passwd vcsa >/dev/null || \
  47. useradd -r -d /dev -s /sbin/nologin -u 69 \
  48. -c "virtual console memory owner" vcsa
  49. exit 0
  50. %triggerpostun -- dev < 3.22
  51. if [ -x /sbin/MAKEDEV ]; then
  52. /sbin/MAKEDEV null
  53. /sbin/MAKEDEV console
  54. else
  55. /bin/mknod /dev/null c 1 3
  56. /bin/mknod /dev/console c 5 1
  57. fi
  58. if [ "$(/sbin/kernelversion)" == "2.4" ] ||
  59. ( [ "$(/sbin/kernelversion)" == "2.6" ] &&
  60. [ $(($(uname -r |cut -f1 -d-|cut -f3 -d.))) -lt 16 ] )
  61. then
  62. mount --bind /.dev.static /dev ||:
  63. if [ -x /sbin/pam_console_apply ] ; then
  64. /sbin/pam_console_apply
  65. fi
  66. fi
  67. %files
  68. %defattr(-,root,root)
  69. %doc COPYING devices-2.6+.txt fedora-changelog
  70. /sbin/MAKEDEV
  71. %{_mandir}/man8/*
  72. %{_sbindir}/mksock
  73. %config(noreplace) %{_sysconfdir}/makedev.d
  74. %changelog
  75. * Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.24-2
  76. - rebuilt with new toolchain
  77. * Mon Mar 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.24-1
  78. - new upstream release
  79. - remove dev package.
  80. * Thu Oct 16 2008 Shu KONNO <owa@bg.wakwak.com> 3.22-1vl5
  81. - applied new versioning policy, spec in utf-8
  82. * Thu Apr 05 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.22-0vl5
  83. - explicitly PreReq: coreutils instead of textutils and fileutils
  84. * Sun Aug 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.22-0vl4
  85. - make vcsa/floppy device on MAKEDEV's %%pre script.
  86. * Wed Jul 19 2006 Shu KONNO <owa@bg.wakwak.com> 3.22-0vl3
  87. - rebuild for x86_64
  88. * Sun May 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.22-0vl2
  89. - make null/console device in triggerpostun scripts
  90. * Sat May 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.22-0vl1
  91. - add dev subpackage for static device files.
  92. - initscripts will mount /.dev.static to /dev
  93. if kernel is not support udev.
  94. - import changes from FC
  95. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.21-1vl1
  96. - update to 3.21-3 from FC
  97. * Sat May 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.3.13-1vl3
  98. - include /dev/mouse (a symlink to /dev/input/mice) in the dev package
  99. please note this change (or revert) only applies to ppc archtecture
  100. * Wed May 12 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.13-1vl2
  101. - do not make mount a symlink to input/mice on non-ppc architecture.
  102. - add "console" and "ptmx" to "generic" device
  103. - add dv1394 device
  104. - change linux1394 device owner from '$ROOT' to '$CONSOLE'.
  105. * Mon May 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.13-1vl1
  106. - merged with fedora package
  107. see %{_docdir}/%{name}-%{version}/fedora-changelog for detail.
  108. * Wed Nov 14 2001 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  109. - 2.5.2-1vl4
  110. - fix change log
  111. * Sun Nov 11 2001 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  112. - 2.5.2-1vl3
  113. - support /dev/hdi - hdt
  114. * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  115. - 2.5.2-1vl2
  116. - rebuild with new %%{_mandir} definition
  117. - added Japanese summary and description
  118. * Sat Nov 18 2000 MACHINO, Satoshi <machino@vinelinux.org> 2.5.2-1vl1
  119. - build with gcc-2.95.3
  120. - partially used rpmmacros
  121. * Wed Mar 01 2000 Nalin Dahyabhai <nalin@redhat.com>
  122. - add audioctl
  123. * Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  124. - make vbi a symlink to vbi0
  125. - make vtx a symlink to vtx0, use vtx from video4linux
  126. * Sat Apr 17 1999 Michael K. Johnson <johnsonm@redhat.com>
  127. - create version 2.5 with a great many devices added from the 2.2 kernel
  128. devices.txt
  129. * Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
  130. - close bug #2157
  131. * Thu Mar 25 1999 Michael Johnson <johnsonm@redhat.com>
  132. - sg unification
  133. - nb devices
  134. * Thu Mar 25 1999 Jakub Jelinek <jj@ultra.linux.cz>
  135. - create correct /dev/console (c 5 1), support for SCSI
  136. disk devices sdi - sddx
  137. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  138. - auto rebuild in the new build environment (release 9)
  139. * Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
  140. - glibc 2.1
  141. * Thu Aug 13 1998 Jeff Johnson <jbj@redhat.com>
  142. - build root
  143. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  144. - translations modified for de
  145. * Thu Apr 23 1998 Prospector System <bugs@redhat.com>
  146. - translations modified for fr, tr
  147. * Thu Apr 23 1998 Erik Troan <ewt@redhat.com>
  148. - fixed group add script (had -r instead of -o)
  149. * Fri Apr 17 1998 Erik Troan <ewt@redhat.com>
  150. - put -o option on groupadd after -g -- I hope Christian can tell me why
  151. * Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
  152. - redirect groupadd call so that we're more quiet
  153. * Fri Oct 24 1997 Michael K. Johnson <johnsonm@redhat.com>
  154. - 2.3.1: use /usr/sbin/groupadd from new shadow utils
  155. * Mon Sep 29 1997 Michael K. Johnson <johnsonm@redhat.com>
  156. - Updated to 2.3, as Nick agreed to me making an interim release while
  157. he figures out whether he wants to be the maintainer.
  158. * Wed Sep 03 1997 Erik Troan <ewt@redhat.com>
  159. - made a noarch package
  160. * Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
  161. - added dependencies