libmediainfo-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203
  1. # Copyright (c) 2007-2008 oc2pus
  2. # This file and all modifications and additions to the pristine
  3. # package are under the same license as the package itself.
  4. #
  5. # Please submit bugfixes or comments to toni@links2linux.de
  6. #
  7. # *** This spec is modified for Vine Linux ***
  8. # norootforbuild
  9. %define _prefix /usr
  10. # %define _SO_nr 0
  11. # %define libzen_version 0.3.6
  12. # %define libzen_SO_nr 0
  13. Name: libmediainfo
  14. Version: 0.7.33
  15. Release: 1%{?_dist_release}
  16. Summary: Supplies technical and tag information about a video or audio file
  17. Summary(ja): ビデオとオーディオファイルの詳細な情報を提供するライブラリ
  18. Group: System/Libraries
  19. License: GPL
  20. URL: http://mediainfo.sourceforge.net/
  21. Source0: libmediainfo_%{version}.tar.bz2
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. ## BuildRequires: dos2unix
  24. BuildRequires: nkf
  25. ## NEED GCC3
  26. BuildRequires: gcc-c++
  27. #BuildRequires: libzen-devel = %{libzen_version}
  28. BuildRequires: libzen-devel
  29. BuildRequires: pkgconfig
  30. BuildRequires: zlib-devel
  31. BuildRequires: doxygen
  32. #Requires: libzen = %{libzen_version}
  33. Requires: libzen
  34. Packager: babasaki
  35. %description
  36. MediaInfo supplies technical and tag information about a video or
  37. audio file.
  38. What information can I get from MediaInfo?
  39. * General: title, author, director, album, track number, date, duration...
  40. * Video: codec, aspect, fps, bitrate...
  41. * Audio: codec, sample rate, channels, language, bitrate...
  42. * Text: language of subtitle
  43. * Chapters: number of chapters, list of chapters
  44. DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1,
  45. MPEG1, MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime,
  46. RealVideo, RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3,
  47. VOB, DVD, WMA, VMW, ASF, 3GP, 3GPP, 3GP2
  48. What format (container) does MediaInfo support?
  49. * Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1,
  50. MPEG-2, MPEG-4, DVD (VOB) (Codecs: DivX, XviD, MSMPEG4, ASP,
  51. H.264, AVC...)
  52. * Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
  53. * Subtitles: SRT, SSA, ASS, SAMI
  54. This package contains the shared library for MediaInfo(-gui).
  55. %description -l ja
  56. MediaInfo はビデオとオーディオファイルの詳細な情報を提供します。
  57. MediaInfo で確認できる情報:
  58. * 全般: タイトル、作者、ディレクター、アルバム、トラック番号、
  59. 日付、時間...
  60. * ビデオ: codec、アスペクト比、フレームレート、ビットレート...
  61. * オーディオ: codec、サンプリングレート、チャンネル数、言語、
  62. ビットレート...
  63. * テキスト: 字幕の言語
  64. * チャプター: チャプター数、チャプターの一覧
  65. DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1,
  66. MPEG1, MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime,
  67. RealVideo, RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3,
  68. VOB, DVD, WMA, VMW, ASF, 3GP, 3GPP, 3GP2
  69. MediaInfo がサポートするフォーマット:
  70. * ビデオ: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1,
  71. MPEG-2, MPEG-4, DVD (VOB) (Codec: DivX, XviD, MSMPEG4, ASP,
  72. H.264, AVC...)
  73. * オーディオ: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
  74. * 字幕: SRT, SSA, ASS, SAMI
  75. このパッケージは Mediainfo(-gui) 用の共有ライブラリを含んでい
  76. ます。
  77. %package -n libmediainfo-devel
  78. Summary: Include files and mandatory librariesfor development
  79. Summary(ja): libmediainfo の開発用のヘッダとライブラリファイル
  80. Group: Development/Libraries
  81. Requires: libmediainfo = %{version}
  82. #Requires: libzen = %{libzen_version}
  83. Requires: libzen
  84. %description -n libmediainfo-devel
  85. Include files and mandatory librariesfor development.
  86. %description -n libmediainfo-devel -l ja
  87. libmediainfo の開発用のヘッダとライブラリファイルです。
  88. %prep
  89. %setup -q -n MediaInfoLib
  90. cp Release/ReadMe_DLL_Linux.txt ReadMe.txt
  91. mv History_DLL.txt History.txt
  92. ## dos2unix *.txt *.html Source/Doc/*.html
  93. nkf --unix --overwrite *.txt *.html Source/Doc/*.html
  94. %__chmod 644 *.txt *.html Source/Doc/*.html
  95. %build
  96. export CFLAGS="$RPM_OPT_FLAGS"
  97. export CPPFLAGS="$RPM_OPT_FLAGS"
  98. export CXXFLAGS="$RPM_OPT_FLAGS"
  99. pushd Source/Doc/
  100. doxygen Doxyfile
  101. popd
  102. cp Source/Doc/*.html ./
  103. pushd Project/GNU/Library
  104. %__chmod +x autogen
  105. ./autogen
  106. %configure --enable-shared --disable-static
  107. %__make clean
  108. %__make %{?jobs:-j%{jobs}}
  109. popd
  110. %install
  111. pushd Project/GNU/Library/
  112. %__make install-strip DESTDIR=%{buildroot}
  113. popd
  114. # MediaInfoDLL headers and MediaInfo-config
  115. for i in MediaInfo MediaInfoDLL; do
  116. %__install -dm 755 %{buildroot}%{_includedir}/$i
  117. %__install -m 644 Source/$i/*.h \
  118. %{buildroot}%{_includedir}/$i
  119. done
  120. %__sed -i -e 's|Version: |Version: %{version}|g' \
  121. Project/GNU/Library/libmediainfo.pc
  122. %__install -dm 755 %{buildroot}%{_libdir}/pkgconfig
  123. %__install -m 644 Project/GNU/Library/libmediainfo.pc \
  124. %{buildroot}%{_libdir}/pkgconfig
  125. # remove unpackaged files
  126. rm -f ${RPM_BUILD_ROOT}/%{_libdir}/*.la
  127. %clean
  128. [ -d "%{buildroot}" -a "%{buildroot}" != "" ] && %__rm -rf "%{buildroot}"
  129. %post -n libmediainfo -p /sbin/ldconfig
  130. %postun -n libmediainfo -p /sbin/ldconfig
  131. %files
  132. %defattr(-,root,root,-)
  133. %doc History.txt License.html ReadMe.txt
  134. %{_libdir}/libmediainfo.so.*
  135. %files -n libmediainfo-devel
  136. %defattr(-,root,root,-)
  137. %doc Changes.txt Documentation.html Doc/*
  138. %dir %{_includedir}/MediaInfo
  139. %{_includedir}/MediaInfo/*
  140. %dir %{_includedir}/MediaInfoDLL
  141. %{_includedir}/MediaInfoDLL/*
  142. #%{_libdir}/libmediainfo.a
  143. #%{_libdir}/libmediainfo.la
  144. %{_libdir}/libmediainfo.so
  145. %{_libdir}/pkgconfig/*.pc
  146. %changelog
  147. * Tue Jun 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.33-1
  148. - new upstream release
  149. * Thu Oct 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.23-1
  150. - new upstream release
  151. * Mon Oct 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.22-1
  152. - new upstream release
  153. * Tue Jul 28 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.7.19-1
  154. - new upstream release
  155. - change spec file name to libmediainfo-vl.spec
  156. - add japanese summary and description
  157. - change group for -devel sub package to Development/Libraries
  158. - not to specify %{libzen_version} strictly
  159. - add configure option --disable-static
  160. - remove unpackaged file (.la)
  161. - add Packager tag
  162. * Tue Jan 01 2009 Jerome Martinez <zen@mediaarea.net> - 0.7.9-0
  163. - See History.txt for more info and real dates
  164. - Previous packages made by Toni Graffy <toni@links2linux.de>