jasper-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. Name: jasper
  4. Summary: implementation of the JPEG-2000 standard, Part 1
  5. Version: 2.0.16
  6. Release: 1%{?_dist_release}
  7. Group: Applications/Graphics
  8. License: Modified BSD (see LICENSE)
  9. URL: http://www.ece.uvic.ca/~mdadams/jasper/
  10. Source: https://github.com/mdadams/jasper/archive/version-%{version}.tar.gz#/%{name}-version-%{version}.tar.gz
  11. # skip hard-coded prefix/lib rpath
  12. Patch1: jasper-2.0.14-rpath.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: autoconf automake libtool
  15. BuildRequires: freeglut-devel
  16. BuildRequires: libGLU-devel
  17. BuildRequires: libjpeg-devel
  18. BuildRequires: pkgconfig
  19. BuildRequires: cmake
  20. Requires: %{name}-libs = %{version}-%{release}
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. %description
  24. JasPer is a collection of software (i.e., a library and application
  25. programs) for the coding and manipulation of images. This software
  26. can handle image data in a variety of formats. One such format
  27. supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
  28. %package devel
  29. Summary: Include Files and Documentation for jasper
  30. Group: Development/Libraries
  31. Requires: %{name}-libs = %{version}-%{release}
  32. Requires: libjpeg-devel
  33. %description devel
  34. This package contains libjasper, a library implementing the JPEG-2000
  35. image compression standard Part 1.
  36. %package libs
  37. Summary: Runtime libraries for %{name}
  38. Group: System Environment/Libraries
  39. %description libs
  40. This package contains runtime libraries for JasPer.
  41. # compat32
  42. %package -n compat32-%{name}-devel
  43. Summary: Include Files and Documentation for jasper
  44. Group: Development/Libraries
  45. Requires: %{name}-libs = %{version}-%{release}
  46. Requires: compat32-libjpeg-devel
  47. %description -n compat32-%{name}-devel
  48. This package contains libjasper, a library implementing the JPEG-2000
  49. image compression standard Part 1.
  50. %package -n compat32-%{name}-libs
  51. Summary: Runtime libraries for %{name}
  52. Group: System Environment/Libraries
  53. %description -n compat32-%{name}-libs
  54. This package contains runtime libraries for JasPer.
  55. %prep
  56. %setup -q -n %{name}-version-%{version}
  57. %patch1 -p1 -b .rpath
  58. %build
  59. mkdir -p builder
  60. pushd builder
  61. %cmake -DJAS_ENABLE_DOC:BOOL=OFF ..
  62. popd
  63. %make_build -C builder
  64. %install
  65. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  66. make install/fast DESTDIR=%{buildroot} -C builder
  67. # Unpackaged files
  68. rm -f doc/README
  69. rm -f %{buildroot}%{_libdir}/lib*.la
  70. rm -rf %{buildroot}%{_docdir}/JasPer
  71. %check
  72. make test -C builder
  73. %clean
  74. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  75. %post libs -p /sbin/ldconfig
  76. %postun libs -p /sbin/ldconfig
  77. %post -n compat32-%{name}-libs -p /sbin/ldconfig
  78. %postun -n compat32-%{name}-libs -p /sbin/ldconfig
  79. %files
  80. %defattr(-,root,root)
  81. %{!?_licensedir:%global license %%doc}
  82. %{_bindir}/*
  83. %{_mandir}/man1/*
  84. %files libs
  85. %license COPYRIGHT LICENSE
  86. %doc INSTALL README doc/README doc/jasper.pdf doc/jpeg2000.pdf
  87. %defattr(-,root,root)
  88. %{_libdir}/libjasper*.so.*
  89. %files devel
  90. %defattr(-,root,root)
  91. %{_includedir}/jasper
  92. %{_libdir}/libjasper*.so
  93. %{_libdir}/pkgconfig/jasper.pc
  94. # compat32
  95. %if %{build_compat32}
  96. %files -n compat32-%{name}-libs
  97. %defattr(-,root,root)
  98. %{_libdir}/libjasper*.so.*
  99. %files -n compat32-%{name}-devel
  100. %defattr(-,root,root)
  101. %{_libdir}/libjasper*.so
  102. %{_libdir}/pkgconfig/jasper.pc
  103. %endif
  104. %changelog
  105. * Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.16-1
  106. - new upstream release.
  107. - dropped Patch1: fixed in upstream.
  108. - imported Patch1 from rawhide.
  109. * Mon Mar 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.12-1
  110. - new upstream release.
  111. - dropped all patches.
  112. - imported patch1 from rawhide.
  113. * Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-11
  114. - added Patch1000-1002 to fix CVE-2016-{1577,2089,2116}.
  115. * Wed Dec 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-10
  116. - imported all patches from RawHide.
  117. * Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.900.1-9
  118. - rebuild with libpng-1.6.12
  119. * Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
  120. - rebuilt with current VineSeed
  121. * Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
  122. - added compat32 subpackage for x86_64 arch support.
  123. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
  124. - splited out runtime library to sub package
  125. - enable opengl again, add BuildRequires: freeglut-devel
  126. * Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
  127. - remove .la
  128. - add --disable-static to configure option
  129. * Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
  130. - added Patch0 from VinePlus/4.0
  131. * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
  132. - add patch100 for fix CVE-2007-2721
  133. - add Vendor/Distributin Tag
  134. * Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
  135. - remove BuildPrereq: freeglut-devel and Requires freeglut
  136. - add --disable-opengl to configure option
  137. * Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
  138. - add BuildPreReq: unzip (used in the %%pre section)
  139. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
  140. - new upstream release
  141. * Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
  142. - new upstream release
  143. - changed Group to System Environment/Libraries
  144. - added --mandir=%{_mandir}
  145. - added %post and %postun section
  146. * Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
  147. - added --libdir=%{_libdir} configure option
  148. * Tue Sep 5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
  149. - build with freeglut
  150. - change BuildPrereq and Requires
  151. * Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
  152. - new upstream version (jasper-1.701.0)
  153. * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
  154. - rebuild for VineSeedPlus
  155. * Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
  156. - source upgrade
  157. - change spec to build for VineLinux
  158. * Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
  159. - spec file created