empathy-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418
  1. %define major_ver 2.32
  2. %define minor_ver 2
  3. %define rel 1
  4. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  5. ## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
  6. ## respectively.
  7. %global gtk2_min_version 2.22
  8. %global glib2_min_version 2.26.0
  9. %global tp_mc_min_version 5.6.0
  10. %global tp_glib_min_version 0.13.0
  11. %global tp_logger_min_version 0.1.5
  12. #global enchant_version 1.4.0
  13. %global aspell_version 0.50
  14. %global libcanberra_version 0.4
  15. %global gnome_keyring_version 2.32
  16. %global libnotify_version 0.4.4
  17. Summary: GNOME Instant Messaging Client
  18. Summary(ja): GNOME インスタントメッセージクラアイント
  19. Name: empathy
  20. Version: %{major_ver}.%{minor_ver}
  21. Release: %{rel}%{?_dist_release}
  22. Group: Applications/Communications
  23. License: GPLv2+
  24. URL: http://live.gnome.org/Empathy
  25. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.bz2
  26. Source1: %{name}-README.ConnectionManagers
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. #BuildRequires: enchant-devel >= %{enchant_version}
  29. BuildRequires: aspell-devel >= %{aspell_version}
  30. BuildRequires: iso-codes
  31. BuildRequires: desktop-file-utils
  32. BuildRequires: evolution-data-server-devel
  33. BuildRequires: GConf2-devel
  34. BuildRequires: gettext
  35. BuildRequires: glib2-devel >= %{glib2_min_version}
  36. BuildRequires: gnome-doc-utils >= 0.17.3
  37. BuildRequires: gnome-panel
  38. BuildRequires: gtk2-devel >= %{gtk2_min_version}
  39. BuildRequires: intltool
  40. BuildRequires: libxml2-devel
  41. BuildRequires: perl(XML::Parser)
  42. BuildRequires: pygtk2-devel
  43. BuildRequires: telepathy-glib-devel >= %{tp_glib_min_version}
  44. BuildRequires: telepathy-mission-control-devel >= %{tp_mc_min_version}
  45. BuildRequires: farsight2-devel
  46. BuildRequires: telepathy-farsight-devel
  47. BuildRequires: libcanberra-devel >= %{libcanberra_version}
  48. BuildRequires: libgnome-keyring-devel >= %{gnome_keyring_version}
  49. BuildRequires: unique-devel
  50. BuildRequires: libnotify-devel >= %{libnotify_version}
  51. BuildRequires: libtelepathy-devel
  52. BuildRequires: libgnomecanvas-devel
  53. BuildRequires: libbonoboui-devel
  54. BuildRequires: folks-devel
  55. BuildRequires: telepathy-logger-devel >= %{tp_logger_min_version}
  56. BuildRequires: gnome-keyring-devel >= %{gnome_keyring_version}
  57. BuildRequires: openssl-devel
  58. BuildRequires: NetworkManager-glib-devel
  59. BuildRequires: WebKit-gtk-devel
  60. BuildRequires: geoclue-devel
  61. BuildRequires: enchant-devel
  62. Requires: telepathy-filesystem
  63. ## Empathy is useless without a proper Telepathy connection manager installed.
  64. ## We hardcode dependencies on Salut and Gabble to support XMPP on a default
  65. ## install, in both the link-local and Jabber/GoogleTalk incarnations.
  66. ## (RHBZ: 308871 and 334221)
  67. ## TODO: Perhaps we can configure these to be installed "on demand" with
  68. ## PackageKit and friends?
  69. Requires: telepathy-gabble
  70. Requires: telepathy-salut
  71. ## Also hardcode Haze dependency since Empathy is the default IM client in F10+
  72. ## and I'd hate for people to simply disregard it for lack of the "out of the
  73. ## box" protocol support that Pidgin has. (RHBZ: 458935)
  74. BuildRequires: telepathy-haze
  75. # Require this for VOIP support
  76. Requires: telepathy-stream-engine
  77. Requires: telepathy-mission-control >= %{tp_mc_min_version}
  78. Requires(post): GConf2
  79. Requires(post): scrollkeeper
  80. Requires(postun): scrollkeeper
  81. ## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
  82. Obsoletes: telepathy-haze-mission-control < 0.2.0-3
  83. Provides: telepathy-haze-mission-control = 0.2.0-3
  84. ## upstream 2.29.1 removed shared libraries: #599086
  85. Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
  86. ## upstream 2.29.1 removed python bindings' #599039
  87. Obsoletes: empathy-python < 2.29.1
  88. %description
  89. Empathy provides a powerful multiple protocol instant messaging
  90. client using the Telepathy framework.
  91. %package -n nautilus-sendto-empathy
  92. License: GPLv2+
  93. Summary: Nautilus-sendto plugin for empathy
  94. Summary(ja): empathy 用 nautilus-sendto プラグイン
  95. Group: User Interface/Desktop
  96. Requires: %{name} = %{version}-%{release}
  97. Requires: nautilus-sendto
  98. BuildRequires: nautilus-sendto-devel
  99. %description -n nautilus-sendto-empathy
  100. This package contains nautilus-sendto plugin for the Empathy IM application.
  101. %prep
  102. %setup -q
  103. %build
  104. ## GCC complains about some unused functions, so we forcibly show those as
  105. ## simple warnings instead of build-halting errors.
  106. %configure \
  107. --with-compile-warnings=yes \
  108. --disable-static \
  109. --enable-nautilus-sendto=yes \
  110. --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
  111. ## RPATHs are yucky.
  112. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  113. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  114. ##make %{?_smp_mflags}
  115. ## don't use _smp_mflags at empathy-2.18.1
  116. make
  117. install -m 0644 %{SOURCE1} ./README.ConnectionManagers
  118. %install
  119. rm -rf $RPM_BUILD_ROOT
  120. make install DESTDIR=$RPM_BUILD_ROOT
  121. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  122. %find_lang %{name}
  123. desktop-file-install --vendor "" --delete-original \
  124. --dir %{buildroot}%{_datadir}/applications \
  125. %{buildroot}%{_datadir}/applications/%{name}.desktop
  126. %clean
  127. rm -rf %{buildroot}
  128. %post
  129. scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
  130. touch --no-create %{_datadir}/icons/hicolor ||:
  131. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  132. %postun
  133. scrollkeeper-update -q || :
  134. touch --no-create %{_datadir}/icons/hicolor || :
  135. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  136. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  137. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  138. fi
  139. %posttrans
  140. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
  141. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  142. %files -f %{name}.lang
  143. %defattr(-,root,root,-)
  144. %doc AUTHORS COPYING README README.ConnectionManagers NEWS
  145. %{_bindir}/empathy
  146. %{_bindir}/empathy-accounts
  147. %{_bindir}/empathy-debugger
  148. %{_libexecdir}/empathy-auth-client
  149. %{_libexecdir}/empathy-av
  150. %{_datadir}/dbus-1/services/*
  151. %{_datadir}/empathy
  152. %{_datadir}/glib-2.0/schemas/*.xml
  153. %{_datadir}/GConf/gsettings/*
  154. %{_datadir}/applications/*.desktop
  155. %{_datadir}/gnome/help/%{name}/
  156. #{_datadir}/omf/%{name}/
  157. %{_datadir}/icons/hicolor/*/apps/%{name}*
  158. #{_datadir}/mission-control/profiles/*.profile
  159. %{_datadir}/telepathy/clients/*.client
  160. %{_mandir}/man1/empathy*.1*
  161. %files -n nautilus-sendto-empathy
  162. %defattr(-,root,root,-)
  163. %{_libdir}/nautilus-sendto/plugins/libnstempathy.so
  164. %changelog
  165. * Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  166. - new upstream release
  167. - add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
  168. geoclue-devel, enchant-devel
  169. - add Requires: telepathy-mission-control
  170. - add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
  171. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
  172. - new upstream release
  173. - add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
  174. - fix %files
  175. - fix %post, %postun
  176. - drop %pre, %preun
  177. * Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
  178. - rebuild with evolution-data-server-2.30.2
  179. - add nautilus-sendto-empathy package
  180. - add configure option (--enable-nautilus-sendto=yes)
  181. - add BuildRequires: nautilus-sendto-devel
  182. * Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
  183. - add Obsoletes: empathy-python < 2.29.1
  184. * Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
  185. - new upstream release
  186. - add new files: %%{_bindir}/empathy-{accounts,debugger}
  187. - drop -libs, -devel, -python sub packages: upstream removed
  188. - Obsoletes: empathy-{libs,devel} < 2.29.1
  189. - drop BuildRequires: python-devel
  190. - drop %%{_bindir}/empathy-logs in %%files: upstream don not install
  191. - drop applet files in %%files: upstream removed the panel applets
  192. - update %%post, %pre and %%preun
  193. - update BuildRequires version for glib2 and tp_glib
  194. - defined major_ver, minor_ver and rel
  195. - fix BuildRequires for gnome-keyring
  196. * Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  197. - new upstream release
  198. - add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
  199. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
  200. - rebuilt with python-2.6.4
  201. * Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
  202. - unuse %%{?_smp_mflags} option to make
  203. * Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
  204. - add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
  205. * Sat Nov 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  206. - new upstream release
  207. * Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  208. - new upstream release
  209. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  210. - initial build for Vine Linux
  211. * Tue Sep 9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
  212. - Update to 2.23.92
  213. * Thu Sep 4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
  214. - Update to 2.23.91
  215. * Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
  216. - Now that Empathy will be the default IM client in F10+, hardcode a dependency
  217. on telepathy-haze to keep the same protocol functionality across upgrades,
  218. for a much improved "out of the box" experience.
  219. - Reference: bug 458935.
  220. * Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
  221. - Update to new upstream release (2.23.90)
  222. * Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
  223. - Apply patch from Colin Walters to automagically update profile namings for
  224. the switch to using Empathy's provided profiles.
  225. - Drop the upgrade script (no longer needed since it's automatically done).
  226. - upgrade-haze-profiles.sh
  227. * Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
  228. - Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
  229. the telepathy-haze-mission-control package. (The Haze-provided ones have grown
  230. horribly stale...). This makes for better automagic functionality (if Haze is
  231. installed, Empathy/MC will autodetect it) and tracks upstream more closely.
  232. + upgrade-haze-profiles.sh
  233. * Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
  234. - Update to new upstream release (2.23.6)
  235. - Use the in-tarball libtool scripts instead of the system copy to workaround
  236. 'make install' errors.
  237. * Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
  238. - Update to 0.23.4.
  239. - Update source url.
  240. * Mon Jun 2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
  241. - Update to 0.23.3.
  242. - Remove reference to stream-engine in connections managers readme.
  243. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
  244. - Update to 0.23.2.
  245. - Add man pages.
  246. - Use enchant-devel, instead of aspell-devel.
  247. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
  248. - Rebuild for new e-d-s.
  249. * Sun May 4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
  250. - Drop multiple copies of COPYING file.
  251. - Drop BR on gnome-vfs2-devel.
  252. - Require telepathy-stream-engine for VOIP support.
  253. - Add BR on iso-codes-devel, so spell-checking is enabled.
  254. * Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
  255. - Update to new upstream release (0.23.1)
  256. - Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
  257. * Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
  258. - Update to new upstream release (0.22.1)
  259. * Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
  260. - Update to new upstream release (0.22.0)
  261. * Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
  262. - Update to new upstream release (0.21.91)
  263. * Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
  264. - Update to new upstream release (0.21.90)
  265. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
  266. - Autorebuild for GCC 4.3
  267. * Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
  268. - Update to new upstream release (0.21.4)
  269. * Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
  270. - Update to new upstream release (0.21.2)
  271. - Drop backported drag-and-drop patch (fixed upstream):
  272. - svn380-fix-contact-DnD.patch
  273. - Update README.ConnectionManagers: Include Haze package note, remove Galago
  274. note (a feed-only connection manager isn't useful for instant messaging),
  275. and fix some wording.
  276. * Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
  277. - Backport upstream patch to fixes crashes when using drag-and-drop of a
  278. contact from the buddy list to the current conversation window to initiate a
  279. conversation:
  280. + svn380-fix-contact-DnD.patch
  281. - Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
  282. dragged a contact ...)
  283. * Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
  284. - Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
  285. is essentially useless due to the need to install an external connection
  286. manager. Also, add a README.ConnectionManagers to the installed
  287. documentation which lists other possibilities.
  288. - Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
  289. and bug 334221 (Default empathy install is useless).
  290. * Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
  291. - Enable VoIP support for those brave enough to test/break/debug it (F9+
  292. only). Though it is functional, it is still deemed rather unstable by
  293. upstream. Use it at your own risk. :)
  294. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
  295. - Disable VoIP support at this time, since it is deemed unstable by upstream
  296. for now. (Thanks to Brian Pepple for the notice.)
  297. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
  298. - Update to new upstream release (0.14).
  299. * Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
  300. - Update to new upstream release (0.13), which adds a panel applet (Megaphone)
  301. and python bindings.
  302. - Split shared libraries into a libs subpackage for easier handling
  303. in multi-lib environments.
  304. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
  305. - Add ldconfig invocations to %%post and %%postun scriptlets.
  306. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
  307. - Update to new upstream release (0.12).
  308. - Build against new mission-control stack.
  309. - Update License tag (GPLv2+).
  310. - Alphabetize BuildRequires list (aesthetic-only change).
  311. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
  312. - Rebuild for selinux ppc32 issue.
  313. * Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
  314. - Update to new upstream release (0.11)
  315. * Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
  316. - bump to 0.8
  317. - Now with aspell support (deat to teh speeling mistaks)
  318. * Sat Jun 9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
  319. - bump to 0.7
  320. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
  321. - Add telepathy-filesystem to Requires
  322. - Move .desktop from autostart to applications
  323. - Nasty hackery to make empathy launch from the menu
  324. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
  325. - Add gettext to BuildRequires
  326. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
  327. - Bump to 0.6
  328. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
  329. - Let Empathy own the directory and not just the files in it
  330. * Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
  331. - Initial package