cairo-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361
  1. Summary: Cairo - multi-platform 2D graphics library.
  2. Summary(ja): Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
  3. Name: cairo
  4. Version: 1.10.2
  5. Release: 2%{?_dist_release}
  6. License: LGPL/MPL
  7. Group: System Environment/Libraries
  8. Source0: http://cairographics.org/releases/%{name}-%{version}.tar.gz
  9. # don't use serverside gradients, most drivers don't handle those and are
  10. # really slow, should workaround performances issues for ati, nouveau and nvidia
  11. # https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
  12. Patch1: cairo-1.10.0-dont_use_server_side_gradients.patch
  13. URL: http://cairographics.org/
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: pkgconfig
  16. BuildRequires: pixman-devel
  17. BuildRequires: glib2-devel
  18. BuildRequires: libpng-devel
  19. BuildRequires: freetype2-devel
  20. BuildRequires: fontconfig-devel
  21. BuildRequires: libX11-devel
  22. BuildRequires: libXrender-devel
  23. BuildRequires: gtk-doc
  24. BuildConflicts: XOrg-compat70-devel
  25. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  26. %description
  27. Cairo provides anti-aliased vector-based rendering for X. Paths
  28. consist of line segments and cubic splines and can be rendered at any
  29. width with various join and cap styles. All colors may be specified
  30. with optional translucence (opacity/alpha) and combined using the
  31. extended Porter/Duff compositing algebra as found in the X Render
  32. Extension.
  33. Cairo exports a stateful rendering API similar in spirit to the path
  34. construction, text, and painting operators of PostScript, (with the
  35. significant addition of translucence in the imaging model). When
  36. complete, the API is intended to support the complete imaging model of
  37. PDF 1.4.
  38. Cairo relies on the Xc library for backend rendering. Xc provides an
  39. abstract interface for rendering to multiple target types. As of this
  40. writing, Xc allows Cairo to target X drawables as well as generic
  41. image buffers. Future backends such as PostScript, PDF, and perhaps
  42. OpenGL are currently being planned.
  43. %package -n compat32-%{name}
  44. Summary: Cairo - multi-platform 2D graphics library.
  45. Summary(ja): Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
  46. Group: System Environment/Libraries
  47. Requires: %{name} = %{version}
  48. %description -n compat32-%{name}
  49. Cairo provides anti-aliased vector-based rendering for X. Paths
  50. consist of line segments and cubic splines and can be rendered at any
  51. width with various join and cap styles. All colors may be specified
  52. with optional translucence (opacity/alpha) and combined using the
  53. extended Porter/Duff compositing algebra as found in the X Render
  54. Extension.
  55. Cairo exports a stateful rendering API similar in spirit to the path
  56. construction, text, and painting operators of PostScript, (with the
  57. significant addition of translucence in the imaging model). When
  58. complete, the API is intended to support the complete imaging model of
  59. PDF 1.4.
  60. Cairo relies on the Xc library for backend rendering. Xc provides an
  61. abstract interface for rendering to multiple target types. As of this
  62. writing, Xc allows Cairo to target X drawables as well as generic
  63. image buffers. Future backends such as PostScript, PDF, and perhaps
  64. OpenGL are currently being planned.
  65. %package devel
  66. Summary: Development files for Cairo library.
  67. Summary(ja): Cairo ライブラリの開発用ファイル
  68. Group: Development/Libraries
  69. Provides: lib%{name}-devel = %{version}-%{release}
  70. Requires: %{name} = %{version}
  71. Requires: libpng-devel
  72. Requires: freetype2-devel
  73. Requires: fontconfig-devel
  74. Requires: libX11-devel
  75. Requires: libXrender-devel
  76. Requires: pixman-devel
  77. Requires: glib2-devel
  78. %description devel
  79. Development files for Cairo library.
  80. %package tools
  81. Summary: Development tools for cairo
  82. Group: Development/Tools
  83. %description tools
  84. Cairo is a 2D graphics library designed to provide high-quality display
  85. and print output.
  86. This package contains tools for working with the cairo graphics library.
  87. * cairo-trace: Record cairo library calls for later playback
  88. %prep
  89. %setup -q
  90. %patch1 -p1 -b .dont-use-server-side-gradients
  91. %build
  92. %configure --disable-static \
  93. --enable-gtk-doc \
  94. --enable-xlib \
  95. --enable-freetype \
  96. --enable-ps \
  97. --enable-pdf \
  98. --enable-svg \
  99. --enable-tee \
  100. --enable-gobject
  101. %ifarch x86_64
  102. cp libtool libtool.old
  103. ldpath="/lib64 /usr/lib64 /usr/lib /usr/X11R6/lib64 /usr/X11R6/lib"
  104. sed "s|^sys_lib_search_path_spec=.*|sys_lib_search_path_spec=$ldpath|" libtool.old \
  105. > libtool
  106. rm libtool.old
  107. %endif
  108. make
  109. %install
  110. rm -rf $RPM_BUILD_ROOT
  111. %makeinstall
  112. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  113. %clean
  114. rm -rf $RPM_BUILD_ROOT
  115. %post -p /sbin/ldconfig
  116. %postun -p /sbin/ldconfig
  117. %post -n compat32-%{name} -p /sbin/ldconfig
  118. %postun -n compat32-%{name} -p /sbin/ldconfig
  119. %files
  120. %defattr(644,root,root,755)
  121. %doc AUTHORS BUGS COPYING COPYING-* ChangeLog NEWS README
  122. %{_libdir}/lib*.so.*
  123. %files devel
  124. %defattr(644,root,root,755)
  125. %{_libdir}/lib*.so
  126. #{_libdir}/lib*.la
  127. %{_includedir}/*
  128. %{_libdir}/pkgconfig/*.pc
  129. #{_libdir}/lib*.a
  130. %{_datadir}/gtk-doc/html/cairo
  131. %files tools
  132. %defattr(-,root,root,-)
  133. %{_bindir}/cairo-trace
  134. %{_libdir}/cairo
  135. %if %{build_compat32}
  136. %files -n compat32-%{name}
  137. %defattr(644,root,root,755)
  138. %{_libdir}/lib*.so.*
  139. %endif
  140. %changelog
  141. * Tue Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-2
  142. - enable tee support
  143. - add configure options specifically
  144. - disable static library
  145. * Wed Jan 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  146. - new upstream release
  147. - add BuildRequires: glib2-devel
  148. - add Requires: glib2-devel (devel package)
  149. * Wed Oct 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
  150. - add patch1 from ubuntu to fix performance regressions
  151. - don't use serverside gradients, most drivers don't handle those and are
  152. really slow, should workaround performances issues for ati, nouveau and nvidia
  153. https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
  154. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
  155. - new upstream release
  156. - add tools sub package
  157. * Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-3
  158. - add BuildRequires: fontconfig-devel
  159. - add Requires: fontconfig-devel (devel package)
  160. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.8.10-2
  161. - build with rpm-4.8.1-1 for pkg-config file
  162. * Tue Mar 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.8.10-1
  163. - new upstream release
  164. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
  165. - new upstream release
  166. * Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.8.6-2
  167. - applied cairo-1.8.6-status-return-fix.patch from Gentoo Linux
  168. - added BuildRequires: gtk-doc
  169. * Sat Jan 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-1
  170. - new upstream release
  171. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-1
  172. - new upstream release
  173. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
  174. - new upstream release
  175. * Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
  176. - new upstream release
  177. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-1
  178. - new upstream release
  179. * Wed May 28 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.4-3
  180. - add Requires: pixman-devel to -devel
  181. * Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-2
  182. - rebuilt with xorg-x11 7.3
  183. - spec in UTF-8
  184. * Thu May 1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-1
  185. - new upstream release
  186. - removed lib*.la from devel package
  187. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-1vl5
  188. - used %%{?_dist_release}
  189. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-0vl1
  190. - new upstream release
  191. * Sun Dec 9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.12-0vl1
  192. - new upstream release
  193. * Tue Jul 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.10-0vl1
  194. - new upstream release
  195. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
  196. - new upstream release
  197. - remove BuildRequires: pango-devel, gtk2-devel
  198. (these are only needed for testing)
  199. * Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.2-0vl1
  200. - upstream release
  201. - Patch30 and Patch40 is skipped (not working correctly)
  202. but held in src.rpm
  203. - add BUGS, ROADMAP to %%doc
  204. - add BuildRequires: pango-devel, gtk2-devel
  205. * Tue Oct 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
  206. - rebuild without XOrg-compat70-devel
  207. - add BuildConflicts: XOrg-compat70-devel
  208. * Sun Oct 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl1
  209. - new upstream release
  210. - remove unneeded Patch20 which breaks 8bpp rendering (<BTS:297>)
  211. * Tue Sep 19 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl3
  212. - added Patch40 for 15bpp problem
  213. * Tue Sep 5 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl2
  214. - added ad-hoc Patch30 for 16bpp problem
  215. * Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
  216. - new upstream release
  217. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
  218. - new upstream release
  219. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
  220. - new upstream release
  221. * Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-0vl4
  222. - added compat32- package for x86_64 architecture support
  223. * Sun Mar 05 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
  224. - added x86_64 architecture support
  225. * Sat Dec 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
  226. - add Patch20 to fix broken desktop rendering on xorg-x11-6.9
  227. - add X.Org 6.9.0 (6090000) to blacklist
  228. * Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
  229. - new upstream release
  230. * Tue Oct 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl5
  231. - update Patch10
  232. * Sun Oct 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl4
  233. - add Patch10 to use embedded bitmap font if available.
  234. (controllable by "embeddedbitmap" in fontconfig)
  235. * Thu Sep 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl3
  236. - rebuild with new fontconfig
  237. * Sun Sep 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl2
  238. - add Requires: libpng-devel, XOrg-devel, freetype2-devel
  239. to devel package instead of BuildRequires (typo)
  240. - add Japanese summaries
  241. * Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
  242. - new upstream release
  243. - remove libpixman dependency (which is now included in cairo)
  244. - obsoletes libpixman <= 0.1.6
  245. - add more BuildRequires
  246. * Sat Aug 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.2-0vl1
  247. - new upstream version
  248. * Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1-0vl1
  249. - new upstream version
  250. - fixed License (http://cairographics.org/introduction)
  251. * Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
  252. - new upstream version
  253. - include gtk-doc files
  254. * Sun Jan 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
  255. - new upstream version
  256. - add Requires: libpixman
  257. * Mon Nov 01 2004 Satoshi MACHINO <machino@vinelinux.org> 0.2.0-0vl1
  258. - new upstream version (cairo-0.2.0)
  259. * Mon Oct 11 2004 Satoshi MACHINO <machino@vinelinux.org> 0.1.23-1vl1
  260. - rebuilt for VineLinux
  261. * Tue Jun 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.23-1mdk
  262. - 0.1.23
  263. - reenable libtoolize
  264. * Wed May 5 2004 G魚Waschk <waschk@linux-mandrake.com> 0.1.22-1mdk
  265. - fix devel provides
  266. - drop redundant buildrequires
  267. - requires new pixman
  268. - autoconf 2.5 macro
  269. - New release 0.1.22
  270. * Fri Feb 06 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-2mdk
  271. - build with X11
  272. * Sun Feb 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-1mdk
  273. - 0.1.17
  274. - provides cairo
  275. - drop patch, use --disable-xlib
  276. - buildrequires
  277. - don't run libtoolize
  278. * Sun Dec 14 2003 Marcel Pol <mpol@mandrake.org> 0.1.13-1mdk
  279. - initial mandrake package