libmediainfo-vl.spec 6.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225
  1. # Copyright (c) 2007-2008 oc2pus
  2. # This file and all modifications and additions to the pristine
  3. # package are under the same license as the package itself.
  4. #
  5. # Please submit bugfixes or comments to toni@links2linux.de
  6. #
  7. # *** This spec is modified for Vine Linux ***
  8. # norootforbuild
  9. %define _prefix /usr
  10. # %define _SO_nr 0
  11. # %define libzen_version 0.3.6
  12. # %define libzen_SO_nr 0
  13. Name: libmediainfo
  14. Version: 0.7.47
  15. Release: 1%{?_dist_release}
  16. Summary: Supplies technical and tag information about a video or audio file
  17. Summary(ja): ビデオとオーディオファイルの詳細な情報を提供するライブラリ
  18. Group: System Environment/Libraries
  19. License: GPL
  20. URL: http://mediainfo.sourceforge.net/
  21. Source0: libmediainfo_%{version}.tar.bz2
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. ## BuildRequires: dos2unix
  24. BuildRequires: nkf
  25. ## NEED GCC3
  26. BuildRequires: gcc-c++
  27. BuildRequires: libzen-devel
  28. BuildRequires: pkgconfig
  29. BuildRequires: zlib-devel
  30. BuildRequires: doxygen
  31. Requires: libzen
  32. Packager: babasaki
  33. %description
  34. MediaInfo supplies technical and tag information about a video or
  35. audio file.
  36. What information can I get from MediaInfo?
  37. * General: title, author, director, album, track number, date, duration...
  38. * Video: codec, aspect, fps, bitrate...
  39. * Audio: codec, sample rate, channels, language, bitrate...
  40. * Text: language of subtitle
  41. * Chapters: number of chapters, list of chapters
  42. DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1,
  43. MPEG1, MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime,
  44. RealVideo, RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3,
  45. VOB, DVD, WMA, VMW, ASF, 3GP, 3GPP, 3GP2
  46. What format (container) does MediaInfo support?
  47. * Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1,
  48. MPEG-2, MPEG-4, DVD (VOB) (Codecs: DivX, XviD, MSMPEG4, ASP,
  49. H.264, AVC...)
  50. * Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
  51. * Subtitles: SRT, SSA, ASS, SAMI
  52. This package contains the shared library for MediaInfo(-gui).
  53. %description -l ja
  54. MediaInfo はビデオとオーディオファイルの詳細な情報を提供します。
  55. MediaInfo で確認できる情報:
  56. * 全般: タイトル、作者、ディレクター、アルバム、トラック番号、
  57. 日付、時間...
  58. * ビデオ: codec、アスペクト比、フレームレート、ビットレート...
  59. * オーディオ: codec、サンプリングレート、チャンネル数、言語、
  60. ビットレート...
  61. * テキスト: 字幕の言語
  62. * チャプター: チャプター数、チャプターの一覧
  63. DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1,
  64. MPEG1, MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime,
  65. RealVideo, RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3,
  66. VOB, DVD, WMA, VMW, ASF, 3GP, 3GPP, 3GP2
  67. MediaInfo がサポートするフォーマット:
  68. * ビデオ: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1,
  69. MPEG-2, MPEG-4, DVD (VOB) (Codec: DivX, XviD, MSMPEG4, ASP,
  70. H.264, AVC...)
  71. * オーディオ: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
  72. * 字幕: SRT, SSA, ASS, SAMI
  73. このパッケージは Mediainfo(-gui) 用の共有ライブラリを含んでい
  74. ます。
  75. %package -n libmediainfo-devel
  76. Summary: Include files and mandatory librariesfor development
  77. Summary(ja): libmediainfo の開発用のヘッダとライブラリファイル
  78. Group: Development/Libraries
  79. Requires: libmediainfo = %{version}
  80. #Requires: libzen = %{libzen_version}
  81. Requires: libzen
  82. %description -n libmediainfo-devel
  83. Include files and mandatory librariesfor development.
  84. %description -n libmediainfo-devel -l ja
  85. libmediainfo の開発用のヘッダとライブラリファイルです。
  86. %prep
  87. %setup -q -n MediaInfoLib
  88. cp Release/ReadMe_DLL_Linux.txt ReadMe.txt
  89. mv History_DLL.txt History.txt
  90. ## dos2unix *.txt *.html Source/Doc/*.html
  91. nkf --unix --overwrite *.txt *.html Source/Doc/*.html
  92. %__chmod 644 *.txt *.html Source/Doc/*.html
  93. %build
  94. export CFLAGS="$RPM_OPT_FLAGS"
  95. export CPPFLAGS="$RPM_OPT_FLAGS"
  96. export CXXFLAGS="$RPM_OPT_FLAGS"
  97. pushd Source/Doc/
  98. doxygen Doxyfile
  99. popd
  100. cp Source/Doc/*.html ./
  101. pushd Project/GNU/Library
  102. %__chmod +x autogen
  103. ./autogen
  104. %configure --enable-shared --disable-static
  105. %__make clean
  106. %__make %{?jobs:-j%{jobs}}
  107. popd
  108. %install
  109. pushd Project/GNU/Library/
  110. %__make install-strip DESTDIR=%{buildroot}
  111. popd
  112. # MediaInfoDLL headers and MediaInfo-config
  113. for i in MediaInfo MediaInfoDLL; do
  114. %__install -dm 755 %{buildroot}%{_includedir}/$i
  115. %__install -m 644 Source/$i/*.h \
  116. %{buildroot}%{_includedir}/$i
  117. done
  118. %__sed -i -e 's|Version: |Version: %{version}|g' \
  119. Project/GNU/Library/libmediainfo.pc
  120. %__install -dm 755 %{buildroot}%{_libdir}/pkgconfig
  121. %__install -m 644 Project/GNU/Library/libmediainfo.pc \
  122. %{buildroot}%{_libdir}/pkgconfig
  123. # remove unpackaged files
  124. rm -f ${RPM_BUILD_ROOT}/%{_libdir}/*.la
  125. %clean
  126. [ -d "%{buildroot}" -a "%{buildroot}" != "" ] && %__rm -rf "%{buildroot}"
  127. %post -n libmediainfo -p /sbin/ldconfig
  128. %postun -n libmediainfo -p /sbin/ldconfig
  129. %files
  130. %defattr(-,root,root,-)
  131. %doc History.txt License.html ReadMe.txt
  132. %{_libdir}/libmediainfo.so.*
  133. %files -n libmediainfo-devel
  134. %defattr(-,root,root,-)
  135. %doc Changes.txt Documentation.html Doc/*
  136. %dir %{_includedir}/MediaInfo
  137. %{_includedir}/MediaInfo/*
  138. %dir %{_includedir}/MediaInfoDLL
  139. %{_includedir}/MediaInfoDLL/*
  140. #%{_libdir}/libmediainfo.a
  141. #%{_libdir}/libmediainfo.la
  142. %{_libdir}/libmediainfo.so
  143. %{_libdir}/pkgconfig/*.pc
  144. %changelog
  145. * Fri Jul 15 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.47-1
  146. - new upstream release
  147. * Wed Jan 26 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.41-1
  148. - new upstream release
  149. * Sat Dec 25 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.38-1
  150. - new upstream release
  151. * Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.37-1
  152. - new upstream release
  153. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.7.35-2
  154. - rebuilt with rpm-4.8.1 for pkg-config
  155. * Fri Sep 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.35-1
  156. - new upstream release
  157. * Sat Aug 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.34-2
  158. - fixed Group to System Environment/Libraries
  159. * Tue Jul 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.34-1
  160. - new upstream release
  161. * Tue Jun 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.33-1
  162. - new upstream release
  163. * Thu Oct 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.23-1
  164. - new upstream release
  165. * Mon Oct 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.22-1
  166. - new upstream release
  167. * Tue Jul 28 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.7.19-1
  168. - new upstream release
  169. - change spec file name to libmediainfo-vl.spec
  170. - add japanese summary and description
  171. - change group for -devel sub package to Development/Libraries
  172. - not to specify %{libzen_version} strictly
  173. - add configure option --disable-static
  174. - remove unpackaged file (.la)
  175. - add Packager tag
  176. * Tue Jan 01 2009 Jerome Martinez <zen@mediaarea.net> - 0.7.9-0
  177. - See History.txt for more info and real dates
  178. - Previous packages made by Toni Graffy <toni@links2linux.de>