libzen-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152
  1. # Copyright (c) 2008 oc2pus
  2. # This file and all modifications and additions to the pristine
  3. # package are under the same license as the package itself.
  4. #
  5. # Please submit bugfixes or comments to toni@links2linux.de
  6. #
  7. # *** This spec is modified for Vine Linux ***
  8. # norootforbuild
  9. %define _prefix /usr
  10. # %define _SO_nr 0
  11. Name: libzen
  12. Version: 0.4.20
  13. Release: 1%{?_dist_release}
  14. Summary: Shared library for libmediainfo and medianfo-*
  15. Summary(ja): libmediainfo 及び mediainfo-* 用の共有ライブラリ
  16. Group: System Environment/Libraries
  17. License: BSD
  18. URL: http://zenlib.sourceforge.net/
  19. Source: libzen_%{version}.tar.bz2
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. # BuildRequires: dos2unix
  22. BuildRequires: nkf
  23. BuildRequires: doxygen
  24. ## Need GCC3
  25. BuildRequires: gcc-c++
  26. Packager: babasaki
  27. %description
  28. Shared library for libmediainfo and medianfo-*.
  29. %description -l ja
  30. libmediainfo 及び mediainfo-* 用の共有ライブラリです。
  31. %package -n libzen-devel
  32. Summary: Include files and mandatory libraries for development
  33. Summary(ja): libzen の開発用のヘッダとライブラリファイル
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. %description -n libzen-devel
  37. Include files and mandatory libraries for development.
  38. %description -n libzen-devel -l ja
  39. libzen の開発用のヘッダとライブラリファイルです。
  40. %prep
  41. %setup -q -n ZenLib
  42. ## dos2unix *.txt Source/Doc/*.html
  43. nkf --unix --overwrite *.txt Source/Doc/*.html
  44. %__chmod 644 *.txt Source/Doc/*.html
  45. %build
  46. export CFLAGS="$RPM_OPT_FLAGS"
  47. export CPPFLAGS="$RPM_OPT_FLAGS"
  48. export CXXFLAGS="$RPM_OPT_FLAGS"
  49. pushd Source/Doc/
  50. doxygen Doxyfile
  51. popd
  52. cp Source/Doc/*.html ./
  53. pushd Project/GNU/Library
  54. %__chmod +x autogen
  55. ./autogen
  56. %configure --enable-shared --disable-static
  57. %__make clean
  58. %__make %{?jobs:-j%{jobs}}
  59. popd
  60. %install
  61. pushd Project/GNU/Library
  62. %__make install-strip DESTDIR=%{buildroot}
  63. popd
  64. # Zenlib headers and ZenLib-config
  65. %__install -dm 755 %{buildroot}%{_includedir}/ZenLib
  66. %__install -m 644 Source/ZenLib/*.h \
  67. %{buildroot}%{_includedir}/ZenLib
  68. for i in Base64 HTTP_Client Format/Html Format/Http TinyXml; do
  69. %__install -dm 755 %{buildroot}%{_includedir}/ZenLib/$i
  70. %__install -m 644 Source/ZenLib/$i/*.h \
  71. %{buildroot}%{_includedir}/ZenLib/$i
  72. done
  73. %__sed -i -e 's|Version: |Version: %{version}|g' \
  74. Project/GNU/Library/libzen.pc
  75. %__install -dm 755 %{buildroot}%{_libdir}/pkgconfig
  76. %__install -m 644 Project/GNU/Library/libzen.pc \
  77. %{buildroot}%{_libdir}/pkgconfig
  78. # remove unpackaged files
  79. rm -f ${RPM_BUILD_ROOT}/%{_libdir}/*.la
  80. %clean
  81. [ -d "%{buildroot}" -a "%{buildroot}" != "" ] && %__rm -rf "%{buildroot}"
  82. %post -n libzen -p /sbin/ldconfig
  83. %postun -n libzen -p /sbin/ldconfig
  84. %files
  85. %defattr(-,root,root,-)
  86. %doc History.txt License.txt ReadMe.txt
  87. %{_libdir}/libzen.so.*
  88. %files -n libzen-devel
  89. %defattr(-,root,root,-)
  90. %doc Documentation.html
  91. %doc Doc/*
  92. %dir %{_includedir}/ZenLib
  93. %{_includedir}/ZenLib/*
  94. %{_libdir}/libzen.so
  95. %{_libdir}/pkgconfig/*.pc
  96. %changelog
  97. * Fri Jul 15 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.20-1
  98. - new upstream release
  99. * Sat Dec 25 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.17-1
  100. - new upstream release
  101. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.15-4
  102. - rebuilt with rpm-4.8.1 for pkg-config
  103. * Sat Aug 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.15-3
  104. - fixed Group to System Environment/Libraries
  105. * Sat Jul 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.15-2
  106. - fix %install (add install directory)
  107. * Tue Jun 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15-1
  108. - new upstream release
  109. * Tue Jul 28 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.3-1
  110. - new upstream release
  111. - change spec file name to libzen-vl.spec
  112. - add japanese summary and description
  113. - change group for -devel sub package to Development/Libraries
  114. - add configure option --disable-static
  115. - remove unpackaged file (.la)
  116. - add Packager tag
  117. * Tue Jan 01 2009 Jerome Martinez <zen@mediaarea.net> - 0.3.6-0
  118. - See History.txt for more info and real dates
  119. - Previous packages made by Toni Graffy <toni@links2linux.de>