libwebp-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199
  1. %bcond_with java
  2. Name: libwebp
  3. Summary: Library and tools for the WebP graphics format
  4. Summary(ja): WebP 画像フォーマットのためのライブラリとツール
  5. Version: 1.3.2
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: iwaim
  11. # Additional IPR is licensed as well. See PATENTS file for details
  12. License: BSD
  13. URL: https://developers.google.com/speed/webp
  14. Source0: https://github.com/webmproject/libwebp/archive/v%{version}.tar.gz#/libwebp-%{version}.tar.gz
  15. Source1: libwebp_jni_example.java
  16. # Fix build with freeglut
  17. Patch0: libwebp-freeglut.patch
  18. # Fix cmake module install location
  19. Patch2: libwebp-cmakedir.patch
  20. # Kill rpath
  21. Patch3: libwebp-rpath.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: cmake
  24. BuildRequires: libjpeg-devel
  25. BuildRequires: libpng-devel
  26. BuildRequires: libtool
  27. BuildRequires: freeglut-devel
  28. %if %{with java}
  29. BuildRequires: swig
  30. BuildRequires: java-1.8.0-openjdk-devel
  31. BuildRequires: jpackage-utils
  32. %endif
  33. %description
  34. WebP is an image format that does lossy compression of digital
  35. photographic images. WebP consists of a codec based on VP8, and a
  36. container based on RIFF. Webmasters, web developers and browser
  37. developers can use WebP to compress, archive and distribute digital
  38. images more efficiently.
  39. %package tools
  40. Summary: The WebP command line tools
  41. Summary(ja): WebP コマンドラインツール
  42. Group: graphics
  43. %description tools
  44. WebP is an image format that does lossy compression of digital
  45. photographic images. WebP consists of a codec based on VP8, and a
  46. container based on RIFF. Webmasters, web developers and browser
  47. developers can use WebP to compress, archive and distribute digital
  48. images more efficiently.
  49. %package devel
  50. Summary: Development files for libwebp, a library for the WebP format
  51. Summary(ja): WebP フォーマットのためのライブラリ libwebp の開発ファイル
  52. Group: programming
  53. Requires: %{name} = %{version}-%{release}
  54. %description devel
  55. WebP is an image format that does lossy compression of digital
  56. photographic images. WebP consists of a codec based on VP8, and a
  57. container based on RIFF. Webmasters, web developers and browser
  58. developers can use WebP to compress, archive and distribute digital
  59. images more efficiently.
  60. %if %{with java}
  61. %package java
  62. Summary: Java bindings for libwebp, a library for the WebP format
  63. Summary(ja): WebP フォーマットのためのライブラリ libwebp の Java バインディング
  64. Group: programming
  65. Requires: %{name} = %{version}-%{release}
  66. Requires: java
  67. Requires: jpackage-utils
  68. %description java
  69. Java bindings for libwebp.
  70. %endif
  71. %debug_package
  72. %prep
  73. %autosetup -p1
  74. %build
  75. %global optflags %{optflags} -fPIC
  76. %cmake
  77. %cmake_build
  78. %if %{with java}
  79. # swig generated Java bindings
  80. cp %{SOURCE1} .
  81. cd swig
  82. rm -rf libwebp.jar libwebp_java_wrap.c
  83. mkdir -p java/com/google/webp
  84. swig -ignoremissing -I../src -java \
  85. -package com.google.webp \
  86. -outdir java/com/google/webp \
  87. -o libwebp_java_wrap.c libwebp.swig
  88. gcc %{optflags} -shared \
  89. -I/usr/lib/jvm/java/include \
  90. -I/usr/lib/jvm/java/include/linux \
  91. -I../src \
  92. -L../src/.libs -lwebp libwebp_java_wrap.c \
  93. -o libwebp_jni.so
  94. cd java
  95. javac com/google/webp/libwebp.java
  96. jar cvf ../libwebp.jar com/google/webp/*.class
  97. %endif
  98. %install
  99. %cmake_install
  100. %if %{with java}
  101. # swig generated Java bindings
  102. mkdir -p %{buildroot}/%{_libdir}/%{name}-java
  103. cp swig/*.jar swig/*.so %{buildroot}/%{_libdir}/%{name}-java/
  104. %endif
  105. %files tools
  106. %{_bindir}/*
  107. %{_mandir}/man*/*
  108. %files -n %{name}
  109. %license COPYING PATENTS
  110. %doc README* NEWS AUTHORS
  111. %{_libdir}/%{name}*.so.*
  112. %{_libdir}/libsharpyuv.so.*
  113. %files devel
  114. %{_libdir}/%{name}*.so
  115. %{_libdir}/libsharpyuv.so
  116. %{_includedir}/*
  117. %{_libdir}/pkgconfig/*
  118. %{_libdir}/cmake/*
  119. %if %{with java}
  120. %files java
  121. %doc libwebp_jni_example.java
  122. %{_libdir}/%{name}-java/
  123. %endif
  124. %changelog
  125. * Thu Sep 28 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.2-1
  126. - new upstream release.
  127. * Wed Jul 05 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-1
  128. - new upstream release.
  129. * Fri Sep 23 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-1
  130. - new upstream release.
  131. * Fri Apr 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.0-1
  132. - new upstream release.
  133. * Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1-1
  134. - new upstream release.
  135. * Sun Oct 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.3.1-3
  136. - moved libwebp to System Environment/Libraries Group
  137. * Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.1-2
  138. - rebuild with libpng-1.6.12
  139. * Sat Oct 12 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.3.1-1
  140. - new upstream release
  141. * Sat Jan 12 2013 IWAI, Masaharu <iwai@alib.jp> 0.2.1-1
  142. - initial build for Vine Linux
  143. * Thu Dec 27 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.2.1-1
  144. - new upstream release 0.2.1
  145. * Fri Dec 21 2012 Adam Tkac <atkac redhat com> - 0.1.3-3
  146. - rebuild against new libjpeg
  147. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.3-2
  148. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  149. * Thu Feb 02 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.3-1
  150. - Several spec improvements by Scott Tsai <scottt.tw@gmail.com>
  151. * Wed May 25 2011 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.2-1
  152. - Initial spec. Based on openSUSE one