gnome-power-manager-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361
  1. %define dbus_version 1.4.16
  2. %define dbus_glib_version 0.96
  3. %define gnome_panel_version 3.2.0
  4. Summary: GNOME power management service
  5. Summary(ja): GNOME 電源管理ツール
  6. Name: gnome-power-manager
  7. Version: 3.2.1
  8. Release: 1%{?_dist_release}
  9. License: GPLv2+ and GFDL
  10. Group: Applications/System
  11. URL: http://projects.gnome.org/gnome-power-manager/
  12. Source0: http://download.gnome.org/sources/gnome-power-manager/3.2/gnome-power-manager-%{version}.tar.xz
  13. # ja.po from l10n
  14. Source101: gnome-power-manager.gnome-2-32.ja.po
  15. # for Vine Linux
  16. Patch10: gnome-power-manager-2.28.2-warningflags.patch
  17. Patch11: gnome-power-manager-2.28.2-math.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: autoconf >= 2.65
  20. BuildRequires: gtk3-devel
  21. BuildRequires: libgnomeui-devel
  22. BuildRequires: libglade2-devel
  23. BuildRequires: libwnck-devel
  24. BuildRequires: dbus-devel >= %{dbus_version}
  25. BuildRequires: libnotify-devel
  26. BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
  27. BuildRequires: scrollkeeper
  28. BuildRequires: gnome-doc-utils >= 0.3.2
  29. BuildRequires: desktop-file-utils
  30. BuildRequires: gettext
  31. BuildRequires: libtool
  32. BuildRequires: cairo-devel
  33. BuildRequires: libcanberra-gtk3-devel
  34. BuildRequires: unique3-devel >= 3.0.0
  35. ## BuildRequires: DeviceKit-power-devel >= 008
  36. BuildRequires: upower-devel >= 0.9.0
  37. BuildRequires: control-center-devel
  38. BuildRequires: intltool
  39. BuildRequires: docbook-utils
  40. Requires: gtk3 >= 3.0.0
  41. Requires: gnome-mime-data
  42. Requires: gnome-icon-theme
  43. Requires: libnotify >= 0.4.3
  44. Requires: dbus-glib >= %{dbus_glib_version}
  45. Requires: dbus-x11 >= %{dbus_version}
  46. Requires: libcanberra-gtk3 >= 0.10
  47. Requires: unique3 >= 3.0.0
  48. Requires: upower >= 0.9.0
  49. Requires(post,postun): scrollkeeper
  50. Requires(post,pre,preun): GConf2
  51. Obsoletes: gnome-power-manager-extra < 3.0.0
  52. Provides: gnome-power-manager-extra
  53. Vendor: Project Vine
  54. Distribution: Vine Linux
  55. Packager: daisuke, Takemikaduchi
  56. %description
  57. GNOME Power Manager uses the information and facilities provided by HAL
  58. displaying icons and handling user callbacks in an interactive GNOME session.
  59. GNOME Power Preferences allows authorised users to set policy and
  60. change preferences.
  61. %prep
  62. %setup -q
  63. #%setup -q -n %{?name}-%{?version}-%{?alphatag}
  64. ## %patch10 -p1 -b .warnings
  65. ## %patch11 -p1 -b .math
  66. # copy ja.po
  67. #cp -f %{SOURCE101} po/ja.po
  68. # autoreconf -i
  69. %build
  70. %configure \
  71. --disable-scrollkeeper
  72. make
  73. # strip unneeded translations from .mo files
  74. # ideally intltool (ha!) would do that for us
  75. # http://bugzilla.gnome.org/show_bug.cgi?id=474987
  76. #cd po
  77. #grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
  78. #mv POTFILES.keep POTFILES.in
  79. #intltool-update --pot
  80. #for p in *.po; do
  81. # msgmerge $p %{name}.pot > $p.out
  82. # msgfmt -o `basename $p .po`.gmo $p.out
  83. #done
  84. %install
  85. rm -rf $RPM_BUILD_ROOT
  86. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  87. make install DESTDIR=$RPM_BUILD_ROOT
  88. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  89. #desktop-file-install --vendor gnome --delete-original \
  90. # --dir $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart \
  91. # $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/gnome-power-manager.desktop
  92. # save space by linking identical images in translated docs
  93. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  94. for f in $helpdir/C/figures/*.png; do
  95. b="$(basename $f)"
  96. for d in $helpdir/*; do
  97. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  98. g="$d/figures/$b"
  99. if [ -f "$g" ]; then
  100. if cmp -s $f $g; then
  101. rm "$g"; ln -s "../../C/figures/$b" "$g"
  102. fi
  103. fi
  104. fi
  105. done
  106. done
  107. %find_lang %name --with-gnome
  108. %clean
  109. rm -rf $RPM_BUILD_ROOT
  110. %post
  111. scrollkeeper-update -q &> /dev/null || :
  112. touch --no-create %{_datadir}/icons/hicolor
  113. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  114. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  115. fi
  116. %postun
  117. scrollkeeper-update -q &> /dev/null || :
  118. touch --no-create %{_datadir}/icons/hicolor
  119. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  120. gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null || :
  121. fi
  122. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  123. %posttrans
  124. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  125. %files -f %{name}.lang
  126. %defattr(-,root,root)
  127. %doc AUTHORS COPYING README
  128. %{_bindir}/gnome-power-statistics
  129. %dir %{_datadir}/gnome-power-manager
  130. %{_datadir}/gnome-power-manager/gpm-statistics.ui
  131. %{_datadir}/applications/gnome-power-statistics.desktop
  132. %{_datadir}/glib-2.0/schemas/*.xml
  133. %{_datadir}/gnome-power-manager/icons/hicolor/*/*/*.*
  134. %{_datadir}/icons/hicolor/*/apps/*
  135. %{_mandir}/man1/gnome-power-statistics.1.gz
  136. %changelog
  137. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  138. - new upstream release
  139. * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  140. - new upstream release
  141. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  142. - new upstream release
  143. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
  144. - new upstream release
  145. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
  146. - new upstream release
  147. - add BuildRequires: gtk3-devel, control-center-devel
  148. - change BuildRequires: libcanberra-gtk3-devel instead of licanberra-devel
  149. - change BuildRequires: unique3-devel instead of unique-devel
  150. - delete -extra sub package
  151. * Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
  152. - add Source101(gnome-power-manager.gnome-2-32.ja.po)
  153. * Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  154. - new upstream release
  155. - change BuildRequires: gnome-panel-devel instead of gnome-panel
  156. - fix %files
  157. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  158. - new upstream release
  159. * Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  160. - new upstream release
  161. - remove Patch1, Patch2, Patch3
  162. - change BuildRequires: DeviceKit-power-devel -> upower-devel
  163. - change Requires: DeviceKit-power -> upower
  164. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  165. - new upstream release
  166. - change BuildRequires: xmlto -> docbook-utils
  167. - remove BuildReuiqres: hal-devel
  168. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  169. - new upstream release
  170. * Tue Dec 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  171. - merge spec file from FC package
  172. - add Patch1, Patch2 and Patch3 from FC package
  173. - add Patch10 and Patch11 for Vine Linux
  174. - remove configure option --enable-policykit
  175. - add new package (extra)
  176. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.4-1
  177. - new upstream release
  178. * Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  179. - new upstream release
  180. * Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  181. - new upstream release
  182. * Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  183. - new upstream release
  184. * Sun Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
  185. - new upstream release
  186. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl2
  187. - rebuild with new environment/toolchain
  188. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
  189. - new upstream release
  190. - drop Patch10 to enable suspend-to-ram.
  191. * Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-0vl1
  192. - new upstream release
  193. * Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.91-0vl1
  194. - new upstream release
  195. * Mon Jul 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.90-0vl1
  196. - new upstream release
  197. * Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.3-0vl1
  198. - new upstream release
  199. * Wed May 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.2-0vl1
  200. - new upstream release
  201. * Wed Apr 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.1-0vl1
  202. - new upstream release
  203. * Mon Apr 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-0vl1
  204. - new upstream release
  205. * Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  206. - new upstream release
  207. * Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
  208. - add Patch10 to disable suspend-to-ram by default.
  209. * Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
  210. - update ja.po from CVS head.
  211. * Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  212. - new upstream release
  213. * Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
  214. - initial build for Vine Linux based on FC package
  215. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-4
  216. - fix the fix in -2 and -3
  217. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-3
  218. - fix the fix in -2
  219. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-2
  220. - fix icon in bubbles (bug 184192).
  221. * Fri Mar 3 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-1
  222. - Update to 2.13.93
  223. - ignore d-bus timeout errors
  224. * Thu Mar 2 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-3
  225. - Add patch from Richard Hughes to potentially fix a
  226. crasher bug (bug 183127)
  227. * Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.92-2
  228. - Buildrequires: gnome-doc-utils
  229. * Sun Feb 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-1
  230. - Update to 2.13.92
  231. * Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.91-1
  232. - Update to 2.13.91
  233. - Drop upstreamed patch
  234. * Wed Feb 15 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.90-1
  235. - Update to 2.13.90
  236. - Require dbus-x11 (#176656)
  237. * Sun Feb 13 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-2
  238. - remove Hibernate and Suspend from menus as part of
  239. panel/g-p-m integration effort
  240. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5.0.20060207-1.1
  241. - bump again for double-long bug on ppc(64)
  242. * Tue Feb 7 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-1
  243. - pull cvs snapshot from HEAD and drop the patches caillon
  244. just added
  245. * Tue Feb 7 2006 Christopher Aillon <caillon@redhat.com> - 2.13.5-3
  246. - Install into the autostart directory
  247. - Don't suspend on lid close while on AC power
  248. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5-2.1
  249. - rebuilt for new gcc4.1 snapshot and glibc changes
  250. * Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.5-2
  251. - rebuild
  252. * Thu Jan 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.5-1
  253. - packaging tweaks
  254. * Thu Jan 26 2006 Christopher Aillon <caillon@redhat.com> 2.13.5-1
  255. - Update to 2.13.5
  256. * Tue Jan 24 2006 Christopher Aillon <caillon@redhat.com> - 0.3.4-2
  257. - Left clicking on the applet should bring up the menu
  258. * Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 0.3.4-1
  259. - update to 0.3.4
  260. - disable updating scrollkeeper database in buildroot
  261. (move to %%post)
  262. * Fri Jan 6 2006 Jeremy Katz <katzj@redhat.com> - 0.3.3-0.cvs.20060106
  263. - update to a cvs snap so that it works with hal cvs snap
  264. - make sure we use libnotify
  265. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> - 0.3.1-2.1
  266. - rebuilt
  267. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
  268. - rebuild for new dbus
  269. * Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> 0.3.1-1
  270. - Update to 0.3.1
  271. * Fri Nov 25 2005 Christopher Aillon <caillon@redhat.com> 0.3.0-1
  272. - Update to 0.3.0
  273. * Wed Oct 19 2005 Ray Strode <rstrode@redhat.com> 0.2.8-1
  274. - update to 0.2.8
  275. * Wed Oct 3 2005 Ray Strode <rstrode@redhat.com> 0.2.6-1
  276. - update to 0.2.6
  277. * Wed Sep 28 2005 Ray Strode <rstrode@redhat.com> 0.2.4-1
  278. - update to 0.2.4
  279. * Fri Sep 02 2005 David Zeuthen <davidz@redhat.com> 0.2.3.1-1
  280. - Initial import based on an SRPM from Richard Hughes