gtest-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137
  1. Summary: Google C++ testing framework
  2. Summary(ja): Google C++ テスティングフレームワーク
  3. Name: gtest
  4. Version: 1.5.0
  5. Release: 2%{?_dist_release}
  6. License: New BSD
  7. Group: Development/Tools
  8. URL: http://code.google.com/p/googletest/
  9. Source0: http://googletest.googlecode.com/files/%{name}-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: chrpath
  12. BuildRequires: python >= 2.3
  13. %description
  14. Google's framework for writing C++ tests on a variety of platforms (GNU/Linux,
  15. Mac OS X, Windows, Windows CE, and Symbian). Based on the xUnit architecture.
  16. Supports automatic test discovery, a rich set of assertions, user-defined
  17. assertions, death tests, fatal and non-fatal failures, various options for
  18. running the tests, and XML test report generation.
  19. %package devel
  20. Summary: Development files for %{name}
  21. Summary(ja): %{name} の開発ファイル
  22. Group: Development/Libraries
  23. Requires: automake
  24. Requires: %{name} = %{version}-%{release}
  25. %description devel
  26. This package contains development files for %{name}.
  27. %prep
  28. %setup -q
  29. # Keep a clean copy of samples.
  30. cp -pr ./samples ./samples.orig
  31. %build
  32. %configure --disable-static
  33. # Omit unused direct shared library dependencies.
  34. sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
  35. make %{?_smp_mflags}
  36. %check
  37. # Two tests fail here, unclear as to why.
  38. make check
  39. # Restore the clean copy of samples.
  40. # To be later listed against %doc.
  41. rm -rf ./samples
  42. mv ./samples.orig ./samples
  43. %install
  44. rm -rf $RPM_BUILD_ROOT
  45. make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
  46. find $RPM_BUILD_ROOT -type f -name "*.la" -delete
  47. # Remove rpaths.
  48. chrpath --delete $RPM_BUILD_ROOT%{_libdir}/libgtest_main.so.0.0.0
  49. %clean
  50. rm -rf $RPM_BUILD_ROOT
  51. %post -p /sbin/ldconfig
  52. %postun -p /sbin/ldconfig
  53. %files
  54. %defattr(-,root,root,-)
  55. %doc CHANGES
  56. %doc CONTRIBUTORS
  57. %doc COPYING
  58. %doc README
  59. %{_libdir}/libgtest.so.*
  60. %{_libdir}/libgtest_main.so.*
  61. %files devel
  62. %defattr(-,root,root,-)
  63. %doc samples
  64. %{_bindir}/%{name}-config
  65. %{_datadir}/aclocal/%{name}.m4
  66. %{_libdir}/libgtest.so
  67. %{_libdir}/libgtest_main.so
  68. %dir %{_includedir}/%{name}
  69. %{_includedir}/%{name}/*.h
  70. %{_includedir}/%{name}/internal
  71. %changelog
  72. * Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-2
  73. - rebuilt with rpm-4.8.1 for pkg-config
  74. * Sun May 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-1
  75. - initial build for VineSeed
  76. * Sat Nov 14 2009 Debarshi Ray <rishi@fedoraproject.org> - 1.4.0-1
  77. - Version bump to 1.4.0.
  78. * New feature: the event listener API.
  79. * New feature: test shuffling.
  80. * New feature: the XML report format is closer to junitreport and can
  81. be parsed by Hudson now.
  82. * New feature: elapsed time for the tests is printed by default.
  83. * New feature: comes with a TR1 tuple implementation such that Boost
  84. is no longer needed for Combine().
  85. * New feature: EXPECT_DEATH_IF_SUPPORTED macro and friends.
  86. * New feature: the Xcode project can now produce static gtest libraries in
  87. addition to a framework.
  88. * Compatibility fixes for gcc and minGW.
  89. * Bug fixes and implementation clean-ups.
  90. * Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 1.3.0-2.20090601svn257
  91. - Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  92. * Mon Jun 01 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.3.0-1
  93. - Version bump to 1.3.0.
  94. * New feature: ability to use Google Test assertions in other testing
  95. frameworks.
  96. * New feature: ability to run disabled test via
  97. --gtest_also_run_disabled_tests.
  98. * New feature: the --help flag for printing the usage.
  99. * New feature: access to Google Test flag values in user code.
  100. * New feature: a script that packs Google Test into one .h and one .cc file
  101. for easy deployment.
  102. * New feature: support for distributing test functions to multiple machines
  103. (requires support from the test runner).
  104. * Bug fixes and implementation clean-ups.
  105. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  107. * Sat Jul 05 2008 Debarshi Ray <rishi@fedoraproject.org> - 1.0.0-1
  108. - Initial build.