ModemManager-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335
  1. #%define git_snapshot .git20130607
  2. %define git_snapshot %{nil}
  3. %define ppp_version 2.4.5
  4. %define glib2_version 2.36
  5. Summary: Mobile broadband modem management service
  6. Summary(ja): Mobile broadband modem management service
  7. Name: ModemManager
  8. Version: 1.0.0
  9. Release: 2%{git_snapshot}%{?_dist_release}
  10. License: GPLv2+
  11. Group: System Environment/Base
  12. URL: http://www.gnome.org/projects/NetworkManager/
  13. #
  14. # Source from git://anongit.freedesktop.org/ModemManager/ModemManager
  15. # tarball built with:
  16. # ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
  17. # make distcheck
  18. #
  19. #Source: %{name}-%{version}%{git_snapshot}.tar.bz2
  20. Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
  21. Patch0: buildsys-hates-openpty.patch
  22. Patch1: ModemManager-1.0.0-git20130911.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  24. Requires: dbus-glib
  25. Requires: glib2
  26. BuildRequires: glib2-devel >= %{glib2_version}
  27. BuildRequires: dbus-glib-devel >= 0.92
  28. BuildRequires: libgudev1-devel >= 143
  29. BuildRequires: ppp = %{ppp_version}
  30. BuildRequires: ppp-devel = %{ppp_version}
  31. BuildRequires: automake autoconf intltool libtool
  32. BuildRequires: gtk-doc
  33. # for xsltproc
  34. BuildRequires: libxslt
  35. %description
  36. The ModemManager service manages WWAN modems and provides a consistent API for
  37. interacting with these devices to client applications.
  38. %package devel
  39. Summary: Development tools for %{name}
  40. Summary(ja): %{name} の開発環境
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. Requires: pkgconfig
  44. %description devel
  45. Header files and libraries for building a extension library for the %{name}.
  46. %package glib
  47. Summary: Libraries for adding ModemManager support to applications that use glib.
  48. Group: Development/Libraries
  49. Requires: glib2 >= %{glib2_version}
  50. %description glib
  51. This package contains the libraries that make it easier to use some ModemManager
  52. functionality from applications that use glib.
  53. %package glib-devel
  54. Summary: Development tools for %{name}-glib
  55. Summary(ja): %{name}-glib の開発環境
  56. Group: Development/Libraries
  57. Requires: %{name}-glib = %{version}-%{release}
  58. Requires: %{name}-devel = %{version}-%{release}
  59. Requires: glib2-devel
  60. Requires: pkgconfig
  61. %description glib-devel
  62. Header files and libraries for building a extension library for the %{name}-glib.
  63. %prep
  64. %setup -q
  65. %patch0 -p1 -b .pty
  66. %patch1 -p1
  67. %build
  68. autoreconf -if
  69. intltoolize --force
  70. pppddir=`ls -1d %{_libdir}/pppd/2*`
  71. %configure \
  72. --enable-more-warnings=yes \
  73. --with-udev-base-dir=/lib/udev \
  74. --with-tests=yes \
  75. --enable-gtk-doc=yes \
  76. --without-qmi \
  77. --disable-static \
  78. --with-pppd-plugin-dir=$pppddir \
  79. --with-polkit=no \
  80. --with-mbim=no
  81. make %{?_smp_mflags}
  82. %check
  83. make check
  84. %install
  85. make install DESTDIR=$RPM_BUILD_ROOT
  86. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  87. rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
  88. %post
  89. /sbin/ldconfig
  90. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  91. %postun
  92. /sbin/ldconfig
  93. if [ $1 -eq 0 ]; then
  94. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  95. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  96. fi
  97. %posttrans
  98. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  99. %post glib -p /sbin/ldconfig
  100. %postun glib -p /sbin/ldconfig
  101. %files
  102. %defattr(0644, root, root, 0755)
  103. %doc COPYING README
  104. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
  105. %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
  106. %attr(0755,root,root) %{_sbindir}/ModemManager
  107. %attr(0755,root,root) %{_bindir}/mmcli
  108. %dir %{_libdir}/%{name}
  109. %attr(0755,root,root) %{_libdir}/%{name}/*.so*
  110. /lib/udev/rules.d/*
  111. %{_datadir}/dbus-1/interfaces/*.xml
  112. %{_datadir}/icons/hicolor/22x22/apps/*.png
  113. %{_mandir}/man8/*
  114. %files devel
  115. %defattr(0644, root, root, 0755)
  116. %{_includedir}/ModemManager/*.h
  117. %dir %{_datadir}/gtk-doc/html/%{name}
  118. %{_datadir}/gtk-doc/html/%{name}/*
  119. %{_libdir}/pkgconfig/%{name}.pc
  120. %files glib
  121. %defattr(0644, root, root, 0755)
  122. %{_libdir}/libmm-glib.so.*
  123. %files glib-devel
  124. %defattr(0644, root, root, 0755)
  125. %{_libdir}/libmm-glib.so
  126. %dir %{_includedir}/libmm-glib
  127. %{_includedir}/libmm-glib/*.h
  128. %{_libdir}/pkgconfig/mm-glib.pc
  129. %dir %{_datadir}/gtk-doc/html/libmm-glib
  130. %{_datadir}/gtk-doc/html/libmm-glib/*
  131. %changelog
  132. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
  133. - add Patch1 (ModemManager-1.0.0-git20130911.patch)
  134. * Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  135. - new upstream release
  136. - update Patch0
  137. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
  138. - update to 0.7.991 snapshot
  139. - fix spec file based on FC package
  140. * Fri Jun 7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
  141. - Update to 0.7.991 snapshot
  142. - Fix SMS validity parsing
  143. - Allow registration changes to 'searching' without disconnecting
  144. - Fix reading SMS messages from some QMI-based devices
  145. - Increase connection timeout for Novatel E362
  146. - Fix PIN retries checking when unlocking Ericsson devices
  147. - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
  148. - add configure option (--enable-gtk-doc=yes, --without-qmi)
  149. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
  150. - new upstream release
  151. * Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
  152. - new upstream release
  153. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
  154. - delete Patch20
  155. * Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
  156. - update Patch20 (ModemManager-0.4-git20110428.patch)
  157. - delete Patch21,22
  158. * Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
  159. - update to 0.4
  160. - add Patch20 (ModemManager-0.4-git20100720.patch)
  161. - add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
  162. - add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
  163. * Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
  164. - initial build for Vine Linux
  165. * Sun May 2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
  166. - core: ignore some failures on disconnect (rh #578280)
  167. - core: add support for platform serial devices
  168. - gsm: better Blackberry DUN support
  169. - gsm: periodically poll access technology
  170. - cdma: prevent crash on modem removal (rh #571921)
  171. - mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
  172. - novatel: better signal strength reporting on CDMA cards
  173. - novatel: add access technology and mode preference support on GSM cards
  174. - zte: fix mode preference retrieval
  175. - longcheer: add support for Zoom modems (4595, 4596, etc)
  176. - longcheer: add access technology and mode preference support
  177. * Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
  178. - Silence %%post
  179. - Update scripts
  180. * Fri Apr 9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
  181. - gsm: fix parsing Blackberry supported character sets response
  182. * Thu Apr 8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
  183. - mbm: fix retrieval of current allowed mode
  184. - gsm: fix initialization issues with some devices (like Blackberries)
  185. * Mon Apr 5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
  186. - core: fix detection of some generic devices (rh #579247)
  187. - core: fix detection regression of some Huawei devices in 0.3-5
  188. - cdma: periodically poll registration state and signal quality
  189. - cdma: really fix registration detection on various devices (rh #569067)
  190. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
  191. - core: fix PPC/SPARC/etc builds
  192. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
  193. - core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
  194. - cdma: handle signal quality requests while connected for more devices
  195. - cdma: handle serving system requests while connected for more devices
  196. - gsm: determine current access technology earlier
  197. - huawei: work around automatic registration issues on some devices
  198. * Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
  199. - core: ensure enabled modems are disabled when MM stops
  200. - core: better capability detection for Blackberry devices (rh #573510)
  201. - cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
  202. - gsm: don't block modem when it requires PIN2
  203. - option: fix access technology updates
  204. * Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
  205. - mbm: add device IDs for C3607w
  206. - mbm: fail earlier during connection failures
  207. - mbm: fix username/password authentication when checked by the network
  208. - hso: implement asynchronous signal quality updates
  209. - option: implement asynchronous signal quality updates
  210. - novatel: correctly handle CDMA signal quality
  211. - core: basic PolicyKit support
  212. - core: fix direct GSM registration information requests
  213. - core: general GSM PIN/PUK unlock fixes
  214. - core: poll GSM registration state internally for quicker status updates
  215. - core: implement GSM 2G/3G preference
  216. - core: implement GSM roaming allowed/disallowed preference
  217. - core: emit signals on access technology changes
  218. - core: better handling of disconnections
  219. - core: fix simple CDMA status requests
  220. * Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
  221. - core: startup speed improvements
  222. - core: GSM PIN checking improvements
  223. - huawei: fix EVDO-only connections on various devices (rh #553199)
  224. - longcheer: add support for more devices
  225. * Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
  226. - anydata: new plugin for AnyData CDMA modems (rh #547294)
  227. - core: fix crashes when devices are unplugged during operation (rh #553953)
  228. - cdma: prefer primary port for status/registration queries
  229. - core: fix probing/detection of some PIN-locked devices (rh #551376)
  230. - longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
  231. - gsm: fix Nokia N80 network scan parsing
  232. * Fri Jan 1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
  233. - core: fix apparent hangs by limiting retried serial writes
  234. - gsm: ensure modem state is reset when disabled
  235. * Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
  236. - sierra: fix CDMA registration detection in some cases (rh #547513)
  237. * Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
  238. - sierra: ensure CDMA device is powered up when trying to use it
  239. - cdma: better signal quality parsing (fixes ex Huawei EC168C)
  240. - zte: handle unsolicited messages better during probing
  241. * Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
  242. - cdma: fix signal strength reporting on some devices
  243. - cdma: better registration state detection when dialing (ex Sierra 5275)
  244. - option: always use the correct tty for dialing commands
  245. * Mon Dec 7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
  246. - core: fix reconnect after manual disconnect (rh #541314)
  247. - core: fix various segfaults during registration
  248. - core: fix probing of various modems on big-endian architectures (ie PPC)
  249. - core: implement modem states to avoid duplicate operations
  250. - hso: fix authentication for Icera-based devices like iCON 505
  251. - zte: use correct port for new devices
  252. - nozomi: fix detection
  253. * Thu Nov 5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
  254. - Update to latest git
  255. - core: fix pppd 2.4.5 errors about 'baudrate 0'
  256. - cdma: wait for network registration before trying to connect
  257. - gsm: add cell access technology reporting
  258. - gsm: allow longer-running network scans
  259. - mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
  260. - nokia: don't power down phones on disconnect
  261. - hso: fix disconnection/disable
  262. * Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
  263. - Fixes for Motorola and Ericsson devices
  264. - Fixes for CDMA "serving-system" command parsing
  265. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
  266. - Fix a typo in one of the udev rules files
  267. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
  268. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  269. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
  270. - Fix source repo location
  271. - Fix directory ownership
  272. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
  273. - Initial version