slang-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: The shared library for the S-Lang extension language
  3. Summary(ja): S-Lang 拡張言語ライブラリ
  4. Name: slang
  5. Version: 2.1.4
  6. Release: 5%{?_dist_release}
  7. License: GPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://www.jedsoft.org/slang/
  10. Source: ftp://space.mit.edu/pub/davis/slang/v2.1/%{name}-%{version}.tar.bz2
  11. Patch1: slang-2.1.4-makefile.patch
  12. Patch2: slang-nointerlibc2.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: libpng-devel
  15. BuildRequires: oniguruma-devel
  16. BuildRequires: pcre-devel
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  20. %description
  21. S-lang (pronounced `sssslang'') is a powerful stack based interpreter
  22. that supports a C-like syntax. It has been designed from the beginning
  23. to be easily embedded into a program to make it extensible. Slang also
  24. provides a way to quickly develop and debug the application embedding it
  25. in a safe and efficient manner. Since slang resembles C, it is easy to
  26. recode slang procedures in C if the need arises.
  27. %description -l ja
  28. S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
  29. ・インタプリタです。開発初期から、プログラムに容易に組み込めるように
  30. デザインされてきました。また、S-lang を用いると、アプリケーションを安
  31. 全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
  32. 必要になれば、S-lang の手続きをCに簡単に変換することもできます。
  33. %package slsh
  34. Summary: Interpreter for S-Lang scripts
  35. Summary(ja): S-Lang スクリプトインタプリタ
  36. Group: Development/Languages
  37. Requires: %{name} = %{version}-%{release}
  38. %description slsh
  39. slsh (slang-shell) is a program for interpreting S-Lang scripts.
  40. It supports dynamic loading of S-Lang modules and includes a readline
  41. interface for interactive use.
  42. This package also includes S-Lang modules that are distributed with
  43. the S-Lang distribution.
  44. %package devel
  45. Summary: Development package for %{name}
  46. Summary(ja): %{name} の開発パッケージ
  47. Group: Development/Libraries
  48. Requires: %{name} = %{version}-%{release}
  49. %description devel
  50. This package contains files which you'll need if you want to
  51. develop S-Lang based applications. Documentation which may help
  52. you write S-Lang based applications is also included.
  53. Install the slang-devel package if you want to develop applications
  54. based on the S-Lang extension language.
  55. #'
  56. %description devel -l ja
  57. このパッケージには S-lang を用いたアプリケーションの開発に必要な静的
  58. ライブラリとヘッダファイルが含まれています。S-lang を記述する助けに
  59. なるようなドキュメントも含まれています。
  60. もし S-lang を使ったアプリケーションを開発するなら、このパッケージを
  61. インストールしてください。
  62. ## to build compat32 for x86_64 architecture support
  63. %package -n compat32-%{name}
  64. Summary: The shared library for the S-Lang extension language
  65. Summary(ja): S-Lang 拡張言語ライブラリ
  66. Group: System Environment/Libraries
  67. Requires: %{name} = %{version}-%{release}
  68. %description -n compat32-%{name}
  69. S-lang (pronounced `sssslang'') is a powerful stack based interpreter
  70. that supports a C-like syntax. It has been designed from the beginning
  71. to be easily embedded into a program to make it extensible. Slang also
  72. provides a way to quickly develop and debug the application embedding it
  73. in a safe and efficient manner. Since slang resembles C, it is easy to
  74. recode slang procedures in C if the need arises.
  75. %description -n compat32-%{name} -l ja
  76. S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
  77. ・インタプリタです。開発初期から、プログラムに容易に組み込めるように
  78. デザインされてきました。また、S-lang を用いると、アプリケーションを安
  79. 全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
  80. 必要になれば、S-lang の手続きをCに簡単に変換することもできます。
  81. %package -n compat32-%{name}-devel
  82. Summary: Development package for %{name}
  83. Summary(ja): %{name} の開発パッケージ
  84. Group: Development/Libraries
  85. Requires: compat32-%{name} = %{version}-%{release}
  86. Requires: %{name}-devel = %{version}-%{release}
  87. %description -n compat32-%{name}-devel
  88. This package contains files which you'll need if you want to
  89. develop S-Lang based applications. Documentation which may help
  90. you write S-Lang based applications is also included.
  91. Install the slang-devel package if you want to develop applications
  92. based on the S-Lang extension language.
  93. #'
  94. %prep
  95. %setup -q
  96. %patch1 -p1 -b .makefile
  97. %patch2 -p1 -b .nointerlibc2
  98. %build
  99. %configure --includedir=%{_includedir}/slang
  100. make %{?_smp_mflags} install_doc_dir=%{_docdir}/%{name}-%{version}
  101. %install
  102. rm -rf ${RPM_BUILD_ROOT}
  103. make install-all INSTALL="install -p" DESTDIR=$RPM_BUILD_ROOT
  104. rm -rf $RPM_BUILD_ROOT%{_docdir}/{slang,slsh}
  105. %clean
  106. rm -rf ${RPM_BUILD_ROOT}
  107. %post -p /sbin/ldconfig
  108. %postun -p /sbin/ldconfig
  109. %post -n compat32-%{name} -p /sbin/ldconfig
  110. %postun -n compat32-%{name} -p /sbin/ldconfig
  111. %files
  112. %defattr(-,root,root)
  113. %doc COPYING doc/README changes.txt doc/*/slang*.txt doc/*.txt
  114. %{_libdir}/libslang*.so.*
  115. %files slsh
  116. %defattr(-,root,root)
  117. %doc slsh/doc/html/slsh*.html
  118. %config(noreplace) %{_sysconfdir}/slsh.rc
  119. %{_bindir}/slsh
  120. %{_libdir}/slang
  121. %{_mandir}/man1/slsh.1*
  122. %{_datadir}/slsh
  123. %files devel
  124. %defattr(-,root,root)
  125. %doc doc/*/cslang*.txt doc/*/cref.txt
  126. %{_libdir}/libslang*.so
  127. %{_libdir}/libslang*.a
  128. %{_includedir}/slang
  129. %if %{build_compat32}
  130. %files -n compat32-%{name}
  131. %defattr(- , root, root)
  132. %{_libdir}/libslang.so.*
  133. %files -n compat32-%{name}-devel
  134. %defattr(- , root, root)
  135. %{_libdir}/libslang.a
  136. %{_libdir}/libslang.so
  137. %endif
  138. %changelog
  139. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.4-5
  140. - rebuild with VineSeed environment
  141. * Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.4-4
  142. - rebuilt with new toolchains
  143. * Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.4-3
  144. - removed unneccesary %if !%{build_compat32} case condition
  145. * Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1.4-2
  146. - rebuilt with oniguruma-5.9.1
  147. * Wed Mar 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-1
  148. - new upstream release
  149. * Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-1
  150. - new upstream release
  151. - drop slang_jp patch
  152. * Sun Aug 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-0vl1
  153. - update to slang-1.4.9
  154. - rediffed slang_jp patch
  155. * Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 1.4.4-0vl5
  156. - change ./configure to %%configure
  157. - uncommented a script to make symbolic link of %%{_libdir}/libslang.so.1
  158. - added compat32-* packages for x86_64 architecture support
  159. * Fri Jul 18 2003 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 1.4.4-0vl4
  160. - rebuild with new toolchains
  161. - s/Copyright/License/
  162. * Sat Feb 9 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl3
  163. - bug fixed canna input for jed
  164. - change patch: bug fixed slsng-console.patch
  165. * Mon Jan 21 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl2
  166. - rebuild with glibc-2.2.4
  167. * Wed Jun 27 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl1
  168. - update to 1.4.4
  169. - use jp0 patch
  170. - use better macros
  171. - use Release No for Vine Linux
  172. * Fri Jan 7 2000 Jun Nishii <jun@vinelinux.org>
  173. [1.2.2_jp-7]
  174. - Japanese summary and description
  175. - change group
  176. * Sun Sep 12 1999 Norihito Ohmori <ohmori@flatout.org>
  177. - rebuild for new environment.
  178. * Fri Jul 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  179. [1.2.2_jp-5]
  180. - Updated to 1.2.2j056
  181. * Sun Feb 21 1999 MATSUMOTO Shoji <vine@flatout.org>
  182. [1.2.2_jp-4]
  183. - fix box bug with KANJI
  184. * Tue Feb 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  185. [1.2.2_jp-2]
  186. - Updated to 1.2.2j054
  187. * Mon Dec 21 1998 MATSUMOTO Shoji <shom@flatout.org>
  188. [1.2.2j052-2]
  189. - patch for linux console and kon
  190. - bug fix for no-kanji version
  191. - separate devel
  192. * Sat Jul 4 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
  193. [1.2.1j-1]
  194. - Updated to 1.2.2 (j052)
  195. * Fri Jun 5 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
  196. [1.2.1j-1]
  197. - japanize patch added
  198. * Mon Apr 13 1998 Manoj Kasichainula <manojk@io.com>
  199. [1.2.1-1]
  200. - Updated to 1.2.1
  201. * Sun Apr 12 1998 Manoj Kasichainula <manojk@io.com>
  202. [1.2.0-1]
  203. - Updated to 1.2.0, the first 1.x non-beta version
  204. * Wed Feb 11 1998 Manoj Kasichainula <manojk@io.com>
  205. [1.0.3-1]
  206. - Updated to 1.0.3
  207. - Minor fixes
  208. * Tue Feb 3 1998 Manoj Kasichainula <manojk@io.com>
  209. - Earlier changes were lost, because of misplacement of RPM:
  210. - BuildRoot
  211. - RPM_OPT_FLAGS
  212. - %clean section
  213. - other minor spec file changes
  214. - Should be buildable by non-root now
  215. - Included untic, a very cool terminfo interpreter (this probably out to be
  216. split out eventually)
  217. - Added bug fix from JED
  218. * Thu Jan 29 1998 Bill Nottingham <wen1@cec.wustl.edu>
  219. - upgraded to 1.0.2
  220. * Wed Jan 28 1998 Bill Nottingham <wen1@cec.wustl.edu>
  221. - Apparently so, Donnie. :)
  222. - upgraded to 1.0.0beta
  223. * Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
  224. - spec file cleanups
  225. * Mon Sep 1 1997 Donnie Barnes <djb@redhat.com>
  226. - upgraded to 0.99.38 (will it EVER go 1.0???)
  227. - all patches removed (all appear to be in this version)
  228. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  229. - built against glibc