cdparanoia-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: cdparanoia
  3. Summary: A Compact Disc Digital Audio (CDDA) extraction tool (or ripper).
  4. Summary(ja): 音楽 CD (CDDA) 用の抽出ツール
  5. Version: 10.2
  6. Release: 4%{?_dist_release}
  7. Group: Applications/Multimedia
  8. License: GPLv2 and LGPLv2
  9. URL: http://www.xiph.org/paranoia/index.html
  10. Source: http://www.xiph.org/paranoia/download/%{name}-III-%{version}.src.tgz
  11. # Patch from upstream to fix cdda_interface.h C++ incompatibility ("private")
  12. # https://trac.xiph.org/changeset/15338
  13. # https://bugzilla.redhat.com/show_bug.cgi?id=463009
  14. Patch0: cdparanoia-10.2-#463009.patch
  15. # #466659
  16. Patch1: cdparanoia-10.2-endian.patch
  17. Patch2: cdparanoia-10.2-install.patch
  18. Patch3: cdparanoia-10.2-format-security.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. %description
  21. Cdparanoia (Paranoia III) reads digital audio directly from a CD, then
  22. writes the data to a file or pipe in WAV, AIFC or raw 16 bit linear
  23. PCM format. Cdparanoia doesn't contain any extra features (like the ones
  24. included in the cdda2wav sampling utility). Instead, cdparanoia's strength
  25. lies in its ability to handle a variety of hardware, including inexpensive
  26. drives prone to misalignment, frame jitter and loss of streaming during
  27. atomic reads. Cdparanoia is also good at reading and repairing data from
  28. damaged CDs.
  29. %package devel
  30. Summary: Development tools for libcdda_paranoia (Paranoia III).
  31. Summary(ja): libcdda_paranoia (Paranoia III) の開発用ファイル
  32. Group: Development/Libraries
  33. License: LGPLv2
  34. Requires: %{name} = %{version}-%{release}
  35. %description devel
  36. The cdparanoia-devel package contains the static libraries and header
  37. files needed for developing applications to read CD Digital Audio disks.
  38. # compat32
  39. %package -n compat32-%{name}
  40. Summary: A Compact Disc Digital Audio (CDDA) extraction tool (or ripper).
  41. Summary(ja): 音楽 CD (CDDA) 用の抽出ツール
  42. Group: Applications/Multimedia
  43. Requires: %{name} = %{version}-%{release}
  44. %description -n compat32-%{name}
  45. Cdparanoia (Paranoia III) reads digital audio directly from a CD, then
  46. writes the data to a file or pipe in WAV, AIFC or raw 16 bit linear
  47. PCM format. Cdparanoia doesn't contain any extra features (like the ones
  48. included in the cdda2wav sampling utility). Instead, cdparanoia's strength
  49. lies in its ability to handle a variety of hardware, including inexpensive
  50. drives prone to misalignment, frame jitter and loss of streaming during
  51. atomic reads. Cdparanoia is also good at reading and repairing data from
  52. damaged CDs.
  53. %package -n compat32-%{name}-devel
  54. Summary: Development tools for libcdda_paranoia (Paranoia III).
  55. Summary(ja): libcdda_paranoia (Paranoia III) の開発用ファイル
  56. Group: Development/Libraries
  57. Requires: compat32-%{name} = %{version}-%{release}
  58. Requires: %{name}-devel = %{version}-%{release}
  59. %description -n compat32-%{name}-devel
  60. The cdparanoia-devel package contains the static libraries and header
  61. files needed for developing applications to read CD Digital Audio disks.
  62. %prep
  63. %setup -q -n %{name}-III-%{version}
  64. %patch0 -p3 -b .#463009
  65. %patch1 -p1 -b .endian
  66. %patch2 -p1 -b .install
  67. %patch3 -p1 -b .fmt-sec
  68. %build
  69. %configure --includedir=%{_includedir}/cdda
  70. # Using -O0 is mandatory, the build fails otherwise...
  71. # Also remove many warnings which we are aware of
  72. # Lastly, don't use _smp_mflags since it also makes the build fail
  73. make OPT="$RPM_OPT_FLAGS -O0 -Wno-pointer-sign -Wno-unused"
  74. %install
  75. rm -rf $RPM_BUILD_ROOT
  76. make install DESTDIR=$RPM_BUILD_ROOT
  77. mkdir -p %{buildroot}%{_mandir}/ja/man1
  78. install -m644 cdparanoia.1.jp %{buildroot}%{_mandir}/ja/man1/cdparanoia.1
  79. %post -p /sbin/ldconfig
  80. %postun -p /sbin/ldconfig
  81. %post -n compat32-%{name} -p /sbin/ldconfig
  82. %postun -n compat32-%{name} -p /sbin/ldconfig
  83. %clean
  84. [ "$RPM_BUILD_ROOT" != "/" -a -d "$RPM_BUILD_ROOT" ] && rm -rf "$RPM_BUILD_ROOT"
  85. %files
  86. %defattr(-,root,root)
  87. %doc README COPYING-GPL COPYING-LGPL
  88. %{_bindir}/*
  89. %{_libdir}/lib*.so.*
  90. %{_mandir}/man1/*
  91. %{_mandir}/ja/man1/*
  92. %files devel
  93. %defattr(-,root,root)
  94. %{_includedir}/cdda
  95. %{_libdir}/lib*.so
  96. %{_libdir}/*.a
  97. # compat32
  98. %if %{build_compat32}
  99. %files -n compat32-%{name}
  100. %defattr(-, root, root)
  101. %{_libdir}/*.so.*
  102. %files -n compat32-%{name}-devel
  103. %defattr(-, root, root)
  104. %{_libdir}/*.so
  105. %endif
  106. %changelog
  107. * Thu Feb 22 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.2-4
  108. - imported Patch1-3 from rawhide.
  109. * Wed Jan 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.2-3
  110. - create compat32 sub packages
  111. * Sun Apr 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.2-2
  112. - rebuilt with new toolchain
  113. - added Japanese summary
  114. * Sun Aug 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.2-1
  115. - new upstream release
  116. - added Requires: cdparanoia to devel package
  117. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> alpha9.8-9vl5
  118. - applied new versioning policy
  119. * Tue Jul 3 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> alpha9.8-8vl6
  120. - add Patch1
  121. * Tue Oct 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> alpha9.8-8vl5
  122. - added fPIC.patch fix a problem on x86_64 archtecture
  123. * Fri Dec 26 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> alpha9.8-8vl4
  124. - rebuild with new toolchain
  125. * Sun Mar 16 2003 IWAI Masaharu <iwai@alib.jp> alpha9.8-8vl3
  126. - rebuild with new toolchain
  127. * Tue Apr 24 2001 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
  128. - alpha9.8-8vl2
  129. - rebuild on VineSeed
  130. * Tue Apr 24 2001 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
  131. - alpha9.8-8vl1
  132. - included japanese manual
  133. * Tue Feb 27 2001 Karsten Hopp <karsten@redhat.de>
  134. - fix spelling error in description
  135. * Thu Dec 7 2000 Crutcher Dunnavant <crutcher@redhat.com>
  136. - rebuild for new tree
  137. * Fri Jul 21 2000 Trond Eivind Glomsrød <teg@redhat.com>
  138. - use %%{_tmppath}
  139. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  140. - automatic rebuild
  141. * Tue Jun 06 2000 Preston Brown <pbrown@redhat.com>
  142. - revert name change
  143. - use new rpm macro paths
  144. * Wed Apr 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
  145. - Switched spec file from the one used in Red Hat Linux 6.2, which
  146. also changes the name
  147. - gzip man page
  148. * Thu Dec 23 1999 Peter Jones <pjones@redhat.com>
  149. - update package to provide cdparanoia-alpha9.7-2.*.rpm and
  150. cdparanoia-devel-alpha9.7-2.*.rpm. Also, URLs point at xiph.org
  151. like they should.
  152. * Wed Dec 22 1999 Peter Jones <pjones@redhat.com>
  153. - updated package for alpha9.7, based on input from:
  154. Monty <xiphmont@xiph.org>
  155. David Philippi <david@torangan.saar.de>
  156. * Mon Apr 12 1999 Michael Maher <mike@redhat.com>
  157. - updated pacakge
  158. * Tue Oct 06 1998 Michael Maher <mike@redhat.com>
  159. - updated package
  160. * Mon Jun 29 1998 Michael Maher <mike@redhat.com>
  161. - built package