corosync-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533
  1. # Conditionals
  2. # Invoke "rpmbuild --without <feature>" or "rpmbuild --with <feature>"
  3. # to disable or enable specific features
  4. %bcond_with testagents
  5. %bcond_with watchdog
  6. %bcond_with monitoring
  7. %bcond_without snmp
  8. %bcond_without dbus
  9. # no InfiniBand stack on s390(x)
  10. #ifnarch s390 s390x
  11. %bcond_with rdma
  12. #endif
  13. %bcond_with systemd
  14. %bcond_without upstart
  15. %bcond_without xmlconf
  16. %bcond_without runautogen
  17. Name: corosync
  18. Summary: The Corosync Cluster Engine and Application Programming Interfaces
  19. Summary(ja): Corosync クラスタエンジン及びその API
  20. Version: 2.3.4
  21. Release: 1%{?_dist_release}
  22. License: BSD
  23. Group: System Environment/Base
  24. URL: http://www.corosync.org/
  25. Source0: http://corosync.org/download/%{name}-%{version}.tar.gz
  26. ExclusiveArch: i686 x86_64
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  28. # Build bits
  29. BuildRequires: groff
  30. BuildRequires: libqb-devel >= 0.14.2
  31. BuildRequires: nss-devel
  32. %if %{with runautogen}
  33. BuildRequires: autoconf automake libtool
  34. %endif
  35. %if %{with monitoring}
  36. BuildRequires: libstatgrab-devel
  37. %endif
  38. %if %{with rdma}
  39. BuildRequires: libibverbs-devel librdmacm-devel
  40. %endif
  41. %if %{with snmp}
  42. BuildRequires: net-snmp-devel
  43. %endif
  44. %if %{with dbus}
  45. BuildRequires: dbus-devel
  46. %endif
  47. %if %{with systemd}
  48. BuildRequires: systemd-units
  49. Requires(post): systemd
  50. Requires(preun): systemd
  51. Requires(postun): systemd
  52. %endif
  53. %if %{with xmlconf}
  54. Requires: libxslt
  55. %endif
  56. # Runtime bits
  57. Requires: corosynclib = %{version}-%{release}
  58. Requires(pre): /usr/sbin/useradd
  59. Requires(post): /sbin/chkconfig
  60. Requires(preun): /sbin/chkconfig
  61. Obsoletes: openais, openais-devel, openaislib, openaislib-devel
  62. Obsoletes: cman, clusterlib, clusterlib-devel
  63. %description
  64. This package contains the Corosync Cluster Engine Executive, several default
  65. APIs and libraries, default configuration files, and an init script.
  66. # optional testagent rpm
  67. #
  68. %if %{with testagents}
  69. %package -n corosync-testagents
  70. Summary: The Corosync Cluster Engine Test Agents
  71. Group: Development/Libraries
  72. Requires: %{name} = %{version}-%{release}
  73. Requires: libqb >= 0.14.2
  74. %description -n corosync-testagents
  75. This package contains corosync test agents.
  76. %endif
  77. # library
  78. #
  79. %package -n corosynclib
  80. Summary: The Corosync Cluster Engine Libraries
  81. Summary(ja): Corosync クラスタエンジンのライブラリ
  82. Group: System Environment/Libraries
  83. Requires: %{name} = %{version}-%{release}
  84. %description -n corosynclib
  85. This package contains corosync libraries.
  86. %package -n corosynclib-devel
  87. Summary: The Corosync Cluster Engine Development Kit
  88. Summary(ja): Corosync クラスタエンジン開発キット
  89. Group: Development/Libraries
  90. Requires: corosynclib = %{version}-%{release}
  91. Requires: pkgconfig
  92. Provides: corosync-devel = %{version}
  93. Obsoletes: corosync-devel < 0.92-7
  94. %description -n corosynclib-devel
  95. This package contains include files and man pages used to develop using
  96. The Corosync Cluster Engine APIs.
  97. %prep
  98. %setup -q -n %{name}-%{version}
  99. %build
  100. %if %{with runautogen}
  101. ./autogen.sh
  102. %endif
  103. %if %{with rdma}
  104. export ibverbs_CFLAGS=-I%{_includedir}/infiniband \
  105. export ibverbs_LIBS=-libverbs \
  106. export rdmacm_CFLAGS=-I%{_includedir}/rdma \
  107. export rdmacm_LIBS=-lrdmacm \
  108. %endif
  109. %{configure} \
  110. %if %{with testagents}
  111. --enable-testagents \
  112. %endif
  113. %if %{with watchdog}
  114. --enable-watchdog \
  115. %endif
  116. %if %{with monitoring}
  117. --enable-monitoring \
  118. %endif
  119. %if %{with snmp}
  120. --enable-snmp \
  121. %endif
  122. %if %{with dbus}
  123. --enable-dbus \
  124. %endif
  125. %if %{with rdma}
  126. --enable-rdma \
  127. %endif
  128. %if %{with systemd}
  129. --enable-systemd \
  130. %endif
  131. %if %{with upstart}
  132. --enable-upstart \
  133. %endif
  134. %if %{with xmlconf}
  135. --enable-xmlconf \
  136. %endif
  137. --with-initddir=%{_initrddir} \
  138. --with-systemddir=%{_unitdir} \
  139. --with-upstartdir=%{_sysconfdir}/init
  140. make %{_smp_mflags}
  141. %install
  142. rm -rf %{buildroot}
  143. make install DESTDIR=%{buildroot}
  144. %if %{with dbus}
  145. mkdir -p -m 0700 %{buildroot}/%{_sysconfdir}/dbus-1/system.d
  146. install -m 644 %{_builddir}/%{name}-%{version}%{?gittarver}/conf/corosync-signals.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/corosync-signals.conf
  147. %endif
  148. ## tree fixup
  149. # drop static libs
  150. rm -f %{buildroot}%{_libdir}/*.a
  151. rm -f %{buildroot}%{_libdir}/*.la
  152. # drop docs and html docs for now
  153. rm -rf %{buildroot}%{_docdir}/*
  154. # /etc/sysconfig/corosync-notifyd
  155. mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
  156. install -m 644 tools/corosync-notifyd.sysconfig.example \
  157. %{buildroot}%{_sysconfdir}/sysconfig/corosync-notifyd
  158. # /etc/sysconfig/corosync
  159. install -m 644 init/corosync.sysconfig.example \
  160. %{buildroot}%{_sysconfdir}/sysconfig/corosync
  161. %clean
  162. rm -rf %{buildroot}
  163. %post
  164. %if %{with systemd} && 0%{?systemd_post:1}
  165. %systemd_post corosync.service
  166. %else
  167. if [ $1 -eq 1 ]; then
  168. /sbin/chkconfig --add corosync || :
  169. fi
  170. %endif
  171. %preun
  172. %if %{with systemd} && 0%{?systemd_preun:1}
  173. %systemd_preun corosync.service
  174. %else
  175. if [ $1 -eq 0 ]; then
  176. /sbin/service corosync stop &>/dev/null || :
  177. /sbin/chkconfig --del corosync || :
  178. fi
  179. %endif
  180. %postun
  181. %if %{with systemd} && 0%{?systemd_postun:1}
  182. %systemd_postun
  183. %endif
  184. %post -n corosynclib -p /sbin/ldconfig
  185. %postun -n corosynclib -p /sbin/ldconfig
  186. %files
  187. %defattr(-,root,root,-)
  188. %doc LICENSE SECURITY
  189. %{_sbindir}/corosync
  190. %{_sbindir}/corosync-keygen
  191. %{_sbindir}/corosync-cmapctl
  192. %{_sbindir}/corosync-cfgtool
  193. %{_sbindir}/corosync-cpgtool
  194. %{_sbindir}/corosync-quorumtool
  195. %{_sbindir}/corosync-notifyd
  196. %{_bindir}/corosync-blackbox
  197. %if %{with xmlconf}
  198. %{_bindir}/corosync-xmlproc
  199. %config(noreplace) %{_sysconfdir}/corosync/corosync.xml.example
  200. %dir %{_datadir}/corosync
  201. %{_datadir}/corosync/xml2conf.xsl
  202. %{_mandir}/man8/corosync-xmlproc.8*
  203. %{_mandir}/man5/corosync.xml.5*
  204. %endif
  205. %dir %{_sysconfdir}/corosync
  206. %dir %{_sysconfdir}/corosync/uidgid.d
  207. %config(noreplace) %{_sysconfdir}/corosync/corosync.conf.example
  208. %config(noreplace) %{_sysconfdir}/corosync/corosync.conf.example.udpu
  209. %config(noreplace) %{_sysconfdir}/sysconfig/corosync-notifyd
  210. %config(noreplace) %{_sysconfdir}/sysconfig/corosync
  211. %if %{with dbus}
  212. %{_sysconfdir}/dbus-1/system.d/corosync-signals.conf
  213. %endif
  214. %if %{with snmp}
  215. %{_datadir}/snmp/mibs/COROSYNC-MIB.txt
  216. %endif
  217. %if %{with systemd}
  218. %{_unitdir}/corosync.service
  219. %{_unitdir}/corosync-notifyd.service
  220. %dir %{_datadir}/corosync
  221. %{_datadir}/corosync/corosync
  222. %{_datadir}/corosync/corosync-notifyd
  223. %else
  224. %{_initrddir}/corosync
  225. %{_initrddir}/corosync-notifyd
  226. %endif
  227. %if %{with upstart}
  228. %{_sysconfdir}/init/corosync.conf
  229. %{_sysconfdir}/init/corosync-notifyd.conf
  230. %endif
  231. %dir %{_localstatedir}/lib/corosync
  232. %dir %{_localstatedir}/log/cluster
  233. %{_mandir}/man8/corosync_overview.8*
  234. %{_mandir}/man8/corosync.8*
  235. %{_mandir}/man8/corosync-blackbox.8*
  236. %{_mandir}/man8/corosync-cmapctl.8*
  237. %{_mandir}/man8/corosync-keygen.8*
  238. %{_mandir}/man8/corosync-cfgtool.8*
  239. %{_mandir}/man8/corosync-cpgtool.8*
  240. %{_mandir}/man8/corosync-notifyd.8*
  241. %{_mandir}/man8/corosync-quorumtool.8*
  242. %{_mandir}/man5/corosync.conf.5*
  243. %{_mandir}/man5/votequorum.5*
  244. %{_mandir}/man8/cmap_keys.8*
  245. %if %{with testagents}
  246. %files -n corosync-testagents
  247. %defattr(755,root,root,-)
  248. %{_datadir}/corosync/tests/mem_leak_test.sh
  249. %{_datadir}/corosync/tests/net_breaker.sh
  250. %{_datadir}/corosync/tests/cmap-dispatch-deadlock.sh
  251. %{_datadir}/corosync/tests/shm_leak_audit.sh
  252. %{_bindir}/cpg_test_agent
  253. %{_bindir}/sam_test_agent
  254. %{_bindir}/votequorum_test_agent
  255. %endif
  256. %files -n corosynclib
  257. %defattr(-,root,root,-)
  258. %doc LICENSE
  259. %{_libdir}/libcfg.so.*
  260. %{_libdir}/libcpg.so.*
  261. %{_libdir}/libcmap.so.*
  262. %{_libdir}/libtotem_pg.so.*
  263. %{_libdir}/libquorum.so.*
  264. %{_libdir}/libvotequorum.so.*
  265. %{_libdir}/libsam.so.*
  266. %{_libdir}/libcorosync_common.so.*
  267. %files -n corosynclib-devel
  268. %defattr(-,root,root,-)
  269. %doc LICENSE
  270. %dir %{_includedir}/corosync/
  271. %{_includedir}/corosync/corodefs.h
  272. %{_includedir}/corosync/cfg.h
  273. %{_includedir}/corosync/cmap.h
  274. %{_includedir}/corosync/corotypes.h
  275. %{_includedir}/corosync/cpg.h
  276. %{_includedir}/corosync/hdb.h
  277. %{_includedir}/corosync/sam.h
  278. %{_includedir}/corosync/quorum.h
  279. %{_includedir}/corosync/votequorum.h
  280. %dir %{_includedir}/corosync/totem/
  281. %{_includedir}/corosync/totem/totem.h
  282. %{_includedir}/corosync/totem/totemip.h
  283. %{_includedir}/corosync/totem/totempg.h
  284. %{_libdir}/libcfg.so
  285. %{_libdir}/libcpg.so
  286. %{_libdir}/libcmap.so
  287. %{_libdir}/libtotem_pg.so
  288. %{_libdir}/libquorum.so
  289. %{_libdir}/libvotequorum.so
  290. %{_libdir}/libsam.so
  291. %{_libdir}/libcorosync_common.so
  292. %{_libdir}/pkgconfig/*.pc
  293. %{_mandir}/man3/cpg_*3*
  294. %{_mandir}/man3/quorum_*3*
  295. %{_mandir}/man3/votequorum_*3*
  296. %{_mandir}/man3/sam_*3*
  297. %{_mandir}/man8/cpg_overview.8*
  298. %{_mandir}/man8/votequorum_overview.8*
  299. %{_mandir}/man8/sam_overview.8*
  300. %{_mandir}/man3/cmap_*3*
  301. %{_mandir}/man8/cmap_overview.8*
  302. %{_mandir}/man8/quorum_overview.8*
  303. %changelog
  304. * Thu Feb 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.4-1
  305. - updated to 2.3.4
  306. - added BR: libqb-devel
  307. * Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
  308. - new upstream release
  309. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-1
  310. - initial build for Vine Linux
  311. * Mon Jul 5 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.6-1
  312. - New upstream release
  313. - Resync spec file with upstream changes
  314. * Tue May 25 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.3-1
  315. - New upstream release
  316. - Rediff revision 2770 patch
  317. * Mon May 17 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.2-1
  318. - New upstream release
  319. - Add upstream trunk revision 2770 to add cpg_model_initialize api.
  320. - Fix URL and Source0 entries.
  321. - Add workaround to broken 1.2.2 Makefile with make -j.
  322. * Wed Mar 24 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.1-1
  323. - New upstream release
  324. * Tue Dec 8 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.0-1
  325. - New upstream release
  326. - Use global instead of define
  327. - Update Source0 url
  328. - Use more %name macro around
  329. - Cleanup install section. Init script is now installed by upstream
  330. - Cleanup whitespace
  331. - Don't deadlock between package upgrade and corosync condrestart
  332. - Ship service.d config directory
  333. - Fix Conflicts vs Requires
  334. - Ship new sam library and man pages
  335. * Fri Oct 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.1.2-1
  336. - New upstream release fixes major regression on specific loads
  337. * Wed Oct 21 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.1.1-1
  338. - New upstream release
  339. * Fri Sep 25 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.1.0-1
  340. - New upstream release
  341. - spec file updates:
  342. * enable IB support
  343. * explicitly define built-in features at configure time
  344. * Tue Sep 22 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.1-1
  345. - New upstream release
  346. - spec file updates:
  347. * use proper configure macro
  348. * Tue Jul 28 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.0-3
  349. - spec file updates:
  350. * more consistent use of macros across the board
  351. * fix directory ownership
  352. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
  353. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  354. * Wed Jul 8 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.0-1
  355. - New upstream release
  356. * Thu Jul 2 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.100-1
  357. - New upstream release
  358. * Sat Jun 20 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.98-1
  359. - New upstream release
  360. - spec file updates:
  361. * Drop corosync-trunk patch and alpha tag.
  362. * Fix alphatag vs buildtrunk handling.
  363. * Drop requirement on ais user/group and stop creating them.
  364. * New config file locations from upstream: /etc/corosync/corosync.conf.
  365. * Wed Jun 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.97-1.svn2233
  366. - spec file updates:
  367. * Update to svn version 2233 to include library linking fixes
  368. * Wed Jun 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.97-1.svn2232
  369. - New upstream release
  370. - spec file updates:
  371. * Drop pkgconfig fix that's now upstream
  372. * Update to svn version 2232
  373. * Define buildtrunk if we are using svn snapshots
  374. * BuildRequires: nss-devel to enable nss crypto for network communication
  375. * Force autogen invokation if buildtrunk is defined
  376. * Whitespace cleanup
  377. * Stop shipping corosync.conf in favour of a generic example
  378. * Update file list
  379. * Mon Mar 30 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.95-2
  380. - Backport svn commit 1913 to fix pkgconfig files generation
  381. and unbreak lvm2 build.
  382. * Tue Mar 24 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.95-1
  383. - New upstream release
  384. - spec file updates:
  385. * Drop alpha tag
  386. * Drop local patches (no longer required)
  387. * Allow to build from svn trunk by supporting rpmbuild --with buildtrunk
  388. * BuildRequires autoconf automake if building from trunk
  389. * Execute autogen.sh if building from trunk and if no configure is available
  390. * Switch to use rpm configure macro and set standard install paths
  391. * Build invokation now supports _smp_mflags
  392. * Remove install section for docs and use proper doc macro instead
  393. * Add tree fixup bits to drop static libs and html docs (only for now)
  394. * Add LICENSE file to all subpackages
  395. * libraries have moved to libdir. Drop ld.so.conf.d corosync file
  396. * Update BuildRoot usage to preferred versions/names
  397. * Tue Mar 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-5.svn1797
  398. - Update the corosync-trunk patch for real this time.
  399. * Tue Mar 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-4.svn1797
  400. - Import fixes from upstream:
  401. * Cleanup logsys format init around to use default settings (1795)
  402. * logsys_format_set should use its own internal copy of format_buffer (1796)
  403. * Add logsys_format_get to logsys API (1797)
  404. - Cherry pick svn1807 to unbreak CPG.
  405. * Mon Mar 9 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-3.svn1794
  406. - Import fixes from upstream:
  407. * Add reserve/release feature to totem message queue space (1793)
  408. * Fix CG shutdown (1794)
  409. * Fri Mar 6 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-2.svn1792
  410. - Import fixes from upstream:
  411. * Fix uninitialized memory. Spotted by valgrind (1788)
  412. * Fix logsys_set_format by updating the right bits (1789)
  413. * logsys: re-add support for timestamp (1790)
  414. * Fix cpg crash (1791)
  415. * Allow logsys_format_set to reset to default (1792)
  416. * Tue Mar 3 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-1
  417. - New upstream release.
  418. - Drop obsolete patches.
  419. - Add soname bump patch that was missing from upstream.
  420. * Wed Feb 25 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.93-4
  421. - Add Makefile fix to install all corosync tools (commit r1780)
  422. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
  423. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  424. * Mon Feb 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.93-2
  425. - Rename gcc-4.4 patch to match svn commit (r1767).
  426. - Backport patch from trunk (commit r1774) to fix quorum engine.
  427. * Thu Feb 19 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.93-1
  428. - New upstream release.
  429. - Drop alphatag from spec file.
  430. - Drop trunk patch.
  431. - Update Provides for corosynclib-devel.
  432. - Backport gcc-4.4 build fix from trunk.
  433. * Mon Feb 2 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-7.svn1756
  434. - Update to svn trunk at revision 1756 from upstream.
  435. - Add support pkgconfig to devel package.
  436. - Tidy up spec files by re-organazing sections according to packages.
  437. - Split libraries from corosync to corosynclib.
  438. - Rename corosync-devel to corosynclib-devel.
  439. - Comply with multiarch requirements (libraries).
  440. * Tue Jan 27 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-6.svn1750
  441. - Update to svn trunk at revision 1750 from upstream.
  442. - Include new quorum service in the packaging.
  443. * Mon Dec 15 2008 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-5.svn1709
  444. - Update to svn trunk at revision 1709 from upstream.
  445. - Update spec file to include new include files.
  446. * Wed Dec 10 2008 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-4.svn1707
  447. - Update to svn trunk at revision 1707 from upstream.
  448. - Update spec file to include new lcrso services and include file.
  449. * Mon Oct 13 2008 Dennis Gilmore <dennis@ausil.us> - 0.92-3
  450. - remove ExclusiveArch line
  451. * Fri Sep 24 2008 Steven Dake <sdake@redhat.com> - 0.92-2
  452. - Add conflicts for openais and openais-devel packages older then 0.90.
  453. * Wed Sep 24 2008 Steven Dake <sdake@redhat.com> - 0.92-1
  454. - New upstream release corosync-0.92.
  455. * Sun Aug 24 2008 Steven Dake <sdake@redhat.com> - 0.91-3
  456. - move logsys_overview.8.* to devel package.
  457. - move shared libs to main package.
  458. * Wed Aug 20 2008 Steven Dake <sdake@redhat.com> - 0.91-2
  459. - use /sbin/service instead of calling init script directly.
  460. - put corosync-objctl man page in the main package.
  461. - change all initrddir to initddir for fedora 10 guidelines.
  462. * Thu Aug 14 2008 Steven Dake <sdake@redhat.com> - 0.91-1
  463. - First upstream packaged version of corosync for rawhide review.