fltk-vl.spec 9.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346
  1. %define _default_patch_fuzz 2
  2. #define snap r9625
  3. #define _disable_static --disable-static
  4. Summary: C++ user interface toolkit
  5. Summary(ja): C++用の軽量GUIライブラリキット
  6. Name: fltk
  7. Version: 1.3.5
  8. %define subversion 2
  9. %if "%{?snap:1}" == "1"
  10. Release: 1.%{snap}%{?_dist_release}
  11. %else
  12. Release: 1%{?_dist_release}
  13. %endif
  14. # see COPYING (or http://www.fltk.org/COPYING.php ) for exceptions details
  15. License: LGPLv2+ with exceptions
  16. Group: System Environment/Libraries
  17. URL: http://www.fltk.org/
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %if "%{?snap:1}" == "1"
  21. Source0: http://ftp.easysw.com/pub/fltk/snapshots/fltk-1.3.x-%{snap}.tar.gz
  22. %else
  23. Source0: https://www.fltk.org/pub/fltk/1.3.5/fltk-%{version}-source.tar.bz2
  24. %endif
  25. ## FIXME/TODO: upstream these asap -- Rex
  26. # add lib64 support, drop extraneous libs (bug #708185) and ldflags (#1112930)
  27. Patch1: fltk-1.3.4-fltk_config.patch
  28. ## upstreamable patches
  29. Patch100: fltk-1.3.4-x-fluid_mimetype.patch
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  31. BuildRequires: libICE-devel libSM-devel
  32. BuildRequires: libXext-devel libXinerama-devel libXft-devel libXt-devel libX11-devel
  33. BuildRequires: xorg-x11-proto-devel xorg-x11-utils
  34. BuildRequires: libjpeg-devel
  35. BuildRequires: zlib-devel
  36. BuildRequires: libpng-devel
  37. BuildRequires: libGL-devel libGLU-devel
  38. BuildRequires: pkgconfig
  39. BuildRequires: desktop-file-utils
  40. BuildRequires: man
  41. %description
  42. FLTK (pronounced "fulltick") is a cross-platform C++ GUI toolkit.
  43. It provides modern GUI functionality without the bloat, and supports
  44. 3D graphics via OpenGL and its built-in GLUT emulation.
  45. %package devel
  46. Summary: Development files for %{name}
  47. Summary(ja): %{name} の開発用ファイル
  48. Group: Development/Libraries
  49. Requires: %{name} = %{version}-%{release}
  50. Requires: libX11-devel
  51. Requires: libXinerama-devel
  52. Requires: libXft-devel
  53. %description devel
  54. %{summary}.
  55. %package fluid
  56. Summary: Fast Light User Interface Designer
  57. Group: Applications/Development
  58. Requires: %{name}-devel = %{version}-%{release}
  59. %description fluid
  60. %{summary}, an interactive GUI designer for %{name}.
  61. %prep
  62. %if "%{?snap:1}" == "1"
  63. %setup -q -n fltk-1.3.x-%{snap}
  64. %else
  65. %setup -q -n %{name}-%{version}
  66. %endif
  67. %patch1 -p1 -b .fltk_config
  68. %patch100 -p1 -b .x-fluid_mimetype
  69. # verbose build output
  70. sed -i.silent '\,^.SILENT:,d' makeinclude.in
  71. autoconf
  72. %build
  73. %configure \
  74. %{?_disable_static} \
  75. --with-optim="%{optflags}" \
  76. --enable-largefile \
  77. --enable-shared \
  78. --enable-threads \
  79. --enable-xdbe \
  80. --enable-xinerama \
  81. --enable-xft
  82. make %{?_smp_mflags}
  83. %install
  84. rm -rf $RPM_BUILD_ROOT
  85. %make_install
  86. make install-linux -C fluid DESTDIR=$RPM_BUILD_ROOT
  87. # omit examples/games:
  88. make -C test uninstall-linux DESTDIR=$RPM_BUILD_ROOT
  89. rm -f $RPM_BUILD_ROOT%{_mandir}/man?/{blocks,checkers,sudoku}*
  90. desktop-file-install \
  91. --delete-original \
  92. --vendor="%{name}" \
  93. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  94. $RPM_BUILD_ROOT%{_datadir}/applications/fluid.desktop
  95. # docs
  96. rm -rf __docs
  97. mv $RPM_BUILD_ROOT%{_docdir}/fltk __docs
  98. ## unpackaged files
  99. # errant docs
  100. rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
  101. # static libs
  102. %if "%{?_disable_static:1}" == "1"
  103. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
  104. %endif
  105. %check
  106. make test ||:
  107. %clean
  108. rm -rf $RPM_BUILD_ROOT
  109. %post -p /sbin/ldconfig
  110. %postun -p /sbin/ldconfig
  111. %post fluid
  112. touch --no-create %{_datadir}/icons/hicolor ||:
  113. gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
  114. update-desktop-database >& /dev/null ||:
  115. %postun fluid
  116. touch --no-create %{_datadir}/icons/hicolor ||:
  117. gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
  118. update-desktop-database >& /dev/null ||:
  119. %files
  120. %defattr(-,root,root,-)
  121. %license COPYING
  122. %doc ANNOUNCEMENT CHANGES CREDITS README
  123. %{_libdir}/libfltk.so.*
  124. %{_libdir}/libfltk_forms.so.*
  125. #{_libdir}/libfltk_gl.so.*
  126. %{_libdir}/libfltk_images.so.*
  127. %files devel
  128. %defattr(-,root,root,-)
  129. %doc __docs/*
  130. %{_bindir}/fltk-config
  131. %{_includedir}/FL/
  132. %{_libdir}/libfltk.so
  133. %{_libdir}/libfltk_forms.so
  134. #{_libdir}/libfltk_gl.so
  135. %{_libdir}/libfltk_images.so
  136. %if "%{?_disable_static:1}" != "1"
  137. %{_libdir}/libfltk.a
  138. %{_libdir}/libfltk_forms.a
  139. #{_libdir}/libfltk_gl.a
  140. %{_libdir}/libfltk_images.a
  141. %endif
  142. %{_mandir}/man1/fltk-config.1*
  143. %{_mandir}/man3/fltk.3*
  144. %files fluid
  145. %defattr(-,root,root,-)
  146. %{_bindir}/fluid
  147. %{_mandir}/man1/fluid.1*
  148. %{_datadir}/applications/fltk-fluid.desktop
  149. %{_datadir}/icons/hicolor/*/*/*
  150. %changelog
  151. * Mon Mar 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.3.5-1
  152. - updated to 1.3.5.
  153. * Sun Sep 02 2018 Toshiaki Ara <ara_t@384.jp> - 1.3.4-1
  154. - update to 1.3.4-2
  155. - remove old patch
  156. - add patches from Fedora
  157. * Mon Oct 24 2016 Toshiaki Ara <ara_t@384.jp> - 1.3.3-3
  158. - add patch1: Fl_XFont_On_Demand.patch
  159. - fixed: undefined reference to 'Fl_XFont_On_Demand::value()'
  160. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.3.3-2
  161. - rebuilt with new toolchain.
  162. * Fri Nov 7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.3.3-1
  163. - update to 1.3.3
  164. - removed duplicated desktop file
  165. - moved fluid subpackage to Applications/Development Group
  166. * Mon Jun 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.3-1.r9625
  167. - update to 1.3.x-r9625
  168. - remove old patches
  169. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 1.1.10-3
  170. - rebuilt with rpm-4.8.1-3
  171. * Sat May 08 2010 Shu KONNO <owa@bg.wakwak.com> - 1.1.10-2
  172. - fixed duplecate desktop files
  173. * Fri May 07 2010 Shu KONNO <owa@bg.wakwak.com> - 1.1.10-1
  174. - updated fltk to 1.1.10
  175. - added japanese summary
  176. * Thu Feb 19 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.9-1
  177. - initial build for Vine Linux
  178. * Wed Oct 01 2008 Rex Dieter <rdieter@fedoraproject.org> 1.1.9-1
  179. - fltk-1.1.9
  180. * Sat Mar 29 2008 Rex Dieter <rdieter@fedoraproject.org> 1.1.8-1
  181. - fltk-1.1.8 (final)
  182. * Fri Feb 29 2008 Rex Dieter <rdieter@fedoraproject.org> 1.1.8-0.8.r6027
  183. - fltk-1.1.x-r6027
  184. * Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 1.1.8-0.7.r5989
  185. - respin (gcc43)
  186. * Wed Dec 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.6.r5989
  187. - --enable-largefile
  188. - fltk-1.1.x-r5989 snapshot (1.1.8 pre-release)
  189. * Mon Aug 20 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.5.r5750
  190. - License: LGPLv2+ with exceptions
  191. * Sat Aug 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.4.r5750
  192. - License: LGPLv2+ (with exceptions)
  193. * Sun Apr 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.3.r5750
  194. - *really* fix --rpath issue, using non-empty patch this time (#238284)
  195. * Sun Apr 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.2.r5750
  196. - nuke --rpath (#238284)
  197. * Thu Apr 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.1.r5750
  198. - fltk-1.1.x-r5750 snapshot (1.1.8 pre-release)
  199. - --enable-xinerama
  200. - patch for undefined symbols in libfltk_gl
  201. * Wed Apr 4 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 1.1.7-9.r5555
  202. - Always apply fltk-config patch (#199656)
  203. - Update fltk-1.1.7-config.patch
  204. * Wed Dec 13 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.1.7-8.r5555
  205. - more 64bit hackage to workaround broken Makefile logic (#219348)
  206. * Wed Dec 13 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.1.7-7.r5555
  207. - fltk-1.1.x-r5555 snapshot, for 64bit issues (#219348)
  208. - restore static libs (they're tightly coupled with fltk-config)
  209. - cleanup %%description's
  210. * Mon Dec 11 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.1.7-6
  211. - move tests to %%check section
  212. * Mon Dec 11 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.1.7-5
  213. - use included icon/.desktop files
  214. - fix up fltk-config (#199656)
  215. * Mon Dec 11 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.1.7-3
  216. - follow icon spec
  217. - omit static libs
  218. * Wed Sep 06 2006 Michael J. Knox <michael[AT]knox.net.nz> - 1.1.7-2
  219. - rebuild for FC6
  220. * Mon Feb 13 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.1.7-1
  221. - Upstream update
  222. * Thu Nov 17 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.1.6-4
  223. - Fixed BR and -devel Requires for modular X
  224. * Sun Nov 13 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.1.6-3
  225. - Update BuildRequires as well
  226. * Sun Nov 13 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.1.6-2
  227. - Update Requires for -devel
  228. * Thu Oct 27 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.1.6-1
  229. - Upstream update
  230. * Thu Aug 18 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 1.1.4-10
  231. - Fixed BR/Requires for x86_64
  232. * Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  233. - rebuilt
  234. * Thu Nov 20 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.8
  235. - Hopefully fixed Xft flags for rh80
  236. * Thu Nov 20 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.7
  237. - Fixed typo
  238. * Thu Nov 20 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.6
  239. - Added xft.pc build dependency
  240. - Added BuildReq:man
  241. * Sun Nov 9 2003 Ville Skyttä <ville.skytta@iki.fi> 0:1.1.4-0.fdr.4
  242. - Spec file cleanup
  243. - Enabled xft and threads
  244. * Tue Oct 28 2003 Dams <anvil[AT]livna.org> - 0:1.1.4-0.fdr.3
  245. - Added missing symlink in includedir
  246. * Wed Oct 1 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.2
  247. - Removed comment after scriptlets
  248. * Wed Oct 1 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.1
  249. - Updated to final 1.1.4
  250. * Wed Sep 24 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.0.4.rc1
  251. - Fixed documentation path in configure
  252. * Fri Aug 29 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.0.3.rc1
  253. - Fixed typo in desktop entry
  254. - Added missing BuildRequires ImageMagick and desktop-file-utils
  255. * Fri Aug 29 2003 Dams <anvil[AT]livna.org> 0:1.1.4-0.fdr.0.2.rc1
  256. - Moved fluid to its own package
  257. - Added missing Requires for devel package
  258. * Sat Aug 16 2003 Dams <anvil[AT]livna.org>
  259. - Initial build.